Core Libs Dev[9] Review request for 8039172: Tidy warnings cleanup for java.net, java.math, java.time, java.rmi

2014-04-04 Thread alexander stepanov
Hello, Could you please review the fix for the following bug: https://bugs.openjdk.java.net/browse/JDK-8039172 Webrev corresponding: http://cr.openjdk.java.net/~yan/8039172/webrev.00/ Just a minor cleanup of javadoc to avoid tidy warnings; no other code affected. Thanks. Regards, Alexander

Re: 8020860: cluster Hashtable/Vector field updates for better transactional memory behaviour

2014-04-04 Thread Paul Sandoz
On Apr 4, 2014, at 1:42 AM, Mike Duigou mike.dui...@oracle.com wrote: I could live with that change in behaviour, but this change completely breaks the fail-fast semantics of the iterators in some cases! If you don't update modCount until after the change is complete, the iterator may

Re: Core Libs Dev[9] Review request for 8039172: Tidy warnings cleanup for java.net, java.math, java.time, java.rmi

2014-04-04 Thread Lance @ Oracle
Looks ok but have one concern/question as to why you added the summary attribute to the table tag as it has been deprecated and believe it is not supported in HTML 5. I would probably not include it Best Lance Lance Andersen| Principal Member of Technical Staff | +1.781.442.2037 Oracle Java

RFR: 8039256 Add sun/jvmstat/monitor/MonitoredVm/CR6672135.java to ProblemList.txt

2014-04-04 Thread Staffan Larsen
Please review the change below to add a test to ProblemList.txt. For details, see https://bugs.openjdk.java.net/browse/JDK-8033104 Thanks, /Staffan diff --git a/test/ProblemList.txt b/test/ProblemList.txt --- a/test/ProblemList.txt +++ b/test/ProblemList.txt @@ -273,4 +273,7 @@ # 8031482

Review of MH/LF patches in the review queue

2014-04-04 Thread Paul Sandoz
Hi, Reviews of two patches in the queue. Paul. http://cr.openjdk.java.net/~vlivanov/8037209/webrev.02/ Looks good, though I don't claim to understand all the nuances around casts and JVM/bytecode correctness. Minor stuff below. InvokerByteCodeGenerator: -- Unused method: static

Re: Core Libs Dev[9] Review request for 8039172: Tidy warnings cleanup for java.net, java.math, java.time, java.rmi

2014-04-04 Thread alexander stepanov
Hello Lance, Thank you for the note; the summaries were removed, please see the updated webrev: http://cr.openjdk.java.net/~yan/8039172/webrev.01/ Regards, Alexander On 04.04.2014 15:16, Lance @ Oracle wrote: Looks ok but have one concern/question as to why you added the summary attribute

Re: i18n dev RFR: 8038306: (tz) Support tzdata2014b

2014-04-04 Thread Aleksej Efimov
Masayoshi, The new webrev with proposed generic names for Antarctica/Troll can be found here: http://cr.openjdk.java.net/~aefimov/8038306/9/webrev.01 Thank you, Aleksej On 04/03/2014 06:29 PM, Aleksej Efimov wrote: Masayoshi, How about Troll Time and ATT for generic long and short names

Re: Core Libs Dev[9] Review request for 8039172: Tidy warnings cleanup for java.net, java.math, java.time, java.rmi

2014-04-04 Thread Lance @ Oracle
Looks fine Lance Andersen| Principal Member of Technical Staff | +1.781.442.2037 Oracle Java Engineering 1 Network Drive Burlington, MA 01803 lance.ander...@oracle.com Sent from my iPad On Apr 4, 2014, at 7:53 AM, alexander stepanov alexander.v.stepa...@oracle.com wrote: Hello Lance,

RE: RFR: 8039256 Add sun/jvmstat/monitor/MonitoredVm/CR6672135.java to ProblemList.txt

2014-04-04 Thread Markus Grönlund
Looks good. /Markus -Original Message- From: Staffan Larsen Sent: den 4 april 2014 13:33 To: serviceability-...@openjdk.java.net serviceability-...@openjdk.java.net; core-libs-dev Libs Subject: RFR: 8039256 Add sun/jvmstat/monitor/MonitoredVm/CR6672135.java to ProblemList.txt Please

Re: Improve timezone mapping for AIX platform

2014-04-04 Thread Volker Simonis
Hi Jonathan, sorry, but I found a few more issues: - please use strncpy instead of strcpy in TimeZone_md.c:798 otherwise somebody could easily crash the VM by specifying a TZ with more than 100 characters. - you can delete the lines 871-872 because the variables are actually not used and you

Re: i18n dev RFR: 8038306: (tz) Support tzdata2014b

2014-04-04 Thread Masayoshi Okutsu
Another option would be Troll Station Time and TST. But your invention is fine with me. Thanks, Masayoshi On 4/4/2014 9:19 PM, Aleksej Efimov wrote: Masayoshi, The new webrev with proposed generic names for Antarctica/Troll can be found here:

String.indexOf optimization

2014-04-04 Thread Zoltan Sziladi
Hi, I am new to this mailing list so please forgive me if this has been discussed before. I was looking at the implementation of String.indexOf and I see that it uses the O(n^2) naive implementation. I have been trying to find out why it does not use some kind of a modern, sophisticated O(n)

Re: JDK-8036003: Add variable not to separate debug information.

2014-04-04 Thread Yasumasa Suenaga
Hi all, This should fix it: http://pkgs.fedoraproject.org/cgit/java-1.8.0-openjdk.git/commit/?id=1734315551d634b7467f28788d90595b467ea5eb I updated OpenJDK8 to java-1.8.0-openjdk-1.8.0.0-0.34.b132.fc20 . However, debuginfo files are not contained ELF sections for debugging. (I checked

Re: String.indexOf optimization

2014-04-04 Thread Alan Bateman
On 04/04/2014 15:49, Zoltan Sziladi wrote: Hi, I am new to this mailing list so please forgive me if this has been discussed before. I was looking at the implementation of String.indexOf and I see that it uses the O(n^2) naive implementation. I have been trying to find out why it does not use

Re: i18n dev RFR: 8038306: (tz) Support tzdata2014b

2014-04-04 Thread Aleksej Efimov
Masayoshi, Thank you for the review. The TST is already used by Asia/Taipei in zh_TW. I'll leave the naming as it is, because I suppose that we probably should see an official short name abbreviation for this time zone in near future. -Aleksej On 04/04/2014 06:25 PM, Masayoshi Okutsu wrote:

Re: Core Libs Dev[9] Review request for 8039172: Tidy warnings cleanup for java.net, java.math, java.time, java.rmi

2014-04-04 Thread Alan Bateman
On 04/04/2014 12:53, alexander stepanov wrote: Hello Lance, Thank you for the note; the summaries were removed, please see the updated webrev: http://cr.openjdk.java.net/~yan/8039172/webrev.01/ I looked through the updated webrev and it looks okay to me. One suggestion for

Re: RFR: 8039256 Add sun/jvmstat/monitor/MonitoredVm/CR6672135.java to ProblemList.txt

2014-04-04 Thread Alan Bateman
On 04/04/2014 12:33, Staffan Larsen wrote: Please review the change below to add a test to ProblemList.txt. For details, see https://bugs.openjdk.java.net/browse/JDK-8033104 Thanks, /Staffan diff --git a/test/ProblemList.txt b/test/ProblemList.txt --- a/test/ProblemList.txt +++

Re: Core Libs Dev[9] Review request for 8039172: Tidy warnings cleanup for java.net, java.math, java.time, java.rmi

2014-04-04 Thread alexander stepanov
Thanks; the line in net-properties.html was splitted. Regards, Alexander On 04.04.2014 19:25, Alan Bateman wrote: On 04/04/2014 12:53, alexander stepanov wrote: Hello Lance, Thank you for the note; the summaries were removed, please see the updated webrev:

Re: String.indexOf optimization

2014-04-04 Thread Remi Forax
On 04/04/2014 05:18 PM, Alan Bateman wrote: On 04/04/2014 15:49, Zoltan Sziladi wrote: Hi, I am new to this mailing list so please forgive me if this has been discussed before. I was looking at the implementation of String.indexOf and I see that it uses the O(n^2) naive implementation. I have

Re: JDK-8036003: Add variable not to separate debug information.

2014-04-04 Thread Dmitry Samersoff
Magnus, Not, we are not doing it now. But we should consider doing it in a future and therefore keep it in mind when designing option to choose debug symbol mode. -Dmitry On 2014-03-24 15:18, Magnus Ihse Bursie wrote: On 2014-03-21 10:36, Dmitry Samersoff wrote: (c) Compression mode: 1.

Re: StringBuilder version of java.util.regex.Matcher.append*

2014-04-04 Thread Xueming Shen
On 4/3/14 4:43 PM, Jeremy Manson wrote: Good catch, thanks. I think we should probably just go with the (equivalent to the) StringBuffer variant. I'm pretty loathe to modify the StringBuilder directly if we are going to back that change out. Do you want me to generate a new patch? I

Re: RFR: 8000975: (process) Merge UNIXProcess.java.bsd UNIXProcess.java.linux ( .solaris .aix)

2014-04-04 Thread roger riggs
Hi Peter, I ran into one test problem when running this through its paces. The test: test/java/lang/ProcessBuilder/SecurityManagerClinit.java throws a package access exception while creating a lambda due to the wacky security manager and forbidding of access to java.util. I hacked the test to

Re: RFR (L) 8037210: Get rid of char-based descriptions 'J' of basic types

2014-04-04 Thread Christian Thalinger
On Apr 3, 2014, at 9:44 PM, John Rose john.r.r...@oracle.com wrote: On Apr 3, 2014, at 6:33 PM, Christian Thalinger christian.thalin...@oracle.com wrote: Of course they are popular because these are the type names. There is no type L; it’s an object. I don’t understand why we have to