Re: Optional.isEmpty()

2017-04-22 Thread Jonathan Bluett-Duncan
Hi Peter, Your reasoning has personally convinced me that a method like `isEmpty()` would pull its weight. However, at the risk of bikeshedding, I think it should be named differently, as `isEmpty()` immediately makes me think that `findModule()` returns a List, which I'd easily find confusing. H

Optional.isEmpty()

2017-04-22 Thread Peter Levart
Hi, Seeing the following line in some JDK test that was up for review: return cf.findModule(target).orElse(null) == null; I immediately jumped to suggest it would look better if written as: return !cf.findModule(target).isPresent(); But then I leaned back and asked myself: "Would it