Re: Fwd: RFR: 8247536: Support pre-generated MethodHandle lambda forms in CDS

2020-08-12 Thread sundararajan . athijegannathan
* File: InvokerBytecodeGeneratorHelper.java copyright header has GNU without the "Classpath exception" clause. * The comment could say this string prefix is known in hotspot (classFileParser.cpp hard codes it) + // The log prefix for tracing resolve + static final String CDS_LOG_PREFIX =

Re: RFR(L) 8244778 Archive full module graph in CDS

2020-08-12 Thread Ioi Lam
Hi Lois, Thanks for the comments. I have an updated webrev http://cr.openjdk.java.net/~iklam/jdk16/8244778-archive-full-module-graph.v02/ http://cr.openjdk.java.net/~iklam/jdk16/8244778-archive-full-module-graph.v02.delta/ Here are the general notes on the changes. Replies to your questions

Re: RFR[8238286]: 'Add new flatMap stream operation that is more amenable to pushing’

2020-08-12 Thread Remi Forax
Hi Patrick, I still don't like the fact that IntMapMultiConsumer, DoubleMapMultiConsumer and LongMapMultiConsumer are not in java.util.function unlike all other functional interfaces used by the Stream API. Otherwise looks good. regards, Rémi - Mail original - > De: "Patrick

Re: Review Request JDK-8244090: public lookup should find public members of public exported types

2020-08-12 Thread Lois Foltan
On 8/11/2020 2:00 PM, Mandy Chung wrote: It was agreed in an offline discussion with Lois, Kim and John that this work should wait for the integration of JDK-8247938 and JEP 347 Enable C++ 14 features. This patch is updated to use scoped enum consistent with JDK-8247938. Updated webrev:

Re: Fwd: RFR: 8247536: Support pre-generated MethodHandle lambda forms in CDS

2020-08-12 Thread calvin . cheung
Hi Yumin, I reviewed mostly the native code. Below are my comments: 1) classListParser.hpp 71   bool    _lambda_format; The above name is too generic. How about _lambda_form or _is_lambda_form? If you rename the above, please also rename the function which returns the above bool.

Re: RFR[testbug]: 8251189: com/sun/jndi/ldap/LdapDnsProviderTest.java failed due to timeout

2020-08-12 Thread Aleks Efimov
Daniel, Vyom, Thanks for your reviews Best Regards, Aleksei On 11/08/2020 14:12, Vyom Tiwari wrote: +1 Vyom On Tue, Aug 11, 2020 at 4:39 PM Daniel Fuchs > wrote: Hi Aleksei, Looks good to me! best regards, -- daniel On 06/08/2020

Re: Possible subtle memory model error in ClassValue

2020-08-12 Thread Andrew Dinn
On 11/08/2020 18:06, Hans Boehm wrote: > I think the relevant statement is: > > "An address dependency between two reads generated by SVE vector load > instructions does not contribute to the Dependency-ordered-before relation." > > This is only an issue if BOTH loads are SVE loads. In

Re: 8245304: Re-examine ThreadLocal usage in java.math.BigDecimal

2020-08-12 Thread Alan Bateman
On 11/08/2020 18:32, Brian Burkhalter wrote: To fix [1], please consider [2] which replaces the ThreadLocal “threadLocalStringBuilderHelper” with straightforward use of a StringBuilderHelper instance. The initial capacity of the StringBuilder instance variable of StringBuilderHelper is also