Re: Review Request JDK-8186050: StackFrame should provide the method signature

2017-09-01 Thread Alan Bateman
On 01/09/2017 06:39, mandy chung wrote: Updated webrev: http://cr.openjdk.java.net/~mchung/jdk10/webrevs/8186050/webrev.01/index.html This introduces two new methods, StackFrame::getMethodType and StackFrame::getDescriptor. The two new methods look good. -Alan

Re: Review Request JDK-8186050: StackFrame should provide the method signature

2017-09-01 Thread mandy chung
On 9/1/17 2:57 AM, fo...@univ-mlv.fr wrote: Hi Mandy, good for me. in Basic.java, in methodTypes(), instead of using a new HashMap, you can use Map.of(). Yes will fix it before push. Mandy cheers, Rémi - Mail original - De: "mandy chung" À: "Remi Forax"

Re: Review Request JDK-8186050: StackFrame should provide the method signature

2017-09-01 Thread mandy chung
Please also review CSR: https://bugs.openjdk.java.net/browse/JDK-8186872 Mandy On 8/31/17 10:39 PM, mandy chung wrote: Updated webrev: http://cr.openjdk.java.net/~mchung/jdk10/webrevs/8186050/webrev.01/index.html This introduces two new methods, StackFrame::getMethodType and

Re: RFR JDK-8186751: Add ISO-8859-16 Charset support

2017-09-01 Thread Alan Bateman
On 31/08/2017 03:14, Xueming Shen wrote: Hi, Please help review the changeset to add the 8859_1 charset support. issue: https://bugs.openjdk.java.net/browse/JDK-8186751 webrev: http://cr.openjdk.java.net/~sherman/8186751/webrev Looks good. -Alan

Re: Review Request JDK-8186050: StackFrame should provide the method signature

2017-09-01 Thread Brent Christian
Looks good. I have only one (minor) comment. In the new Javadoc for getMethodType(): StackWalker.java: 133 * Returns {@link MethodType} representing the parameter types and The docs for similar methods all begin with, "Returns _the_ ..." -Brent On 08/31/2017 10:39 PM, mandy

Re: Review Request JDK-8186050: StackFrame should provide the method signature

2017-09-01 Thread mandy chung
On 9/1/17 10:21 AM, Brent Christian wrote: Looks good.  I have only one (minor) comment. In the new Javadoc for getMethodType(): StackWalker.java:  133  * Returns {@link MethodType} representing the parameter types and The docs for similar methods all begin with, "Returns _the_

Re: [10] RFR 8180469: Wrong short form text for supplemental Japanese era

2017-09-01 Thread Naoto Sato
Hi Mitsuru-san, Yes, I remember we discussed on this issue before. The reason that LONG and SHORT names for Japanese era are the same is that CLDR's era names are not very consistent on length. They have "eraNames", "eraAbbr", and "eraNarrow" variations. We simply assign LONG to eraNames and

Re: RFR: JDK-8186947: Fix accessibility and other issues in the java.xml.ws module

2017-09-01 Thread Lance Andersen
looks fine Jon > On Sep 1, 2017, at 4:34 PM, Jonathan Gibbons > wrote: > > Please review this small change to fix a broken link in the API docs for the > java.xml.ws module. > > Although I've also posted a full webrev and API, the change is more easily > seen

Re: RFR JDK-8186751: Add ISO-8859-16 Charset support

2017-09-01 Thread Ulf Zibis
Hi again, Am 31.08.2017 um 23:29 schrieb Xueming Shen: The 8859-16 aliases are the copy/paste from https://www.iana.org/assignments/character-sets/character-sets.xhtml From the same page we have the followings for 8859-15 ISO_8859-15 Latin-9 csISO885915 It appears only the first one is

RFR: JDK-8186946: Fix accessibility and other issues in the java.xml.bind module

2017-09-01 Thread Jonathan Gibbons
Please review these changes to address accessibility and other minor issues in the API docs for the java.xml.bind module. JBS: https://bugs.openjdk.java.net/browse/JDK-8186946 Webrev: http://cr.openjdk.java.net/~jjg/8186946/webrev API:

RFR: JDK-8186947: Fix accessibility and other issues in the java.xml.ws module

2017-09-01 Thread Jonathan Gibbons
Please review this small change to fix a broken link in the API docs for the java.xml.ws module. Although I've also posted a full webrev and API, the change is more easily seen here: --- old/src/java.xml.ws/share/classes/javax/xml/ws/wsaddressing/W3CEndpointReferenceBuilder.java

Re: RFR: JDK-8186946: Fix accessibility and other issues in the java.xml.bind module

2017-09-01 Thread mandy chung
Typo in the href link: e.g.See should be {@docRoot}/javax/xml/bind/XXX.html Mandy On 9/1/17 1:34 PM, Jonathan Gibbons wrote: Please review these changes to address accessibility and other minor issues in the API docs for the java.xml.bind module. JBS:

Re: Update: Re: RFR: JDK-8186946: Fix accessibility and other issues in the java.xml.bind module

2017-09-01 Thread mandy chung
No worries.  Thanks for doing all these javadoc cleanup. Mandy On 9/1/17 2:42 PM, Jonathan Gibbons wrote: Sigh. The bad news is that I accidentally committed and pushed the changes for this issue (JDK-8186946) before they had been approved, along with the changes for JDK-8186947, which had

Update: Re: RFR: JDK-8186946: Fix accessibility and other issues in the java.xml.bind module

2017-09-01 Thread Jonathan Gibbons
Sigh. The bad news is that I accidentally committed and pushed the changes for this issue (JDK-8186946) before they had been approved, along with the changes for JDK-8186947, which had been approved. The good news is that I had already addressed and verified Mandy's comments regarding broken

Re: RFR JDK-8186751: Add ISO-8859-16 Charset support

2017-09-01 Thread Florent Guillaume
Hi, >From https://www.cs.tut.fi/~jkorpela/latin9.html: > Originally (http://www.indigo.ie/egt/standards/iso8859/latin00.html) the project > which lead to the creation of ISO Latin 9 used the working name "Latin Alphabet > Number Zero" for it. Therefore it has often been referred to as "Latin 0".

Re: RFR: JDK-8186947: Fix accessibility and other issues in the java.xml.ws module

2017-09-01 Thread mandy chung
+1 Mandy On 9/1/17 1:34 PM, Jonathan Gibbons wrote: Please review this small change to fix a broken link in the API docs for the java.xml.ws module. Although I've also posted a full webrev and API, the change is more easily seen here: ---

Re: RFR: JDK-8186947: Fix accessibility and other issues in the java.xml.ws module

2017-09-01 Thread joe darcy
+1 -Joe On 9/1/2017 1:34 PM, Jonathan Gibbons wrote: Please review this small change to fix a broken link in the API docs for the java.xml.ws module. Although I've also posted a full webrev and API, the change is more easily seen here: ---

Re: RFR: JDK-8186946: Fix accessibility and other issues in the java.xml.bind module

2017-09-01 Thread Lance Andersen
Looks fine except for what mandy pointed out which is is a few files. > On Sep 1, 2017, at 4:50 PM, mandy chung wrote: > > Typo in the href link: > e.g.See > > should be {@docRoot}/javax/xml/bind/XXX.html > > Mandy > > On 9/1/17 1:34 PM, Jonathan Gibbons wrote: >>

Re: RFR JDK-8186464: ZipFile cannot read some InfoZip ZIP64 zip files

2017-09-01 Thread Xueming Shen
On 8/22/17, 5:54 PM, Martin Buchholz wrote: On Tue, Aug 22, 2017 at 3:27 PM, Xueming Shen > wrote: How about to add an option to our zipfs to force the ZIP64 end record when enabled. Harmless if not specified. I agree

Re: RFR: 8187033: [PPC] Imporve performance of ObjectStreamClass.getClassDataLayout()

2017-09-01 Thread Kazunori Ogata
Hi Aleksey and Hans, Thank you for your comments. I'll try to see how much Unsafe approach improves performance. I'm now thinking the approach to use final that Aleksey mentioned in the first reply is a good one. I checked the JIT generated code. It puts MEMBAR-store-store and

Re: Review Request JDK-8186050: StackFrame should provide the method signature

2017-09-01 Thread forax
Hi Mandy, good for me. in Basic.java, in methodTypes(), instead of using a new HashMap, you can use Map.of(). cheers, Rémi - Mail original - > De: "mandy chung" > À: "Remi Forax" > Cc: "core-libs-dev" >

Re: RFR: 8187033: [PPC] Imporve performance of ObjectStreamClass.getClassDataLayout()

2017-09-01 Thread Aleksey Shipilev
On 08/31/2017 09:39 PM, Hans Boehm wrote: >> I guess you can make VarHandle.fullFence() between getClassDataLayout0() and >> storing it to the >> non-volatile field... > > ... with the usual warning about this sort of thing: > > According to the JMM, it's not guaranteed to work, because the