Re: [12] RFR 8208483: Add 5 JNDI tests to com/sun/jndi/dns/FactoryTests/

2018-08-07 Thread Chris Yin
Hi, Vyom Thanks a lot for your comment, I didn’t realize it, sure, I moved this constant to LookupFactoryBase as you suggested and also abstract the same verify logic into base class as ‘verifyLookupObjectAndValue’, hope that looks better, update new webrev as below, thanks

Re: RFR (XXS) 8201394: Update java.se module summary to reflect removal of java.se.ee module

2018-08-07 Thread mandy chung
On 8/6/18 8:21 PM, Iris Clark wrote: diff -r 331888ea4a78 src/java.se/share/classes/module-info.java --- a/src/java.se/share/classes/module-info.javaTue Jul 31 14:04:29 2018 -0700 +++ b/src/java.se/share/classes/module-info.javaMon Aug 06 14:53:37 2018 -0700 @@ -24,7 +24,7

Re: 8143850: retrofit ArrayDeque to implement List

2018-08-07 Thread Roger Riggs
Hi, Compare with sun.awt.util.IdentityLinkedList.java; not likely to be exactly what you are looking for but it is an implementation with similar features. $.02, Roger On 8/4/18 4:11 AM, Peter Levart wrote: Hi all, On 08/04/2018 01:51 AM, Stuart Marks wrote: Thanks, Patrick! This is very

Re: JDK 12 RFR of JDK-8209024: Use SuppressWarnings on serialVersionUID fields in interfaces

2018-08-07 Thread Alan Bateman
On 06/08/2018 20:11, joe darcy wrote: Hello, Various interfaces in the JDK extend Serializable and declare serialVersionUID fields. Such fields are ineffectual and @SuppressWarnings("serial") should be applied to such fields to suppress future planned serial lint checks (JDK-8202056).

[12]RFR 8208656: Move java/util/Calendar/CalendarTestScripts tests into OpenJDK

2018-08-07 Thread Ying Zhou
Hello, Please help review the patch to move some tests to OpenJDK. Thank you! Bug: https://bugs.openjdk.java.net/browse/JDK-8208656 Webrev: http://cr.openjdk.java.net/~dzhou/8208656/webrev.00/ Regards, Daisy

Re: RFR (XXS) 8201394: Update java.se module summary to reflect removal of java.se.ee module

2018-08-07 Thread Alan Bateman
On 07/08/2018 04:21, Iris Clark wrote: : This is the diff: diff -r 331888ea4a78 src/java.se/share/classes/module-info.java --- a/src/java.se/share/classes/module-info.javaTue Jul 31 14:04:29 2018 -0700 +++ b/src/java.se/share/classes/module-info.javaMon Aug 06 14:53:37 2018

Re: [11] RFR: 8208691: Tighten up jdk.includeInExceptions security property

2018-08-07 Thread Alan Bateman
On 06/08/2018 20:23, Sean Mullan wrote: After further evaluation of the new jdk.includeInExceptions security property originally introduced in JDK-8204233 [1] and further generalized in JDK-8207846 [2], I felt that a stronger warning should be added to the description of the property alerting

Re: RFR(XXS): 8209018 ProblemList tests affected by JDK-8208690

2018-08-07 Thread Alan Bateman
On 06/08/2018 17:49, Daniel D. Daugherty wrote: : +java/net/Socket/LingerTest.java 8208690 generic-all +sun/net/www/http/HttpClient/MultiThreadTest.java 8208690 generic-all +   Can these tests be changed to /othervm

RE: RFR (XXS) 8201394: Update java.se module summary to reflect removal of java.se.ee module

2018-08-07 Thread Iris Clark
Pushed. Thank your Lance, Alan, and Mandy for the super-fast reviews! iris -Original Message- From: mandy chung Sent: Tuesday, August 7, 2018 10:39 AM To: Iris Clark Cc: core-libs-dev Subject: Re: RFR (XXS) 8201394: Update java.se module summary to reflect removal of java.se.ee

Re: RFR: 8209003: Consolidate use of empty collections in java.lang.module

2018-08-07 Thread Claes Redestad
Alan, Mandy, thanks for reviewing. Pushed. /Claes On 2018-08-07 21:05, mandy chung wrote: This cleanup looks fine. Mandy

Re: [12] (AIX) 8207744: Clean up inconsistent use of opendir/closedir versus opendir64/closedir64

2018-08-07 Thread Brian Burkhalter
Hi Matthias, Yes, that was intentional. From the documentation it looks as if the Linux / Solaris *64 functions in question are now legacy so I changed them for hopefully better consistency. I did not see any problems in building or testing with these changes. If someone knows these changes to

Re: [12] RFR 8208279: Add 8 JNDI tests to com/sun/jndi/dns/EnvTests/

2018-08-07 Thread Chris Yin
Thank you Roger, sure, I will expand initContext() inline in the test method for future tests Regards, Chris > On 8 Aug 2018, at 3:11 AM, Roger Riggs wrote: > > Hi Chris, > > Looks ok. > > For future tests, I think I would put the contents of the initContext() > methods inline in the test

Re: [12] RFR 8208483: Add 5 JNDI tests to com/sun/jndi/dns/FactoryTests/

2018-08-07 Thread Chris Yin
Just one more minor revision to expand initContext() into test method for easier read, new webrev as below, thanks http://cr.openjdk.java.net/~xyin/8208483/webrev.04/ Regards, Chris > On 7 Aug 2018, at 5:41 PM, Chris Yin wrote: > > Hi, Vyom > > Thanks a lot for your comment, I didn’t

Re: [11] RFR(S) : 8205687 : TimeoutHandler generates huge core files

2018-08-07 Thread David Holmes
Hi Igor, This all seems okay. However we probably need to check that the people operating their own build/test farms are okay with this change. Don't forget to update copyright years. Minor comment below ... On 8/08/2018 7:19 AM, Igor Ignatyev wrote:

Re: RFR: 8209003: Consolidate use of empty collections in java.lang.module

2018-08-07 Thread Alan Bateman
On 07/08/2018 17:16, Claes Redestad wrote: Hi, feel free to review this cleanup to consolidate some uses of Collections.empty/unmodifiableXx.. to Set/Map/List.of()/copyOf(), as appropriate. This aligns better with code already generated by jlink, so avoids observing a mix of many

Re: RFR: 8209003: Consolidate use of empty collections in java.lang.module

2018-08-07 Thread mandy chung
This cleanup looks fine. Mandy On 8/7/18 9:16 AM, Claes Redestad wrote: Hi, feel free to review this cleanup to consolidate some uses of Collections.empty/unmodifiableXx.. to Set/Map/List.of()/copyOf(), as appropriate. This aligns better with code already generated by jlink, so avoids

Re: [12] RFR 8208279: Add 8 JNDI tests to com/sun/jndi/dns/EnvTests/

2018-08-07 Thread Roger Riggs
Hi Chris, Looks ok. For future tests, I think I would put the contents of the initContext() methods inline in the test method so the setup and the testing of the conditions were in the same method, making it easier to read. Thanks, Roger On 8/6/2018 11:53 PM, Chris Yin wrote: Hi, Roger

[11] RFR(S) : 8205687 : TimeoutHandler generates huge core files

2018-08-07 Thread Igor Ignatyev
http://cr.openjdk.java.net/~iignatyev//8205687/webrev.00/index.html > 18 lines changed: 3 ins; 5 del; 10 mod; Hi all, could you please review this small fix for TimeoutHandler? gcore dumps non committed memory, which is a problem when JVM is run w/ ZGC or in other configurations where memory

RFR 8209064: Make intellij support more robust after changes for 2018.2

2018-08-07 Thread Maurizio Cimadamore
Hi, last week I submitted an 'emergency' patch to fix intellij project support after 2018.2 changes. The goal of these changes was to move the build.xml ant file out of the .idea folder, as the IDE no longer supported DOM indexing in such folders (as a result of

Re: RFR(XXS): 8209018 ProblemList tests affected by JDK-8208690

2018-08-07 Thread Daniel D. Daugherty
On 8/7/18 2:29 AM, Alan Bateman wrote: On 06/08/2018 17:49, Daniel D. Daugherty wrote: : +java/net/Socket/LingerTest.java 8208690 generic-all +sun/net/www/http/HttpClient/MultiThreadTest.java 8208690 generic-all +  

Re: [11] RFR: 8208691: Tighten up jdk.includeInExceptions security property

2018-08-07 Thread Sean Mullan
On 8/7/18 3:09 AM, Alan Bateman wrote: On 06/08/2018 20:23, Sean Mullan wrote: After further evaluation of the new jdk.includeInExceptions security property originally introduced in JDK-8204233 [1] and further generalized in JDK-8207846 [2], I felt that a stronger warning should be added to

Re: RFR (XXS) 8201394: Update java.se module summary to reflect removal of java.se.ee module

2018-08-07 Thread Lance Andersen
Hi Iris I think the revised wording is fine > On Aug 6, 2018, at 11:21 PM, Iris Clark wrote: > > Hi. > > Please review the following minor change to update the java.se > module summary. > >8201394: Update java.se module summary to reflect removal of java.se.ee > module >

Re: RFR: JDK-8205461 Create Collector which merges results of two other collectors

2018-08-07 Thread Peter Levart
Hi Tagir, Unless you have already got a sponsor (can't remember if somebody already offered you a sponsorship), I can volunteer. Regarding the code, I only have one comment about the naming of the last parameter: "finisher". To avoid confusion, it would be good to name it differently from

Re: [12] RFR 8208483: Add 5 JNDI tests to com/sun/jndi/dns/FactoryTests/

2018-08-07 Thread vyom tewari
Hi Chris, Overall latest code looks good to me, one minor comment did you consider moving  "private static final String ATTRIBUTE_VALUE = "1.2.4.1";" in "LookupFactoryBase" ? as both LookupWithAnyAttrProp & LookupWithAttrProp inherit "LookupFactoryBase". .Thanks, Vyom On Monday 06 August

RE: [12] (AIX) 8207744: Clean up inconsistent use of opendir/closedir versus opendir64/closedir64

2018-08-07 Thread Baesken, Matthias
Hi Brian, small remark from my side , looks like you changed in src/java.base/unix/native/libjava/TimeZone_md.c src/java.base/unix/native/libjava/childproc.c and src/jdk.management/unix/native/libmanagement_ext/OperatingSystemImpl.c at some places dirent64 / readdir64 to dirent /

RFR: 8209003: Consolidate use of empty collections in java.lang.module

2018-08-07 Thread Claes Redestad
Hi, feel free to review this cleanup to consolidate some uses of Collections.empty/unmodifiableXx.. to Set/Map/List.of()/copyOf(), as appropriate. This aligns better with code already generated by jlink, so avoids observing a mix of many implementation classes in some places.. Webrev:

Re: RFR: JDK-8205461 Create Collector which merges results of two other collectors

2018-08-07 Thread Roger Riggs
Hi, As an API addition, it will need a CSR as well and it should have a couple of reviewers that are fully aware of Streams design. Regards, Roger On 8/7/18 4:08 AM, Peter Levart wrote: Hi Tagir, Unless you have already got a sponsor (can't remember if somebody already offered you a

Re: Draft JEP proposal: JDK-8200758: Packaging Tool

2018-08-07 Thread Lennart Börjeson
I'm concerned about the possible loss of the packager service, i.e. the UserJvmOptionsService class and associated underlying machinery in the jpackager. Background: I'm developing and maintaining an internal GUI tool for log analysis. It reads, parses and aggregates data from many different

RE: [RFR] 8205525 : Improve exception messages during manifest parsing of jar archives

2018-08-07 Thread Baesken, Matthias
Ping  , any reviews / comments ? Thanks , Matthias > -Original Message- > From: Baesken, Matthias > Sent: Dienstag, 31. Juli 2018 12:28 > To: 'Chris Hegarty' ; Alan Bateman > > Cc: core-libs-dev@openjdk.java.net; Lindenmaier, Goetz > ; Langer, Christoph > > Subject: RE: [RFR]

Re: RFR: JDK-8205461 Create Collector which merges results of two other collectors

2018-08-07 Thread Brian Goetz
On 6/21/2018 12:33 AM, Tagir Valeev wrote: Please review and sponsor: https://bugs.openjdk.java.net/browse/JDK-8205461 http://cr.openjdk.java.net/~tvaleev/webrev/8205461/r1/ See also previous discussion thread at [1]. It seems that we did not reach the final conclusion about the collector