Re: Review Request for 6878481: Add performance counters in the JDK

2009-09-13 Thread Alan Bateman
Mandy Chung wrote: Alan, David, Remi, Iris, Thanks for the review and the revised webrev at: http://cr.openjdk.java.net/~mchung/6878481/webrev.01/ I incorporate the comments you have and minimize the number of System.nanoTime() calls and also remove the number of opened jars perf

Re: Replacement of Quicksort in java.util.Arrays with new Dual-Pivot Quicksort

2009-09-13 Thread Goktug Gokdogan
I reviewed the code. A few simple tricks helped me to speed-up code in my tests:1. Falling back-to insertion sort at 17 instead of 27 (JDK 6 Arrays.sort falls back 7) 2. (a[great] pivot2) test is more likely to fail compared to (k great) in the while loop, so exchange them (ie. use while

Re: 4206909 - adding Z_SYNC_FLUSH support to deflaters

2009-09-13 Thread David M. Lloyd
On 09/12/2009 04:45 PM, Martin Buchholz wrote: On Fri, Sep 11, 2009 at 16:13, Xueming Shenxueming.s...@sun.com wrote: David wrote: This is not unusual in the JDK or elsewhere - that a stream calls the underlying stream's flush() method I mean - and I think in the (unlikely) event that someone

Re: Replacement of Quicksort in java.util.Arrays with new Dual-Pivot Quicksort

2009-09-13 Thread Oleg Anashkin
Hello Vladimir, First thing that came to mind - have you thought about extrapolating this approach to more pivots? If 2-pivot algorithm is faster than 1-pivot, then 3-pivot might be even faster, right? Can the number of pivots be chosen as a function of array size (to mitigate overhead)? Thanks,

Re: 4206909 - adding Z_SYNC_FLUSH support to deflaters

2009-09-13 Thread Alan Bateman
Martin Buchholz wrote: : The use case for full flush is partial recoverability from future corruption of the data. If the competing java zib libraries are supporting this flush variant, we probably should too, for completeness. It's worth considering although we get into detail as to how the

Re: Review Request for 6878481: Add performance counters in the JDK

2009-09-13 Thread David Holmes - Sun Microsystems
Just to add 2c to Alan's method naming comments: Alan Bateman said the following on 09/13/09 18:07: Method naming is hard (and often subjective) but there are updates like this: PerfCounter.getParentDelegationTime.inc(t1 - t0); which might be easier to read as:

Re: Review Request for 6878481: Add performance counters in the JDK

2009-09-13 Thread Mandy Chung
Alan, David, Thanks for the review. Comments inlined below. Alan Bateman wrote: Minor nit but I assume you can initialize perf as: private static final Perf perf = AccessController.doPrivileged(new Perf.GetPerfAction()); Fixed. David Holmes wrote: Just to add 2c to Alan's method

Re: AWT Dev Review Request for 6879044

2009-09-13 Thread Oleg Sukhodolsky
On Mon, Sep 14, 2009 at 5:32 AM, Mandy Chung mandy.ch...@sun.com wrote: 6879044: Eliminate the dependency of logging from the JRE core/awt/swing classes Webrev:  http://cr.openjdk.java.net/~mchung/6879044/webrev.00/ Summary: 1. A new sun.util.logging.PlatformLogger class that will handle

Re: 4206909 - adding Z_SYNC_FLUSH support to deflaters

2009-09-13 Thread Xueming Shen
The ZOutputStream of the competing jzlib has its flush control in its write() method, it invokes defalter.deflate() with a flush parameter, the flushparameter is a protected instance variable of the ZOutputStream class with a default value of z_no_flush. So its subclass can set whatever value