Re: RFR: 8196340: (coll) Examine overriding inherited methods in ArrayList and ArrayList.SubList

2018-05-11 Thread Ivan Gerasimov
Hi Claes! One thing I can't figure out is why both these two checks are necessary: 1303 checkForComodification(); 1304 root.checkForComodification(expectedModCount); The former compares the current root.modCount with the one at the time this subList was created. The

Re: RFR: 8196340: (coll) Examine overriding inherited methods in ArrayList and ArrayList.SubList

2018-05-11 Thread Claes Redestad
Good, this demonstrates the gain from specializing o.getClass() == ArrayList.class, which is most of the speed-up here as well as in my own micro: Patched: Method  Millis Ratio ArrayList equals    17 1.000 ArrayList$SubList equals   108 6.312

Re: RFR: 8196340: (coll) Examine overriding inherited methods in ArrayList and ArrayList.SubList

2018-05-11 Thread Claes Redestad
Anyhow, this is the current state of things: http://cr.openjdk.java.net/~redestad/8196340/open.01/ I think the remaining difference between ArrayList$SubList and COWAL is down to the comodification checks in the former eating up too much inlining budget, but haven't had any luck yet. /Claes

Re: RFR(XS): 8202329 [AIX] Fix codepage mappings for IBM-943 and Big5

2018-05-11 Thread Thomas Stüfe
Great! So far we (sap) have developed the AIX port alone, good to finally have IBM on our side :) For authorship/committership info, see: See: http://openjdk.java.net/contribute/ Among other things, your patches need to be ran through a battery of tests at

Re: RFR: JDK-8200377 String::strip, String::stripLeading, String::stripTrailing

2018-05-11 Thread Sundararajan Athijegannathan
Looks good. http://mail.openjdk.java.net/pipermail/core-libs-dev/2018-May/053034.html Thanks, -Sundar

Re: RFR(XS): 8202329 [AIX] Fix codepage mappings for IBM-943 and Big5

2018-05-11 Thread Bhaktavatsal R Maram
Hi Thomas, Yes, there are many more to come :) - Bhaktavatsal -"Thomas Stüfe" wrote: - To: Ichiroh Takiguchi , Bhaktavatsal R Maram From: "Thomas Stüfe" Date: 05/11/2018 11:49AM Cc:

Re: RFR(XS): 8202329 [AIX] Fix codepage mappings for IBM-943 and Big5

2018-05-11 Thread Thomas Stüfe
Hi, I'll test and review next week. We also have some in-house tests which I'd like to run. You IBM folks should really apply for authorship so that this contribution process gets streamlined. After all, if something breaks in this code, you want to be able to fix it, yes? So even if you do not

Re: RFR: 8201274: Launch Single-File Source-Code Programs

2018-05-11 Thread Maurizio Cimadamore
Thumbs up - thanks for taking the comments into account. Great job! Maurizio On 04/05/18 22:59, Jonathan Gibbons wrote: Here's an update to the previously proposed patch for JEP 330: Launch Single-File Source-Code Programs. It includes all review feedback so far. The changes are mostly

RFR 8202708, Add a check of opening stream for not-existing UNC url

2018-05-11 Thread Felix Yang
Hi all,    please review a change to add additional checking for opening stream with not-existing UNC url. Bug:     https://bugs.openjdk.java.net/browse/JDK-8202708 Webrev:     http://cr.openjdk.java.net/~xiaofeya/8202708/webrev.00/ Thanks, Felix

Re: [11] RFR for JDK-8202544: Hide unused exports in libzip

2018-05-11 Thread Alexey Ivanov
Hi Christoph, Thank you for your review. I was checking the changeset before pushing and noticed I had forgotten to remove JNIEXPORT modifier from ZIP_GetEntry in zip_util.h. Here's the updated webrev: http://cr.openjdk.java.net/~aivanov/8202544/jdk11/webrev.1/ The only difference with

Re: [AIX] Add charset IBM-964 (default charset for zh_TW.IBM-eucTW) to stdcs

2018-05-11 Thread Ichiroh Takiguchi
Hello Bhaktavatsal. We may need to contribute some IBM's EUC converters. They may extend SimpleEUCEncoder. I think, for maintenance, SimpleEUCEncoder should be under sun.nio.cs. On 2018-05-11 12:20, Bhaktavatsal R Maram wrote: Hi Ichiroh, Yes, moving SimpleEUCEncoder.java to sun.nio.cs

Re: Initial JDK 11 RFR of JDK-8202385: Annotation to mark serial-related fields and methods

2018-05-11 Thread Alan Bateman
On 10/05/2018 16:55, joe darcy wrote: Hello, Please review the webrev (code below) to address     JDK-8202385: Annotation to mark serial-related fields and methods     http://cr.openjdk.java.net/~darcy/8202385.0/ I see the exchange with Roger about Externalizable and I think the wording looks

Re: RFR 8202708, Add a check of opening stream for not-existing UNC url

2018-05-11 Thread Roger Riggs
Hi Felix, Looks fine Roger On 5/11/18 6:15 AM, Felix Yang wrote: Hi all,    please review a change to add additional checking for opening stream with not-existing UNC url. Bug:     https://bugs.openjdk.java.net/browse/JDK-8202708 Webrev:    

Re: RFR: jsr166 jdk integration 2018-05

2018-05-11 Thread Paul Sandoz
> On May 9, 2018, at 11:17 AM, Martin Buchholz wrote: > > Time to do this, since Claes is also touching ArrayList. > > http://cr.openjdk.java.net/~martin/webrevs/jdk/jsr166-integration/overview.html > >

RE: RFR (S): 8202915: [JAXP] Performance enhancements and cleanups in com.sun.org.apache.xerces.internal.impl.dtd.XMLDTDValidator

2018-05-11 Thread Langer, Christoph
Hi Joe, jaxp_all ran well - I'll push this one next week then. Thanks Christoph From: Joe Wang [mailto:huizhe.w...@oracle.com] Sent: Freitag, 11. Mai 2018 00:03 To: Langer, Christoph ; core-libs-dev@openjdk.java.net Subject: Re: RFR (S): 8202915: [JAXP] Performance

RFR: 8202997: Split test/jdk/:tier1 to enable better parallel execution

2018-05-11 Thread Christian Tornqvist
Please review this small change that splits the test/jdk/:tier1 group into 3 parts to enable us to better execute it in parallel, also fixed the tier2 group to correctly include java/util/Arrays/TimSortStackSize2.java Webrev: http://cr.openjdk.java.net/~ctornqvi/webrev/8202997/webrev.00/

RFR: 8196340: (coll) Examine overriding inherited methods in ArrayList and ArrayList.SubList

2018-05-11 Thread Claes Redestad
Hi, ArrayList doesn't override AbstracList#equals, and ArrayList$SubList doesn't override indexOf and equals. This provides specialized and more efficient implementations. Webrev: http://cr.openjdk.java.net/~redestad/8196340/open.00/ Bug: https://bugs.openjdk.java.net/browse/JDK-8196340

speedup factors of the proposed re-implementation of Double.toString(double)

2018-05-11 Thread raffaello . giulietti
Hi, in order to elicit some concrete interest in the proposed re-implementation of Double.toString(double) [1] to overcome the known issues [2], I prepared a jar in [3] that runs some benchmarks comparing the execution times. It can be executed directly as: java --module-path todecbench.jar

Re: RFR: JDK-8202788: Explicitly reclaim cached thread-local direct buffers at thread exit

2018-05-11 Thread Alan Bateman
On 08/05/2018 16:07, Tony Printezis wrote: Hi all, Following the discussion on this a few weeks ago, here’s the first version of the change: http://cr.openjdk.java.net/~tonyp/8202788/webrev.0/ I think the consensus was that it’d be easier if the exit hooks were only available within

RE: [11] RFR for JDK-8202544: Hide unused exports in libzip

2018-05-11 Thread Langer, Christoph
Hi Alexey, good catch, I missed that. Best regards Christoph > -Original Message- > From: Alexey Ivanov [mailto:alexey.iva...@oracle.com] > Sent: Freitag, 11. Mai 2018 13:21 > To: Langer, Christoph ; core-libs d...@openjdk.java.net>; hotspot-dev

Re: RFR: jsr166 jdk integration 2018-05

2018-05-11 Thread Claes Redestad
On 2018-05-09 20:17, Martin Buchholz wrote: 8202685: Improve ArrayList replaceAll http://cr.openjdk.java.net/~martin/webrevs/jdk/jsr166-integration/replaceAll/index.html

Re: RFR: JDK-8200377 String::strip, String::stripLeading, String::stripTrailing

2018-05-11 Thread Roger Riggs
Hi Jim, The implementations of the strip methods in StringLatin1 and StringUTF16 should return the original string if there is no  leading/trailing whitespace.  It will save a test for null and replacement in java.lang.String methods. It also seems odd that for the empty string, a new empty

Re: RFR: 8201274: Launch Single-File Source-Code Programs

2018-05-11 Thread Jan Lahoda
On 11.5.2018 12:31, Maurizio Cimadamore wrote: Thumbs up - thanks for taking the comments into account. Great job! +1 Jan Maurizio On 04/05/18 22:59, Jonathan Gibbons wrote: Here's an update to the previously proposed patch for JEP 330: Launch Single-File Source-Code Programs. It

Re: Initial JDK 11 RFR of JDK-8202385: Annotation to mark serial-related fields and methods

2018-05-11 Thread David Lloyd
On Thu, May 10, 2018 at 7:52 PM, joe darcy wrote: > Hi David, > > On 5/10/2018 1:39 PM, David Lloyd wrote: >> >> Would it be allowed to enable the serial lint without using the >> @Serial annotation? >> >> > > Certainly. > > A limited serial lint checker already exists in

Re: Review Request JDK-8202113: Reflection API is causing caller classes to leak

2018-05-11 Thread Alan Bateman
On 11/05/2018 17:09, mandy chung wrote: It could but leave it as is.  I found that this change breaks the hack that uses reflection to change a static final field by changing the private modifiers field in the Field object. That is a terrible hack but I think it's better to separate this

Re: RFR: jsr166 jdk integration 2018-05

2018-05-11 Thread Martin Buchholz
On Fri, May 11, 2018 at 9:06 AM, Paul Sandoz wrote: > > > On May 9, 2018, at 11:17 AM, Martin Buchholz wrote: > > Time to do this, since Claes is also touching ArrayList. > > http://cr.openjdk.java.net/~martin/webrevs/jdk/jsr166- >

Re: [AIX] Add charset IBM-964 (default charset for zh_TW.IBM-eucTW) to stdcs

2018-05-11 Thread Xueming Shen
SimpleEUCEncoder is something leftover when I reimplemented the charsets to be map-based-built-during-build-time. I would recommend to leave them as Bhaktavatsal suggested for now. Ideally any new charsets added to the platform needs to be based on the new model

Re: [11] RFR: api/java_text/SimpleDateFormat/index.html#Format testcases started to fail with JDK11 b12

2018-05-11 Thread Xueming Shen
+1 On 05/10/2018 12:27 PM, naoto.s...@oracle.com wrote: Hello, Please review the fix to the following issue: https://bugs.openjdk.java.net/browse/JDK-8202764 The proposed fix is located at: http://cr.openjdk.java.net/~naoto/8202764/webrev.00/ This is a regression caused by 8181157, where

Re: RFR: 8196340: (coll) Examine overriding inherited methods in ArrayList and ArrayList.SubList

2018-05-11 Thread Martin Buchholz
Thanks Claes, This all looks correct, but I would - rename the ranged version of lastIndexOf lastIndexOfRange - introduce hashCodeRange and equalsRange - add "final" to all the Object[] es - hesitate to optimize ArrayList.equals(ArrayList). Do you have a particular use case in mind? At

Re: [PATCH] JDK-8159797 Throw a right IllegalArgumentException from the bytecode generated by Method/ConstructorAccessor

2018-05-11 Thread mandy chung
Hi Jaikiran, Thanks for the contribution. With your patch, IAE thrown with empty message is less desirable even though it does not provide less information than the current message (NPE::toString).   I wonder if we could define an exception message in MethodAccessorImpl for this IAE or even

Re: RFR: 8196340: (coll) Examine overriding inherited methods in ArrayList and ArrayList.SubList

2018-05-11 Thread Remi Forax
Hi Claes, lastIndexOf of SubList should call lastIndexOfRange (that should be renamed) instead of indexOfRange. in ArrayList.equals(), i wonder if the test 'if (o.getClass() == ArrayList.class) {' should not be moved in front of the instanceof test, so the JIT may be able to not include a test

Re: Review Request JDK-8202113: Reflection API is causing caller classes to leak

2018-05-11 Thread mandy chung
On 4/30/18 10:21 AM, Alan Bateman wrote: The updated webrev looks good. A minor comment is that I assume you can remove the cast from Executable::declaredAnnotations if you leave Executable::getRoot in place. It could but leave it as is.  I found that this change breaks the hack that

Re: RFR: 8202997: Split test/jdk/:tier1 to enable better parallel execution

2018-05-11 Thread Erik Joelsson
Looks good. /Erik On 2018-05-11 08:43, Christian Tornqvist wrote: Please review this small change that splits the test/jdk/:tier1 group into 3 parts to enable us to better execute it in parallel, also fixed the tier2 group to correctly include java/util/Arrays/TimSortStackSize2.java

Re: RFR: 8196340: (coll) Examine overriding inherited methods in ArrayList and ArrayList.SubList

2018-05-11 Thread Claes Redestad
Hi, On 2018-05-11 19:02, Martin Buchholz wrote: Thanks Claes, This all looks correct, but I would - rename the ranged version of lastIndexOf lastIndexOfRange - introduce hashCodeRange and equalsRange - add "final" to all the Object[] es sure, - hesitate to optimize

Re: RFR: 8196340: (coll) Examine overriding inherited methods in ArrayList and ArrayList.SubList

2018-05-11 Thread Martin Buchholz
Yet another microbenchmark coming your way. Embarrassing to have COWAL win all these so handily. --- IteratorMicroBenchmark.java 11 May 2018 18:19:10 - 1.45 +++ IteratorMicroBenchmark.java 11 May 2018 22:35:32 - 1.46 @@ -564,6 +564,12 @@ sum[0] = 0;

Re: RFR: 8196340: (coll) Examine overriding inherited methods in ArrayList and ArrayList.SubList

2018-05-11 Thread Martin Buchholz
Yet another way to iterate over a collection. Coming in via jsr166 soon. Seeing CopyOnWriteArrayList beat ArrayList decisively suggests that optimizing it is defintely worth doing. And of course the numbers below contain more low-hanging fruit if anyone still cares about the performance of

Re: RFR: 8196340: (coll) Examine overriding inherited methods in ArrayList and ArrayList.SubList

2018-05-11 Thread Claes Redestad
Right, and with the patch I've proposed ArrayList#hashCode is on par with current COWAL on my machine in your micro: $ ~/src/jdk/build/linux-x64/images/jdk/bin/java -cp ./open/test/jdk/java/util/Collection IteratorMicroBenchmark filter=ArrayList.*hashCode.* Method