Re: Hbase packaging

2011-02-17 Thread Stack
On Thu, Feb 17, 2011 at 11:34 AM, Eric Yang ey...@yahoo-inc.com wrote: Hi, I am trying to understand the release package process for HBase.  In the current maven pom.xml, I don't see tarball generation as part of the packaging phase. The assembly plugin does it for us. Run: $ mvn

Re: Hbase packaging

2011-02-17 Thread Eric Yang
Hi Stack, Thanks for the pointer. This is very useful. What do you think about making jar file creation to prepare-package phase, and having assembly:single be part of package phase? This would make room for running both rpm plugin and jdeb plugin in the packaging phase. Enclosed patch can

Re: Hbase packaging

2011-02-17 Thread Eric Yang
Sorry the attachment didn¹t make it through the mailing list. The patch looks like this: Index: pom.xml === --- pom.xml (revision 1071461) +++ pom.xml (working copy) @@ -321,6 +321,15 @@

Re: Hbase packaging

2011-02-17 Thread Eric Yang
Thanks Ted. I will include this build phase patch with the rpm/deb packaging patch. :) Regards, Eric On 2/17/11 12:58 PM, Ted Dunning tdunn...@maprtech.com wrote: Attaching the packaging to the normal life cycle step is a great idea. Having the packaging to RPM and deb packaging all in one

Re: Hbase packaging

2011-02-17 Thread Ryan Rawson
Can there be a way to turn it off for those of us who build and use the .tar.gz but dont want the time sink in generating deb/rpms? On Thu, Feb 17, 2011 at 1:25 PM, Eric Yang ey...@yahoo-inc.com wrote: Thanks Ted.  I will include this build phase patch with the rpm/deb packaging patch. :)

Re: Hbase packaging

2011-02-17 Thread Eric Yang
Hi Ryan, This would fall in the second proposal, use profile as toggle to switch between packaging mechanism. I.e. mvn -DskipTests package builds tarball. mvn -DskipTests package -p rpm,deb builds tarball, rpm and deb. Does this work for you? Regards, Eric On 2/17/11 1:27 PM, Ryan Rawson

Re: Hbase packaging

2011-02-17 Thread Ryan Rawson
Sounds good, thanks! -ryan On Thu, Feb 17, 2011 at 1:40 PM, Eric Yang ey...@yahoo-inc.com wrote: Hi Ryan, This would fall in the second proposal, use profile as toggle to switch between packaging mechanism. I.e. mvn –DskipTests package builds tarball. mvn –DskipTests package –p rpm,deb

Re: Hbase packaging

2011-02-17 Thread Stack
This proposal of using profiles as toggle would be an easier sell. St.Ack On Thu, Feb 17, 2011 at 1:40 PM, Eric Yang ey...@yahoo-inc.com wrote: Hi Ryan, This would fall in the second proposal, use profile as toggle to switch between packaging mechanism. I.e. mvn -DskipTests package

version check for hbase-default.xml

2011-02-17 Thread Ted Yu
We re-package hbase jar into the jar containing our classes. [sjc1-hadoop0.sjc1:hadoop 36789]jar tvf /usr/local/hadoop/sims/lib/flow-m2m_hbase_regr-38.jar | grep MetaSca 7030 Fri Feb 11 11:50:28 GMT+00:00 2011 org/apache/hadoop/hbase/client/MetaScanner.class 2027 Fri Feb 11 11:50:28 GMT+00:00

Re: version check for hbase-default.xml

2011-02-17 Thread Todd Lipcon
Where are you getting the hbase-defaults.xml file that you're packaging into your jar? You need to take it out of the hbase jar that ships with 0.90.1 and package that one -- my guess is you've packaged one from an older version. -Todd On Thu, Feb 17, 2011 at 3:01 PM, Ted Yu yuzhih...@gmail.com

Re: version check for hbase-default.xml

2011-02-17 Thread Ted Yu
An alternative is to check the value of a well-known config parameter which has changed from 20.6 (0.89) to 0.90.x After almost all 0.20.6 and 0.89 deployments are gone in the world, toggle to version check. On Thu, Feb 17, 2011 at 3:51 PM, Ted Yu yuzhih...@gmail.com wrote: Your change cannot

Re: version check for hbase-default.xml

2011-02-17 Thread Todd Lipcon
On Thu, Feb 17, 2011 at 4:19 PM, Ted Yu yuzhih...@gmail.com wrote: My earlier point was that we shouldn't require hbase-default.xml to be present in the classpath because users may repackage hbase jar. We should fault out if there *is* one hbase-default.xml in the classpath *and* it doesn't

Re: version check for hbase-default.xml

2011-02-17 Thread Todd Lipcon
Yes, it has always been an implicit requirement. Now it is an explicit one, because we found people didn't listen to the implicit one. On Thu, Feb 17, 2011 at 4:29 PM, Ted Yu yuzhih...@gmail.com wrote: Was this a requirement for 0.20.6 and 0.89 ? On Thu, Feb 17, 2011 at 4:25 PM, Todd Lipcon

Re: API changes between 0.20.6 and 0.90.1

2011-02-17 Thread Ted Yu
In order to minimize maintenance, we produced an hbase-0.20.6 jar which contains the changed APIs (limited to our use cases) in 0.90.1 This way our code builds with both jars and we can easily switch. FYI On Wed, Feb 16, 2011 at 3:29 PM, Ryan Rawson ryano...@gmail.com wrote: Step 1 is to add

Re: [VOTE] HBase 0.90.1 rc1 available for download

2011-02-17 Thread Todd Lipcon
With three PMC +1s and no -1s, the vote passes. Thanks for voting! Stack and I will undertake the release process tonight/tomorrow and send out a formal announcement when the binary is up on the mirrors, etc. -Todd On Mon, Feb 14, 2011 at 5:37 PM, Todd Lipcon t...@cloudera.com wrote: The

Re: API changes between 0.20.6 and 0.90.1

2011-02-17 Thread Ted Yu
The changes were made to 0.20.6 - I wonder if they're useful. People using 0.89 may do the same. On Thu, Feb 17, 2011 at 7:33 PM, Stack st...@duboce.net wrote: Do you want to post your patch to an issue Ted? Others might be interested. Thanks, St.Ack On Thu, Feb 17, 2011 at 5:03 PM, Ted

Re: version check for hbase-default.xml

2011-02-17 Thread Ted Yu
How about calling setQuietMode(false) before your check and turn it on after the check ? This should give the user more clue in case of version mismatch. On Thu, Feb 17, 2011 at 4:32 PM, Todd Lipcon t...@cloudera.com wrote: Yes, it has always been an implicit requirement. Now it is an explicit

Re: API changes between 0.20.6 and 0.90.1

2011-02-17 Thread Andrew Purtell
From: Ted Yu yuzhih...@gmail.com In order to minimize maintenance, we produced an hbase-0.20.6 jar which contains the changed APIs (limited to our use cases) in 0.90.1 This way our code builds with both jars and we can easily switch. On Thu, Feb 17, 2011 at 7:33 PM, Stack