Re: NB 17-rc2 Rename Refactoring silently failed

2023-01-29 Thread Scott Palmer
More failures to rename... Module Java Refactoring threw java.lang.IllegalStateException: java.lang.NullPointerException: Cannot invoke "com.sun.tools.javac.code.Type.getThrownTypes()" because "tree.meth.type" is null. Please report a bug against Java Refactoring module and attach your

Re: NB 17-rc2 Rename Refactoring silently failed

2023-01-29 Thread Scott Palmer
Checking the logs I noticed a typo in a warning message, "evaulate" instead of "evaluate": INFO [org.netbeans.modules.gradle.execute.GradleDistributionProviderImpl]: Cannot evaulate Gradle Wrapper I also see an assertion to do with VanillaCompileWorker that is repeated a few times... I'm

Re: switch to: Require approval for all outside collaborators

2023-01-29 Thread Michael Bien
thanks for the +1s Laszlo and Antonio, filed a ticket: https://issues.apache.org/jira/browse/INFRA-24148 regards, michael On 29.01.23 08:36, Antonio wrote: +1 I think ASF Infra will be happy to reduce the consumption of resources. AFAIK Github (Microsoft) allocates a finite number of

Re: NB 17-rc2 Rename Refactoring silently failed

2023-01-29 Thread Laszlo Kishalmi
Can you check the message log for an earlier exception, maybe regarding java parser? The mentioned exception is logging some null handle at:

Re: NB 17-rc2 Gradle "included builds" are missing from class path

2023-01-29 Thread Laszlo Kishalmi
Hi Scott, I could not reproduce your issue with the included build. MainApp looks all right, though I noticed something odd in the reported dependencies, that actually could cause things like that. I'm still investigating... On 1/26/23 16:01, Scott Palmer wrote: Interestingly, while making

Re: [DISCUSSION] integrating cleanup PRs

2023-01-29 Thread Michael Bien
Hi Antonio, On 29.01.23 09:26, Antonio wrote: Hi Michael, Refactoring the code because of aesthetic, academic or modernization reasons is a non-ending task in a >500KLOC codebase that will turn 27 this year. By the time we end up modernizing all the code it will then be outdated. Yes,

NB 17-rc2 Rename Refactoring silently failed

2023-01-29 Thread Scott Palmer
I had some trouble trying to do a simple rename of a public static utility method. When I tried renaming it from where the method was defined it resulted in the following message. (It's a lie. In fact "find usages" on this method has no problem.) "The original element being refactored is not

Re: Arrays.asList...stream to Arrays.stream

2023-01-29 Thread Łukasz Bownik
Readability strongly depends on case, sometimes it is better, sometimes worse. Additionaly it is also a matter of personal preference. Paralelization is easy, Just use https://docs.oracle.com/javase/8/docs/api/java/util/stream/BaseStream.html#parallel-- But there is a trap. All invocations use

Re: Arrays.asList...stream to Arrays.stream

2023-01-29 Thread Eric Bresie
My understanding is the Stream/lambda usage provides a "functional" way of doing things, (some say) better readability, and provides opportunities for parallel processing (i.e. the internal mechanisms leverage the multi-core/process artifactures a little better if I understand correctly). Eric

Re: Arrays.asList...stream to Arrays.stream

2023-01-29 Thread Łukasz Bownik
Agreed.. but this is such a sexy hammer ;) niedz., 29 sty 2023, 15:56 użytkownik Laszlo Kishalmi < laszlo.kisha...@gmail.com> napisał: > As of readability and debug-ability, I'm sorry to say but old-school wins. > > It starting to look like when you found the hammer everything seems to > be a

Re: switch to: Require approval for all outside collaborators

2023-01-29 Thread Laszlo Kishalmi
+1 On 1/28/23 13:19, Michael Bien wrote: Hi devs, gh has a setting which controls when workflows need approval before they run, the default seems to be: "require approval for first-time contributors" or at least this is the setting the netbeans project is running on. I would like to

Re: Arrays.asList...stream to Arrays.stream

2023-01-29 Thread Laszlo Kishalmi
As of readability and debug-ability, I'm sorry to say but old-school wins. It starting to look like when you found the hammer everything seems to be a nail... On 1/29/23 02:21, Łukasz Bownik wrote: I can't help it It's stronger than me! AARGH! ;););););)

Re: Arrays.asList...stream to Arrays.stream

2023-01-29 Thread Łukasz Bownik
I can't help it It's stronger than me! AARGH! ;););););) toURLs(Stream.of(prjs). flatMap(this::toArtifacts). flatMap(this::toLocations). collect(toList()); } private Stream toArtifacts(Project prj) { return

Re: Arrays.asList...stream to Arrays.stream

2023-01-29 Thread Svata Dedic
And what about old school List uris = new ArrayList<>(prjs.length); for (Project p : prjs) { for (AntArtifact a : AntArtifactQuery.findArtifactsByType(p, JavaProjectConstants.ARTIFACT_TYPE_JAR)) {

Re: [DISCUSSION] integrating cleanup PRs

2023-01-29 Thread Antonio
Hi Michael, Refactoring the code because of aesthetic, academic or modernization reasons is a non-ending task in a >500KLOC codebase that will turn 27 this year. By the time we end up modernizing all the code it will then be outdated. IMHO we need contributors that are conscious of the

Re: Arrays.asList...stream to Arrays.stream

2023-01-29 Thread Antonio
Hi, So what is the value added if you submit this change? Is this a ten element list or a ten hundred thousand element list? Is this running inside a loop? What are the pros and cons of this change? Is this going to win ten manoseconds or ten minutes in running time? Thanks, Antonio On

Re: Arrays.asList...stream to Arrays.stream

2023-01-29 Thread Łukasz Bownik
How about "Stream.of"? it reads more like English :) niedz., 29 sty 2023, 06:59 użytkownik name name2 napisał: > toURLs( > Arrays.asList(prjs).stream().flatMap( > (prj) -> Arrays.asList( > AntArtifactQuery.findArtifactsByType(prj, > JavaProjectConstants.ARTIFACT_TYPE_JAR) >