[dpdk-dev] [PATCH] Add an API to query enabled core index

2014-06-12 Thread Thomas Monjalon
Hi, 2014-06-11 13:45, Patrick Lu: > EAL -c option allows the user to enable any lcore in the system. > Oftentimes, the user app wants to know 1st enabled core, 2nd > enabled core, etc, rather than phyical core ID (rte_lcore_id().) > > The new API rte_lcore_id2() will return an index from enabled

[dpdk-dev] [PATCHv2 0/5] ACL library

2014-06-12 Thread Thomas Monjalon
Hi Konstantin, 2014-05-28 20:26, Konstantin Ananyev: > v2 fixes: > * Fixed several checkpatch.pl issues It seems that many checkpatch issues are remaining. Could you re-check please? Thanks -- Thomas

[dpdk-dev] [PATCH v2 0/2] 10G PMD: vectorized RX and TX functions

2014-06-12 Thread Thomas Monjalon
Hi Bruce, You are introducing a new option CONFIG_RTE_IXGBE_RX_OLFLAGS_DISABLE. I feel a comment in the code would be helpful here. Sorry for not having checked before but there are some checkpatch issues in this PMD. Other simple cleanup: I think some include directives are useless. Could you

[dpdk-dev] [PATCH v2 0/2] 10G PMD: vectorized RX and TX functions

2014-06-12 Thread Thomas Monjalon
2014-06-11 22:27, Richardson, Bruce: > > From: Thomas Monjalon [mailto:thomas.monjalon at 6wind.com] > > You are introducing a new option CONFIG_RTE_IXGBE_RX_OLFLAGS_DISABLE. > > I feel a comment in the code would be helpful here. > > Comment in the code, or in the config file where the option is

[dpdk-dev] [PATCH] Add an API to query enabled core index

2014-06-12 Thread Thomas Monjalon
2014-06-11 21:58, Lu, Patrick: > From: Thomas Monjalon [mailto:thomas.monjalon at 6wind.com] > > 2014-06-11 13:45, Patrick Lu: > > > The new API rte_lcore_id2() will return an index from enabled lcores > > > starting from zero. > > > > I think core_id2 is not a representative name. > > What do

[dpdk-dev] [PATCH] Add an API to query enabled core index

2014-06-12 Thread Richardson, Bruce
> -Original Message- > From: Thomas Monjalon [mailto:thomas.monjalon at 6wind.com] > Sent: Wednesday, June 11, 2014 3:50 PM > To: Richardson, Bruce > Cc: Lu, Patrick; dev at dpdk.org > Subject: Re: [dpdk-dev] [PATCH] Add an API to query enabled core index > > 2014-06-11 21:57, Richardson,

[dpdk-dev] [PATCH] Add an API to query enabled core index

2014-06-12 Thread Dumitrescu, Cristian
Maybe we could simplify this discussion by simply creating a new function to return the mask of all enabled cores (as provided through -c coremask EAL option) and have the user utilize this mask to derive whatever info it needs? Right now, to get the mask of enabled cores, a for loop is

[dpdk-dev] [PATCH v2 05/27] mbuf: add new packet flags for i40e

2014-06-12 Thread Zhang, Helin
Adding cc list. -Original Message- From: Zhang, Helin Sent: Friday, June 6, 2014 8:30 AM To: Stephen Hemminger Subject: RE: [dpdk-dev] [PATCH v2 05/27] mbuf: add new packet flags for i40e Hi Hemminger Thanks for pointing out that! As ol_flags is currently 16 bits, we do not have

[dpdk-dev] tailroom in rte_mbuf

2014-06-12 Thread Vivek Soni
Hello, My application requires to reserve some tailroom in the packet mbuf after the packet payload. I see that in the default configuration the packet mbuf reserves only the headroom. When I send larger packets, the payload is copied until the last byte of the packet mbuf before going to next

[dpdk-dev] [PATCH] examples/vmdq: Fix core id issue for TX burst

2014-06-12 Thread Ouyang Changchun
This patch fixes a core id issue in sample vmdq, in case core mask doesn't start with lcore_id 0 but 20, for instance, it should use core_id instead of lcore_id. Signed-off-by: Ouyang Changchun Tested-by: Waterman Cao This patch includes 1 file, and has been tested by Intel. Please see

[dpdk-dev] [PATCH v2 0/4] NIC filters support for generic filter

2014-06-12 Thread Wu, Jingjing
Hi, Thomas Thanks for your reply. About your first concern: The pool field is used in virtualization scenario. It is acting as one of input set during filter matching in ixgbe. My patch didn't consider the virtualization scenario in generic filter feature. Because in 82599 datasheet, it is

[dpdk-dev] [PATCH] kni: compatibility with RHEL 7

2014-06-12 Thread Hiroshi Shimamoto
From: Hiroshi Shimamoto Compilation in RHEL7 is failed. This fixes the build issue. RHEL7 has skb_set_hash, the kernel version is 3.10 though. Don't define skb_set_hash for RHEL7. Signed-off-by: Hiroshi Shimamoto Reviewed-by: Hayato Momma ---

[dpdk-dev] [PATCH] rte_memory.h: include stdio.h for FILE

2014-06-12 Thread Hiroshi Shimamoto
From: Hiroshi Shimamoto The below commit requires stdio FILE structure. commit 591a9d7985c1230652d9f7ea1f9221e8c66ec188 Author: Stephen Hemminger Date: Fri May 2 16:42:56 2014 -0700 add FILE argument to debug functions Application which includes rte_memory.h

[dpdk-dev] [PATCH] Add an API to query enabled core index

2014-06-12 Thread Olivier MATZ
Hello, On 06/11/2014 11:57 PM, Richardson, Bruce wrote: >> I think core_id2 is not a representative name. >> What do you think of renaming core_id as lcore_hwid and core_id2 as >> lcore_index? >> >> -- > I like lcore_index as the name for the new function. However, I'm not sure in > that case

[dpdk-dev] [PATCH] kni: compatibility with RHEL 7

2014-06-12 Thread Cao, Waterman
Hi Shimamoto, Can you give details about Linux Kernel version and complier version? Because we tried to build code in the Redhat 7.0 before, but we don't meet this issue. Please see information as the following: Linux kernel 3.10.0-54.0.1.el7.x86_64 RHEL70BETA_64 GCC 4.8.2 ICC: 14.0.0

[dpdk-dev] [PATCH] kni: compatibility with RHEL 7

2014-06-12 Thread Hiroshi Shimamoto
Hi, > Subject: RE: [PATCH] kni: compatibility with RHEL 7 > > Hi Shimamoto, > > Can you give details about Linux Kernel version and complier version? > Because we tried to build code in the Redhat 7.0 before, but we don't meet > this issue. > Please see information as the following: >

[dpdk-dev] [PATCHv2 0/2] L3FWD sample optimisation

2014-06-12 Thread Thomas Monjalon
> Konstantin Ananyev (2): > lpm: Introduce rte_lpm_lookupx4 > l3fwd: reorganise and optimize l3fwd LPM code path. Applied for version 1.7.0. Thanks -- Thomas

[dpdk-dev] [PATCH v3 0/4] NIC filters support for generic filter

2014-06-12 Thread Jingjing Wu
--- the v3 patchset changes: --- comments alignment --- the v2 patchset changes: --- add NIC filter support for 82576 --- rework for the whitespace and tab warning if using git apply to apply patch A generic filter mechanism for handling special packet is required. It will allow filters to be

[dpdk-dev] [PATCH v3 1/4] ethdev: add ethdev APIs for NIC filters of generic filter

2014-06-12 Thread Jingjing Wu
This patch adds APIs for NIC filters list below: ethertype filter, syn filter, 2tuple filter, flex filter, 5tuple filter Signed-off-by: jingjing.wu --- lib/librte_ether/rte_ethdev.c | 281 lib/librte_ether/rte_ethdev.h | 425

[dpdk-dev] [PATCH v3 2/4] e1000: add igb NIC filters of generic filter feature

2014-06-12 Thread Jingjing Wu
This patch adds following igb NIC filters implement: syn filter, ethertype filter, 2tuple filter, flex filter for intel NIC 82580 and i350 syn filter, ethertype filter, 5tuple filter for intel NIC 82576 Signed-off-by: jingjing.wu --- lib/librte_pmd_e1000/e1000_ethdev.h | 53 +++

[dpdk-dev] [PATCH v3 4/4] app/test-pmd: add commands in testpmd for NIC filters

2014-06-12 Thread Jingjing Wu
add commands in testpmd for NIC filters: add_ethertype_filter remove_ethertype_filter get_ethertype_filter add_2tuple_filter remove_2tuple_filter get_2tuple_filter add_5tuple_filter remove_5tuple_filter get_5tuple_filter add_syn_filter remove_syn_filter get_syn_filter add_flex_filter

[dpdk-dev] [PATCH v3 3/4] ixgbe: add ixgbe NIC filters of generic filter feature

2014-06-12 Thread Jingjing Wu
This patch adds following ixgbe NIC filters implement: syn filter, ethertype filter, 5tuple filter for intel NIC 82599 Signed-off-by: jingjing.wu --- lib/librte_pmd_ixgbe/ixgbe_ethdev.c | 408 lib/librte_pmd_ixgbe/ixgbe_ethdev.h | 34 +++ 2 files changed,

[dpdk-dev] [PATCH v2 0/5] New library: rte_distributor

2014-06-12 Thread Thomas Monjalon
> This adds a new library to the Intel DPDK whereby a set of packets can be > distributed one-at-a-time to a set of worker cores, with dynamic load > balancing being done between those workers. Flows are identified by a tag > within the mbuf (currently the RSS hash field, 32-bit value), which is

[dpdk-dev] [PATCH 3/5] ethdev: add mtu accessors

2014-06-12 Thread David Marchand
Hello Konstantin, Mmm, good points. I am looking into them. I will send new patches by tomorrow (hopefully). On 06/10/2014 07:23 PM, Ananyev, Konstantin wrote: > Hi David, > >> This patch adds two new functions in ethdev api to retrieve current MTU and >> change MTU of a port. >> These

[dpdk-dev] A deadlock may occur in kni kernel thread while netif_receive_skb is called

2014-06-12 Thread Tyrone Lau
Hi, all. I have found recently the Linux kernel will complain occasionally a dead lock, while I use the kernel module rte_kni provided in DPDK. After reviewing the dpdk source code and googling, I found that the deadlock occurred because netif_receive_skb is invoked in a non-softirq context. The

[dpdk-dev] multi segment TX/RX for vmxnet3

2014-06-12 Thread Hyunseok
Hi, Do you guys plan to include this feature in the upcoming DPDK release? Best, -hs

[dpdk-dev] [PATCH v2 0/4] NIC filters support for generic filter

2014-06-12 Thread Thomas Monjalon
> 2014-06-11 17:45, Thomas Monjalon: > > My main concern is that Vladimir Medvedkin suggested another API and I'd > > like you give your opinion about it: > > http://dpdk.org/ml/archives/dev/2014-June/003053.html > > It offers pool number in configuration of the filters. 2014-06-12

[dpdk-dev] A deadlock may occur in kni kernel thread while netif_receive_skb is called

2014-06-12 Thread Stephen Hemminger
On Thu, 12 Jun 2014 22:46:14 +0800 Tyrone Lau wrote: > Hi, all. I have found recently the Linux kernel will complain occasionally > a dead lock, while I use the kernel module rte_kni provided in DPDK. After > reviewing the dpdk source code and googling, > I found that the deadlock occurred

[dpdk-dev] [PATCH v2 09/10] igbuio: show irq mode in sysfs

2014-06-12 Thread Neil Horman
On Wed, Jun 11, 2014 at 06:27:35PM +, Carew, Alan wrote: > > -Original Message- > > From: Neil Horman [mailto:nhorman at tuxdriver.com] > > Sent: Sunday, June 08, 2014 4:37 PM > > To: Stephen Hemminger > > Cc: Carew, Alan; dev at dpdk.org > > Subject: Re: [dpdk-dev] [PATCH v2 09/10]

[dpdk-dev] [PATCH 2/2] virtio: fix build with debug enabled

2014-06-12 Thread Stephen Hemminger
Remove useless message that breaks if VIRTIO_DEBUG_DRIVER is defined. virtio_ethdev.c:224:2: error: dereferencing type-punned pointer will break strict-aliasing rules [-Werror=strict-aliasing] Signed-off-by: Stephen Hemminger --- a/lib/librte_pmd_virtio/virtio_ethdev.c 2014-06-10

[dpdk-dev] [PATCH 1/2] virtio: checkpatch cleanups

2014-06-12 Thread Stephen Hemminger
This fixes style problems reported by checkpatch including: * extra whitespace * spaces before tabs * strings broken across lines * excessively long lines * missing spaces after keywords * unnecessary paren's in return statements Signed-off-by: Stephen Hemminger ---

[dpdk-dev] [PATCH 2/5] vmxnet3: cleanup style and indentation

2014-06-12 Thread Stephen Hemminger
This driver had several style problems, the worst of which was botched indentation. Fix almost all the problems reported by checkpatch. Signed-off-by: Stephen Hemminger --- lib/librte_pmd_vmxnet3/vmxnet3_ethdev.c | 158 lib/librte_pmd_vmxnet3/vmxnet3_ethdev.h | 24 +-

[dpdk-dev] [PATCH 3/5] vmxnet3: fix double spacing of log messages

2014-06-12 Thread Stephen Hemminger
The debug log macro's already include newline, no need to double space the output. Note: other drivers have the same problem Signed-off-by: Stephen Hemminger --- lib/librte_pmd_vmxnet3/vmxnet3_ethdev.c | 42 +-- lib/librte_pmd_vmxnet3/vmxnet3_rxtx.c | 70

[dpdk-dev] [PATCH 4/5] vmxnet3: add per-queue stats

2014-06-12 Thread Stephen Hemminger
Update per-queue statistics and add missing multicast into statistics. Also, no need to zero statistics since they are already cleared in rte_stats_get. Signed-off-by: Stephen Hemminger --- lib/librte_pmd_vmxnet3/vmxnet3_ethdev.c | 60 +--- 1 file changed, 32

[dpdk-dev] [PATCH 5/5] vmxnet3: remove useless adapter wrapper

2014-06-12 Thread Stephen Hemminger
The adapter struct is just a wrapper around the vmxnet3_hw structure. Eliminate the wrapper and get rid of the macro used to access and needlessly cast the private data. Signed-off-by: Stephen Hemminger --- lib/librte_pmd_vmxnet3/vmxnet3_ethdev.c | 30 +-