Re: [Dev] Concerns regarding the mechanism

2015-07-30 Thread fr33domlover
erified statically instead of relying on tests to catch them (Yesod in general seems to take this approach seriously). All the m0ney related stuff is probably at least somewhat critical, so perhaps more work with types could replace some tests. Just a random idea, I don't know how the code

Re: [Dev] [PATCH] Add libravatar support

2015-08-02 Thread fr33domlover
I tried making a fork in git.gnu.io but got 404s, so I sent the patch here. On 2015-08-02 fr33domlo...@riseup.net wrote: > From: fr33domlover > > Until now, if there is no avatar URL, no other source is used to display an > avatar. With this commit, if there is no avatar URL

[Dev] [PATCH] Add libravatar support

2015-08-02 Thread fr33domlover
From: fr33domlover Until now, if there is no avatar URL, no other source is used to display an avatar. With this commit, if there is no avatar URL but the user does have a verified email address, the email address is passed through libravatar to get an avatar URL from it. Things to consider

[Dev] GitLab events => IRC announcements

2015-08-09 Thread fr33domlover
Hello everyone! For a while, I've been running an IRC bot: <https://notabug.org/fr33domlover/funbot> Recently, I added web hook support, and it now can report events like Git commits to IRC. I just added, few minutes ago, support for Gitlab web hooks and tested it using GitLab&#

[Dev] FunBot updates

2015-08-17 Thread fr33domlover
ls the channel with spam. Also, all repo branches' commits were announced. I fixed these, still needs testing though: 1) Branches to announce/block can now be set in bot config per-repo; 2) There is an option to shorter big pushes in a friendly way, y

[Dev] Snowcaster

2015-08-21 Thread fr33domlover
Hello, Since a few days ago, fpbot is announcing RSS and Atom feed items. But it's done in a test channel. I noticed it announces some Snowdrift project feed items, but not all of them. Is it possible for me to see Snowcaster's rss2irc config? Then I can compare and figure out why fpbot misses it

Re: [Dev] Snowcaster

2015-08-22 Thread fr33domlover
On Fri, 21 Aug 2015 13:03:50 -0700 Bryan Richter wrote: > On Fri, Aug 21, 2015 at 01:43:51PM +0300, fr33domlover wrote: > > Hello, > > > > Since a few days ago, fpbot is announcing RSS and Atom feed items. > > But it's done in a test channel. I noticed it anno

[Dev] test - please ignore this

2015-09-18 Thread fr33domlover
This is just a test message for the snowdrift mail server, please ignore. ___ Dev mailing list Dev@lists.snowdrift.coop https://lists.snowdrift.coop/mailman/listinfo/dev

[Snowdrift-dev] [PATCH] Foundation: Provide 'authenticate' instead of deprecated 'getAuthId'

2016-02-29 Thread fr33domlover
From: fr33domlover --- src/Foundation.hs | 25 - 1 file changed, 16 insertions(+), 9 deletions(-) diff --git a/src/Foundation.hs b/src/Foundation.hs index 7a78f98..78797fc 100644 --- a/src/Foundation.hs +++ b/src/Foundation.hs @@ -17,6 +17,7 @@ import Text.Hamlet

Re: [Snowdrift-dev] [Dev] development meeting: agenda

2016-02-29 Thread fr33domlover
Hello, Some random notes below. On Fri, 26 Feb 2016 13:22:16 -0800 Bryan Richter wrote: > I want (re)start engineering-circle meetings. I'd like to brainstorm > some meeting topics so we know what we'll be talking about. :) I'll > kick things off with a (sorted) list of potential topics: > > -

[Snowdrift-dev] [PATCH] Add new route /u/

2016-03-01 Thread fr33domlover
From: fr33domlover A URL path like `/u/wolftune` is much more convenient than `/u/3`, and most websites seem to use the former indeed. This is a (mostly, see below) non-breaking change which: 1. Adds a new handler for `/u/` which returns the usual user page 2. Makes `/u/` be a simple

Re: [Snowdrift-dev] Patch for /u/

2016-03-01 Thread fr33domlover
Hello, I talked to Aaron on IRC and he told me `userIdent` is often an email address because that's what Persona logins use. So adding the new route means exposing people's email addresses, which we don't necessarily want. How do we fix this? Should Persona email addresses be considered public p

[Snowdrift-dev] [PATCH] Upgrade to github-0.14 which is in LTS

2016-03-06 Thread fr33domlover
From: fr33domlover --- src/Model/Issue.hs | 19 ++- src/Model/Project.hs | 21 - stack.yaml | 4 3 files changed, 22 insertions(+), 22 deletions(-) diff --git a/src/Model/Issue.hs b/src/Model/Issue.hs index f9cccd4..1e0b61b 100644 --- a/src

Re: [Snowdrift-dev] Updating to work with github-0.14 (in LTS)

2016-03-06 Thread fr33domlover
On Wed, 2 Mar 2016 13:31:59 -0800 Bryan Richter wrote: > The github package is in LTS now, but it changed its interface to use > better types (Text, Vector, and vanilla UTCTime). I spent a bit of > time trying to upgrade the code, but decided to pass on it for now. If > someone else wants to upda

Re: [Snowdrift-dev] Patch for /u/

2016-03-06 Thread fr33domlover
On Wed, 2 Mar 2016 16:06:55 -0500 Stephen Michel wrote: > Q: Do we allow users to change their vanity name, or is it fixed? > A: For MVP, fixed. In the future, I don't know. > > Q: If people can change their vanity name, what do we want to do with > the old name? Allow someone else to claim it,

Re: [Snowdrift-dev] [PATCH] Add new route /u/

2016-03-06 Thread fr33domlover
On Tue, 1 Mar 2016 16:27:41 -0800 Bryan Richter wrote: > ** Tech action items > > - UserHandle should be redefined to Text > - The existing route should be renamed getUserByIdR and should use > UserId instead of UserHandle > - The new route should get the original name UserR One thing I notic

[Snowdrift-dev] [PATCH] User nicknames as public user IDs: Change UserR route

2016-03-07 Thread fr33domlover
From: fr33domlover Making UserR take a Text that refers to a whole new User field is a big change. Many handlers and templates need to be updated. Therefore please read below carefully to understand my plan and what exactly this commit does. The GOAL is to move all UserId-based routes to use

[Snowdrift-dev] [PATCH 1/2] 'userDisplayName' now takes a User, not Entity User

2016-03-07 Thread fr33domlover
From: fr33domlover Username display is going to use only the 'userNick' and 'userName' fields. The ID column and the login ident are internal details. Therefore it becomes easier to the widely used 'userDisplayName' function to take just a 'User' value. T

[Snowdrift-dev] [PATCH 2/2] Change all /u routes to use UserHandle

2016-03-07 Thread fr33domlover
From: fr33domlover --- config/routes| 68 - src/Handler/NewDesign.hs | 5 +- src/Handler/ResetPassphrase.hs | 3 +- src/Handler/User/Balance.hs | 28 ++-- src/Handler/User/ChangePassphrase.hs | 20 +-- src

Re: [Snowdrift-dev] [PATCH] User nicknames as public user IDs: Change UserR route

2016-03-07 Thread fr33domlover
On Mon, 7 Mar 2016 16:39:11 -0800 Bryan Richter wrote: > Doing so, of course, massively conflicts with the changes you (fr33) > are making; changes that are hard to make precisely because there's so > much dead weight. This causes me — and presumably you — some tension. Ah, I didn't know you wer

[Snowdrift-dev] DB admin code

2016-03-09 Thread fr33domlover
I found this in Keter, maybe we can (re)use it somehow instead of hacking our own? http://haddock.stackage.org/lts-5.6/keter-1.4.3.1/Keter-Plugin-Postgres.html#v:setupDBInfo --fr33 ___ Dev mailing list Dev@lists.snowdrift.coop https://lists.snowdrift.co

Re: [Snowdrift-dev] Code reboot going into master

2016-03-19 Thread fr33domlover
On Fri, 18 Mar 2016 15:01:12 -0700 Bryan Richter wrote: > On Thu, Mar 17, 2016 at 11:20:22AM -0700, Bryan Richter wrote: > > As I may (or may not?) have mentioned earlier on this list, I > > started paring down the codebase to just the features we need for > > MVP. That has been happening on a br

[Snowdrift-dev] Gitit patches

2016-03-31 Thread fr33domlover
://notabug.org/fr33domlover/gitit ikomi: I'm tweaking dependency versions, trying to solve the category bug. Updates will come soon. -- fr33 signature.asc Description: PGP signature ___ Dev mailing list Dev@lists.snowdrift.coop https://lists.snowdrift

[Snowdrift-dev] [PATCH] Make Snowdrift project wiki search redirect to the gitit wiki

2016-05-17 Thread fr33domlover
From: fr33domlover --- website/Snowdrift.cabal | 1 + website/config/routes | 1 + website/src/Handler.hs | 4 3 files changed, 6 insertions(+) diff --git a/website/Snowdrift.cabal b/website/Snowdrift.cabal index 5cf461c..0994000 100644 --- a/website/Snowdrift.cabal +++ b/website

[Snowdrift-dev] SASS

2016-06-12 Thread fr33domlover
Hello, There are Haskell packages for using SASS in Yesod: - - I don't know if that's currently relevant. Just wanted to share in case it is. --fr33 signature.asc Description: PGP signature _

[Snowdrift-dev] Eletronic payment

2016-06-17 Thread fr33domlover
I think Bryan doesn't like to use new not-yet-field-tested software, but just in case: https://taler.net ___ Dev mailing list Dev@lists.snowdrift.coop https://lists.snowdrift.coop/mailman/listinfo/dev

[Snowdrift-dev] [PATCH] Discourse SSO support

2016-12-04 Thread fr33domlover
From: fr33domlover --- website/Snowdrift.cabal | 7 website/config/routes| 2 ++ website/config/settings.yml | 4 +++ website/src/Application.hs | 1 + website/src/Discourse.hs | 73 website/src/Handler

[Snowdrift-dev] [PATCH] Discourse SSO support

2016-12-05 Thread fr33domlover
From: fr33domlover --- website/Snowdrift.cabal | 8 website/config/routes| 2 + website/config/settings.yml | 3 ++ website/src/Application.hs | 1 + website/src/Discourse.hs | 86 website/src/Handler

Re: [Snowdrift-dev] [PATCH] Discourse SSO support

2016-12-05 Thread fr33domlover
e'll see where that discussion goes. > > On Mon, Dec 05, 2016 at 04:13:42AM +0200, fr33domlover wrote: > > From: fr33domlover > > > > --- > > website/Snowdrift.cabal | 7 > > website/config/routes| 2 ++ > > website

Re: [Snowdrift-dev] [PATCH] Discourse SSO support

2016-12-06 Thread fr33domlover
t; being the page from which you came. That way, after login you are redirected back to where you were. Bryan's code, which replaces YesodAuth, doesn't have that part implemented, or it's still buggy. So, Bryan, waiting for your input on this. For now, I suppose it's not super cri

[Snowdrift-dev] Chance for lightweight learning through patching the IRC bot

2016-12-24 Thread fr33domlover
Hey people, As some of you probably know, I wrote an IRC bot in Haskell from scratch, called FunBot. There's currently a single known instance of it, under the nickname "fpbot", running in #snowdrift and several other channels in Freenode. It's primary functional purpose is to help the free softwa

[Snowdrift-dev] [PATCH] Port Snowdrift tests from HSpec to Tasty

2017-07-01 Thread fr33domlover
From: fr33domlover --- website/Snowdrift.cabal | 11 ++- website/test/AlertsSpec.hs| 6 +++--- website/test/AuthSiteSpec.hs | 8 website/test/DiscourseSpec.hs | 35 --- website/test/HandlerSpec.hs | 6 +++--- website/test

[Snowdrift-dev] [PATCH] Implement Alerts using Yesod.Core.Handler's messages

2017-07-01 Thread fr33domlover
From: fr33domlover Yesod supports multiple messages now, which makes this possible. I left the AlertSpec test, just adapted it to the changes, but I must say it's somewhat useless now because Alerts is just a tiny tiny thin wrapper now. Also note the changes in the hamlet file, the d

[Snowdrift-dev] [PATCH] Port Snowdrift tests from HSpec to Tasty

2017-07-08 Thread fr33domlover
From: fr33domlover --- website/Snowdrift.cabal | 12 +++- website/test/AlertsSpec.hs| 6 +++--- website/test/AuthSiteSpec.hs | 8 website/test/DiscourseSpec.hs | 35 --- website/test/HandlerSpec.hs | 6 +++--- website/test

[Snowdrift-dev] [PATCH] crowdmatch: Use (SqlPersistT env) monad to allow combining queries

2017-07-08 Thread fr33domlover
From: fr33domlover Before this commit, crowdmatch actions run database queries separately inside them like a black box. That means in practice many applications of `runDB`, one per query, so a transaction per query. This is an unnecessary waste, and doesn't gain much (or anything at all, as

[Snowdrift-dev] [PATCH] Override Stripe secret key in test settings

2017-07-10 Thread fr33domlover
From: fr33domlover --- website/config/test-settings.yml | 9 + 1 file changed, 9 insertions(+) diff --git a/website/config/test-settings.yml b/website/config/test-settings.yml index b2d43ca..ded169e 100644 --- a/website/config/test-settings.yml +++ b/website/config/test-settings.yml

[Snowdrift-dev] [PATCH] Add a real Stripe runner to crowdmatch test module, using test key

2017-07-10 Thread fr33domlover
From: fr33domlover The runner isn't being used, I just added it there so that we can start writing tests with it. May wish to move it to a TestImport module once we split crowdmatch tests into multiple modules. --- crowdmatch/crowdmatch.cabal | 1 + crowdmatch/test/main.hs

[Snowdrift-dev] [PATCH] Use appStripe as stripe client in handlers

2017-07-10 Thread fr33domlover
From: fr33domlover --- crowdmatch/crowdmatch.cabal| 3 ++- crowdmatch/src/Crowdmatch.hs | 32 +++- website/src/AppDataTypes.hs| 6 ++ website/src/Handler/PaymentInfo.hs | 11 ++- website/src/Handler/Util.hs| 14

Re: [Snowdrift-dev] [PATCH] Use appStripe as stripe client in handlers

2017-07-10 Thread fr33domlover
On Mon, 10 Jul 2017 18:44:44 -0700 Bryan Richter wrote: > To whom it may concern: > > fr33domlover and I know this doesn't compile.. it was submitted for > discussion. > > Now, on with the discussing: > > On Tue, Jul 11, 2017 at 03:57:31AM +0300, fr33domlover

Re: [Snowdrift-dev] [PATCH] Use appStripe as stripe client in handlers

2017-07-10 Thread fr33domlover
I tried replacing all the 'StripeClient' with the actual type. It gives exactly the same type error. So, no harm in having the type alias. pgpK943rc6S5J.pgp Description: OpenPGP digital signature ___ Dev mailing list Dev@lists.snowdrift.coop https://lis

[Snowdrift-dev] [PATCH] Use appStripe as stripe client in handlers

2017-07-10 Thread fr33domlover
From: fr33domlover This is a new version of the patch, it uses runStripe in appStripe. It avoids the StripeClient mess but still has a type error due to StripeRunner being having the 'forall io' thing. The errors can be fixed using type annotations probably, but using those in every si

Re: [Snowdrift-dev] Weekly dev news 2017-07-22

2017-07-24 Thread fr33domlover
nto Yesod. There are packages for this purpose, but they > do not do Haskell splice interpolations (which makes me wonder what the point > of the package even is). There's been some discussion of options on IRC, and > I'm leaning toward compiling Sass to "Lucius" (aka CSS) i

[Snowdrift-dev] Shakespeare splice support for SASS

2017-07-24 Thread fr33domlover
Hello people, I made a patch for shakespeare-sass which makes it support splices like the other shakespeare languages. I'd like to explain why and how because it's not easy to understand from my still ugly-and-undocumented code. First, how do these splices work in shakespeare in general? Answe

Re: [Snowdrift-dev] Weekly dev news 2017-07-22

2017-07-24 Thread fr33domlover
Oops I forgot the link: https://notabug.org/fr33domlover/shakespeare-sass ___ Dev mailing list Dev@lists.snowdrift.coop https://lists.snowdrift.coop/mailman/listinfo/dev