[Issue 12438] New: Wrong code for result of assignment to `ref`/`out` struct parameter

2014-03-22 Thread d-bugmail
https://d.puremagic.com/issues/show_bug.cgi?id=12438 Summary: Wrong code for result of assignment to `ref`/`out` struct parameter Product: D Version: D2 Platform: All OS/Version: All Status: NEW Keywords:

[Issue 12439] New: Can't access to property call result if the call is in parantheses

2014-03-22 Thread d-bugmail
https://d.puremagic.com/issues/show_bug.cgi?id=12439 Summary: Can't access to property call result if the call is in parantheses Product: D Version: D2 Platform: All OS/Version: All Status: NEW Keywords:

[Issue 9106] Rename std.random.randomShuffle as std.random.shuffle and small usage change

2014-03-22 Thread d-bugmail
https://d.puremagic.com/issues/show_bug.cgi?id=9106 Joseph Rushton Wakeling joseph.wakel...@webdrake.net changed: What|Removed |Added CC|

[Issue 11461] `Error`s are not thrown as `pure nothrow` functions are optimized out with -O -release

2014-03-22 Thread d-bugmail
https://d.puremagic.com/issues/show_bug.cgi?id=11461 Rainer Schuetze r.sagita...@gmx.de changed: What|Removed |Added CC|

[Issue 9106] Rename std.random.randomShuffle as std.random.shuffle and small usage change

2014-03-22 Thread d-bugmail
https://d.puremagic.com/issues/show_bug.cgi?id=9106 --- Comment #6 from bearophile_h...@eml.cc 2014-03-22 05:28:41 PDT --- (In reply to comment #5) Is there any favour for renaming the other randomSomething functions and types in this way? Note that one rationale for the existing names is by

[Issue 9106] Rename std.random.randomShuffle as std.random.shuffle and small usage change

2014-03-22 Thread d-bugmail
https://d.puremagic.com/issues/show_bug.cgi?id=9106 --- Comment #7 from bearophile_h...@eml.cc 2014-03-22 05:30:12 PDT --- (In reply to comment #5) Is there any favour for renaming the other randomSomething functions and types in this way? Note that one rationale for the existing names is by

[Issue 11461] `Error`s are not thrown as `pure nothrow` functions are optimized out with -O -release

2014-03-22 Thread d-bugmail
https://d.puremagic.com/issues/show_bug.cgi?id=11461 bearophile_h...@eml.cc changed: What|Removed |Added CC||bearophile_h...@eml.cc ---

[Issue 9106] Rename std.random.randomShuffle as std.random.shuffle and small usage change

2014-03-22 Thread d-bugmail
https://d.puremagic.com/issues/show_bug.cgi?id=9106 Ivan Kazmenko ga...@mail.ru changed: What|Removed |Added CC||ga...@mail.ru ---

[Issue 9106] Rename std.random.randomShuffle as std.random.shuffle and small usage change

2014-03-22 Thread d-bugmail
https://d.puremagic.com/issues/show_bug.cgi?id=9106 --- Comment #9 from Joseph Rushton Wakeling joseph.wakel...@webdrake.net 2014-03-22 10:42:07 PDT --- (In reply to comment #8) Initially, I would have been against the renaming. The main argument would be that what we have now is consistent

[Issue 9106] Rename std.random.randomShuffle as std.random.shuffle and small usage change

2014-03-22 Thread d-bugmail
https://d.puremagic.com/issues/show_bug.cgi?id=9106 --- Comment #10 from bearophile_h...@eml.cc 2014-03-22 10:58:29 PDT --- (In reply to comment #9) to switch randomSample = sample (again maintaining an alias for the older name). Is randomSample a documented alias? For this first

[Issue 9106] Rename std.random.randomShuffle as std.random.shuffle and small usage change

2014-03-22 Thread d-bugmail
https://d.puremagic.com/issues/show_bug.cgi?id=9106 --- Comment #11 from Joseph Rushton Wakeling joseph.wakel...@webdrake.net 2014-03-22 11:10:28 PDT --- (In reply to comment #10) Is randomSample a documented alias? Is? I haven't even made the patch yet :-P But yes, it will be. Then I

[Issue 12440] New: Implement whole-program analysis

2014-03-22 Thread d-bugmail
https://d.puremagic.com/issues/show_bug.cgi?id=12440 Summary: Implement whole-program analysis Product: D Version: D2 Platform: All OS/Version: All Status: NEW Severity: enhancement Priority: P2 Component:

[Issue 12440] Implement whole-program analysis

2014-03-22 Thread d-bugmail
https://d.puremagic.com/issues/show_bug.cgi?id=12440 bearophile_h...@eml.cc changed: What|Removed |Added CC||bearophile_h...@eml.cc ---

[Issue 12434] std.algorithm.sum of immutable array too

2014-03-22 Thread d-bugmail
https://d.puremagic.com/issues/show_bug.cgi?id=12434 monarchdo...@gmail.com changed: What|Removed |Added CC||monarchdo...@gmail.com ---

[Issue 11461] `Error`s are not thrown as `pure nothrow` functions are optimized out with -O -release

2014-03-22 Thread d-bugmail
https://d.puremagic.com/issues/show_bug.cgi?id=11461 --- Comment #13 from monarchdo...@gmail.com 2014-03-22 14:59:11 PDT --- Maybe the problem can be worked around by making the function(s) *weakly* pure? (In reply to comment #11) (In reply to comment #7) Commit pushed to master at

[Issue 9515] UFCS fails with local aliases

2014-03-22 Thread d-bugmail
https://d.puremagic.com/issues/show_bug.cgi?id=9515 Andrej Mitrovic andrej.mitrov...@gmail.com changed: What|Removed |Added Status|RESOLVED|REOPENED

[Issue 3882] Unused result of pure functions

2014-03-22 Thread d-bugmail
https://d.puremagic.com/issues/show_bug.cgi?id=3882 --- Comment #36 from github-bugzi...@puremagic.com 2014-03-22 15:16:12 PDT --- Commits pushed to master at https://github.com/D-Programming-Language/dmd

[Issue 12441] New: DDoc should ignore interleaved non-doc comments

2014-03-22 Thread d-bugmail
https://d.puremagic.com/issues/show_bug.cgi?id=12441 Summary: DDoc should ignore interleaved non-doc comments Product: D Version: D2 Platform: All OS/Version: All Status: NEW Severity: normal Priority: P2