Update specific keys within nested Django JSONField data

2018-02-21 Thread askpriyansh
Hello ! I have come up with a solution to #29112 , using jsonb_set function. However, this function is only available from PostgreSQL 9.5, and we need to give support for PostgreSQL 9.4 as well. We can use PL/Python extension to write a custom funct

Re: Google Summer of Code 2018

2018-02-21 Thread askpriyansh
Hello ! I am still looking for Track tickets and other references (including third-party solutions) to formalise the idea. The work I propose should ideally make the process of using any arbitrary backend (like Google App Engine) much easier and uniform for every datastore. The exams will take

Re: Support for `Q` objects in `get_or_create` and `update_or_create`

2018-02-21 Thread 'Mike Lissner' via Django developers (Contributions to Django itself)
OK, I created a ticket, but I fear I'm not the best person to get the docs ironed out. I took a stab at it, but it was terrible and I got the sense it'd get rejected for not explaining things properly/well. Perhaps somebody else can pick this up: https://code.djangoproject.com/ticket/29148 Mike

Re: Consider renaming `mark_safe` to `dangerously_trust_html` (etc)

2018-02-21 Thread Josh Smeaton
I agree that the names are misleading and we should probably provide better names. I'm wary of deprecating the old names because it'll create a lot of churn (some of which would be the right thing to do). Maybe we could just alias and warn when using the old name, leaving a decision on deprecati

Re: Consider renaming `mark_safe` to `dangerously_trust_html` (etc)

2018-02-21 Thread Collin Anderson
> Maybe we could just alias and warn when using the old name, leaving a decision on deprecation until some time in the future. I'm a fan of delaying deprecation/removal if we do change it. :) On Wed, Feb 21, 2018 at 4:41 PM, Josh Smeaton wrote: > I agree that the names are misleading and we sho