[PATCH] drm/i915/ttm: Fix error code in i915_ttm_eviction_valuable()

2021-11-21 Thread Dan Carpenter
This function returns a bool type so returning -EBUSY is equivalent to returning true. It should return false instead. Fixes: 7ae034590cea ("drm/i915/ttm: add tt shmem backend") Signed-off-by: Dan Carpenter --- drivers/gpu/drm/i915/gem/i915_gem_ttm.c | 2 +- 1 file changed, 1 insertion(+), 1

Re: [PATCH] drm/kmb: fix potential memleak in error branch

2021-11-21 Thread kernel test robot
Hi Bernard, Thank you for the patch! Yet something to improve: [auto build test ERROR on drm/drm-next] [also build test ERROR on v5.16-rc2 next-2028] [If your patch is applied to the wrong git tree, kindly drop us a note. And when submitting patch, we suggest to use '--base' as documented in

Re: [PATCH v3] media: mtk-vcodec: Align width and height to 64 bytes

2021-11-21 Thread Dafna Hirschfeld
On 04.11.21 14:24, Yunfei Dong wrote: Width and height need to 64 bytes aligned when setting the format. Need to make sure all is 64 bytes align when use width and height to calculate buffer size. Signed-off-by: Yunfei Dong Acked-by: Nicolas Dufresne Tested-by: Steve Cho ---

Re: [PATCH linux-next] drm/i915/request: Remove unused variables

2021-11-21 Thread kernel test robot
Hi, Thank you for the patch! Yet something to improve: [auto build test ERROR on next-2028] url: https://github.com/0day-ci/linux/commits/cgel-zte-gmail-com/drm-i915-request-Remove-unused-variables/20211121-181441 base:5191249f880367a4cd675825cd721a8d78f26a45 config: x86_64

[PATCH 2/2] drm: exynos: dsi: Add mode_set function

2021-11-21 Thread Jagan Teki
Get the display mode settings via mode_set bridge function instead of explicitly de-reference. Signed-off-by: Jagan Teki --- drivers/gpu/drm/exynos/exynos_drm_dsi.c | 13 - 1 file changed, 12 insertions(+), 1 deletion(-) diff --git a/drivers/gpu/drm/exynos/exynos_drm_dsi.c

[PATCH 1/2] drm: exynos: dsi: Convert to bridge driver

2021-11-21 Thread Jagan Teki
Some display panels would come up with a non-DSI output, those can have an option to connect the DSI host by means of interface bridge converter. This DSI to non-DSI interface bridge converter would requires DSI Host to handle drm bridge functionalities in order to DSI Host to Interface bridge.

[PATCH 0/2] drm: exynos: dsi: Convert drm bridge

2021-11-21 Thread Jagan Teki
This is initial step to convert exynos dsi to bridge and make use of i.MX8MMini. The previous RFC series for this is here [1] I'm trying to add minimalist patches as I don't have hardware to validate, the next plan is to add panel_bridge and other improvements. [1]

[DO NOT MERGE] [PATCH v5 7/7] ARM: dts: sun8i: Enable DLPC3433 Bridge (I2C)

2021-11-21 Thread Jagan Teki
Signed-off-by: Jagan Teki --- arch/arm/boot/dts/sun8i-r16-renew-vista-e.dts | 79 +-- 1 file changed, 73 insertions(+), 6 deletions(-) diff --git a/arch/arm/boot/dts/sun8i-r16-renew-vista-e.dts b/arch/arm/boot/dts/sun8i-r16-renew-vista-e.dts index d28b7b35a3c5..c3ee6a879ddb

[DO NOT MERGE] [PATCH v5 6/7] ARM: dts: sun8i: bananapi-m2m: Enable ICN6211 DSI Bridge

2021-11-21 Thread Jagan Teki
Bananapi S070WV20-CT16 is a pure RGB output panel with ICN6211 DSI/RGB convertor bridge. Enable bridge along with associated panel. Signed-off-by: Jagan Teki --- arch/arm/boot/dts/sun8i-r16-bananapi-m2m.dts | 63 1 file changed, 63 insertions(+) diff --git

[DO NOT MERGE] [PATCH v5 5/7] ARM: dts: sun8i: bananapi-m2m: Enable S070WV20-CT16 Panel

2021-11-21 Thread Jagan Teki
This patch add support for Bananapi S070WV20-CT16 panel to BPI-M2M board. This specific DSI Bananapi S070WV20-CT16 panel driver is not available in upstream, added for testing purpose. Signed-off-by: Jagan Teki --- arch/arm/boot/dts/sun8i-r16-bananapi-m2m.dts | 40 1 file

[PATCH v5 4/7] drm: sun4i: dsi: Add mode_set function

2021-11-21 Thread Jagan Teki
Get the display mode settings via mode_set bridge function instead of explicitly de-reference. Signed-off-by: Jagan Teki --- Changes for v5: - new patch drivers/gpu/drm/sun4i/sun6i_mipi_dsi.c | 12 +++- drivers/gpu/drm/sun4i/sun6i_mipi_dsi.h | 1 + 2 files changed, 12 insertions(+), 1

[PATCH v5 3/7] drm: sun4i: dsi: Convert to bridge driver

2021-11-21 Thread Jagan Teki
Some display panels would come up with a non-DSI output, those can have an option to connect the DSI host by means of interface bridge converter. This DSI to non-DSI interface bridge converter would requires DSI Host to handle drm bridge functionalities in order to DSI Host to Interface bridge.

[PATCH v5 2/7] drm: sun4i: dsi: Add component only once DSI device attached

2021-11-21 Thread Jagan Teki
Having component_add for running all drm bind callbacks returns error or unbound due to chain of DSI devices connected across bridge topology on a display pipeline. In a typical bridge oriented display pipeline where the host is connected to the bridge converter and that indeed connected to a

[PATCH v5 1/7] drm: sun4i: dsi: Drop DRM bind race with bridge attach

2021-11-21 Thread Jagan Teki
Existing host driver will keep looking for DRM pointer in sun6i_dsi_attach and defers even if the particular DSI device is found for the first time. Meanwhile it triggers the bind callback and gets the DRM pointer and then continues the sun6i_dsi_attach. This makes a deadlock situation if

[PATCH v5 0/7] drm: sun4i: dsi: Convert drm bridge

2021-11-21 Thread Jagan Teki
This series convert Allwinner DSI controller to full functional drm bridge driver for supporting all variants of DSI devices. Here, are the previous version changes[1]. Patch 1: Drop the DRM bind race while attaching bridges Patch 2: Move component_add into sun6i_dsi_attach Patch 3: Convert

Re: [PATCH linux-next] drm/i915/request: Remove unused variables

2021-11-21 Thread kernel test robot
Hi, Thank you for the patch! Yet something to improve: [auto build test ERROR on next-2028] url: https://github.com/0day-ci/linux/commits/cgel-zte-gmail-com/drm-i915-request-Remove-unused-variables/20211121-181441 base:5191249f880367a4cd675825cd721a8d78f26a45 config: x86_64

Re: [PATCH v1 1/9] mm: add zone device coherent type memory support

2021-11-21 Thread Alistair Popple
> >> diff --git a/mm/migrate.c b/mm/migrate.c > >> index 1852d787e6ab..f74422a42192 100644 > >> --- a/mm/migrate.c > >> +++ b/mm/migrate.c > >> @@ -362,7 +362,7 @@ static int expected_page_refs(struct address_space > >> *mapping, struct page *page) > >> * Device private pages have an extra

Re: [PATCH v1 00/12] drm/rockchip: RK356x VOP2 support

2021-11-21 Thread Alex Bee
Hi Sascha, Am 17.11.21 um 15:33 schrieb Sascha Hauer: > This series adds initial graphics support for the Rockchip RK356[68] > SoCs. Graphics support is based around the VOP2 controller which > replaces the VOP controller found on earlier Rockchip SoCs. The driver > has been tested with HDMI

Re: 5.15 regression: CONFIG_SYSFB_SIMPLEFB breaks console scrolling

2021-11-21 Thread Thorsten Leemhuis
Hi, this is your Linux kernel regression tracker speaking. On 16.11.21 05:52, Harald Dunkel wrote: > > if I enable CONFIG_SYSFB_SIMPLEFB in 5.15.2 and use grub's default > configuration > (Debian sid amd64), then a few lines at the bottom of /dev/tty1 including > login prompt are off-screen.

Re: [PATCH 01/15] iio: buffer-dma: Get rid of incoming/outgoing queues

2021-11-21 Thread Paul Cercueil
Le dim., nov. 21 2021 at 19:49:03 +0100, Lars-Peter Clausen a écrit : On 11/21/21 6:52 PM, Paul Cercueil wrote: Hi Lars, Le dim., nov. 21 2021 at 17:23:35 +0100, Lars-Peter Clausen  a écrit : On 11/15/21 3:19 PM, Paul Cercueil wrote: The buffer-dma code was using two queues, incoming

[PATCH] drm/i915: Remove unused intel_gmbus_set_speed() function

2021-11-21 Thread Hans de Goede
The intel_gmbus_set_speed() function is not used anywhere, remove it. Note drivers/gpu/drm/gma500 has its own copy called gma_intel_gmbus_set_speed() which is used, the intel_gmbus_set_speed() version in the i915 code is not used at all Signed-off-by: Hans de Goede ---

Re: [PATCH 01/15] iio: buffer-dma: Get rid of incoming/outgoing queues

2021-11-21 Thread Lars-Peter Clausen
On 11/21/21 6:52 PM, Paul Cercueil wrote: Hi Lars, Le dim., nov. 21 2021 at 17:23:35 +0100, Lars-Peter Clausen a écrit : On 11/15/21 3:19 PM, Paul Cercueil wrote: The buffer-dma code was using two queues, incoming and outgoing, to manage the state of the blocks in use. While this totally

Re: [PATCH 01/15] iio: buffer-dma: Get rid of incoming/outgoing queues

2021-11-21 Thread Paul Cercueil
Hi Lars, Le dim., nov. 21 2021 at 17:23:35 +0100, Lars-Peter Clausen a écrit : On 11/15/21 3:19 PM, Paul Cercueil wrote: The buffer-dma code was using two queues, incoming and outgoing, to manage the state of the blocks in use. While this totally works, it adds some complexity to the code,

Re: [PATCH 15/15] Documentation: iio: Document high-speed DMABUF based API

2021-11-21 Thread Paul Cercueil
Hi Jonathan, Le dim., nov. 21 2021 at 15:10:26 +, Jonathan Cameron a écrit : On Mon, 15 Nov 2021 14:22:43 + Paul Cercueil wrote: Document the new DMABUF based API. Signed-off-by: Paul Cercueil Hi Paul, A few trivial things inline but looks good to me if we do end up using

Re: [PATCH 11/15] iio: buffer-dma: Boost performance using write-combine cache setting

2021-11-21 Thread Paul Cercueil
Hi Jonathan, Le dim., nov. 21 2021 at 15:00:37 +, Jonathan Cameron a écrit : On Mon, 15 Nov 2021 14:19:21 + Paul Cercueil wrote: We can be certain that the input buffers will only be accessed by userspace for reading, and output buffers will mostly be accessed by userspace for

[PATCH 2/2] drm/amdkfd: Slighly optimize 'init_doorbell_bitmap()'

2021-11-21 Thread Christophe JAILLET
The 'doorbell_bitmap' bitmap has just been allocated. So we can use the non-atomic '__set_bit()' function to save a few cycles as no concurrent access can happen. Signed-off-by: Christophe JAILLET --- bitmap_set() could certainly also be use, but range checking would be tricky. ---

[PATCH 1/2] drm/amdkfd: Use bitmap_zalloc() when applicable

2021-11-21 Thread Christophe JAILLET
'doorbell_bitmap' is a bitmap. So use 'bitmap_zalloc()' to simplify code, improve the semantic and avoid some open-coded arithmetic in allocator arguments. Also change the corresponding 'kfree()' into 'bitmap_free()' to keep consistency. Signed-off-by: Christophe JAILLET ---

[Bug 205089] amdgpu : drm:amdgpu_cs_ioctl : Failed to initialize parser -125

2021-11-21 Thread bugzilla-daemon
https://bugzilla.kernel.org/show_bug.cgi?id=205089 Hristos (kernel-b...@hristos.co) changed: What|Removed |Added CC||kernel-b...@hristos.co

Re: [PATCH 04/15] iio: buffer-dma: Enable buffer write support

2021-11-21 Thread Paul Cercueil
Hi Jonathan, Le dim., nov. 21 2021 at 14:20:49 +, Jonathan Cameron a écrit : On Mon, 15 Nov 2021 14:19:14 + Paul Cercueil wrote: Adding write support to the buffer-dma code is easy - the write() function basically needs to do the exact same thing as the read() function: dequeue

Re: [PATCH 01/15] iio: buffer-dma: Get rid of incoming/outgoing queues

2021-11-21 Thread Lars-Peter Clausen
On 11/15/21 3:19 PM, Paul Cercueil wrote: The buffer-dma code was using two queues, incoming and outgoing, to manage the state of the blocks in use. While this totally works, it adds some complexity to the code, especially since the code only manages 2 blocks. It is much easier to just check

[PATCH] drm: ttm: correct ttm_range_manager kernel-doc notation

2021-11-21 Thread Randy Dunlap
Fix kernel-doc warnings in ttm_range_manager.c: drivers/gpu/drm/ttm/ttm_range_manager.c:144: warning: expecting prototype for ttm_range_man_init(). Prototype was for ttm_range_man_init_nocheck() instead drivers/gpu/drm/ttm/ttm_range_manager.c:178: warning: expecting prototype for

Re: [PATCH 15/15] Documentation: iio: Document high-speed DMABUF based API

2021-11-21 Thread Jonathan Cameron
On Mon, 15 Nov 2021 14:22:43 + Paul Cercueil wrote: > Document the new DMABUF based API. > > Signed-off-by: Paul Cercueil Hi Paul, A few trivial things inline but looks good to me if we do end up using DMABUF anyway. Jonathan > --- > Documentation/driver-api/dma-buf.rst | 2 + >

Re: [PATCH 11/15] iio: buffer-dma: Boost performance using write-combine cache setting

2021-11-21 Thread Jonathan Cameron
On Mon, 15 Nov 2021 14:19:21 + Paul Cercueil wrote: > We can be certain that the input buffers will only be accessed by > userspace for reading, and output buffers will mostly be accessed by > userspace for writing. Mostly? Perhaps a little more info on why that's not 'only'. > >

[WARN][AMDGPU] Linux 5.15.4 with AMD Bonaire GPU

2021-11-21 Thread Chris Rankin
Hi, i have found this warning in my vanilla 5.15.4 kernel's dmesg log: [ 87.687139] [ cut here ] [ 87.710799] WARNING: CPU: 1 PID: 1 at drivers/gpu/drm/ttm/ttm_bo.c:409 ttm_bo_release+0x1c/0x266 [ttm] [ 87.718965] Modules linked in: nf_nat_ftp nf_conntrack_ftp

Re: [PATCH 07/15] iio: core: Add new DMABUF interface infrastructure

2021-11-21 Thread Jonathan Cameron
On Mon, 15 Nov 2021 14:19:17 + Paul Cercueil wrote: > Add the necessary infrastructure to the IIO core to support a new DMABUF > based interface. > > The advantage of this new DMABUF based interface vs. the read() > interface, is that it avoids an extra copy of the data between the > kernel

Re: [PATCH 04/15] iio: buffer-dma: Enable buffer write support

2021-11-21 Thread Jonathan Cameron
On Mon, 15 Nov 2021 14:19:14 + Paul Cercueil wrote: > Adding write support to the buffer-dma code is easy - the write() > function basically needs to do the exact same thing as the read() > function: dequeue a block, read or write the data, enqueue the block > when entirely processed. > >

Re: [PATCH 03/15] iio: buffer-dma: Use round_down() instead of rounddown()

2021-11-21 Thread Jonathan Cameron
On Mon, 15 Nov 2021 14:19:13 + Paul Cercueil wrote: > We know that the buffer's alignment will always be a power of two; > therefore, we can use the faster round_down() macro. > > Signed-off-by: Paul Cercueil *groan*. I don't want to know where the naming of these two came from but that

Re: [PATCH 01/15] iio: buffer-dma: Get rid of incoming/outgoing queues

2021-11-21 Thread Jonathan Cameron
On Mon, 15 Nov 2021 14:19:11 + Paul Cercueil wrote: > The buffer-dma code was using two queues, incoming and outgoing, to > manage the state of the blocks in use. > > While this totally works, it adds some complexity to the code, > especially since the code only manages 2 blocks. It is much

Re: [PATCH 00/15] iio: buffer-dma: write() and new DMABUF based API

2021-11-21 Thread Jonathan Cameron
On Mon, 15 Nov 2021 14:19:10 + Paul Cercueil wrote: > Hi Jonathan, > > This patchset introduces a new userspace interface based on DMABUF > objects, to complement the existing fileio based API. > > The advantage of this DMABUF based interface vs. the fileio > interface, is that it avoids

Re: [PATCH 08/15] iio: buffer-dma: split iio_dma_buffer_fileio_free() function

2021-11-21 Thread Jonathan Cameron
On Tue, 16 Nov 2021 12:59:30 +0200 Alexandru Ardelean wrote: > On Mon, Nov 15, 2021 at 4:20 PM Paul Cercueil wrote: > > > > From: Alexandru Ardelean > > > > A part of the logic in the iio_dma_buffer_exit() is required for the change > > to add mmap support to IIO buffers. > > This change

[PATCH v2 2/2] drm/i915: Use to_root_gt() to refer to the root tile

2021-11-21 Thread Andi Shyti
Starting from a patch from Matt to_root_gt() returns the reference to the root tile in order to abstract the root tile from th callers. Being the root tile identified as tile '0', embed the id in the name so that i915->gt becomes i915->gt0. The renaming has been mostly done with the following

[PATCH v2 1/2] drm/i915: Store backpointer to GT in uncore

2021-11-21 Thread Andi Shyti
From: Michał Winiarski We now support a per-gt uncore, yet we're not able to infer which GT we're operating upon. Let's store a backpointer for now. Signed-off-by: Michał Winiarski Signed-off-by: Matt Roper Reviewed-by: Andi Shyti Signed-off-by: Andi Shyti ---

[PATCH v2 0/2] More preparation for multi gt patches

2021-11-21 Thread Andi Shyti
From: Andi Shyti Hi, the first of the two patches concludes the first stage of refactoring which makes the use of intel_gt on the different subsystem. It's taken from Matt's series and it has alread been reviewed. The patch has just been replaced before any multitile patches and I think it can

Re: [Intel-gfx] [PATCH 2/2] drm/i915: Rename gt to gt0

2021-11-21 Thread Andi Shyti
Hi Chris, > > --- a/drivers/gpu/drm/i915/display/intel_atomic_plane.c > > +++ b/drivers/gpu/drm/i915/display/intel_atomic_plane.c > > @@ -817,7 +817,7 @@ intel_prepare_plane_fb(struct drm_plane *_plane, > > * maximum clocks following a vblank miss (see do_rps_boost()). > > */ >

Re: [PATCH linux-next] drm/i915/request: Remove unused variables

2021-11-21 Thread Christophe JAILLET
Le 21/11/2021 à 11:13, cgel@gmail.com a écrit : From: yong yiran The clang_analyzer complains as follows: drivers/gpu/drm/i915/i915_request.c:2119:2 warning: Value stored to 'x' is never read Reported-by: Zeal Robot Signed-off-by: yong yiran --- drivers/gpu/drm/i915/i915_request.c | 3

[PATCH 2/2] drm/i915/backlight: Make ext_pwm_disable_backlight() call intel_backlight_set_pwm_level()

2021-11-21 Thread Hans de Goede
At least the Bay Trail LPSS PWM controller used with DSI panels on many Bay Trail tablets seems to leave the PWM pin in whatever state it was (high or low) ATM that the PWM gets disabled. Combined with some panels not having a separate backlight-enable pin this leads to the backlight sometimes

[PATCH 1/2] drm/i915/backlight: Drop duplicate intel_panel_actually_set_backlight()

2021-11-21 Thread Hans de Goede
After the recent refactoring of the backlight code the contents of intel_panel_actually_set_backlight() is exactly the same (minus a small wording difference in the drm_dbg_kms() as the contents if the more widely used intel_backlight_set_pwm_level() function. Drop the duplicate

[PATCH linux-next] drm/i915/request: Remove unused variables

2021-11-21 Thread cgel . zte
From: yong yiran The clang_analyzer complains as follows: drivers/gpu/drm/i915/i915_request.c:2119:2 warning: Value stored to 'x' is never read Reported-by: Zeal Robot Signed-off-by: yong yiran --- drivers/gpu/drm/i915/i915_request.c | 3 --- 1 file changed, 3 deletions(-) diff --git