Re: [PATCH 1/2] drm/tidss: Fix initial plane zpos values

2024-02-13 Thread Daniel Stone
Hi, On Tue, 13 Feb 2024 at 10:18, Marius Vlad wrote: > On Tue, Feb 13, 2024 at 11:57:59AM +0200, Tomi Valkeinen wrote: > > I haven't. I'm quite unfamiliar with Weston, and Randolph from TI (cc'd) has > > been working on the Weston side of things. I also don't know if there's > > something TI

[PATCH v2 6/6] drm/i915/mst: enable MST mode for 128b/132b single-stream sideband

2024-02-13 Thread Jani Nikula
If the sink supports 128b/132b and single-stream sideband messaging, enable MST mode. With this, the topology manager will still write DP_MSTM_CTRL, which should be ignored by the sink. In the future, the topology manager should probably only set the sideband messaging related parts of the

[PATCH v2 5/6] drm/i915/mst: add intel_dp_mst_disconnect()

2024-02-13 Thread Jani Nikula
Abstract the MST mode disconnect to a separate function. Cc: Arun R Murthy Cc: Ville Syrjälä Signed-off-by: Jani Nikula --- drivers/gpu/drm/i915/display/intel_dp.c | 24 +++- 1 file changed, 15 insertions(+), 9 deletions(-) diff --git

[PATCH v2 4/6] drm/i915/mst: use the MST mode detected previously

2024-02-13 Thread Jani Nikula
Drop the duplicate read of DP_MSTM_CAP DPCD register, and the duplicate logic for choosing MST mode, and store the chosen mode in struct intel_dp. Rename intel_dp_configure_mst() to intel_dp_mst_configure() while at it. Cc: Arun R Murthy Cc: Ville Syrjälä Signed-off-by: Jani Nikula ---

[PATCH v2 3/6] drm/i915/mst: abstract choosing the MST mode to use

2024-02-13 Thread Jani Nikula
Clarify the conditions for choosing the MST mode to use by adding a new function intel_dp_mst_mode_choose(). This also prepares for being able to extend the MST modes to single-stream sideband messaging. Cc: Arun R Murthy Cc: Ville Syrjälä Signed-off-by: Jani Nikula ---

[PATCH v2 2/6] drm/i915/mst: improve debug logging of DP MST mode detect

2024-02-13 Thread Jani Nikula
Rename intel_dp_can_mst() to intel_dp_mst_detect(), and move all DP MST detect debug logging there. Debug log the sink's MST capability, including single-stream sideband messaging support, and the decision whether to enable MST mode or not. Do this regardless of whether we're actually enabling MST

[PATCH v2 1/6] drm/mst: read sideband messaging cap

2024-02-13 Thread Jani Nikula
Amend drm_dp_read_mst_cap() to return an enum, indicating "SST", "SST with sideband messaging", or "MST". Modify all call sites to take the new return value into account. v2: - Rename enumerators (Ville) Cc: Arun R Murthy Cc: Ville Syrjälä Signed-off-by: Jani Nikula ---

[PATCH v2 0/6] drm/i915/mst: enable MST mode for 128b/132b single-stream sideband

2024-02-13 Thread Jani Nikula
Sort of successor to [1], but revamped. BR, Jani. [1] https://patchwork.freedesktop.org/series/129468/ Jani Nikula (6): drm/mst: read sideband messaging cap drm/i915/mst: improve debug logging of DP MST mode detect drm/i915/mst: abstract choosing the MST mode to use drm/i915/mst: use

Re: [PATCH v2 16/19] drm/msm/dpu: modify encoder programming for CDM over DP

2024-02-13 Thread Dmitry Baryshkov
On Sat, 10 Feb 2024 at 03:53, Paloma Arellano wrote: > > Adjust the encoder format programming in the case of video mode for DP > to accommodate CDM related changes. > > Changes in v2: > - Move timing engine programming to a separate patch from this > one > - Move

[PATCH] char/agp: remove agp_bridge_data::type

2024-02-13 Thread Jiri Slaby (SUSE)
agp_bridge_data::type is unused (and I cannot find when was used last). Therefore, remove it. Found by https://github.com/jirislaby/clang-struct. Signed-off-by: Jiri Slaby (SUSE) Cc: David Airlie Cc: dri-devel@lists.freedesktop.org --- drivers/char/agp/agp.h | 1 - 1 file changed, 1

Re: [PATCH 00/28] Plane Color Pipeline support for Intel platforms

2024-02-13 Thread Pekka Paalanen
On Tue, 13 Feb 2024 12:18:07 +0530 Uma Shankar wrote: > This series intends to add support for Plane Color Management for > Intel platforms. This is based on the design which has been agreed > upon by the community. Series implementing the design for generic > DRM core has been sent out by Harry

Re: [PATCH 17/28] drm/i915: Define segmented Lut and add capabilities to colorop

2024-02-13 Thread Pekka Paalanen
On Tue, 13 Feb 2024 12:18:24 +0530 Uma Shankar wrote: > This defines the lut segments and create the color pipeline > > Signed-off-by: Uma Shankar > Signed-off-by: Chaitanya Kumar Borah > --- > drivers/gpu/drm/i915/display/intel_color.c | 109 + > 1 file changed, 109

Re: [PATCH 1/2] drm/tidss: Fix initial plane zpos values

2024-02-13 Thread Marius Vlad
On Tue, Feb 13, 2024 at 11:57:59AM +0200, Tomi Valkeinen wrote: > Hi, Hi, > > On 13/02/2024 11:04, Pekka Paalanen wrote: > > On Tue, 13 Feb 2024 10:16:36 +0200 > > Tomi Valkeinen wrote: > > > > > When the driver sets up the zpos property it sets the default zpos value > > > to the HW id of the

Re: [PATCH] drm/xe: avoid function cast warnings

2024-02-13 Thread Thomas Hellström
On Tue, 2024-02-13 at 10:56 +0100, Arnd Bergmann wrote: > From: Arnd Bergmann > > clang-16 warns about a cast between incompatible function types: > > drivers/gpu/drm/xe/xe_range_fence.c:155:10: error: cast from 'void > (*)(const void *)' to 'void (*)(struct xe_range_fence *)' converts to >

Re: [PATCH drm-misc-next] drm/xe: fix arguments to drm_err_printer()

2024-02-13 Thread Jani Nikula
On Tue, 13 Feb 2024, Thomas Hellström wrote: > On Tue, 2024-02-13 at 10:49 +0200, Jani Nikula wrote: >> The commit below changed drm_err_printer() arguments, but failed to >> update all places. >> >> Reported-by: Stephen Rothwell >> Closes: >>

Re: [PATCH 1/2] drm/tidss: Fix initial plane zpos values

2024-02-13 Thread Tomi Valkeinen
Hi, On 13/02/2024 11:04, Pekka Paalanen wrote: On Tue, 13 Feb 2024 10:16:36 +0200 Tomi Valkeinen wrote: When the driver sets up the zpos property it sets the default zpos value to the HW id of the plane. That is fine as such, but as on many DSS versions the driver arranges the DRM planes in

[PATCH] nouveau: fix function cast warnings

2024-02-13 Thread Arnd Bergmann
From: Arnd Bergmann clang-16 warns about casting between incompatible function types: drivers/gpu/drm/nouveau/nvkm/subdev/bios/shadow.c:161:10: error: cast from 'void (*)(const struct firmware *)' to 'void (*)(void *)' converts to incompatible function type

[PATCH] drm/xe: avoid function cast warnings

2024-02-13 Thread Arnd Bergmann
From: Arnd Bergmann clang-16 warns about a cast between incompatible function types: drivers/gpu/drm/xe/xe_range_fence.c:155:10: error: cast from 'void (*)(const void *)' to 'void (*)(struct xe_range_fence *)' converts to incompatible function type [-Werror,-Wcast-function-type-strict] 155

Re: [PATCH v2 2/3] Subject: [PATCH] drm/mediatek/dp: Add HDCP2.x feature for DisplayPort

2024-02-13 Thread kernel test robot
Hi mac.shen, kernel test robot noticed the following build errors: [auto build test ERROR on drm-misc/drm-misc-next] [also build test ERROR on pza/reset/next linus/master v6.8-rc4 next-20240213] [cannot apply to pza/imx-drm/next] [If your patch is applied to the wrong git tree, kindly drop us

Re: [PATCH drm-misc-next] drm/xe: fix arguments to drm_err_printer()

2024-02-13 Thread Thomas Hellström
On Tue, 2024-02-13 at 10:49 +0200, Jani Nikula wrote: > The commit below changed drm_err_printer() arguments, but failed to > update all places. > > Reported-by: Stephen Rothwell > Closes: > https://lore.kernel.org/r/20240213120410.75c45...@canb.auug.org.au > Fixes: 5e0c04c8c40b ("drm/print:

Re: [PATCH] drm: document userspace expectations around the Colorspace connector property

2024-02-13 Thread Ville Syrjälä
On Mon, Feb 12, 2024 at 05:50:36PM +0100, Sebastian Wick wrote: > On Mon, Feb 12, 2024 at 11:10:15AM +0200, Pekka Paalanen wrote: > > On Fri, 9 Feb 2024 17:53:07 +0100 > > Xaver Hugl wrote: > > > > > Signed-off-by: Xaver Hugl > > > --- > > > drivers/gpu/drm/drm_connector.c | 8 > > >

Re: [PATCH 05/28] drm: Add support for 3x3 CTM

2024-02-13 Thread Pekka Paalanen
On Tue, 13 Feb 2024 12:18:12 +0530 Uma Shankar wrote: > From: Chaitanya Kumar Borah > > Add support for 3x3 Color Transformation Matrices in Color Pipeline. > > Signed-off-by: Chaitanya Kumar Borah > Signed-off-by: Uma Shankar > --- > drivers/gpu/drm/drm_atomic_uapi.c | 3 +++ >

Re: [PATCH 1/2] drm/tidss: Fix initial plane zpos values

2024-02-13 Thread Pekka Paalanen
On Tue, 13 Feb 2024 10:16:36 +0200 Tomi Valkeinen wrote: > When the driver sets up the zpos property it sets the default zpos value > to the HW id of the plane. That is fine as such, but as on many DSS > versions the driver arranges the DRM planes in a different order than > the HW planes (to

Re: [PATCH] drm: document userspace expectations around the Colorspace connector property

2024-02-13 Thread Pekka Paalanen
On Mon, 12 Feb 2024 17:50:36 +0100 Sebastian Wick wrote: > On Mon, Feb 12, 2024 at 11:10:15AM +0200, Pekka Paalanen wrote: > > On Fri, 9 Feb 2024 17:53:07 +0100 > > Xaver Hugl wrote: > > > > > Signed-off-by: Xaver Hugl > > > --- > > > drivers/gpu/drm/drm_connector.c | 8 > > > 1

[PATCH drm-misc-next] drm/xe: fix arguments to drm_err_printer()

2024-02-13 Thread Jani Nikula
The commit below changed drm_err_printer() arguments, but failed to update all places. Reported-by: Stephen Rothwell Closes: https://lore.kernel.org/r/20240213120410.75c45...@canb.auug.org.au Fixes: 5e0c04c8c40b ("drm/print: make drm_err_printer() device specific by using drm_err()") Cc: Luca

[PATCH v2 7/8] fbdev: Clean up forward declarations in header file

2024-02-13 Thread Thomas Zimmermann
Add forward declarations for struct i2c_adapter and struct module, and sort the list alphabetically. Signed-off-by: Thomas Zimmermann Reviewed-by: Jani Nikula --- include/linux/fb.h | 8 +--- 1 file changed, 5 insertions(+), 3 deletions(-) diff --git a/include/linux/fb.h

[PATCH v2 8/8] fbdev: Clean up include statements in header file

2024-02-13 Thread Thomas Zimmermann
Include mutex.h, printk.h and types.h, remove several unnecessary include statements, and sort the list alphabetically. Signed-off-by: Thomas Zimmermann Reviewed-by: Jani Nikula --- include/linux/fb.h | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git

[PATCH v2 0/8] fbdev: Clean up include dependencies in header

2024-02-13 Thread Thomas Zimmermann
Remove unnecessary dependencies in the include statements of the header file . Several files throughout the kernel include the fbdev header, so reducing dependencies positively affects other subsystems as well. Also fix up nouveau and fbtft, which need backlight.h in some their source files. v2:

[PATCH v2 6/8] fbdev: Do not include in header

2024-02-13 Thread Thomas Zimmermann
Forward declare struct page and remove the include statement. Signed-off-by: Thomas Zimmermann Reviewed-by: Jani Nikula --- include/linux/fb.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/include/linux/fb.h b/include/linux/fb.h index 90f348f14a490..42155898374b1 100644

[PATCH v2 5/8] fbdev: Do not include in header

2024-02-13 Thread Thomas Zimmermann
Forward declare struct notifier_block and remove the include statement. Signed-off-by: Thomas Zimmermann Reviewed-by: Jani Nikula --- include/linux/fb.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/include/linux/fb.h b/include/linux/fb.h index

[PATCH v2 4/8] fbdev: Do not include in header

2024-02-13 Thread Thomas Zimmermann
Forward declare struct inode and remove the include statement. Signed-off-by: Thomas Zimmermann Reviewed-by: Jani Nikula --- include/linux/fb.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/include/linux/fb.h b/include/linux/fb.h index 7380d959c5d53..f269ba5202809 100644

[PATCH v2 3/8] fbdev: Do not include in header

2024-02-13 Thread Thomas Zimmermann
Forward declare struct backlight_device and remove the include statement. Signed-off-by: Thomas Zimmermann Reviewed-by: Jani Nikula --- include/linux/fb.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/include/linux/fb.h b/include/linux/fb.h index

[PATCH v2 2/8] staging/fbtft: Include

2024-02-13 Thread Thomas Zimmermann
Resolved the proxy include via , which does not require the backlight header. Signed-off-by: Thomas Zimmermann --- drivers/staging/fbtft/fb_ssd1351.c | 2 ++ 1 file changed, 2 insertions(+) diff --git a/drivers/staging/fbtft/fb_ssd1351.c b/drivers/staging/fbtft/fb_ssd1351.c index

[PATCH v2 1/8] drm/nouveau: Include

2024-02-13 Thread Thomas Zimmermann
Resolved the proxy include via , which does not require the backlight header. Signed-off-by: Thomas Zimmermann Reviewed-by: Jani Nikula --- drivers/gpu/drm/nouveau/dispnv50/disp.c | 1 + 1 file changed, 1 insertion(+) diff --git a/drivers/gpu/drm/nouveau/dispnv50/disp.c

Re: Re: Re: Re: Re: Re: [PATCH v5 08/44] drm/connector: hdmi: Add Broadcast RGB property

2024-02-13 Thread Ville Syrjälä
On Mon, Feb 12, 2024 at 05:53:48PM +0100, Maxime Ripard wrote: > On Mon, Feb 12, 2024 at 05:49:33PM +0200, Ville Syrjälä wrote: > > On Mon, Feb 12, 2024 at 11:01:07AM +0100, Maxime Ripard wrote: > > > On Fri, Feb 09, 2024 at 09:34:35PM +0100, Sebastian Wick wrote: > > > > On Mon, Feb 05, 2024 at

[PATCH 2/2] drm/tidss: Fix sync-lost issue with two displays

2024-02-13 Thread Tomi Valkeinen
A sync lost issue can be observed with two displays, when moving a plane from one disabled display to an another disabled display, and then enabling the display to which the plane was moved to. The exact requirements for this to trigger are not clear. It looks like the issue is that the layers

[PATCH 1/2] drm/tidss: Fix initial plane zpos values

2024-02-13 Thread Tomi Valkeinen
When the driver sets up the zpos property it sets the default zpos value to the HW id of the plane. That is fine as such, but as on many DSS versions the driver arranges the DRM planes in a different order than the HW planes (to keep the non-scalable planes first), this leads to odd initial zpos

[PATCH 0/2] drm/tidss: Fixes for zpos and multi-display

2024-02-13 Thread Tomi Valkeinen
drivers/gpu/drm/tidss/tidss_crtc.c | 10 ++ drivers/gpu/drm/tidss/tidss_plane.c | 2 +- 2 files changed, 11 insertions(+), 1 deletion(-) --- base-commit: 423af970da74db7eed1b14f2b7f115714a67aeb8 change-id: 20240213-tidss-fixes-cc3741cd604c Best regards, -- Tomi Valkeinen

Re: [PATCH 4/7] drm/panel: st7703: Add Panel Rotation Support

2024-02-13 Thread Guido Günther
Hi, On Mon, Feb 12, 2024 at 12:49:47PM -0600, Chris Morgan wrote: > From: Chris Morgan > > Add support for panel rotation to ST7703 based devices. > > Signed-off-by: Chris Morgan > --- > drivers/gpu/drm/panel/panel-sitronix-st7703.c | 13 + > 1 file changed, 13 insertions(+) > >

Re: [PATCH 3/7] dt-bindings: display: Document ST7703 panel rotation

2024-02-13 Thread Guido Günther
Hi, On Mon, Feb 12, 2024 at 12:49:46PM -0600, Chris Morgan wrote: > From: Chris Morgan > > Document the rotation property for ST7703 based panels. > > Signed-off-by: Chris Morgan > --- > .../devicetree/bindings/display/panel/rocktech,jh057n00900.yaml | 2 ++ > 1 file changed, 2 insertions(+)

Re: [PATCH 2/7] drm/panel: st7703: Add Powkiddy RGB10MAX3 Panel Support

2024-02-13 Thread Guido Günther
Hi, On Mon, Feb 12, 2024 at 12:49:45PM -0600, Chris Morgan wrote: > From: Chris Morgan > > The Powkiddy RGB10MAX3 is a handheld device with a 5 inch 720x1280 > display panel with a Sitronix ST7703 display controller. The panel > is installed rotated 270 degrees. > > Signed-off-by: Chris Morgan

Re: [PATCH 1/7] dt-bindings: display: st7703: Add Powkiddy RGB10MAX3 panel

2024-02-13 Thread Guido Günther
Hi, On Mon, Feb 12, 2024 at 12:49:44PM -0600, Chris Morgan wrote: > From: Chris Morgan > > The RGB10MAX3 panel is a panel specific to the Powkiddy RGB10MAX3 > handheld device that measures 5 inches diagonally with a resolution > of 720x1280. > > Signed-off-by: Chris Morgan > --- >

<    1   2