[GIT PULL FOR v6.4] drm: rcar-du: Miscellaneous fixes and improvements

2023-03-25 Thread Laurent Pinchart
/kernel/git/pinchartl/linux.git tags/drm-rcar-next-20230325 for you to fetch changes up to 40f43730f43699ce8557e4fe59622d4f4b69f44a: drm: rcar-du: Fix a NULL vs IS_ERR() bug (2023-03-25 22:38:10 +0200) drm: rcar-du: Miscellaneous

[PATCH v2] drm/amdgpu: Remove unused variable that holds a return value

2023-03-25 Thread Carlos Eduardo Gallo Filho
Compiling amdgpu with W=1 get that unused-but-set-variable warning. drivers/gpu/drm/amd/amdgpu/amdgpu_mes.c: In function ‘amdgpu_mes_ctx_alloc_meta_data’: drivers/gpu/drm/amd/amdgpu/amdgpu_mes.c:1099:13: warning: variable ‘r’ set but not used [-Wunused-but-set-variable] 1099 | int r;

Re: [PATCH] drm/display: Add missing OLED Vesa brightnesses definitions

2023-03-25 Thread Pavel Machek
On Wed 2023-03-22 10:05:13, Rodrigo Siqueira wrote: > Cc: Anthony Koo > Cc: Iswara Negulendran > Cc: Felipe Clark > Cc: Harry Wentland > Signed-off-by: Rodrigo Siqueira Some changelog would be useful. > +++ b/include/drm/display/drm_dp.h > @@ -977,6 +977,8 @@ > # define

Re: [PATCH v4 04/14] drm/msm/a6xx: Extend and explain UBWC config

2023-03-25 Thread Rob Clark
On Tue, Mar 14, 2023 at 8:28 AM Konrad Dybcio wrote: > > Rename lower_bit to hbb_lo and explain what it signifies. > Add explanations (wherever possible to other tunables). > > Port setting min_access_length, ubwc_mode and hbb_hi from downstream. > > Signed-off-by: Konrad Dybcio Reviewed-by:

[pull] drm: dma-fence-deadline-core for v6.4

2023-03-25 Thread Rob Clark
Hi Dave and Daniel, Here is the series for dma-fence deadline hint, without driver specific patches, with the intent that it can be merged into drm-next as well as -driver next trees to enable landing driver specific support through their corresponding -next trees. The following changes since

[PATCH] drm/amdgpu: Remove ununsed variable that holds a return value

2023-03-25 Thread Carlos Eduardo Gallo Filho
Compiling amdgpu with W=1 get that unused-but-set-variable warning. drivers/gpu/drm/amd/amdgpu/amdgpu_mes.c: In function ‘amdgpu_mes_ctx_alloc_meta_data’: drivers/gpu/drm/amd/amdgpu/amdgpu_mes.c:1099:13: warning: variable ‘r’ set but not used [-Wunused-but-set-variable] 1099 | int r;

[PATCH v2] drm/i915/overlay: Remove redundant drm_rect_visible() use

2023-03-25 Thread Arthur Grillo
The drm_rect_intersect() already returns if the intersection is visible or not, so the use of drm_rect_visible() is duplicate. Signed-off-by: Arthur Grillo --- v1->v2: https://lore.kernel.org/all/20230324142533.6357-1-arthurgri...@riseup.net/ - Split the if condition. ---

Re: [PATCH v13 01/10] drm/shmem-helper: Switch to reservation lock

2023-03-25 Thread Dmitry Osipenko
On 3/15/23 16:46, Dmitry Osipenko wrote: > On 3/14/23 05:26, Dmitry Osipenko wrote: >> @@ -633,7 +605,10 @@ int drm_gem_shmem_mmap(struct drm_gem_shmem_object >> *shmem, struct vm_area_struct >> return ret; >> } >> >> +dma_resv_lock(shmem->base.resv, NULL); >> ret =

[PATCH] drm/amd/display: remove unused matching_stream_ptrs variable

2023-03-25 Thread Tom Rix
clang with W=1 reports drivers/gpu/drm/amd/amdgpu/../display/dc/core/dc_link_enc_cfg.c:625:6: error: variable 'matching_stream_ptrs' set but not used [-Werror,-Wunused-but-set-variable] int matching_stream_ptrs = 0; ^ This variable is not used so remove it. Signed-off-by:

[PATCH] drm/scheduler: Fix variable name in function description

2023-03-25 Thread Caio Novais
Compiling AMD GPU drivers displays two warnings: drivers/gpu/drm/scheduler/sched_main.c:738: warning: Function parameter or member 'file' not described in 'drm_sched_job_add_syncobj_dependency' drivers/gpu/drm/scheduler/sched_main.c:738: warning: Excess function parameter 'file_private'

Re: [PATCH] drm/sun4i: uncouple DSI dotclock divider from TCON0_DCLK_REG

2023-03-25 Thread Frank Oltmanns
Hi, On 2023-03-20 at 17:16:36 +0100, Roman Beranek wrote: > In the case of DSI output, the value of SUN4I_TCON0_DCLK_DIV (4) does > not represent the actual dotclock divider, PLL_MIPI instead runs at > (bpp / lanes )-multiple [1] of the dotclock. [2] Setting 4 as dotclock > divder thus leads to

[bug report] vga_switcheroo: set audio client id according to bound GPU id

2023-03-25 Thread Dan Carpenter
Hello Jim Qu, The patch 4aaf448fa975: "vga_switcheroo: set audio client id according to bound GPU id" from Jul 17, 2018, leads to the following Smatch static checker warning: drivers/gpu/vga/vga_switcheroo.c:378 vga_switcheroo_register_audio_client() warn: unsigned 'id' is never

Re: [PATCH resent] drm/amd/display: Fix exception handling in dm_validate_stream_and_context()

2023-03-25 Thread Markus Elfring
>> The label “cleanup” was used to jump to another pointer check despite of >> the detail in the implementation of the function >> “dm_validate_stream_and_context” >> that it was determined already that corresponding variables contained >> still null pointers. >> >> 1. Thus return directly if >>  

[PATCH resent] drm/amd/display: Fix exception handling in dm_validate_stream_and_context()

2023-03-25 Thread Markus Elfring
Date: Sat, 18 Mar 2023 16:21:32 +0100 The label “cleanup” was used to jump to another pointer check despite of the detail in the implementation of the function “dm_validate_stream_and_context” that it was determined already that corresponding variables contained still null pointers. 1. Thus

[PATCH] drm/fbdev-generic: optimize out a redundant assignment clause

2023-03-25 Thread Sui Jingfeng
The assignment already done in drm_client_buffer_vmap(), just trival clean, no functional change. Signed-off-by: Sui Jingfeng <15330273...@189.cn> --- drivers/gpu/drm/drm_fbdev_generic.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git

Re: [PATCH v2 2/2] checkpatch: allow Closes tags with links

2023-03-25 Thread Thorsten Leemhuis
On 24.03.23 19:52, Matthieu Baerts wrote: > As a follow-up of the previous patch modifying the documentation to > allow using the "Closes:" tag, checkpatch.pl is updated accordingly. > > checkpatch.pl now mentions the "Closes:" tag between brackets to express > the fact it should be used only if

Re: [PATCH v6 5/8] drm/i915/pxp: Add ARB session creation and cleanup

2023-03-25 Thread Teres Alexis, Alan Previn
alan:snip > @@ -353,8 +367,20 @@ int intel_pxp_start(struct intel_pxp *pxp) alan:snip > > + if (HAS_ENGINE(pxp->ctrl_gt, GSC0)) { > > + /* > > +* GSC-fw loading, GSC-proxy init (requiring an mei component > > driver) and > > +* HuC-fw loading must all occur

Re: [PATCH] drm/bridge: it6505: Add lock for it6505 i2c bank

2023-03-25 Thread Hsin-Yi Wang
On Fri, Mar 24, 2023 at 11:34 PM Hsin-Yi Wang wrote: > > On Fri, Mar 24, 2023 at 8:18 PM Andrzej Hajda wrote: > > > > > > > > On 24.03.2023 08:29, Hsin-Yi Wang wrote: > > > From: xiazhengqiao > > > > > > When the i2c bank register (REG_BANK_SEL) is set to 1, > > > only the registers belong to

Re: [PATCH v6 5/8] drm/i915/pxp: Add ARB session creation and cleanup

2023-03-25 Thread Teres Alexis, Alan Previn
On Fri, 2023-03-03 at 17:34 -0800, Ceraolo Spurio, Daniele wrote: > > On 2/27/2023 6:21 PM, Alan Previn wrote: > > Add MTL's function for ARB session creation using PXP firmware > > version 4.3 ABI structure format. > alan:snip > > + ret = gsccs_send_message_retry_complete(pxp, > > +