[PATCH] staging: lustre: lnet: prefer kcalloc over kzalloc with multiply

2018-01-19 Thread Sumit Pundir
Use kcalloc for allocating an array instead of kzalloc with multiply. kcalloc is the preferred API. Issue reported by checkpatch.pl Signed-off-by: Sumit Pundir --- drivers/staging/lustre/lnet/lnet/config.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/lu

Re: [PATCH v3 3/7] x86/hyper-v: reenlightenment notifications support

2018-01-19 Thread Thomas Gleixner
0180118] > > [cannot apply to tip/x86/core kvm/linux-next] > > [if your patch is applied to the wrong git tree, please drop us a note to > > help improve the system] > > > > url: > > https://github.com/0day-ci/linux/commits/Vitaly-Kuznetsov/x86-kvm-hype

Re: [PATCH 1/2] staging: lustre: Fix comment style

2018-01-19 Thread Joe Perches
On Thu, 2018-01-18 at 16:51 +0100, Fabian Huegel wrote: > Most multi-line comments started on the first line, but the preferred > linux kernel style is to start multi-line comments on the second line. > Some comments became less readable after the change, so we changed them > to single-line comment

[PATCH net-next] hv_netvsc: Use the num_online_cpus() for channel limit

2018-01-19 Thread Haiyang Zhang
From: Haiyang Zhang Since we no longer localize channel/CPU affiliation within one NUMA node, num_online_cpus() is used as the number of channel cap, instead of the number of processors in a NUMA node. This patch allows a bigger range for tuning the number of channels. Signed-off-by: Haiyang Zh

[PATCH net-next] hv_netvsc: Use the num_online_cpus() for channel limit

2018-01-19 Thread Haiyang Zhang
From: Haiyang Zhang Since we no longer localize channel/CPU affiliation within one NUMA node, num_online_cpus() is used as the number of channel cap, instead of the number of processors in a NUMA node. This patch allows a bigger range for tuning the number of channels. Signed-off-by: Haiyang Zh

Re: [PATCH] staging: android: ion: Zero CMA allocated memory

2018-01-19 Thread Dan Carpenter
On Fri, Jan 19, 2018 at 11:16:47AM -0800, Liam Mark wrote: > Since the CMA API is now used directly the allocated memory is no longer > automatically zeroed. > > Explicitly zero CMA allocated memory to ensure that no data is exposed > to userspace. > > Change-Id: I08e143707a0d31610821a7f16826c262

[PATCH] staging: android: ion: Zero CMA allocated memory

2018-01-19 Thread Liam Mark
Since the CMA API is now used directly the allocated memory is no longer automatically zeroed. Explicitly zero CMA allocated memory to ensure that no data is exposed to userspace. Change-Id: I08e143707a0d31610821a7f16826c262bf3c1999 Signed-off-by: Liam Mark --- drivers/staging/android/ion/ion_c

[PATCH v3 4/4] Staging: rtl8723bs: Use !x instead of NULL comparison

2018-01-19 Thread Shreeya Patel
If "x" is compared to NULL, use "!x" instead of it, so as to follow the kernel coding style. Signed-off-by: Shreeya Patel --- drivers/staging/rtl8723bs/hal/sdio_ops.c | 16 1 file changed, 8 insertions(+), 8 deletions(-) diff --git a/drivers/staging/rtl8723bs/hal/sdio_ops.c b/

[PATCH v3 3/4] Staging: rtl8723bs: Remove dead code

2018-01-19 Thread Shreeya Patel
"oldmem==NULL;" The above bug under the ifdef code would have caused a GCC warning if it were ever compiled. Hence, remove the dead ifdefed code from the file. Signed-off-by: Shreeya Patel --- Changes in v3 -Remove dead code. drivers/staging/rtl8723bs/hal/sdio_ops.c | 15 --- 1 f

[PATCH v3 2/4] Staging: rtl8723bs: Change names to conform to the kernel code

2018-01-19 Thread Shreeya Patel
Change names of some variables and functions to conform to the kernel coding style. The changes include some removal of CamelCase warnings and renaming the variable and field names that encode their type (eg the pointers seem to start with p). Signed-off-by: Shreeya Patel --- Changes in v3 -Ed

PROJECT FUNDING..

2018-01-19 Thread ALBERT HERNANDEZ
Good day, Well We are investment Research Company and we undertake the services of assisting prospective companies and individuals to satisfactorily meet the needs of their capital investment abroad,I'm contacting you because We are currently expanding our global presence by investing in projec

[PATCH v3 1/4] Staging: rtl8723bs: Replace true with x and false with !x

2018-01-19 Thread Shreeya Patel
Replace true and false keywords with "x" and "!x" respectively to follow the kernel coding style. Signed-off-by: Shreeya Patel --- drivers/staging/rtl8723bs/hal/sdio_ops.c | 30 ++ 1 file changed, 14 insertions(+), 16 deletions(-) diff --git a/drivers/staging/rtl8723

[PATCH v3 0/4] Remove checkpatch warnings

2018-01-19 Thread Shreeya Patel
This patchset removes some warnings generated by checkpatch for cleanup of the rtl8723bs driver. Also some additional cleanups are introduced in the *[1/4] and *[3/4] patches to make the code according to the kernel coding style. Changes in v2 -Rebase and resend all patches. Changes in v3 -Ed

Re: [PATCH 04/14] staging: wilc1000: rename host_int_ParseJoinBssParam() and it's variable using camelCase

2018-01-19 Thread Claudiu Beznea
On 19.01.2018 14:44, Dan Carpenter wrote: > On Fri, Jan 19, 2018 at 01:20:00PM +0200, Claudiu Beznea wrote: >> It is hard to review this. Anyway, Reviewed-by: Claudiu Beznea >> >> > > I have a script I use. It's sort of hacky, but it's a time saver. I've > attached it. > > To review this on

Re: [PATCH 04/14] staging: wilc1000: rename host_int_ParseJoinBssParam() and it's variable using camelCase

2018-01-19 Thread Dan Carpenter
On Fri, Jan 19, 2018 at 01:20:00PM +0200, Claudiu Beznea wrote: > It is hard to review this. Anyway, Reviewed-by: Claudiu Beznea > > I have a script I use. It's sort of hacky, but it's a time saver. I've attached it. To review this one, I do `cat | rename_rev.pl -a` regards, dan carpenter

Re: [PATCH 00/14] fix to remove unnecessary parenthesis,typedef and avoid camelCase

2018-01-19 Thread Claudiu Beznea
All series Reviewed-by: Claudiu Beznea with the inline comments. Ajay, one general remark, please use Capital letters when beginning new sentences (I'm talking about commit descriptions). Thanks, Claudiu Beznea On 18.01.2018 15:16, Ajay Singh wrote: > This patch series contains changes to fix i

Re: [PATCH 05/14] staging: wilc1000: rename camelCase used in Handle_DelAllSta() and its variable

2018-01-19 Thread Claudiu Beznea
On 18.01.2018 15:17, Ajay Singh wrote: > fix "Avoid camelCase" issue reported by checkpatch.pl script. > > Signed-off-by: Ajay Singh > --- > drivers/staging/wilc1000/host_interface.c | 24 > 1 file changed, 12 insertions(+), 12 deletions(-) > > diff --git a/drivers/st

Re: [PATCH 04/14] staging: wilc1000: rename host_int_ParseJoinBssParam() and it's variable using camelCase

2018-01-19 Thread Claudiu Beznea
It is hard to review this. Anyway, Reviewed-by: Claudiu Beznea On 18.01.2018 15:17, Ajay Singh wrote: > fix "Avoid CamelCase:" issue reported by checkpatch.pl script > Rename host_int_ParseJoinBssParam() & its variables name using > camelCase. > > Signed-off-by: Ajay Singh > --- > drivers/sta

Re: [PATCH 10/14] staging: wilc1000: rename ptstrJoinBssParam variable to avoid camelCase

2018-01-19 Thread Claudiu Beznea
On 18.01.2018 15:17, Ajay Singh wrote: > fix "Avoid camelCase" issue reported by checkpatch.pl script. > > Signed-off-by: Ajay Singh > --- > drivers/staging/wilc1000/host_interface.c | 78 > +++ > 1 file changed, 39 insertions(+), 39 deletions(-) > > diff --git a/

Re: [PATCH 09/14] staging: wilc1000: rename pstrHostIFconnectAttr argument to avoid camelCase

2018-01-19 Thread Claudiu Beznea
On 18.01.2018 15:17, Ajay Singh wrote: > fix "Avoid camelCase" issue found by checkpatch.pl script. > > Signed-off-by: Ajay Singh > --- > drivers/staging/wilc1000/host_interface.c | 104 > ++ > 1 file changed, 49 insertions(+), 55 deletions(-) > > diff --git a/dri

Re: [PATCH v3 7/7] x86/kvm: support Hyper-V reenlightenment

2018-01-19 Thread kbuild test robot
improve the system] url: https://github.com/0day-ci/linux/commits/Vitaly-Kuznetsov/x86-kvm-hyperv-stable-clocksorce-for-L2-guests-when-running-nested-KVM-on-Hyper-V/20180119-160814 reproduce: # apt-get install sparse make ARCH=x86_64 allmodconfig make C=1 CF=-D__CHECK_ENDIAN__

[RFC PATCH] x86/kvm: kvm_hyperv_tsc_notifier() can be static

2018-01-19 Thread kbuild test robot
Fixes: ce386b0e39a0 ("x86/kvm: support Hyper-V reenlightenment") Signed-off-by: Fengguang Wu --- x86.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/arch/x86/kvm/x86.c b/arch/x86/kvm/x86.c index 94f28e6..27e590a 100644 --- a/arch/x86/kvm/x86.c +++ b/arch/x86/kvm/x86.c @@

Re: [PATCH v3 3/7] x86/hyper-v: reenlightenment notifications support

2018-01-19 Thread kbuild test robot
improve the system] url: https://github.com/0day-ci/linux/commits/Vitaly-Kuznetsov/x86-kvm-hyperv-stable-clocksorce-for-L2-guests-when-running-nested-KVM-on-Hyper-V/20180119-160814 config: x86_64-randconfig-s5-01191733 (attached as .config) compiler: gcc-7 (Debian 7.2.0-12) 7.2.1 20171025 reproduce

Re: [PATCH v3 3/7] x86/hyper-v: reenlightenment notifications support

2018-01-19 Thread Vitaly Kuznetsov
applied to the wrong git tree, please drop us a note to > help improve the system] > > url: > https://github.com/0day-ci/linux/commits/Vitaly-Kuznetsov/x86-kvm-hyperv-stable-clocksorce-for-L2-guests-when-running-nested-KVM-on-Hyper-V/20180119-160814 > config: x86_64-allmodconfig

Re: [PATCH v3 3/7] x86/hyper-v: reenlightenment notifications support

2018-01-19 Thread kbuild test robot
improve the system] url: https://github.com/0day-ci/linux/commits/Vitaly-Kuznetsov/x86-kvm-hyperv-stable-clocksorce-for-L2-guests-when-running-nested-KVM-on-Hyper-V/20180119-160814 config: x86_64-allmodconfig (attached as .config) compiler: gcc-7 (Debian 7.2.0-12) 7.2.1 20171025 reproduce