[PATCH 37/42] staging: unisys: visorbus: fix multi-line function definition

2017-07-17 Thread David Kershner
From: Charles Daniels Fixed incorrectly styled function definitions in visorbus/visorchipset.c by placing the function names on the same line as the return. Signed-off-by: Charles Daniels Signed-off-by: David Kershner

[PATCH 38/42] staging: unisys: visorbus: visorchannel.c: fix multi-line function definition

2017-07-17 Thread David Kershner
From: Charles Daniels Fixed incorrect function definition style in visorbus/visorchannel.c by placing the function names on the same line as the return. Signed-off-by: Charles Daniels Signed-off-by: David Kershner

[PATCH 34/42] staging: unisys: visorbus: cleaned up include block of visorchipset.c

2017-07-17 Thread David Kershner
From: Mark Foresta Removed 4 unneeded includes netdevice, nls, fs, and ctype. Signed-off-by: Mark Foresta Signed-off-by: David Kershner Reviewed-by: David Binder ---

[PATCH 39/42] staging: unisys: visorhba: fix multi-line function definition

2017-07-17 Thread David Kershner
From: Charles Daniels Fixed incorrect function definition style in visorhba/visorhba_main.c by placing the function names on the same line as the return. Signed-off-by: Charles Daniels Signed-off-by: David Kershner

[PATCH 41/42] staging: unisys: visornic: fix multi-line function definition

2017-07-17 Thread David Kershner
From: Charles Daniels Fixed incorrect function declaration style in visornic/visornic_main.c by placing the function names on the same line as the return. Signed-off-by: Charles Daniels Signed-off-by: David Kershner

[PATCH 42/42] staging: unisys: visornic: update the struct viosrnic_devdata to have kernel-doc like comments

2017-07-17 Thread David Kershner
From: Sameer Wadgaonkar Cleaned up the in-line comments in the structure and added a kernel-doc like comment for the structure. Signed-off-by: Sameer Wadgaonkar Signed-off-by: David Kershner Reviewed-by:

[PATCH 33/42] staging: unisys: visorbus: Removed unused define from visorbus_main.c

2017-07-17 Thread David Kershner
From: Mark Foresta Removed unused #define CURRENT_FILE_PC. Signed-off-by: Mark Foresta Signed-off-by: David Kershner Reviewed-by: David Binder ---

[PATCH 32/42] staging: unisys: visorbus: removed blank line in viorbus_main.c

2017-07-17 Thread David Kershner
From: Mark Foresta Removed blank line between #defines. Signed-off-by: Mark Foresta Signed-off-by: David Kershner Reviewed-by: David Binder ---

[PATCH 16/42] staging: unisys: visorbus: visorbus_main.c: remove extra checks for dev->visorchannel

2017-07-17 Thread David Kershner
From: Sameer Wadgaonkar Removed checks for dev->visorchannel in visorbus_release_device() and visorbus_remove_instance() since it is also checked in the visorchannel_destroy() function. Signed-off-by: Sameer Wadgaonkar Signed-off-by:

[PATCH 40/42] staging: unisys: visorinput: fix multi-line function definition

2017-07-17 Thread David Kershner
From: Charles Daniels Fixed incorrect function declaration style in visorinput/visorinput.c by placing the function names on the same line as the return. Signed-off-by: Charles Daniels Signed-off-by: David Kershner

[PATCH 27/42] staging: unisys: visorbus: rename fix_vbus_dev_info

2017-07-17 Thread David Kershner
From: Erik Arfvidson Rename fix_vbus_dev_info to something clearer: publish_vbus_dev_info. Signed-off-by: Erik Arfvidson Signed-off-by: David Kershner Reviewed-by: David Binder ---

[patch v2 2/3] staging: speakup: use tty_kopen instead of tty_open_by_driver

2017-07-17 Thread Okash Khawaja
This patch replaces call to tty_open_by_driver with a tty_kopen. Signed-off-by: Okash Khawaja --- drivers/staging/speakup/spk_ttyio.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) --- a/drivers/staging/speakup/spk_ttyio.c +++

[patch v2 1/3] tty: resolve tty contention between kernel and user space

2017-07-17 Thread Okash Khawaja
The commit 12e84c71b7d4ee (tty: export tty_open_by_driver) exports tty_open_by_device to allow tty to be opened from inside kernel which works fine except that it doesn't handle contention with user space or another kernel-space open of the same tty. For example, opening a tty from user space

[patch v2 3/3] tty: undo export of tty_open_by_driver

2017-07-17 Thread Okash Khawaja
Since we have tty_kopen, we no longer need to export tty_open_by_driver. This patch makes this function static. Signed-off-by: Okash Khawaja --- drivers/tty/tty_io.c |3 +-- include/linux/tty.h |5 - 2 files changed, 1 insertion(+), 7 deletions(-) ---

[patch v2 0/3] tty contention resulting from tty_open_by_driver export

2017-07-17 Thread Okash Khawaja
Hi, I have reworked the previous patch set. These are the changes: 1. Patch 1 fixes tty->count mismatch reported by check_tty_count when a tty is kopened. 2. Patch 1 incorporates patch 4 in the previous patch set - it returns -ENODEV when tty is not configured. Thanks, Okash

Re: [PATCH] staging: gs_fpgaboot: add buffer overflow checks

2017-07-17 Thread Jacob von Chorus
On Mon, Jul 17, 2017 at 10:53:25PM +0300, Dan Carpenter wrote: > > + if (len + 1 > n) { > > It's more idiomatic to say "if (len >= n)". Plus that's a good habbit My reasoning behind using "((len + 1) > n)" is that len represents the length of the string without null-termination. "buf" is

Re: [PATCH 1/3] staging: ccree: Replace kzalloc with devm_kzalloc

2017-07-17 Thread Suniel Mahesh
On Monday 17 July 2017 06:03 PM, Greg KH wrote: > On Sat, Jul 15, 2017 at 01:21:54PM +0530, suni...@techveda.org wrote: >> From: Suniel Mahesh >> >> It is recommended to use managed function devm_kzalloc, which >> simplifies driver cleanup paths and driver code. >> This

Re: [PATCH v2 2/2] staging: gs_fpgaboot: change char to u8

2017-07-17 Thread Joe Perches
On Mon, 2017-07-17 at 20:47 -0400, Jacob von Chorus wrote: > The bitstream storage variables were changed from char to u8 arrays to > prevent issues such as negative lengths. This change makes the code > compatible with the "data" field in "struct firmware" which is of type > u8. > >

Re: [PATCH] staging: unisys: visorbus: constify attribute_group structures.

2017-07-17 Thread Greg KH
On Mon, Jul 17, 2017 at 09:36:58PM +, Kershner, David A wrote: > > -Original Message- > > From: Greg KH [mailto:g...@kroah.com] > > Sent: Monday, July 17, 2017 8:38 AM > > To: Arvind Yadav > > Cc: Kershner, David A ; Sell, Timothy

[PATCH] staging: pi433: Fix a couple of spelling mistakes

2017-07-17 Thread Colin King
From: Colin Ian King Trivial fix to spelling mistakes in dev_dbg debug messages "wiat" -> "wait" "fonud" -> "found" Signed-off-by: Colin Ian King --- drivers/staging/pi433/pi433_if.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)

[PATCH] staging: iio: adc: add space around substraction operation

2017-07-17 Thread Hari Prasath
Fix checkpatch warning to add space around the substraction operation Signed-off-by: Hari Prasath --- drivers/staging/iio/adc/ad7280a.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/iio/adc/ad7280a.c

[PATCH v2] staging: unisys: visorbus: Constify attribute_group structures.

2017-07-17 Thread Arvind Yadav
attribute_group are not supposed to change at runtime. All functions working with attribute_group provided by work with const attribute_group. So mark the non-const structs as const. Signed-off-by: Arvind Yadav --- Changes in v2: Change log typo was not

[PATCH v2 1/2] staging: gs_fpgaboot: add buffer overflow checks

2017-07-17 Thread Jacob von Chorus
Four fields in struct fpgaimage are char arrays of length MAX_STR (256). The amount of data read into these buffers is controlled by a length field in the bitstream file read from userspace. If a corrupt or malicious firmware file was supplied, kernel data beyond these buffers can be overwritten

[PATCH v2 2/2] staging: gs_fpgaboot: change char to u8

2017-07-17 Thread Jacob von Chorus
The bitstream storage variables were changed from char to u8 arrays to prevent issues such as negative lengths. This change makes the code compatible with the "data" field in "struct firmware" which is of type u8. Signed-off-by: Jacob von Chorus ---

Re: [PATCH v2 2/2] staging: gs_fpgaboot: change char to u8

2017-07-17 Thread Jacob von Chorus
On Mon, Jul 17, 2017 at 06:22:08PM -0700, Joe Perches wrote: > read_bitstream takes an int rdsize, not a u16. > and this function will overflow tbuf if len > 64 > > static void readinfo_bitstream(char *bitdata, char *buf, int *offset) > { > char tbuf[64]; > s32 len; > > /* read

Re: [patch 0/3] Re: tty contention resulting from tty_open_by_device export

2017-07-17 Thread Alan Cox
> Sure. I can fix the tty->count mismatch based on Alan's suggestion. However I > don't understand why the exclusivity flag should belong to tty_port and not > tty_struct. It will be good to know why. We are trying to move all the flags that we can and structs into the tty_port, except any

Re: [PATCH 14/14] [media] fix warning on v4l2_subdev_call() result interpreted as bool

2017-07-17 Thread Arnd Bergmann
On Mon, Jul 17, 2017 at 4:35 PM, Hans Verkuil wrote: > On 17/07/17 16:26, Arnd Bergmann wrote: >> Let me try again without ccache for now and see what warnings remain. >> We can find a solution for those first, and then decide how to deal with >> ccache. > > Sounds good. > >

Re: [PATCH v2 2/2] staging: atomisp2: hmm: Alignment code (rebased)

2017-07-17 Thread Sakari Ailus
On Thu, Jul 13, 2017 at 09:26:50PM +0200, Philipp wrote: > > > On 13. Jul 2017, at 17:45, Sakari Ailus wrote: > > > > On Thu, Jul 13, 2017 at 08:55:43AM +0200, Philipp Guendisch wrote: > >> This patch fixed code alignment to open paranthesis. > >> Semantic should not be

RE: [PATCH] staging: unisys: visorbus: constify attribute_group structures.

2017-07-17 Thread Kershner, David A
> -Original Message- > From: Greg KH [mailto:g...@kroah.com] > Sent: Monday, July 17, 2017 8:38 AM > To: Arvind Yadav > Cc: Kershner, David A ; Sell, Timothy C > ; Thompson, Bryan E. >

Re: [PATCH 1/1] drivers/staging/pi433: New driver

2017-07-17 Thread kbuild test robot
Hi Marcus, [auto build test WARNING on staging/staging-testing] [also build test WARNING on v4.13-rc1 next-20170714] [if your patch is applied to the wrong git tree, please drop us a note to help improve the system] url:

Re: [PATCH v9 03/10] x86/hyper-v: make hv_do_hypercall() inline

2017-07-17 Thread kbuild test robot
Hi Vitaly, [auto build test ERROR on linus/master] [also build test ERROR on v4.13-rc1 next-20170717] [cannot apply to tip/x86/core] [if your patch is applied to the wrong git tree, please drop us a note to help improve the system] url: https://github.com/0day-ci/linux/commits/Vitaly

<    1   2