[PATCH V2] staging: vc04_services: handle kzalloc failure

2019-04-18 Thread Nicholas Mc Guire
The kzalloc here was being used without checking the return - if the kzalloc fails return VCHIQ_ERROR. The call-site of vchiq_platform_init_state() vchiq_init_state() was not responding to an allocation failure so checks for != VCHIQ_SUCCESS and pass VCHIQ_ERROR up to vchiq_platform_init() which

Re: [PATCH] media: staging/imx: add media device to capture register

2019-04-18 Thread Steve Longerbeam
Acked-by: Steve Longerbeam On 4/12/19 9:44 AM, Rui Miguel Silva wrote: When register the capture media device it is assumed that the device data is the media device. In the imx6 case is but in the imx7 is not case. The device data is the csi structure. Add the explicit argument of the media

Re: [PATCH] media: staging/imx: add media device to capture register

2019-04-18 Thread Laurent Pinchart
Hi Rui, Thank you for the patch. On Fri, Apr 12, 2019 at 05:44:00PM +0100, Rui Miguel Silva wrote: > When register the capture media device it is assumed that the device > data is the media device. In the imx6 case is but in the imx7 is not > case. The device data is the csi structure. > > Add

Re: [PATCH v2] staging: greybus: power_supply: use struct_size() helper

2019-04-18 Thread Gustavo A. R. Silva
On 4/18/19 1:27 AM, Johan Hovold wrote: > On Wed, Apr 17, 2019 at 01:44:40PM -0500, Gustavo A. R. Silva wrote: >> Make use of the struct_size() helper instead of an open-coded version >> in order to avoid any potential type mistakes, in particular in the >> context in which this code is being

Re: [PATCH] staging: rtl8723bs: hal: fix spelling mistake "singal" -> "signal"

2019-04-18 Thread Mukesh Ojha
On 4/18/2019 5:50 PM, Colin King wrote: From: Colin Ian King There are multiple spelling mistakes in variable names, fix these. Signed-off-by: Colin Ian King Well, this one a bit sensitive to touch. Reviewed-by: Mukesh Ojha Cheers, -Mukesh ---

Re: [PATCH RFC] staging: vc04_services: handle kzalloc failure

2019-04-18 Thread Stefan Wahren
On 18.04.19 12:29, Nicholas Mc Guire wrote: > The kzalloc here was being used without checking the return - if the > kzalloc fails return VCHIQ_ERROR. The call-site of > vchiq_platform_init_state() vchiq_init_state() was not responding > to an allocation failure so checks for != VCHIQ_SUCCESS >

[PATCH] staging: rtl8723bs: hal: fix spelling mistake "singal" -> "signal"

2019-04-18 Thread Colin King
From: Colin Ian King There are multiple spelling mistakes in variable names, fix these. Signed-off-by: Colin Ian King --- drivers/staging/rtl8723bs/hal/hal_com.c | 18 +- drivers/staging/rtl8723bs/include/rtw_recv.h | 4 ++-- 2 files changed, 11 insertions(+), 11

Re: [PATCH v3 09/26] compat_ioctl: move drivers to compat_ptr_ioctl

2019-04-18 Thread Stefan Hajnoczi
On Tue, Apr 16, 2019 at 10:19:47PM +0200, Arnd Bergmann wrote: > Each of these drivers has a copy of the same trivial helper function to > convert the pointer argument and then call the native ioctl handler. > > We now have a generic implementation of that, so use it. > > Acked-by: Greg

[PATCH RFC] staging: vc04_services: handle kzalloc failure

2019-04-18 Thread Nicholas Mc Guire
The kzalloc here was being used without checking the return - if the kzalloc fails return VCHIQ_ERROR. The call-site of vchiq_platform_init_state() vchiq_init_state() was not responding to an allocation failure so checks for != VCHIQ_SUCCESS and pass VCHIQ_ERROR up to vchiq_platform_init() which

Re: [PATCH v2] staging: greybus: power_supply: use struct_size() helper

2019-04-18 Thread Rui Miguel Silva
Oi Gustavo, Thanks for the patch, and the rebasing. On Wed 17 Apr 2019 at 19:44, Gustavo A. R. Silva wrote: Make use of the struct_size() helper instead of an open-coded version in order to avoid any potential type mistakes, in particular in the context in which this code is being used. So,

[PATCH] staging: olpc_dcon: Convert all uses of old GPIO API to new descriptor API

2019-04-18 Thread Jerry Lin
This commit eliminate all uses of legacy integer base GPIO API in olpc_dcon_xo_1_5.c and replace them with new descriptor GPIO API like those in olpc_dcon_xo_1.c. Also pull some common code with olpc_dcon_xo_1.c to olpc_dcon.h for code sharing. Signed-off-by: Jerry Lin ---

Re: [PATCH v2] staging: greybus: power_supply: use struct_size() helper

2019-04-18 Thread Johan Hovold
On Wed, Apr 17, 2019 at 01:44:40PM -0500, Gustavo A. R. Silva wrote: > Make use of the struct_size() helper instead of an open-coded version > in order to avoid any potential type mistakes, in particular in the > context in which this code is being used. > > So, replace code of the following