Re: [edk2] [PATCH edk2-platforms v2 18/18] ARM/JunoPkg: Add HDLCD platform library

2017-12-23 Thread Ard Biesheuvel
On 22 December 2017 at 19:08, wrote: > From: Girish Pathak > > This change adds the HDLCD platform lib for the Juno plaform. This > library will be instantiated as a LcdPlatformLib to link with > LcdGraphicsOutputDxe for the Juno platform. > > HDLCD

Re: [edk2] [PATCH edk2-platforms v2 17/18] ARM/JunoPkg: Adding SCMI MTL library

2017-12-23 Thread Ard Biesheuvel
On 22 December 2017 at 19:08, wrote: > From: Girish Pathak > > This change adds a new Mailbox Transport Layer library for the Juno > platform. This library is required for ArmScmiDxe driver communication > with the SCP. > > Contributed-under: TianoCore

Re: [edk2] [PATCH edk2-platforms v2 16/18] ARM/JunoPkg: Mapping Non-Trused SRAM as device memory

2017-12-23 Thread Ard Biesheuvel
On 22 December 2017 at 19:08, wrote: > From: Girish Pathak > > This fix changes the cache attribute of Non-Trusted SRAM on the Juno > platform to device memory. This change is required to avoid coherency > problems as Non-Trusted SRAM is used as a

Re: [edk2] [PATCH edk2-platforms v2 15/18] ARM/VExpressPkg: New DP500/DP550/DP650 platform library.

2017-12-23 Thread Ard Biesheuvel
On 22 December 2017 at 19:08, wrote: > From: Girish Pathak > > This change adds LcdPlatformLib implementation for ARM Mali > DP500/DP500/DP650 display processors for models (with DP550 support). > > NOTE: Versions for actual hardware are liable to require extra handling >

Re: [edk2] [PATCH edk2-platforms v2 14/18] ARM/VExpressPkg: Reserving framebuffer at build

2017-12-23 Thread Ard Biesheuvel
On 22 December 2017 at 19:08, wrote: > From: Girish Pathak > > This change uses two PCDs, PcdArmLcdFrameBufferBase and > PcdArmLcdFrameBufferSize introduced in correspondiong EDK2 patch to > reserve framebuffer in DRAM if these values are defined in platform > specific DSC

Re: [edk2] [PATCH edk2-platforms v2 13/18] ARM/VExpressPkg: PL111 and HDLCD: Add PCD to select pixel format

2017-12-23 Thread Ard Biesheuvel
On 22 December 2017 at 19:08, wrote: > From: Girish Pathak > > Current HDLCD and PL111 platform libraries do not support display modes > with PixelBlueGreenRedReserved8BitPerColor format, i.e. because of > historical confusion, they do not support the UEFI default >

Re: [edk2] [PATCH edk2-platforms v2 12/18] ARM/VExpressPkg: Redefine LcdPlatformGetTimings function

2017-12-23 Thread Ard Biesheuvel
On 22 December 2017 at 19:08, wrote: > From: Girish Pathak > > The LcdPlatformGetTimings interface function takes similar sets of > multiple parameters for horizontal and vertical timings which can be > aggregated in a common data type. This change defines a structure >

Re: [edk2] [PATCH edk2-platforms v2 11/18] ARM/VExpressPkg: HdLcdArmVExpressLib: Remove redundant Bpp

2017-12-23 Thread Ard Biesheuvel
On 22 December 2017 at 19:08, wrote: > From: EvanLloyd > > Because of copy/paste effects, HdLcdArmVExpress.c contained a > table entry "LCD_BPP Bpp;" specifying the Bits per Pixel for each mode. > However, all modes are LCD_BITS_PER_PIXEL_24. > > This change removes the

Re: [edk2] [PATCH edk2-platforms v2 10/18] ARM/VExpressPkg: HdLcdArmVExpressLib: Remove status check EFI_TIMEOUT

2017-12-23 Thread Ard Biesheuvel
On 22 December 2017 at 19:08, wrote: > From: Girish Pathak > > None of the ArmPlatformSys* functions returns EFI_TIMEOUT. Hence checking > this in the do {} while loop in LcdPlatformSetMode is wrong. Therefore > remove this comparision and as a result remove the do {} while

Re: [edk2] [PATCH edk2-platforms v2 09/18] ARM/VExpressPkg: PL11LcdArmVExpressLib: Improvement conditional

2017-12-23 Thread Ard Biesheuvel
On 22 December 2017 at 19:08, wrote: > From: Girish Pathak > > PL111_CLCD_SITE and ARM_VE_MOTHERBOARD_SITE are both constants and > available at build time. Use conditional compilation to process the code > based on the value of PL111_CLCD_SITE, instead of selecting code in

Re: [edk2] [PATCH edk2-platforms v2 08/18] ARM/VExpressPkg: PL111 and HDLCD: Use FixedPcdGet32

2017-12-23 Thread Ard Biesheuvel
On 22 December 2017 at 19:08, wrote: > From: Girish Pathak > > This change replaces PcdGet32 with FixedPcdGet32 for the PCDs which > are defined as fixed PCDs. > > Contributed-under: TianoCore Contribution Agreement 1.1 > Signed-off-by: Girish Pathak

Re: [edk2] [PATCH edk2-platforms v2 07/18] ARM/VExpressPkg: PL111LcdArmVExpressLib: Minor code cleanup

2017-12-23 Thread Ard Biesheuvel
On 22 December 2017 at 19:08, wrote: > From: Girish Pathak > > This minor change removes some unecessary initializations and variables > in PL111LcdArmVExpress.c > > Contributed-under: TianoCore Contribution Agreement 1.1 > Signed-off-by: Girish Pathak

Re: [edk2] [PATCH edk2-platforms v2 06/18] ARM/VExpressPkg: Add and update debug ASSERTS

2017-12-23 Thread Ard Biesheuvel
On 22 December 2017 at 19:08, wrote: > From: Girish Pathak > > This change adds some debug assertions e.g to catch NULL pointer errors > missing in PL11Lcd and HdLcd platform libraries. > > Contributed-under: TianoCore Contribution Agreement 1.1 > Signed-off-by: Girish

Re: [edk2] [PATCH edk2-platforms v2 05/18] ARM/VExpressPkg: PL111 and HDLCD: add const qualifier

2017-12-23 Thread Ard Biesheuvel
On 22 December 2017 at 19:08, wrote: > From: Girish Pathak > > This change adds some STATIC and CONST qualifiers (mainly to arguments > of functions) in PL111 and HdLcd platform libraries. > > Contributed-under: TianoCore Contribution Agreement 1.1 > Signed-off-by: Girish

Re: [edk2] [PATCH edk2-platforms v2 04/18] ARM/VExpressPkg: Remove unused PcdPL111LcdMaxMode from HDLCD inf

2017-12-23 Thread Ard Biesheuvel
On 22 December 2017 at 19:08, wrote: > From: Girish Pathak > > PCD PcdPL111LcdMaxMode is not used in HDLCD platform library. > Presence of this PCD in HDLCD is probably due to copy/paste code > from PL111 Lcd platform library. This change removes it

Re: [edk2] [PATCH edk2-platforms v2 02/18] ARM/VExpressPkg: Tidy HDLCD and PL11LCD platform Lib: Coding standard

2017-12-23 Thread Ard Biesheuvel
On 22 December 2017 at 19:08, wrote: > From: Girish Pathak > > There is no functional modification in this change > As preparation for further work, the formatting is corrected to meet > the EDKII coding standard. > > Contributed-under: TianoCore Contribution Agreement 1.1 >

Re: [edk2] [PATCH edk2-platforms v2 03/18] ARM/VExpressPkg: Tidy HdLcd/PL111Lcd code: Updated comments

2017-12-23 Thread Ard Biesheuvel
On 22 December 2017 at 19:08, wrote: > From: Girish Pathak > > There is no functional modification in this change. > In this change some comments in HDLCD and PL111LCD platform library > code are modified and a few new comments are added. This is to > prevent mixing

Re: [edk2] [PATCH v2 13/13] ArmPlatformPkg: Introduce SCMI protocol

2017-12-23 Thread Ard Biesheuvel
, couOn 22 December 2017 at 18:34, wrote: > From: Girish Pathak > > This change introduces a new SCMI protocol driver for > Arm Platforms. The driver currently supports only clock > and performance management protocols. Other protocols > will be added

Re: [edk2] [PATCH v2 12/13] ArmPlatformPkg: New DP500/DP550/DP650 GOP driver.

2017-12-23 Thread Ard Biesheuvel
On 22 December 2017 at 18:34, wrote: > From: Girish Pathak > > This change adds support for the ARM Mali DP500/DP500/DP650 display > processors using the GOP protocol. It has been tested on FVP base > models + DP550 support. This change adds platform independant LcdHwLib >

Re: [edk2] [PATCH v2 11/13] ArmPlatformPkg: Reserving framebuffer at build

2017-12-23 Thread Ard Biesheuvel
On 22 December 2017 at 18:34, wrote: > From: Girish Pathak > > Currently framebuffer memory is either reserved in special VRAM or > dynamically allocated using boot services memory allocation functions. > When allocated using boot services calls the memory has to be

Re: [edk2] [PATCH v2 10/13] ArmPlatformPkg: Additional display modes

2017-12-23 Thread Ard Biesheuvel
On 22 December 2017 at 18:34, wrote: > From: Girish Pathak > > Add definitions for new display modes such as HD 720. > This has no effect on existing display drivers. > > Contributed-under: TianoCore Contribution Agreement 1.1 > Signed-off-by: Girish Pathak

Re: [edk2] [PATCH v2 09/13] ArmPlatformPkg: PCD to swap red/blue format for HDLCD

2017-12-23 Thread Ard Biesheuvel
On 22 December 2017 at 18:34, wrote: > From: Girish Pathak > > This change adds a new PCD PcdArmHdlcdSwapBlueRedSelect > to swap values for HDLCD RED_SELECT and BLUE_SELECT registers > on platforms where blue and red hardware lines are swapped. > > If set to TRUE in the

Re: [edk2] [PATCH v2 08/13] ArmPlatformPkg: Add PCD to select pixel format

2017-12-23 Thread Ard Biesheuvel
On 22 December 2017 at 18:34, wrote: > From: Girish Pathak > > Current HDLCD and PL111 platform libraries do not support display modes > with PixelBlueGreenRedReserved8BitPerColor format, i.e. because of > historical confusion, they do not support the UEFI default >

Re: [edk2] [PATCH v2 07/13] ArmPlatformPkg: Redefine LcdPlatformGetTimings function

2017-12-23 Thread Ard Biesheuvel
On 22 December 2017 at 18:34, wrote: > From: Girish Pathak > > The LcdPlatformGetTimings interface function takes similar sets of > multiple parameters for horizontal and vertical timings which can be > aggregated in a common data type. This change defines a structure >

Re: [edk2] [PATCH v2 06/13] ArmPlatformPkg: Implement LcdIdentify function for HDLCD GOP

2017-12-23 Thread Ard Biesheuvel
On 22 December 2017 at 18:34, wrote: > From: Girish Pathak > > LcdIdentify function does not currently check presence of HDLCD > controller. > > Implement this functionality by reading HDLCD_REG_VERSION and checking > against the PRODUCT_ID field to detect presence of HDLCD

Re: [edk2] [PATCH v2 05/13] ArmPlatformPkg: PL111Lcd: Replace magic number with macro

2017-12-23 Thread Ard Biesheuvel
On 22 December 2017 at 18:34, wrote: > From: Girish Pathak > > Minor code change, replaces magic number with macro in LCD disable. > > Contributed-under: TianoCore Contribution Agreement 1.1 > Signed-off-by: Girish Pathak > Signed-off-by: Evan Lloyd

Re: [edk2] [PATCH v2 04/13] ArmPlatformPkg: HDLCD and PL111: Update debug ASSERTS

2017-12-23 Thread Ard Biesheuvel
On 22 December 2017 at 18:34, wrote: > From: Girish Pathak > > This change moves some ASSERTs in error handling code > to improve efficiency in DEBUG build. > > Contributed-under: TianoCore Contribution Agreement 1.1 > Signed-off-by: Girish Pathak >

Re: [edk2] [PATCH v2 03/13] ArmPlatformPkg: PL111 and HDLCD: add const qualifier

2017-12-23 Thread Ard Biesheuvel
On 22 December 2017 at 18:34, wrote: > From: Girish Pathak > > This change adds CONST qualifiers (mainly to arguments > of functions) in PL111 and HdLcd libraries. > > Contributed-under: TianoCore Contribution Agreement 1.1 > Signed-off-by: Girish Pathak

Re: [edk2] [PATCH v2 01/13] ArmPlatformPkg: Tidy Lcd code: Coding standard

2017-12-23 Thread Ard Biesheuvel
On 22 December 2017 at 18:34, wrote: > From: Girish Pathak > > There is no functional modification in this change > As preparation for further work, the formatting is corrected to meet > the EDKII coding standard. > Of specific note, some invalid include guards were fixed. >