[elixir-core:6936] Re: Proposal

2017-02-21 Thread Myron Marston
This is something I've asked for in the past[1] (albeit for different reason at the time). While not directly, supported, there's a fairly simple way to add a `mix test_all` task that does what you want. [2] José said he might be more open to it being built-in in the future, so it's nice to

[elixir-core:6935] Re: Proposal: Streamlining child specs

2017-02-21 Thread Myron Marston
I definitely like this proposal overall. There are some nuances I don't understand yet, but it sounds like y'all are asking the right questions. In our code base we've already been defined a function like `child_spec` a few times for this exact purpose, so it neatly aligns with how I'd like to

[elixir-core:6933] Deprecation table

2017-02-21 Thread eksperimental
I would also like to propose to introduce a new page in the project that lists all the deprecated functions, what was the version it was deprecated, and if they have been replaced/renamed by new function. It happed to me once that I was using a package that was written for elixir 0.9.x, this

Re: [elixir-core:6931] Questions about introduction of List.starts_with?/2

2017-02-21 Thread eksperimental
Sorry José, I was wrong when i wrote > If we support improper lists, prefix could be any term, not just a list. what meant is that if we support List.ends_with?/2, then suffix could be any term (but I will show that this is still wrong) List.ends_with?([1, 2 | 3], 3) #=> true but that could be

Re: [elixir-core:6928] Proposal: Streamlining child specs

2017-02-21 Thread José Valim
> > By removing the application callbacks we remove the primary place of > injecting dynamic configuration into an application. Dynamic configuration > is already a major hurdle, without this proposal or with it, but I'm afraid > this will only worsen the situation. > The best place for dynamic

Re: [elixir-core:6926] Proposal: Streamlining child specs

2017-02-21 Thread Michał Muskała
On 21 Feb 2017, 20:10 +0100, Louis Pilfold , wrote: > Hello! > > Very interesting. It does seem like this would be easier to learn :) > > Little nitpick: I find the name child_spec/1 a little confusing. I would > expect it to be the spec of the children of a supervisor defined by

[elixir-core:6922] Proposal: Streamlining child specs

2017-02-21 Thread José Valim
Note: this proposal is also available in a gist - https://gist.github.com/josevalim/82fb1d20c9738bb3cc96449e67407df6 Streamlining child specs Hello everyone, This is a proposal for improving how supervisors are defined and used in Elixir. Before we go to the improvements, let's discuss the pain

Re: [elixir-core:6920] Proposal: add new tag to functions and modules: @available_since

2017-02-21 Thread eksperimental
that's great. We are connected then! :-) On Tue, 21 Feb 2017 16:00:18 +0100 José Valim wrote: > Yes! > > Andrea proposed something similar to the Elixir team this week. He has been > assigned for building a full proposal once he finds some time. :) > > > >

Re: [elixir-core:6918] Proposal: add new tag to functions and modules: @available_since

2017-02-21 Thread José Valim
Yes! Andrea proposed something similar to the Elixir team this week. He has been assigned for building a full proposal once he finds some time. :) *José Valim* www.plataformatec.com.br Skype: jv.ptec Founder and Director of R On Tue, Feb 21, 2017 at 3:46 PM, eksperimental

Re: [elixir-core:6914] Deprecate global in favour of via

2017-02-21 Thread José Valim
While there are reasons for removing :global, there are also reasons for keeping it around: 1. It is kept in sync with Erlang options 2. It shows the global aspect is a mode of operation supported out of the box 3. Erlang OTP 20/21 will ship with a much improved global mode that may promote its