Re: Alternative to Function.bind

2009-03-27 Thread Igor Bukanov
2009/3/27 Erik Arvidsson erik.arvids...@gmail.com: Here is one way to implement object.bind.method using ES3.1 The provided example has a drawback that obj.bind would not work with methods that are added to obj later. So it would not be the true bounded-method view for obj but rather a

Re: Alternative to Function.bind

2009-03-27 Thread Brendan Eich
On Mar 27, 2009, at 11:42 AM, Igor Bukanov wrote: 2009/3/27 Brendan Eich bren...@mozilla.com: although perhaps the name should be something else: obj.bindSelfTo.method or just obj.bindTo.method IMO a better name would be boundedMethods or just bounded to emphasis that the result is a view

Re: Alternative to Function.bind

2009-03-27 Thread Erik Arvidsson
On Fri, Mar 27, 2009 at 17:23, Brendan Eich bren...@mozilla.com wrote: You are right that this wants catch-alls, as do all the tiered virtualization sandbox schemes in the works and out there. We should get back to discussing catch-alls -- I have a draft saved somewhere... With catch-alls a