[FFmpeg-devel] [PATCH] avfilter/vf_fade: fix start/duration max value

2018-11-11 Thread Mark Harris
A fade out (usually at the end of a video) can easily start beyond INT32_MAX (about 36 minutes). Regression since d40dc64173. --- libavfilter/vf_fade.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/libavfilter/vf_fade.c b/libavfilter/vf_fade.c index

Re: [FFmpeg-devel] [PATCH] lavf/dashenc: Add support for per-stream container type selection.

2018-11-11 Thread Jeyapal, Karthick
On 11/8/18 10:27 PM, Andrey Semashev wrote: > This commit restores the ability to create DASH streams with codecs > that require different containers that was lost after commit > 2efdbf7367989cf9d296c25fa3d2aff8d6e25fdd. It extends the dash_segment_type > option syntax to allow to specify segment

Re: [FFmpeg-devel] [PATCH] fate: Add test for vc1test demuxer

2018-11-11 Thread myp...@gmail.com
On Wed, Oct 24, 2018 at 11:10 PM Jun Zhao wrote: > > Signed-off-by: Jun Zhao > --- > tests/fate/microsoft.mak |6 ++ > tests/ref/fate/vc1test_smm0005 | 29 + > tests/ref/fate/vc1test_smm0015 | 30 ++ > 3 files changed, 65

Re: [FFmpeg-devel] [PATCH] vaapi_encode: fix slices number check.

2018-11-11 Thread myp...@gmail.com
On Tue, Oct 30, 2018 at 1:25 PM Jun Zhao wrote: > > fix slice number check logic. > > Signed-off-by: Jun Zhao > --- > libavcodec/vaapi_encode.c |2 +- > 1 files changed, 1 insertions(+), 1 deletions(-) > > diff --git a/libavcodec/vaapi_encode.c b/libavcodec/vaapi_encode.c > index

Re: [FFmpeg-devel] [PATCH V2 1/3] fftools/ffmpeg: Remove the micor like "#if 1"

2018-11-11 Thread myp...@gmail.com
On Sun, Nov 11, 2018 at 4:47 AM Michael Niedermayer wrote: > > On Fri, Nov 09, 2018 at 09:11:31PM +0800, Jun Zhao wrote: > > They are come from 2003 and delete them. > > > > Signed-off-by: Jun Zhao > > --- > > fftools/ffmpeg.c |6 -- > > 1 files changed, 0 insertions(+), 6 deletions(-)

Re: [FFmpeg-devel] [PATCH V2 2/3] fftools/ffmpeg: Put the variable declaration at uppper for block.

2018-11-11 Thread myp...@gmail.com
On Fri, Nov 9, 2018 at 11:11 PM Carl Eugen Hoyos wrote: > > 2018-11-09 14:11 GMT+01:00, Jun Zhao : > > move the variable declaration at start of upper for block and > > remove the redundant brace. > > Why? > > (You never had to use git blame and were unhappy about the > necessary iterations?) > >

Re: [FFmpeg-devel] [PATCH] cbs_h2645: Improve performance of writing slices

2018-11-11 Thread Mark Thompson
On 11/11/18 22:43, Andreas Rheinhardt wrote: > Instead of using a combination of bitreader and -writer for copying data, > one can byte-align the (obsolete and removed) bitreader to improve > performance. > With the right alignment one can even use memcpy. The right alignment > normally exists

[FFmpeg-devel] [PATCH] cbs_h2645: Improve performance of writing slices

2018-11-11 Thread Andreas Rheinhardt
Instead of using a combination of bitreader and -writer for copying data, one can byte-align the (obsolete and removed) bitreader to improve performance. With the right alignment one can even use memcpy. The right alignment normally exists for CABAC and hence for H.265 in general. For aligned data

Re: [FFmpeg-devel] [PATCH 2/3] cbs_h264: Improve performance of writing slices

2018-11-11 Thread Andreas Rheinhardt
I have created a new version that addresses all your concerns. Will send it in a moment. I actually wanted to make a separate function, but decided against it because the code already contained the duplication, so I thought that is how you liked it. Thanks for the review. Btw: What was the

Re: [FFmpeg-devel] avcodec : add prores_metadata bsf and fate test

2018-11-11 Thread James Almer
On 11/11/2018 7:20 PM, James Almer wrote: > On 11/8/2018 6:31 PM, Martin Vignali wrote: >> Le dim. 28 oct. 2018 à 12:59, Martin Vignali a >> écrit : >> >>> Thanks for the comments >>> >>> New patch in attach >>> >>> - Change the options, to only authorized few value in prores frame (based >>> on

Re: [FFmpeg-devel] avcodec : add prores_metadata bsf and fate test

2018-11-11 Thread James Almer
On 11/8/2018 6:31 PM, Martin Vignali wrote: > Le dim. 28 oct. 2018 à 12:59, Martin Vignali a > écrit : > >> Thanks for the comments >> >> New patch in attach >> >> - Change the options, to only authorized few value in prores frame (based >> on rdd36). >> - Change option name to match setparams

Re: [FFmpeg-devel] Fate samples

2018-11-11 Thread Michael Niedermayer
On Sun, Nov 11, 2018 at 10:47:58AM -0300, James Almer wrote: > On 11/11/2018 8:57 AM, Michael Niedermayer wrote: > > Hi all > > > > I think we need another volunteer to help with uploading fate samples > > why i think so, well, if i dont do it it seems to not happen currently > > until i do it

Re: [FFmpeg-devel] Fate samples

2018-11-11 Thread Michael Niedermayer
On Sun, Nov 11, 2018 at 03:47:42PM +0100, Paul B Mahol wrote: > On 11/11/18, James Almer wrote: > > On 11/11/2018 11:01 AM, Paul B Mahol wrote: > >> On 11/11/18, Michael Niedermayer wrote: > >>> Hi all > >>> > >>> I think we need another volunteer to help with uploading fate samples > >>> why i

Re: [FFmpeg-devel] [PATCH] avfilter/vf_freezedetect: add filter to detect frozen input

2018-11-11 Thread Paul B Mahol
On 11/11/18, Marton Balint wrote: > Signed-off-by: Marton Balint > --- > Changelog | 1 + > configure | 1 + > doc/filters.texi | 29 + > libavfilter/Makefile | 1 + > libavfilter/allfilters.c | 1 + >

Re: [FFmpeg-devel] [PATCH 2/3] cbs_h264: Improve performance of writing slices

2018-11-11 Thread Mark Thompson
On 04/11/18 04:48, Andreas Rheinhardt wrote: > Instead of using a combination of bitreader and -writer for copying data, > one can byte-align the (obsolete and removed) bitreader to improve > performance. > With the right alignment one can even use memcpy. The right alignment > normally exists

[FFmpeg-devel] [PATCH 2/2] avfilter/vf_bwdif: Use common yadif frame management logic

2018-11-11 Thread Philip Langdale
After adding field type management to the common yadif logic, we can remove the duplicate copy of that logic from bwdif. --- libavfilter/bwdif.h | 34 + libavfilter/vf_bwdif.c | 235 +--- libavfilter/x86/vf_bwdif_init.c | 3 +- 3 files

[FFmpeg-devel] [PATCH 1/2] avfilter/yadif_common: Add field type tracking to help bwdif

2018-11-11 Thread Philip Langdale
The bwdif filter can use common yadif frame management if we track when a field is the first or last field in a sequence. While this information is not used by yadif, the added benefit of removing the duplicated frame management logic makes it worth tracking this state in the common code. ---

[FFmpeg-devel] [PATCH 0/2] Update vf_bwdif to use yadif_common v2

2018-11-11 Thread Philip Langdale
vf_bwdif's frame management logic is almost identical to that of yadif. The only difference is that it tracks the first and last fields in a sequence, and that requires slight changes to the common code. Assuming it's reasonable to do that tracking even though yadif doesn't need it, we can then

[FFmpeg-devel] [PATCH] avfilter/vf_freezedetect: add filter to detect frozen input

2018-11-11 Thread Marton Balint
Signed-off-by: Marton Balint --- Changelog | 1 + configure | 1 + doc/filters.texi | 29 + libavfilter/Makefile | 1 + libavfilter/allfilters.c | 1 + libavfilter/version.h | 2 +-

Re: [FFmpeg-devel] [PATCH 1/3] avfilter/vf_framerate: factorize SAD functions which compute SAD for a whole frame

2018-11-11 Thread Marton Balint
On Sat, 10 Nov 2018, Marton Balint wrote: On Sun, 4 Nov 2018, Marton Balint wrote: On Sun, 4 Nov 2018, James Almer wrote: On 11/4/2018 9:06 AM, Marton Balint wrote: Also add SIMD which works on lines because it is faster then calculating it on 8x8 blocks using pixelutils.

Re: [FFmpeg-devel] [PATCH 1/3] cbs_mpeg2: Improve performance of writing slices

2018-11-11 Thread Mark Thompson
On 04/11/18 04:48, Andreas Rheinhardt wrote: > Instead of using a combination of bitreader and -writer for copying data, > one can byte-align the (obsolete and removed) bitreader to improve > performance. > One can even use memcpy in the normal case. > This improved the time needed for writing

Re: [FFmpeg-devel] [PATCH v2] cbs_h265: Add a lot more SEI parsing support

2018-11-11 Thread Mark Thompson
On 11/11/18 17:32, James Almer wrote: > On 11/11/2018 2:27 PM, Mark Thompson wrote: >> Supports both prefix and suffix SEI, decoding all of the common SEI >> types and some more obscure ones. Most of this is tested by the >> existing tests in fate. >> --- >> On 11/11/18 15:57, James Almer wrote:

Re: [FFmpeg-devel] [PATCH v2] cbs_h265: Add a lot more SEI parsing support

2018-11-11 Thread James Almer
On 11/11/2018 2:27 PM, Mark Thompson wrote: > Supports both prefix and suffix SEI, decoding all of the common SEI > types and some more obscure ones. Most of this is tested by the > existing tests in fate. > --- > On 11/11/18 15:57, James Almer wrote: >> On 10/27/2018 6:39 PM, Mark Thompson

[FFmpeg-devel] [PATCH v2] cbs_h265: Add a lot more SEI parsing support

2018-11-11 Thread Mark Thompson
Supports both prefix and suffix SEI, decoding all of the common SEI types and some more obscure ones. Most of this is tested by the existing tests in fate. --- On 11/11/18 15:57, James Almer wrote: > On 10/27/2018 6:39 PM, Mark Thompson wrote: >> Supports both prefix and suffix SEI, decoding all

Re: [FFmpeg-devel] [PATCH 1/2] avfilter/yadif_common: Add field type tracking to help bwdif

2018-11-11 Thread Thomas Mundt
Am Sa., 10. Nov. 2018 um 18:47 Uhr schrieb Philip Langdale < phil...@overt.org>: > The bwdif filter can use common yadif frame management if we track > when a field is the first or last field in a sequence. While this > information is not used by yadif, the added benefit of removing the >

[FFmpeg-devel] [PATCH 1/2] lavu: add locale-independent sscanf implementation

2018-11-11 Thread Paul B Mahol
Signed-off-by: Paul B Mahol --- libavutil/avstring.c | 938 +++ libavutil/avstring.h | 6 + 2 files changed, 944 insertions(+) diff --git a/libavutil/avstring.c b/libavutil/avstring.c index f03dd25141..d33153a8f3 100644 --- a/libavutil/avstring.c +++

[FFmpeg-devel] [PATCH 2/2] avfilter/vf_lut3d: use av_sscanf

2018-11-11 Thread Paul B Mahol
Signed-off-by: Paul B Mahol --- libavfilter/vf_lut3d.c | 16 1 file changed, 8 insertions(+), 8 deletions(-) diff --git a/libavfilter/vf_lut3d.c b/libavfilter/vf_lut3d.c index e7601a05ac..93053ed263 100644 --- a/libavfilter/vf_lut3d.c +++ b/libavfilter/vf_lut3d.c @@ -367,7

[FFmpeg-devel] [PATCH] mjpegdec: Fill raw huffman tables with default values too

2018-11-11 Thread Mark Thompson
These may be used by hwaccel decoders when the standard tables are not otherwise available. At the same time, clean up that code into an array so it's a little less repetitive. --- On 29/10/18 10:26, Jun Zhao wrote: > From: Jun Zhao > > Now VA-API HWAccel MJPEG decoding uninitialized huffman

Re: [FFmpeg-devel] [PATCH 4/4] cbs_h265: Add a lot more SEI parsing support

2018-11-11 Thread James Almer
On 10/27/2018 6:39 PM, Mark Thompson wrote: > Supports both prefix and suffix SEI, decoding all of the common SEI > types and some more obscure ones. Most of this is tested by the > existing tests in fate. It would be neat to make the *_metadata filters not decompose unit types it doesn't care

Re: [FFmpeg-devel] [PATCH v3 1/6] fate/libavcodec: Fix config dependency of h264-levels test

2018-11-11 Thread James Almer
On 10/27/2018 7:19 PM, Mark Thompson wrote: > --- > tests/fate/libavcodec.mak | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/tests/fate/libavcodec.mak b/tests/fate/libavcodec.mak > index aa4c36b112..5dde1243fa 100644 > --- a/tests/fate/libavcodec.mak > +++

[FFmpeg-devel] [PATCH 1/3] ffmpeg_qsv: Remove format-specific get_buffer

2018-11-11 Thread Mark Thompson
It does exactly the same thing as the default get_buffer. --- fftools/ffmpeg_qsv.c | 8 1 file changed, 8 deletions(-) diff --git a/fftools/ffmpeg_qsv.c b/fftools/ffmpeg_qsv.c index 9c4285b6c7..aef0c26bcc 100644 --- a/fftools/ffmpeg_qsv.c +++ b/fftools/ffmpeg_qsv.c @@ -30,13 +30,6 @@

[FFmpeg-devel] [PATCH 3/3] qsvdec: Fix running with assert_level > 0

2018-11-11 Thread Mark Thompson
Assertion avctx->codec_id != AV_CODEC_ID_NONE failed at src/libavcodec/parser.c:128 The setting on the internal AVCodecContext used for parsing only is otherwise irrelevant, so just set it to avoid the assert. --- libavcodec/qsvdec.c | 2 ++ 1 file changed, 2 insertions(+) diff --git

[FFmpeg-devel] [PATCH 2/3] ffmpeg: Remove get_buffer override

2018-11-11 Thread Mark Thompson
Since nothing sets hwaccel_get_buffer any more, this is always equivalent to the default case. --- fftools/ffmpeg.c | 11 --- fftools/ffmpeg.h | 1 - 2 files changed, 12 deletions(-) diff --git a/fftools/ffmpeg.c b/fftools/ffmpeg.c index 38c21e944a..e0ffd1b779 100644 ---

Re: [FFmpeg-devel] [PATCH v3] fftools/ffmpeg: add an option to forbid the fallback to software path when hardware init fails

2018-11-11 Thread Mark Thompson
On 09/11/18 09:05, Linjie Fu wrote: > Currently ff_get_format will go through all usable choices if the chosen > format was not supported. It will fallback to software path if the hardware > init fails. > > Provided an option "-require_hwaccel 1" in user-code to detect frame->format > and >

[FFmpeg-devel] [PATCH] ffmpeg: Add option to force a specific decode format

2018-11-11 Thread Mark Thompson
Fixes #7519. --- I've had this lying around for a bit with intent to use it to support non-hwaccel hardware decoders (in particular, v4l2m2m), but it actually fixes the force-hwaccel use-case too in a sensible way. doc/ffmpeg.texi | 12 fftools/ffmpeg.c | 4

Re: [FFmpeg-devel] Fate samples

2018-11-11 Thread James Almer
On 11/11/2018 11:47 AM, Paul B Mahol wrote: > On 11/11/18, James Almer wrote: >> On 11/11/2018 11:01 AM, Paul B Mahol wrote: >>> On 11/11/18, Michael Niedermayer wrote: Hi all I think we need another volunteer to help with uploading fate samples why i think so, well, if i

Re: [FFmpeg-devel] Fate samples

2018-11-11 Thread Paul B Mahol
On 11/11/18, James Almer wrote: > On 11/11/2018 11:01 AM, Paul B Mahol wrote: >> On 11/11/18, Michael Niedermayer wrote: >>> Hi all >>> >>> I think we need another volunteer to help with uploading fate samples >>> why i think so, well, if i dont do it it seems to not happen currently >>> until i

Re: [FFmpeg-devel] Fate samples

2018-11-11 Thread James Almer
On 11/11/2018 11:01 AM, Paul B Mahol wrote: > On 11/11/18, Michael Niedermayer wrote: >> Hi all >> >> I think we need another volunteer to help with uploading fate samples >> why i think so, well, if i dont do it it seems to not happen currently >> until i do it ... >> This is worsened as james

Re: [FFmpeg-devel] [PATCH] avfilter/vf_alphamerge: switch to activate

2018-11-11 Thread Paul B Mahol
On 11/11/18, Gyan wrote: > On Sun, Nov 11, 2018 at 5:00 PM Paul B Mahol wrote: > >> Signed-off-by: Paul B Mahol >> --- >> libavfilter/vf_alphamerge.c | 88 ++--- >> 1 file changed, 44 insertions(+), 44 deletions(-) >> > > Does this fix #7543? For me Yes.

Re: [FFmpeg-devel] [PATCH 2/4] lavfi/opencl: Handle overlay input formats correctly.

2018-11-11 Thread Mark Thompson
On 29/10/18 05:56, Ruiling Song wrote: > The main input may have alpha channel, we just ignore it. This doesn't ignore it - it leaves it uninitialised in the output, so a YUVA or GBRAP output will never write to the A plane. I don't think that's what you're intending. > Also add some checks

Re: [FFmpeg-devel] Fate samples

2018-11-11 Thread Paul B Mahol
On 11/11/18, Michael Niedermayer wrote: > Hi all > > I think we need another volunteer to help with uploading fate samples > why i think so, well, if i dont do it it seems to not happen currently > until i do it ... > This is worsened as james has technical problems with uploads ATM > > Do we

Re: [FFmpeg-devel] [PATCH] avfilter/vf_alphamerge: switch to activate

2018-11-11 Thread Gyan
On Sun, Nov 11, 2018 at 5:00 PM Paul B Mahol wrote: > Signed-off-by: Paul B Mahol > --- > libavfilter/vf_alphamerge.c | 88 ++--- > 1 file changed, 44 insertions(+), 44 deletions(-) > Does this fix #7543? Gyan ___

Re: [FFmpeg-devel] Fate samples

2018-11-11 Thread James Almer
On 11/11/2018 8:57 AM, Michael Niedermayer wrote: > Hi all > > I think we need another volunteer to help with uploading fate samples > why i think so, well, if i dont do it it seems to not happen currently > until i do it ... > This is worsened as james has technical problems with uploads ATM >

[FFmpeg-devel] [PATCH] avformat/hlsenc: removed specific filename format code for non-zero segment sizes

2018-11-11 Thread Stephen Dawkins
This patch removes some duplicate code in hls_start that prevents the usage of strftime base filenames in conjuction with hls_segment_size. Signed-off-by: Stephen Dawkins --- libavformat/hlsenc.c | 13 - 1 file changed, 13 deletions(-) diff --git a/libavformat/hlsenc.c

[FFmpeg-devel] Fate samples

2018-11-11 Thread Michael Niedermayer
Hi all I think we need another volunteer to help with uploading fate samples why i think so, well, if i dont do it it seems to not happen currently until i do it ... This is worsened as james has technical problems with uploads ATM Do we have anyone who wants to help upload fate samples for

[FFmpeg-devel] [PATCH] avfilter/vf_alphamerge: switch to activate

2018-11-11 Thread Paul B Mahol
Signed-off-by: Paul B Mahol --- libavfilter/vf_alphamerge.c | 88 ++--- 1 file changed, 44 insertions(+), 44 deletions(-) diff --git a/libavfilter/vf_alphamerge.c b/libavfilter/vf_alphamerge.c index 45fa340fcc..b0a590adb3 100644 --- a/libavfilter/vf_alphamerge.c

[FFmpeg-devel] [RFC] Try to improve 1:N transcode performance with thread.

2018-11-11 Thread Jun Zhao
Add a new option "abr_pipeline" with mutil-thread to improve the 1:N transcode performance, currently, the code just as a PoC(proof of concept) prototype, and post it to maillist for RFC(Requect for Comment). Jun Zhao (1): ffmpeg: Improved the performance of 1:N for adaptive bitrate

[FFmpeg-devel] [RFC] ffmpeg: Improved the performance of 1:N for adaptive bitrate scenario.

2018-11-11 Thread Jun Zhao
Improved the performance of 1 decode + N filter graphs and adaptive bitrate scenario. With new option "-abr_pipeline" 1. It enabled multiple filter graph concurrency, which bring above about 5%~20% improvement in some 1:N scenario by CPU or GPU acceleration 2. Next step will continue to improve