Re: [FFmpeg-devel] [PATCH v2 1/1] avcodec/libjxlenc: Add libjxl_animated encoder

2023-12-15 Thread Leo Izen
On 12/15/23 16:31, Zsolt Vadász via ffmpeg-devel wrote: On Friday, December 15th, 2023 at 10:12 PM, Leo Izen wrote: On 12/15/23 11:40, Zsolt Vadász via ffmpeg-devel wrote: On Friday, December 15th, 2023 at 12:20 AM, Leo Izen leo.i...@gmail.com wrote: + AVFrame *last; I don't see the

Re: [FFmpeg-devel] [PATCH v2 1/1] avcodec/libjxlenc: Add libjxl_animated encoder

2023-12-15 Thread Zsolt Vadász via ffmpeg-devel
On Friday, December 15th, 2023 at 10:12 PM, Leo Izen wrote: > On 12/15/23 11:40, Zsolt Vadász via ffmpeg-devel wrote: > > > On Friday, December 15th, 2023 at 12:20 AM, Leo Izen leo.i...@gmail.com > > wrote: > > > > > > + AVFrame *last; > > > > > > I don't see the purpose of keeping this

[FFmpeg-devel] [PATCH 3/8] ffmpeg: add support for muxing AVStreamGroups

2023-12-15 Thread James Almer
Starting with IAMF support. Signed-off-by: James Almer --- doc/ffmpeg.texi | 200 ++ fftools/ffmpeg.h | 2 + fftools/ffmpeg_mux_init.c | 342 ++ fftools/ffmpeg_opt.c | 2 + 4 files changed, 546 insertions(+)

Re: [FFmpeg-devel] [PATCH v2 1/1] avcodec/libjxlenc: Add libjxl_animated encoder

2023-12-15 Thread Leo Izen
On 12/15/23 11:40, Zsolt Vadász via ffmpeg-devel wrote: On Friday, December 15th, 2023 at 12:20 AM, Leo Izen wrote: + AVFrame *last; I don't see the purpose of keeping this here. The name is misleading, I should have named it `previous`, since it always contains the previous frame. I

[FFmpeg-devel] [PATCH v2] avcodec/libjxldec: emit proper PTS to decoded AVFrame

2023-12-15 Thread Leo Izen
If a sequence of JXL images is encapsulated in a container that has PTS information, we should use the PTS information from the container. At this time there is no container that does this, but if JPEG XL support is ever added to NUT, AVTransport, or some other container, this commit should allow

[FFmpeg-devel] [PATCH v2] riscv: Tweak names of cpu flags, print flags in libavutil/tests/cpu

2023-12-15 Thread Martin Storsjö
The names of the cpu flags, when parsed from a string with av_parse_cpu_caps, are parsed by the libavutil eval functions. These interpret dashes as subtractions. Therefore, these previous cpu flag names haven't been possible to set. Use the official names for these extensions, as the previous

Re: [FFmpeg-devel] [PATCH] Add new vf_tiltandshift filter

2023-12-15 Thread Vittorio Giovara
On Fri, Dec 15, 2023 at 12:34 PM Andreas Rheinhardt < andreas.rheinha...@outlook.com> wrote: > > +static int list_add_frame(FrameList **list, size_t *size, AVFrame > > *frame) > > +{ > > +FrameList *element = av_mallocz(sizeof(FrameList)); > > The overhead of this FrameList is unnecessary:

[FFmpeg-devel] [PATCH v8 5/5] fate: add test for animated WebP

2023-12-15 Thread Thilo Borgmann via ffmpeg-devel
--- tests/fate/image.mak | 3 +++ tests/ref/fate/webp-anim | 22 ++ 2 files changed, 25 insertions(+) create mode 100644 tests/ref/fate/webp-anim diff --git a/tests/fate/image.mak b/tests/fate/image.mak index 400199c28a..2e0d1e8e3f 100644 --- a/tests/fate/image.mak +++

[FFmpeg-devel] [PATCH v8 3/5] avcodec/webp: make init_canvas_frame static

2023-12-15 Thread Thilo Borgmann via ffmpeg-devel
--- libavcodec/webp.c | 142 +++--- 1 file changed, 70 insertions(+), 72 deletions(-) diff --git a/libavcodec/webp.c b/libavcodec/webp.c index 4f989b8f0a..a2e6e199a7 100644 --- a/libavcodec/webp.c +++ b/libavcodec/webp.c @@ -1378,7 +1378,76 @@ static int

[FFmpeg-devel] [PATCH v8 4/5] libavformat/webp: add WebP demuxer

2023-12-15 Thread Thilo Borgmann via ffmpeg-devel
From: Josef Zlomek Adds the demuxer of animated WebP files. It supports non-animated, animated, truncated, and concatenated files. Reading from a pipe (and other non-seekable inputs) is also supported. The WebP demuxer splits the input stream into packets containing one frame. It also marks the

[FFmpeg-devel] [PATCH v8 2/5] libavcodec/webp: add support for animated WebP decoding

2023-12-15 Thread Thilo Borgmann via ffmpeg-devel
From: Josef Zlomek Fixes: 4907 Adds support for decoding of animated WebP. The WebP decoder adds the animation related features according to the specs: https://developers.google.com/speed/webp/docs/riff_container#animation The frames of the animation may be smaller than the image canvas.

[FFmpeg-devel] [PATCH v8 0/5] webp: add support for animated WebP decoding

2023-12-15 Thread Thilo Borgmann via ffmpeg-devel
Still images fixed, includes FATE tests, VP8 decoder decoupled so there are no more data races, fixed more asserts, fixed ffprobe regression, removed unnecessary parser changes, put the whole animated sequence into one packet. Patch 3/5 is still there for making changes in lavc/webp reviewable

[FFmpeg-devel] [PATCH v8 1/5] avcodec/webp: remove unused definitions

2023-12-15 Thread Thilo Borgmann via ffmpeg-devel
--- libavcodec/webp.c | 2 -- 1 file changed, 2 deletions(-) diff --git a/libavcodec/webp.c b/libavcodec/webp.c index 54b3fde6dc..4fd107aa0c 100644 --- a/libavcodec/webp.c +++ b/libavcodec/webp.c @@ -59,8 +59,6 @@ #define VP8X_FLAG_ALPHA 0x10 #define VP8X_FLAG_ICC

Re: [FFmpeg-devel] [PATCH] riscv: vc1dsp: Don't check vlenb before checking the CPU flags

2023-12-15 Thread Martin Storsjö
On Fri, 15 Dec 2023, Rémi Denis-Courmont wrote: Le 15 décembre 2023 17:39:48 GMT+02:00, "Martin Storsjö" a écrit : On Fri, 15 Dec 2023, Rémi Denis-Courmont wrote: Le 15 décembre 2023 15:02:04 GMT+02:00, "Martin Storsjö" a écrit : We can't call ff_get_rv_vlenb() if we don't have RVV

Re: [FFmpeg-devel] [PATCH] riscv: vc1dsp: Don't check vlenb before checking the CPU flags

2023-12-15 Thread Rémi Denis-Courmont
Le 15 décembre 2023 17:39:48 GMT+02:00, "Martin Storsjö" a écrit : >On Fri, 15 Dec 2023, Rémi Denis-Courmont wrote: > >> Le 15 décembre 2023 15:02:04 GMT+02:00, "Martin Storsjö" >> a écrit : >>> We can't call ff_get_rv_vlenb() if we don't have RVV available >>> at all. >>> >>> Due to the

Re: [FFmpeg-devel] [PATCH v2] swr/swresample: avoid reapplication of firstpts

2023-12-15 Thread Michael Niedermayer
On Fri, Dec 15, 2023 at 12:30:46PM +0530, Gyan Doshi wrote: > During a resampling operation where > > 1) user has specified first_pts > 2) SWR_FLAG_RESAMPLE is not set initially (directly or otherwise) > 3) first_pts has been fulfilled (always using hard compensation) > > then upon first

Re: [FFmpeg-devel] [PATCH] Add new vf_tiltandshift filter

2023-12-15 Thread Andreas Rheinhardt
Vittorio Giovara: > +#include "avfilter.h" > +#include "formats.h" > +#include "internal.h" > +#include "video.h" > + > +#define TILT_NONE -1 > +#define TILT_FRAME 0 > +#define TILT_BLACK 1 Why is this not an enum? > + > +typedef struct FrameList { > +AVFrame *frame; > +struct

Re: [FFmpeg-devel] [PATCH] riscv: Tweak names of cpu flags, print flags in libavutil/tests/cpu

2023-12-15 Thread Rémi Denis-Courmont
Le 15 décembre 2023 18:39:28 GMT+02:00, "Martin Storsjö" a écrit : >On Fri, 15 Dec 2023, Rémi Denis-Courmont wrote: > >> Le 15 décembre 2023 15:05:10 GMT+02:00, "Martin Storsjö" >> a écrit : >>> The names of the cpu flags are pased by the libavutil eval >> >> PaSsed > >Actually, I meant

Re: [FFmpeg-devel] [PATCH v2 1/1] avcodec/libjxlenc: Add libjxl_animated encoder

2023-12-15 Thread Zsolt Vadász via ffmpeg-devel
On Friday, December 15th, 2023 at 12:20 AM, Leo Izen wrote: > > + AVFrame *last; > > > I don't see the purpose of keeping this here. > The name is misleading, I should have named it `previous`, since it always contains the previous frame. I did it this way so I could call

Re: [FFmpeg-devel] [PATCH] riscv: Tweak names of cpu flags, print flags in libavutil/tests/cpu

2023-12-15 Thread Martin Storsjö
On Fri, 15 Dec 2023, Rémi Denis-Courmont wrote: Le 15 décembre 2023 15:05:10 GMT+02:00, "Martin Storsjö" a écrit : The names of the cpu flags are pased by the libavutil eval PaSsed Actually, I meant "parsed" functions - names with dashes are parsed as a subtraction. Replace dashes with

Re: [FFmpeg-devel] [PATCH] riscv: Tweak names of cpu flags, print flags in libavutil/tests/cpu

2023-12-15 Thread Rémi Denis-Courmont
Le 15 décembre 2023 15:05:10 GMT+02:00, "Martin Storsjö" a écrit : >The names of the cpu flags are pased by the libavutil eval PaSsed >functions - names with dashes are parsed as a subtraction. >Replace dashes with underscores. My personal preference would be to use official extension

Re: [FFmpeg-devel] [PATCH] riscv: vc1dsp: Don't check vlenb before checking the CPU flags

2023-12-15 Thread Martin Storsjö
On Fri, 15 Dec 2023, Rémi Denis-Courmont wrote: Le 15 décembre 2023 15:02:04 GMT+02:00, "Martin Storsjö" a écrit : We can't call ff_get_rv_vlenb() if we don't have RVV available at all. Due to the SIGILL signal handler in checkasm catching it, in an unexpected place, this caused checkasm to

[FFmpeg-devel] [PATCH v2] riscv: vc1dsp: Don't check vlenb before checking the CPU flags

2023-12-15 Thread Martin Storsjö
We can't call ff_get_rv_vlenb() if we don't have RVV available at all. Due to the SIGILL signal handler in checkasm catching it, in an unexpected place, this caused checkasm to hang instead of reporting the issue. --- libavcodec/riscv/vc1dsp_init.c | 8 +++- 1 file changed, 3 insertions(+),

Re: [FFmpeg-devel] [PATCH] riscv: vc1dsp: Don't check vlenb before checking the CPU flags

2023-12-15 Thread Rémi Denis-Courmont
Le 15 décembre 2023 15:02:04 GMT+02:00, "Martin Storsjö" a écrit : >We can't call ff_get_rv_vlenb() if we don't have RVV available >at all. > >Due to the SIGILL signal handler in checkasm catching it, in an >unexpected place, this caused checkasm to hang instead of reporting >the issue. >--- >

Re: [FFmpeg-devel] [PATCH 1/2] avfilter: Add fsync filter

2023-12-15 Thread Andreas Rheinhardt
Thilo Borgmann via ffmpeg-devel: > --- > Changelog| 1 + > MAINTAINERS | 1 + > doc/filters.texi | 33 + > libavfilter/Makefile | 1 + > libavfilter/allfilters.c | 1 + > libavfilter/version.h| 2 +- > libavfilter/vf_fsync.c | 304

Re: [FFmpeg-devel] [PATCH] riscv: Tweak names of cpu flags, print flags in libavutil/tests/cpu

2023-12-15 Thread James Almer
On 12/15/2023 10:05 AM, Martin Storsjö wrote: The names of the cpu flags are pased by the libavutil eval functions - names with dashes are parsed as a subtraction. Replace dashes with underscores. Add these cpu flags to libavutil/tests/cpu, so that the detected cpu flags also get printed when

[FFmpeg-devel] [PATCH] riscv: Tweak names of cpu flags, print flags in libavutil/tests/cpu

2023-12-15 Thread Martin Storsjö
The names of the cpu flags are pased by the libavutil eval functions - names with dashes are parsed as a subtraction. Replace dashes with underscores. Add these cpu flags to libavutil/tests/cpu, so that the detected cpu flags also get printed when run, also as part of the fate-cpu test. ---

[FFmpeg-devel] [PATCH] riscv: vc1dsp: Don't check vlenb before checking the CPU flags

2023-12-15 Thread Martin Storsjö
We can't call ff_get_rv_vlenb() if we don't have RVV available at all. Due to the SIGILL signal handler in checkasm catching it, in an unexpected place, this caused checkasm to hang instead of reporting the issue. --- libavcodec/riscv/vc1dsp_init.c | 16 +++- 1 file changed, 7

[FFmpeg-devel] [PATCH] configure: Add a --disable-version-tracking option

2023-12-15 Thread Martin Storsjö
This disables regenerating ffversion.h whenever the checked out git commit changes, speeding up development rebuilds. Whenever this option is set, force the version to be printed as "unknown" rather than showing potentially stale information. --- Makefile | 7 ++- configure | 4 2

Re: [FFmpeg-devel] [PATCH v2 1/4] libavfiter/dnn_backend_openvino: Add multiple output support

2023-12-15 Thread Guo, Yejun
> -Original Message- > From: ffmpeg-devel On Behalf Of > wenbin.chen-at-intel@ffmpeg.org > Sent: Tuesday, December 12, 2023 10:34 AM > To: ffmpeg-devel@ffmpeg.org > Subject: [FFmpeg-devel] [PATCH v2 1/4] libavfiter/dnn_backend_openvino: > Add multiple output support > > From:

Re: [FFmpeg-devel] [RFC] fftools/ffmpeg and libavdevice/sdl issue

2023-12-15 Thread Alexander Strasser via ffmpeg-devel
On 2023-12-14 01:47 +0100, Stefano Sabatini wrote: > On date Wednesday 2023-12-13 10:08:45 +0100, Anton Khirnov wrote: > > Quoting Zhao Zhili (2023-12-12 18:27:39) > [...] > > Honestly I don't see how this could be done in ffmpeg CLI without > > disgusting hacks, but before that the question is: >

Re: [FFmpeg-devel] [PATCH 10 bit support v5 1/3] avcodec/amfenc: Fixes the color information in the output.

2023-12-15 Thread Evgeny Pavlov
On Mon, Dec 11, 2023 at 10:21 PM Mark Thompson wrote: > > Not the same, but here is a freely-available test video which has the same > effect: . Output below. > > It doesn't seem like this should be dependent on the underlying hardware > since

Re: [FFmpeg-devel] [PATCH] avfoundation: Fix version checks

2023-12-15 Thread Zhao Zhili
> On Dec 15, 2023, at 19:41, Thilo Borgmann via ffmpeg-devel > wrote: > > Am 15.12.23 um 12:32 schrieb Martin Storsjö via ffmpeg-devel: >> On Fri, 15 Dec 2023, Zhao Zhili wrote: >>> On Dec 15, 2023, at 18:11, Martin Storsjö wrote: _VERSION_MAX_ALLOWED indicates what version

Re: [FFmpeg-devel] [PATCH] avfoundation: Fix version checks

2023-12-15 Thread Thilo Borgmann via ffmpeg-devel
Am 15.12.23 um 12:32 schrieb Martin Storsjö via ffmpeg-devel: On Fri, 15 Dec 2023, Zhao Zhili wrote: On Dec 15, 2023, at 18:11, Martin Storsjö wrote: _VERSION_MAX_ALLOWED indicates what version is available in the SDK, while _VERSION_MIN_REQUIRED is the version we can assume is available,

Re: [FFmpeg-devel] [PATCH] avfoundation: Fix version checks

2023-12-15 Thread Martin Storsjö via ffmpeg-devel
On Fri, 15 Dec 2023, Zhao Zhili wrote: On Dec 15, 2023, at 18:11, Martin Storsjö wrote: _VERSION_MAX_ALLOWED indicates what version is available in the SDK, while _VERSION_MIN_REQUIRED is the version we can assume is available, i.e. similar to what is set with e.g. -miphoneos-version-min on

Re: [FFmpeg-devel] [PATCH] avfoundation: Fix version checks

2023-12-15 Thread Zhao Zhili
> On Dec 15, 2023, at 18:11, Martin Storsjö wrote: > > _VERSION_MAX_ALLOWED indicates what version is available in > the SDK, while _VERSION_MIN_REQUIRED is the version we can > assume is available, i.e. similar to what is set with e.g. > -miphoneos-version-min on the command line. >

Re: [FFmpeg-devel] [PATCH] avfoundation: Fix version checks

2023-12-15 Thread Thilo Borgmann via ffmpeg-devel
Am 15.12.23 um 11:11 schrieb Martin Storsjö: _VERSION_MAX_ALLOWED indicates what version is available in the SDK, while _VERSION_MIN_REQUIRED is the version we can assume is available, i.e. similar to what is set with e.g. -miphoneos-version-min on the command line. This fixes build errors like

[FFmpeg-devel] [PATCH] avfoundation: Fix version checks

2023-12-15 Thread Martin Storsjö
_VERSION_MAX_ALLOWED indicates what version is available in the SDK, while _VERSION_MIN_REQUIRED is the version we can assume is available, i.e. similar to what is set with e.g. -miphoneos-version-min on the command line. This fixes build errors like these: src/libavdevice/avfoundation.m:788:37:

Re: [FFmpeg-devel] [PATCH 4/4] libavfilter/vf_dnn_detect: Set used pointer to NULL

2023-12-15 Thread Guo, Yejun
> -Original Message- > From: ffmpeg-devel On Behalf Of > wenbin.chen-at-intel@ffmpeg.org > Sent: Thursday, December 14, 2023 10:49 AM > To: ffmpeg-devel@ffmpeg.org > Subject: [FFmpeg-devel] [PATCH 4/4] libavfilter/vf_dnn_detect: Set used > pointer to NULL > > From: Wenbin Chen > >