Re: [FFmpeg-devel] avutil/x86util : add macro for 128 bits constant load

2017-12-02 Thread Martin Vignali
2017-12-02 13:13 GMT+01:00 Henrik Gramner : > On Fri, Dec 1, 2017 at 9:03 PM, Martin Vignali > wrote: > > If no one have objections, i will push these patch tomorrow. > > > > Martin > > Follow James' suggestion to use >16 instead of ==32, otherwise OK. > Pushed, with mmsize > 16 in the macro pat

Re: [FFmpeg-devel] avutil/x86util : add macro for 128 bits constant load

2017-12-02 Thread Henrik Gramner
On Fri, Dec 1, 2017 at 9:03 PM, Martin Vignali wrote: > If no one have objections, i will push these patch tomorrow. > > Martin Follow James' suggestion to use >16 instead of ==32, otherwise OK. ___ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org http

Re: [FFmpeg-devel] avutil/x86util : add macro for 128 bits constant load

2017-12-01 Thread Martin Vignali
2017-11-28 21:04 GMT+01:00 Henrik Gramner : > On Mon, Nov 27, 2017 at 11:37 PM, James Almer wrote: > > On 11/27/2017 7:33 PM, James Darnley wrote: > >> If the condition was made "mmsize > 16" would this work correctly for > >> zmm registers? (Assume I finally push my AVX-512 patches). > > > > No

Re: [FFmpeg-devel] avutil/x86util : add macro for 128 bits constant load

2017-11-28 Thread Henrik Gramner
On Mon, Nov 27, 2017 at 11:37 PM, James Almer wrote: > On 11/27/2017 7:33 PM, James Darnley wrote: >> If the condition was made "mmsize > 16" would this work correctly for >> zmm registers? (Assume I finally push my AVX-512 patches). > > No, there's no EVEX variant of vbroadcasti128. For that you

Re: [FFmpeg-devel] avutil/x86util : add macro for 128 bits constant load

2017-11-27 Thread James Almer
On 11/27/2017 7:33 PM, James Darnley wrote: > On 2017-11-27 20:19, Martin Vignali wrote: >> +%macro VBROADCASTI128 2 ; dst xmm/ymm, src : 128bits val >> +%if mmsize == 32 >> +vbroadcasti128 %1, %2 >> +%else >> +mova %1, %2 >> +%endif >> +%endmacro > > If the condition was made "m

Re: [FFmpeg-devel] avutil/x86util : add macro for 128 bits constant load

2017-11-27 Thread James Darnley
On 2017-11-27 20:19, Martin Vignali wrote: > +%macro VBROADCASTI128 2 ; dst xmm/ymm, src : 128bits val > +%if mmsize == 32 > +vbroadcasti128 %1, %2 > +%else > +mova %1, %2 > +%endif > +%endmacro If the condition was made "mmsize > 16" would this work correctly for zmm registers?

[FFmpeg-devel] avutil/x86util : add macro for 128 bits constant load

2017-11-27 Thread Martin Vignali
Hello Following suggestion by Henrik Gramner in attach a patch to add a macro in x86_utils.asm in order to load a 128 bits constantes in an XMM register or in each part of a ZMM register Not sure about the name of this macro, and the position in the x86utils file Patch 002 : Use this new macro,