[FFmpeg-devel] have some major changes for nvenc support

2015-11-05 Thread Agatha Hu
Hi, Recently Nvidia did some work on improving nvenc performance, it includes lots of change so I attach the patch instead of direct send. Here are the explanations: 1) The first main change is adding an nvresize filter (1:N, one input, multiple outputs) to do hardware resizing, because

[FFmpeg-devel] FFmpeg at Chemnitzer Linux-Tage 2016

2015-11-05 Thread Thilo Borgmann
Hi, I just registered FFmpeg for participation at the annual Chemnitzer Linux-Tage in 2016 (CLT) which takes place in Chemnitz, Germany from the 19th to the 20th March 2016. Like in the past years, we are planning to man a booth with some of our developers, give direct user support and receiving

Re: [FFmpeg-devel] [PATCH 3/3] doc/filters: move scattered remark on av_strtod to a common location

2015-11-05 Thread Ganesh Ajjanagadde
On Sun, Nov 1, 2015 at 11:57 AM, Ganesh Ajjanagadde wrote: > All filters now use av_strtod for accepting floating point parameters. > There was an isolated remark on this, but the point applies generally > now. > > This moves the comment and suitably elaborates on it for

Re: [FFmpeg-devel] [PATCH] swresample/resample: speed up build_filter for Blackman-Nuttall filter

2015-11-05 Thread Ganesh Ajjanagadde
On Thu, Nov 5, 2015 at 6:05 AM, Moritz Barsnick wrote: > On Wed, Nov 04, 2015 at 22:08:27 -0500, Ganesh Ajjanagadde wrote: >> This uses the trigonometric double and triple angle formulae to avoid >> repeated (expensive) evaluation of libc's cos(). > [...] >> -y

Re: [FFmpeg-devel] [PATCH] XMA1 and XMA2 stereo decoders

2015-11-05 Thread Paul B Mahol
On 11/4/15, Alexander Strasser wrote: > Hi Paul! > > On 2015-11-04 14:18 +0100, Paul B Mahol wrote: > [...] >> diff --git a/libavcodec/wmaprodec.c b/libavcodec/wmaprodec.c >> index 19dc335..7471961 100644 >> --- a/libavcodec/wmaprodec.c >> +++ b/libavcodec/wmaprodec.c >> @@

Re: [FFmpeg-devel] [PATCH] Added QSV based VPP filter - second try

2015-11-05 Thread Sven Dueking
> -Ursprüngliche Nachricht- > Von: ffmpeg-devel [mailto:ffmpeg-devel-boun...@ffmpeg.org] Im Auftrag > von wm4 > Gesendet: Donnerstag, 5. November 2015 13:43 > An: ffmpeg-devel@ffmpeg.org > Betreff: Re: [FFmpeg-devel] [PATCH] Added QSV based VPP filter - second > try > > On Thu, 5 Nov

Re: [FFmpeg-devel] have some major changes for nvenc support

2015-11-05 Thread wm4
On Thu, 5 Nov 2015 16:23:04 +0800 Agatha Hu wrote: > 2) We use AVFrame::opaque field to store a customized ffnvinfo struture > to prevent expensive CPU<->GPU transferration. Without it, the workflow > will be like CPU AVFrame input-->copy to GPU-->do CUDA resizing-->copy > to

Re: [FFmpeg-devel] [PATCH] Added QSV based VPP filter - second try

2015-11-05 Thread wm4
On Thu, 5 Nov 2015 12:49:50 +0100 "Sven Dueking" wrote: > > > +} else if (ret == MFX_WRN_DEVICE_BUSY) { > > > +av_usleep(500); > > > > What. Use proper event-based waiting. > > That´s the same behavior as we have in the qsv encoder and decoder.

Re: [FFmpeg-devel] [PATCH] Added QSV based VPP filter - second try

2015-11-05 Thread Sven Dueking
> -Ursprüngliche Nachricht- > Von: ffmpeg-devel [mailto:ffmpeg-devel-boun...@ffmpeg.org] Im Auftrag > von Sven Dueking > Gesendet: Montag, 2. November 2015 10:33 > An: 'FFmpeg development discussions and patches' > Betreff: Re: [FFmpeg-devel] [PATCH] Added QSV based VPP filter - second >

Re: [FFmpeg-devel] [PATCH] Added QSV based VPP filter - second try

2015-11-05 Thread Moritz Barsnick
On Thu, Nov 05, 2015 at 11:18:38 +0100, Sven Dueking wrote: +The VPP library is part of the Intel® Media SDK and exposes the media acceleration capabilities of Intel® platforms. You're probably supposed to limit the line length in the free text to some width, but I don't know the style guide

Re: [FFmpeg-devel] [PATCH] Added QSV based VPP filter - second try

2015-11-05 Thread wm4
On Thu, 5 Nov 2015 11:18:38 +0100 "Sven Dueking" wrote: > From 0fe140c8204b4e09f577358b02295b76c2b5f3be Mon Sep 17 00:00:00 2001 > From: Sven Dueking > Date: Thu, 5 Nov 2015 09:26:43 + > Subject: [PATCH] added QSV VPP filter > > --- > configure

Re: [FFmpeg-devel] [PATCH] Added QSV based VPP filter - second try

2015-11-05 Thread Sven Dueking
> -Ursprüngliche Nachricht- > Von: ffmpeg-devel [mailto:ffmpeg-devel-boun...@ffmpeg.org] Im Auftrag > von wm4 > Gesendet: Donnerstag, 5. November 2015 12:19 > An: ffmpeg-devel@ffmpeg.org > Betreff: Re: [FFmpeg-devel] [PATCH] Added QSV based VPP filter - second > try > > On Thu, 5 Nov

Re: [FFmpeg-devel] [PATCH 3/3] doc/filters: move scattered remark on av_strtod to a common location

2015-11-05 Thread Ganesh Ajjanagadde
On Thu, Nov 5, 2015 at 9:47 AM, Ronald S. Bultje wrote: > Hi, > > On Thu, Nov 5, 2015 at 9:20 AM, Ganesh Ajjanagadde > wrote: >> >> On Sun, Nov 1, 2015 at 11:57 AM, Ganesh Ajjanagadde >> wrote: >> > All filters now use

[FFmpeg-devel] Past Duration too large

2015-11-05 Thread Nicholas Robbins
It seems like this is more an ffmpeg-user question. I asked there and got no responses. During some of my encodes, I get quite a lot of these warnings. What do they mean? For example: here is a chuck of the output I am talking about Past duration 0.998009 too large= 718546kB time=01:33:23.23

Re: [FFmpeg-devel] [PATCH] avcodec: remove old avpriv_mpa_decode_header function

2015-11-05 Thread Andreas Cadhalpun
On 21.10.2015 00:57, Andreas Cadhalpun wrote: > Replace its last use by avpriv_mpa_decode_header2 and drop the 2 suffix. > > Signed-off-by: Andreas Cadhalpun > --- > libavcodec/mpegaudio_parser.c | 2 +- > libavcodec/mpegaudiodecheader.c | 7 +-- >

[FFmpeg-devel] [PATCHv3 1/2] mpegtsenc: Add support for muxing Opus in MPEG-TS

2015-11-05 Thread Sebastian Dröge
From: Sebastian Dröge Signed-off-by: Sebastian Dröge --- libavformat/mpegtsenc.c | 180 +++- 1 file changed, 179 insertions(+), 1 deletion(-) diff --git a/libavformat/mpegtsenc.c

Re: [FFmpeg-devel] [PATCHv2] avfilter: add anoisesrc

2015-11-05 Thread Clément Bœsch
On Thu, Nov 05, 2015 at 09:49:32PM +0100, Nicolas George wrote: > Le quintidi 15 brumaire, an CCXXIV, Paul B Mahol a écrit : > > Hmm, why not simple enum/int? > > Did you miss the fact that AV_OPT_TYPE_FLAG is exactly for that? > AV_OPT_TYPE_FLAG is for concatenated "bool" flags (foo+bar+baz),

Re: [FFmpeg-devel] [PATCHv2] avfilter: add anoisesrc

2015-11-05 Thread Nicolas George
Le quintidi 15 brumaire, an CCXXIV, Clement Boesch a écrit : > AV_OPT_TYPE_FLAG is for concatenated "bool" flags (foo+bar+baz), > AV_OPT_TYPE_INT is probably what is needed here (it supports > AV_OPT_TYPE_CONST sub items) Oh, my bad, that was AV_OPT_TYPE_CONST I was referring to. Sorry for the

[FFmpeg-devel] Intel QuickSync Video

2015-11-05 Thread Sevan Gelici
Hello, I try to transcode with quick sync, but it doesn't work. I did follow: https://ffmpeg.org/general.html#Intel-QuickSync-Video When i use this command: ./ffmpeg -y -fflags +genpts -loglevel warning -probesize 1000 -analyzeduration 1500 -i

Re: [FFmpeg-devel] [PATCHv2 1/2] mpegtsenc: Add support for muxing Opus in MPEG-TS

2015-11-05 Thread Sebastian Dröge
On So, 2015-11-01 at 23:44 +0200, Sebastian Dröge wrote: >  > +} else if (st->codec->extradata[18] == 1 && st- > >codec->channels <= 8 && > +   st->codec->extradata_size >= 22 + st- > >codec->channels) { Off by one here, this should be 21 and not

Re: [FFmpeg-devel] [PATCH 1/3] swscale: rename sws_alloc_set_opts to ff_sws_alloc_set_opts

2015-11-05 Thread Andreas Cadhalpun
On 27.10.2015 23:10, Andreas Cadhalpun wrote: > It is an internal swscale function and thus should not be exported. > > Signed-off-by: Andreas Cadhalpun > --- > libswscale/swscale_internal.h | 2 +- > libswscale/utils.c| 10 +- > 2 files

Re: [FFmpeg-devel] [PATCHv2] avfilter: add anoisesrc

2015-11-05 Thread Nicolas George
Le quintidi 15 brumaire, an CCXXIV, Paul B Mahol a écrit : > Hmm, why not simple enum/int? Did you miss the fact that AV_OPT_TYPE_FLAG is exactly for that? Regards, -- Nicolas George signature.asc Description: Digital signature ___ ffmpeg-devel

Re: [FFmpeg-devel] [PATCHv2] avfilter: add anoisesrc

2015-11-05 Thread Paul B Mahol
On 11/5/15, Nicolas George wrote: > Le quintidi 15 brumaire, an CCXXIV, Kyle Swanson a ecrit : >> +{ "color","set noise color", OFFSET(color), >> AV_OPT_TYPE_STRING,{.str = "white"}, CHAR_MIN, CHAR_MAX, FLAGS }, > >> +if (!strcmp(s->color, "pink")) { >> +

Re: [FFmpeg-devel] [PATCHv2] avfilter: add anoisesrc

2015-11-05 Thread Nicolas George
Le quintidi 15 brumaire, an CCXXIV, Kyle Swanson a écrit : > +{ "color","set noise color", OFFSET(color), > AV_OPT_TYPE_STRING,{.str = "white"}, CHAR_MIN, CHAR_MAX, FLAGS }, > +if (!strcmp(s->color, "pink")) { > +s->filter = pink_filter; > +} else

Re: [FFmpeg-devel] [PATCHv3 1/4] fate: add concat demuxer tests

2015-11-05 Thread Marton Balint
On Thu, 5 Nov 2015, Clément Bœsch wrote: On Wed, Nov 04, 2015 at 03:33:16PM +0100, Nicolas George wrote: Le quartidi 14 brumaire, an CCXXIV, Marton Balint a écrit : + run ffprobe${PROGSUF} -show_streams -show_packets -v 0 -fflags keepside -safe 0 $extra_args $concatfile > $packetfile

[FFmpeg-devel] [PATCHv2] avfilter: add anoisesrc

2015-11-05 Thread Kyle Swanson
Here's a new version of this patch based on everyone's comments. Sample format is still AV_SAMPLE_FMT_DBL despite concerns about that. The current pink and brown filter implementations are not designed for fixed-point DSP, and I was unable to come up with anything equal or better using

[FFmpeg-devel] [PATCHv4] swresample/resample: improve bessel function accuracy and speed

2015-11-05 Thread Ganesh Ajjanagadde
This improves accuracy for the bessel function at large arguments, and this in turn should improve the quality of the Kaiser window. It also improves the performance of the bessel function and hence build_filter by ~ 20%. Details are given below. Algorithm: taken from the Boost project, who have

Re: [FFmpeg-devel] [PATCHv4] swresample/resample: improve bessel function accuracy and speed

2015-11-05 Thread Ganesh Ajjanagadde
On Thu, Nov 5, 2015 at 8:15 PM, Ganesh Ajjanagadde wrote: > [...] Nothing new here, just moved the copyright to the top of the file to satisfy some legal requirements I am completely unaware of, don't know why an inline copyright does not work. Anyway, I don't want to

[FFmpeg-devel] [PATCH] avfilter: add anoisesrc

2015-11-05 Thread Kyle Swanson
Here's v3. Uses AV_OPT_TYPE_CONST now. Signed-off-by: Kyle Swanson --- Changelog| 1 + doc/filters.texi | 36 libavfilter/Makefile | 1 + libavfilter/allfilters.c | 1 + libavfilter/asrc_anoisesrc.c | 208

Re: [FFmpeg-devel] [PATCH] swresample/resample: speed up build_filter for Blackman-Nuttall filter

2015-11-05 Thread Michael Niedermayer
On Wed, Nov 04, 2015 at 10:08:27PM -0500, Ganesh Ajjanagadde wrote: > This uses the trigonometric double and triple angle formulae to avoid > repeated (expensive) evaluation of libc's cos(). > > Sample benchmark (x86-64, Haswell, GNU/Linux) > old: > 1104466600 decicycles in build_filter(loop

Re: [FFmpeg-devel] [PATCH] swresample/options: change rematrix_maxval default to 1.0

2015-11-05 Thread Michael Niedermayer
On Wed, Nov 04, 2015 at 10:40:45PM -0500, Ganesh Ajjanagadde wrote: > This changes the default to not clip, and thus matches libavresample as > well. > > Documentation has been accordingly updated (with some typo fixes). > > API users have complained about this, see e.g >

[FFmpeg-devel] [PATCHv3] avfilter: add anoisesrc

2015-11-05 Thread Kyle Swanson
Here's v3. Uses AV_OPT_TYPE_CONST now. Just sent this with the wrong subject line, here it is again. (sorry!) Signed-off-by: Kyle Swanson --- Changelog| 1 + doc/filters.texi | 36 libavfilter/Makefile | 1 +

Re: [FFmpeg-devel] [PATCH 0/2] mpegtsenc: Add support for muxing Opus into MPEG-TS

2015-11-05 Thread Michael Niedermayer
On Thu, Nov 05, 2015 at 04:01:33PM +, Kieran Kunhya wrote: > > Please review carefully, thanks! > > Both patches look ok. applied thanks [...] -- Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB The bravest are surely those who have the clearest vision of what is

Re: [FFmpeg-devel] [PATCH] swresample/resample: speed up build_filter for Blackman-Nuttall filter

2015-11-05 Thread Ganesh Ajjanagadde
On Thu, Nov 5, 2015 at 9:29 PM, Michael Niedermayer wrote: > On Wed, Nov 04, 2015 at 10:08:27PM -0500, Ganesh Ajjanagadde wrote: >> This uses the trigonometric double and triple angle formulae to avoid >> repeated (expensive) evaluation of libc's cos(). >> >> Sample

Re: [FFmpeg-devel] have some major changes for nvenc support

2015-11-05 Thread Agatha Hu
在 2015/11/5 18:31, wm4 写道: On Thu, 5 Nov 2015 16:23:04 +0800 Agatha Hu wrote: 2) We use AVFrame::opaque field to store a customized ffnvinfo struture to prevent expensive CPU<->GPU transferration. Without it, the workflow will be like CPU AVFrame input-->copy to GPU-->do CUDA

Re: [FFmpeg-devel] [PATCHv3 1/2] mpegtsenc: Add support for muxing Opus in MPEG-TS

2015-11-05 Thread Michael Niedermayer
On Thu, Nov 05, 2015 at 11:35:42PM +0100, Sebastian Dröge wrote: > From: Sebastian Dröge > > Signed-off-by: Sebastian Dröge > --- > libavformat/mpegtsenc.c | 180 > +++- > 1 file changed, 179

Re: [FFmpeg-devel] [PATCHv3 2/2] mpegtsenc: Implement writing of Opus trim_start/trim_end control values

2015-11-05 Thread Michael Niedermayer
On Mon, Nov 02, 2015 at 09:06:19AM +0200, Sebastian Dröge wrote: > From: Sebastian Dröge > > Signed-off-by: Sebastian Dröge > --- > libavformat/mpegtsenc.c | 43 --- > 1 file changed, 40

Re: [FFmpeg-devel] [PATCH] avfilter: add anoisesrc

2015-11-05 Thread Nicolas George
Le quintidi 15 brumaire, an CCXXIV, Kyle Swanson a écrit : > +{ "color","set noise color", OFFSET(color), > AV_OPT_TYPE_INT, {.i64 = 1}, 0, INT64_MAX, FLAGS, "color" }, > +{ "colour", "set noise color", OFFSET(color), > AV_OPT_TYPE_INT,

Re: [FFmpeg-devel] Intel QuickSync Video

2015-11-05 Thread Sven Dueking
> -Ursprüngliche Nachricht- > Von: ffmpeg-devel [mailto:ffmpeg-devel-boun...@ffmpeg.org] Im Auftrag > von Sevan Gelici > Gesendet: Freitag, 6. November 2015 00:42 > An: ffmpeg-devel@ffmpeg.org > Betreff: [FFmpeg-devel] Intel QuickSync Video > > Hello, > > I try to transcode with quick

Re: [FFmpeg-devel] [PATCH] swresample/options: change rematrix_maxval default to 1.0

2015-11-05 Thread Nicolas George
Le sextidi 16 brumaire, an CCXXIV, Michael Niedermayer a écrit : > iam with whatever default people prefer IIRC, the current default yields different results when rematrixing from float to float and then converting from float to int than when doing both in a single step. I beliee this is not

Re: [FFmpeg-devel] [PATCH] Added QSV based VPP filter - second try

2015-11-05 Thread Ivan Uskov
Hello wm4, Thursday, November 5, 2015, 5:07:08 PM, you wrote: >> >> >> > > +} else if (ret == MFX_WRN_DEVICE_BUSY) { >> >> > > +av_usleep(500); >> >> > >> >> > What. Use proper event-based waiting. >> It is not possible. >> >> >> >> That´s the same behavior as

Re: [FFmpeg-devel] [PATCH 3/3] doc/filters: move scattered remark on av_strtod to a common location

2015-11-05 Thread Ronald S. Bultje
Hi, On Thu, Nov 5, 2015 at 9:20 AM, Ganesh Ajjanagadde wrote: > On Sun, Nov 1, 2015 at 11:57 AM, Ganesh Ajjanagadde > wrote: > > All filters now use av_strtod for accepting floating point parameters. > > There was an isolated remark on this, but

Re: [FFmpeg-devel] [PATCHv3 1/4] fate: add concat demuxer tests

2015-11-05 Thread Clément Bœsch
On Wed, Nov 04, 2015 at 03:33:16PM +0100, Nicolas George wrote: > Le quartidi 14 brumaire, an CCXXIV, Marton Balint a écrit : > > + run ffprobe${PROGSUF} -show_streams -show_packets -v 0 -fflags > > keepside -safe 0 $extra_args $concatfile > $packetfile > > Maybe -of compact, that makes the

Re: [FFmpeg-devel] [PATCH] Added QSV based VPP filter - second try

2015-11-05 Thread wm4
On Thu, 5 Nov 2015 16:28:30 +0300 Ivan Uskov wrote: > Hello wm4, > > Thursday, November 5, 2015, 3:42:30 PM, you wrote: > > w> On Thu, 5 Nov 2015 12:49:50 +0100 > w> "Sven Dueking" wrote: > > >> > > +} else if (ret == MFX_WRN_DEVICE_BUSY)

[FFmpeg-devel] [PATCH] hevc: extract SEI caption data

2015-11-05 Thread Will Kelleher
Signed-off-by: Will Kelleher --- libavcodec/hevc.c | 10 +++ libavcodec/hevc.h | 4 +++ libavcodec/hevc_sei.c | 79 +++ 3 files changed, 93 insertions(+) diff --git a/libavcodec/hevc.c b/libavcodec/hevc.c index

Re: [FFmpeg-devel] [PATCH] Added QSV based VPP filter - second try

2015-11-05 Thread Ivan Uskov
Hello wm4, Thursday, November 5, 2015, 3:42:30 PM, you wrote: w> On Thu, 5 Nov 2015 12:49:50 +0100 w> "Sven Dueking" wrote: >> > > +} else if (ret == MFX_WRN_DEVICE_BUSY) { >> > > +av_usleep(500); >> > >> > What. Use proper event-based waiting.