Re: [FFmpeg-devel] [PATCH] avcodec/cuviddec: update amount of decoder surfaces from within sequence decode callback

2023-08-08 Thread Michael Diesel
Hello , after this patch I get stutter in the output video when using h264_cuvid as decoder With "surfaces" as -1 will result : CUVIDPARSERPARAMS::ulMaxNumDecodeSurfaces = 5 = CUVID_DEFAULT_NUM_SURFACES CUVIDDECODECREATEINFO::ulNumDecodeSurfaces = 8 = format->min_num_decode_surfaces

Re: [FFmpeg-devel] What is FFmpeg and what should it be

2023-08-08 Thread Rémi Denis-Courmont
Le tiistaina 8. elokuuta 2023, 18.22.49 EEST Michael Niedermayer a écrit : > > > That is missing that people suggest a path forward but > > > with too few details to easily walk that path. > > > > Uh, I hate to state the patently obvious, but if "no path forward is > > needed", then there should

Re: [FFmpeg-devel] [PATCH] Fix failure to initialize ddagrab if adapter ID is specified

2023-08-08 Thread James Almer
On 8/8/2023 2:52 PM, Jøger Hansegård wrote: Fix failure to initialize ddagrab if adapter ID is specified. If an adapter ID is specified when initializing hw device for d3d11va, ddagrab does not work on Windows 11. This prevents capturing screens connected to a secondary adapter. Failing

[FFmpeg-devel] [PATCH] Fix failure to initialize ddagrab if adapter ID is specified

2023-08-08 Thread Jøger Hansegård
Fix failure to initialize ddagrab if adapter ID is specified. If an adapter ID is specified when initializing hw device for d3d11va, ddagrab does not work on Windows 11. This prevents capturing screens connected to a secondary adapter. Failing command: ffmpeg -init_hw_device d3d11va:0

Re: [FFmpeg-devel] [PATCH] Replace br return with ret

2023-08-08 Thread Martin Storsjö
On Tue, 8 Aug 2023, Casey Smalley wrote: This patch changes the return instruction in the tr_32x4 macro from br to ret. Using ret properly hints that the branch is a function return. On devices that support BTI a landing pad is required when branching with br, or the instruction can be

Re: [FFmpeg-devel] [PATCH v2] avcodec/on2avc: use correct fft sizes

2023-08-08 Thread Marton Balint
On Mon, 7 Aug 2023, Lynne wrote: Aug 6, 2023, 21:45 by c...@passwd.hu: Also rename the contexts and the functions so their names will reflect their intended size. With the earlier patch this fixes the audio corruption regression caused by 6ba0aa1770ba29eb4126c6a706f6b0cd3809648f. Fixes

Re: [FFmpeg-devel] [PATCH] avcodec/on2avc: use the matching AVTX context for the 512 sized iMDCT

2023-08-08 Thread Marton Balint
On Sat, 5 Aug 2023, Lynne wrote: Aug 5, 2023, 10:33 by c...@passwd.hu: Improves the audio corruption regression caused by 6ba0aa1770ba29eb4126c6a706f6b0cd3809648f reported in ticket #10029. There is still however a noticable audio glitch, so the FFT conversion to AVTX probably also needs

[FFmpeg-devel] [PATCH 15/15] avformat/matroskaenc: Don't write \0 unnecessarily

2023-08-08 Thread Andreas Rheinhardt
Writing the duration SimpleTag is special: It's size is reserved in advance via an EBML Void element (if seekable) and this reserved space is overwritten when writing the trailer; it does not use put_ebml_string(). The string to write is created via snprintf on a buffer of size 20; this buffer is

[FFmpeg-devel] [PATCH 12/15] avformat/matroskaenc: Add const where appropriate

2023-08-08 Thread Andreas Rheinhardt
Also move getting the DOVI side data immediately before its use. Signed-off-by: Andreas Rheinhardt --- libavformat/matroskaenc.c | 9 + 1 file changed, 5 insertions(+), 4 deletions(-) diff --git a/libavformat/matroskaenc.c b/libavformat/matroskaenc.c index 12a28a6b5c..abac70dd80 100644

[FFmpeg-devel] [PATCH 11/15] avformat/dovi_isom: Don't use AVFormatContext* for logctx

2023-08-08 Thread Andreas Rheinhardt
Pass it as void* instead. While just at it, also constify the pointee of AVDOVIDecoderConfigurationRecord* in ff_isom_put_dvcc_dvvc(). Signed-off-by: Andreas Rheinhardt --- libavformat/dovi_isom.c | 12 +++- libavformat/dovi_isom.h | 7 --- 2 files changed, 11 insertions(+), 8

[FFmpeg-devel] [PATCH 10/15] avformat/matroskaenc: Avoid allocations when writing Dynamic HDR10+

2023-08-08 Thread Andreas Rheinhardt
Possible since 61b27b15fc924d7fa35baa61cfbc91568945f5db. Signed-off-by: Andreas Rheinhardt --- libavformat/matroskaenc.c | 26 +++--- 1 file changed, 7 insertions(+), 19 deletions(-) diff --git a/libavformat/matroskaenc.c b/libavformat/matroskaenc.c index

[FFmpeg-devel] [PATCH 09/15] avformat/matroskaenc: Use dedicated pointer for accesses

2023-08-08 Thread Andreas Rheinhardt
Improves readability; also split overlong lines. Signed-off-by: Andreas Rheinhardt --- libavformat/matroskaenc.c | 20 +--- 1 file changed, 13 insertions(+), 7 deletions(-) diff --git a/libavformat/matroskaenc.c b/libavformat/matroskaenc.c index bfe6342d9b..323379c8bc 100644

[FFmpeg-devel] [PATCH 08/15] avformat/matroskaenc: Use proper AVIOContext

2023-08-08 Thread Andreas Rheinhardt
These two AVIOContexts currently coincide, but this is not guaranteed to remain so (in fact, I have plans to write each TrackEntry into its own AVIOContext). Signed-off-by: Andreas Rheinhardt --- libavformat/matroskaenc.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

[FFmpeg-devel] [PATCH 14/15] avformat/matroskaenc: Reindent after the previous commit

2023-08-08 Thread Andreas Rheinhardt
Signed-off-by: Andreas Rheinhardt --- libavformat/matroskaenc.c | 49 --- 1 file changed, 25 insertions(+), 24 deletions(-) diff --git a/libavformat/matroskaenc.c b/libavformat/matroskaenc.c index 5c251cec7b..7cbae47e42 100644 --- a/libavformat/matroskaenc.c

[FFmpeg-devel] [PATCH 13/15] avformat/matroskaenc: Don't reserve space for HDR10+ when unnecessary

2023-08-08 Thread Andreas Rheinhardt
Do it only for video (the only thing for type for which HDR10+ makes sense). This effectively reverts changes to several FATE ref-files made in bda44f0f39e8ee646e54f15989d7845f4bf58d26. Signed-off-by: Andreas Rheinhardt --- libavformat/matroskaenc.c | 9 +++-

[FFmpeg-devel] [PATCH 07/15] avformat/matroskaenc: Remove unnecessary check

2023-08-08 Thread Andreas Rheinhardt
It is only WebVTT which is special in WebM; hypothetical future subtitle codecs in WebM will presumably use the ordinary code. Signed-off-by: Andreas Rheinhardt --- libavformat/matroskaenc.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/libavformat/matroskaenc.c

[FFmpeg-devel] [PATCH 06/15] avformat/matroskaenc: Hoist check out of loop

2023-08-08 Thread Andreas Rheinhardt
Signed-off-by: Andreas Rheinhardt --- libavformat/matroskaenc.c | 8 ++-- 1 file changed, 6 insertions(+), 2 deletions(-) diff --git a/libavformat/matroskaenc.c b/libavformat/matroskaenc.c index be70e7a6f1..d9bc31daee 100644 --- a/libavformat/matroskaenc.c +++ b/libavformat/matroskaenc.c @@

Re: [FFmpeg-devel] [PATCH v4 0/4] Add passthrough support for SCTE-35

2023-08-08 Thread Dennis Mungai
On Tue, 8 Aug 2023, 17:31 Devin Heitmueller, < devin.heitmuel...@ltnglobal.com> wrote: > On Fri, Aug 4, 2023 at 7:16 AM Devin Heitmueller > wrote: > > > > On Mon, Jul 31, 2023 at 9:38 AM Devin Heitmueller > > wrote: > > > > > > Properly set up the MPEG-TS mux and recalculate the pts_adjust

Re: [FFmpeg-devel] What is FFmpeg and what should it be

2023-08-08 Thread Paul B Mahol
On Tue, Aug 8, 2023 at 5:23 PM Michael Niedermayer wrote: > Hi > > On Mon, Aug 07, 2023 at 06:39:10PM +0300, Rémi Denis-Courmont wrote: > > Le sunnuntaina 6. elokuuta 2023, 22.53.23 EEST Michael Niedermayer a > écrit : > > > > > > Did you ask people to do that? > > > > > > > > > > yes, multiple

Re: [FFmpeg-devel] What is FFmpeg and what should it be

2023-08-08 Thread Michael Niedermayer
Hi On Mon, Aug 07, 2023 at 06:39:10PM +0300, Rémi Denis-Courmont wrote: > Le sunnuntaina 6. elokuuta 2023, 22.53.23 EEST Michael Niedermayer a écrit : > > > > > Did you ask people to do that? > > > > > > > > yes, multiple times. > > > > Also normally patch objections come with a path forward,

Re: [FFmpeg-devel] [PATCH v4 0/4] Add passthrough support for SCTE-35

2023-08-08 Thread Devin Heitmueller
On Fri, Aug 4, 2023 at 7:16 AM Devin Heitmueller wrote: > > On Mon, Jul 31, 2023 at 9:38 AM Devin Heitmueller > wrote: > > > > Properly set up the MPEG-TS mux and recalculate the pts_adjust field > > in SCTE_35 packets, such that a user can transparently pass through > > SCTE-35 streams when

Re: [FFmpeg-devel] [PATCH v2] avdevice: Fix disabling audiotoolbox_outdev build on iOS

2023-08-08 Thread L. E. Segovia
Ping for review. amyspark On 29/07/2023 16:00, L. E. Segovia wrote: > audiotoolbox.m uses CoreAudio APIs that are only available in macOS. > The existing CoreAudio framework check is already enough for this case > (as CoreAudio.h does not exist for the iDevices), however, it was never > passed

Re: [FFmpeg-devel] [PATCH v1 1/1] lavc/qsvenc: disable SEI frame before each P-frame

2023-08-08 Thread sirius hu
Hi, How can I disable SEI frame? Is there any other option? 获取 Outlook for iOS 发件人: Xiang, Haihao 发送时间: Monday, August 7, 2023 10:06:41 AM 收件人: ffmpeg-devel@ffmpeg.org 抄送: siriu...@hotmail.com 主题: Re: [FFmpeg-devel] [PATCH v1 1/1]

[FFmpeg-devel] [PATCH] Replace br return with ret

2023-08-08 Thread Casey Smalley
This patch changes the return instruction in the tr_32x4 macro from br to ret. Using ret properly hints that the branch is a function return. On devices that support BTI a landing pad is required when branching with br, or the instruction can be replaced with a ret. The change fixes

Re: [FFmpeg-devel] [PATCH 2/2] fate/audio: Add SBaGen/ffwavesynth test

2023-08-08 Thread Andreas Rheinhardt
Paul B Mahol: > Why you adding test for target that breaks numerous rules and should be > removed completely? > As long as it is there, it should be tested. You may of course send patches proposing to remove ffwavesynth and sbg. - Andreas ___

Re: [FFmpeg-devel] [PATCH] fftools/ffprobe: Use proper enum type

2023-08-08 Thread Andreas Rheinhardt
Stefano Sabatini: > On date Sunday 2023-08-06 15:28:00 +0200, Andreas Rheinhardt wrote: >> This is a bit cleaner as int need not be the underlying type >> of an enum if a smaller type can hold all its values. >> Also declare the children_ids array as const as it never changes. >> >> Signed-off-by:

[FFmpeg-devel] [PATCH v2 8/8] cbs_h266: slice_header, fix inference for pred_weight_table

2023-08-08 Thread Nuo Mi
--- libavcodec/cbs_h266_syntax_template.c | 19 +-- 1 file changed, 9 insertions(+), 10 deletions(-) diff --git a/libavcodec/cbs_h266_syntax_template.c b/libavcodec/cbs_h266_syntax_template.c index b26d7c1a72..4075897b9a 100644 --- a/libavcodec/cbs_h266_syntax_template.c +++

[FFmpeg-devel] [PATCH v2 7/8] cbs_h266: H266RawSliceHeader, expose NumRefIdxActive[]

2023-08-08 Thread Nuo Mi
--- libavcodec/cbs_h266.h | 1 + libavcodec/cbs_h266_syntax_template.c | 41 +-- 2 files changed, 21 insertions(+), 21 deletions(-) diff --git a/libavcodec/cbs_h266.h b/libavcodec/cbs_h266.h index 87a2d02cfd..3a6f6d96b5 100644 --- a/libavcodec/cbs_h266.h

[FFmpeg-devel] [PATCH v2 6/8] cbs_h266: H266RawPredWeightTable, expose num_weights_l0 and num_weights_l1

2023-08-08 Thread Nuo Mi
--- libavcodec/cbs_h266.h | 3 ++ libavcodec/cbs_h266_syntax_template.c | 43 +-- 2 files changed, 23 insertions(+), 23 deletions(-) diff --git a/libavcodec/cbs_h266.h b/libavcodec/cbs_h266.h index 1d80c74feb..87a2d02cfd 100644 --- a/libavcodec/cbs_h266.h

[FFmpeg-devel] [PATCH v2 5/8] cbs_h266: H266RawSliceHeader, expose NumEntryPoints

2023-08-08 Thread Nuo Mi
--- libavcodec/cbs_h266.h | 3 +++ libavcodec/cbs_h266_syntax_template.c | 17 + 2 files changed, 12 insertions(+), 8 deletions(-) diff --git a/libavcodec/cbs_h266.h b/libavcodec/cbs_h266.h index 0196f46bc0..1d80c74feb 100644 --- a/libavcodec/cbs_h266.h +++

[FFmpeg-devel] [PATCH v2 4/8] cbs_h266: fix slice_height_in_ctus for single slice tile

2023-08-08 Thread Nuo Mi
Failed clips: TILE_E_Nokia_2.bit TILE_D_Nokia_2.bit LMCS_A_Dolby_3.bit --- libavcodec/cbs_h266_syntax_template.c | 1 + 1 file changed, 1 insertion(+) diff --git a/libavcodec/cbs_h266_syntax_template.c b/libavcodec/cbs_h266_syntax_template.c index 7277154c40..43b3346359 100644 ---

[FFmpeg-devel] [PATCH v2 2/8] cbs_h266: fix inference for sh_alf_enabled_flag

2023-08-08 Thread Nuo Mi
if pps_alf_info_in_ph_flag is true sh_alf_enabled_flag infered from ph Failed clip: LTRP_A_ERICSSON_3.bit --- libavcodec/cbs_h266_syntax_template.c | 81 --- 1 file changed, 47 insertions(+), 34 deletions(-) diff --git a/libavcodec/cbs_h266_syntax_template.c

[FFmpeg-devel] [PATCH v2 3/8] cbs_h266: fix inference for xh_deblocking_filter_disabled_flag

2023-08-08 Thread Nuo Mi
if !ph_deblocking_params_present_flag is true, ph_deblocking_filter_disabled_flag infered from pps if !sh_deblocking_params_present_flag is true, sh_deblocking_filter_disabled_flag infered from ph Failed clips: ENT444MAINTIER_C_Sony_3.bit ENT444HIGHTIER_D_Sony_3.bit ---

[FFmpeg-devel] [PATCH v2 1/8] cbs_h266: fix inference for sh_lmcs_used_flag and sh_explicit_scaling_list_used_flag

2023-08-08 Thread Nuo Mi
if sh_picture_header_in_slice_header_flag is true sh_lmcs_used_flag and sh_explicit_scaling_list_used_flag are infered from ph Failed clips: LMCS: CLM_A_KDDI_2.bit STILL444_A_KDDI_1.bit Scaling: SCALING_B_InterDigital_1.bit SCALING_A_InterDigital_1.bit --- libavcodec/cbs_h266_syntax_template.c |

Re: [FFmpeg-devel] [PATCH] lavu: add AVVideoHint API

2023-08-08 Thread Stefano Sabatini
On date Wednesday 2023-08-02 07:36:43 +0200, Stefano Sabatini wrote: > On date Friday 2023-07-28 09:44:37 +0200, Stefano Sabatini wrote: > > On date Wednesday 2023-07-26 10:52:57 +, Carotti, Elias wrote: [...] > > > Agreed. > > > For clarity I am attaching again the patch with Anton's changes

Re: [FFmpeg-devel] [PATCH 2/2] lavc/libx264: add mb_info option

2023-08-08 Thread Stefano Sabatini
On date Monday 2023-07-03 15:55:40 +, Carotti, Elias wrote: > On Wed, 2023-06-21 at 15:57 +, Carotti, Elias wrote: > > Hi all, > > please find the second part of the patch set. > > Best, > > Elias > > Hi all, > please find the second part of the patch, updating libavcodec/libx264.c > to

Re: [FFmpeg-devel] [PATCH 2/2] fate/audio: Add SBaGen/ffwavesynth test

2023-08-08 Thread Paul B Mahol
Why you adding test for target that breaks numerous rules and should be removed completely? ___ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org https://ffmpeg.org/mailman/listinfo/ffmpeg-devel To unsubscribe, visit link above, or email

Re: [FFmpeg-devel] [PATCH] fftools/ffprobe: Use proper enum type

2023-08-08 Thread Stefano Sabatini
On date Sunday 2023-08-06 15:28:00 +0200, Andreas Rheinhardt wrote: > This is a bit cleaner as int need not be the underlying type > of an enum if a smaller type can hold all its values. > Also declare the children_ids array as const as it never changes. > > Signed-off-by: Andreas Rheinhardt >

Re: [FFmpeg-devel] [PATCH 1/2] avformat/sbgdec: Use avio_read_to_bprint() where appropriate

2023-08-08 Thread Nicolas George
Andreas Rheinhardt (12023-08-08): > Note: There is a slight difference in the handling of > the max_file_size option: The earlier code used it to mean > to limit the size of the buffer to allocate; the new code > treats it more literally as maximum size to read from > the input. > >

Re: [FFmpeg-devel] [PATCH v3] vulkan_h264: fill correct ScalingList8x8 entries

2023-08-08 Thread Lynne
Aug 1, 2023, 16:21 by b...@bcheng.me: > The Vulkan spec wants ScalingList8x8 as defined by ITU spec, which is in > a different order from how ffmpeg parses it. > > v2: generalize for 444 case > v3: fix whitespace > --- > libavcodec/vulkan_h264.c | 6 -- > 1 file changed, 4 insertions(+), 2

Re: [FFmpeg-devel] [PATCH v5 1/9] libavutil: add hwcontext_d3d12va and AV_PIX_FMT_D3D12

2023-08-08 Thread Wu, Tong1
>Aug 4, 2023, 15:50 by tong1.wu-at-intel@ffmpeg.org: > >> From: Wu Jianhua >> >> Signed-off-by: Wu Jianhua >> Signed-off-by: Tong Wu >> --- >> configure | 5 + >> doc/APIchanges | 7 + >> libavutil/Makefile | 3