Re: [FFmpeg-devel] [RFC] [Vote] Drop Windows XP support

2017-12-14 Thread Reino Wijnsma
On 14-12-2017 20:51, Lou Logan wrote: > Also, I believe Zeranoe stopped providing XP builds in 2016 so it will > be no issue downstream. I still am . But hey, it's your call in the end. -- Reino

Re: [FFmpeg-devel] [RFC] [Vote] Drop Windows XP support

2017-12-14 Thread Lou Logan
On Thu, Dec 14, 2017, at 04:26 AM, wm4 wrote: > The subject of the vote is: > > Should we drop support for Windows XP starting in git master and the > next FFmpeg major release? I vote "yes". (But I can't remember if I'm on the vote list and I couldn't find it.) Also, I believe Zeranoe

Re: [FFmpeg-devel] [RFC] [Vote] Drop Windows XP support

2017-12-14 Thread James Almer
On 12/14/2017 10:26 AM, wm4 wrote: > I propose that FFmpeg sets the minimum supported Windows version to > Windows Vista (or maybe Windows 7). This would remove Windows XP > support. > > The reason is that Windows XP does not provide certain convenient APIs, > in particular locking primitives

Re: [FFmpeg-devel] [RFC] [Vote] Drop Windows XP support

2017-12-14 Thread wm4
On Thu, 14 Dec 2017 16:01:55 +0100 Michael Niedermayer wrote: > On Thu, Dec 14, 2017 at 02:26:31PM +0100, wm4 wrote: > > I propose that FFmpeg sets the minimum supported Windows version to > > Windows Vista (or maybe Windows 7). This would remove Windows XP > > support. >

Re: [FFmpeg-devel] [RFC] [Vote] Drop Windows XP support

2017-12-14 Thread Michael Niedermayer
On Thu, Dec 14, 2017 at 02:26:31PM +0100, wm4 wrote: > I propose that FFmpeg sets the minimum supported Windows version to > Windows Vista (or maybe Windows 7). This would remove Windows XP > support. > > The reason is that Windows XP does not provide certain convenient APIs, > in particular

Re: [FFmpeg-devel] [RFC] [Vote] Drop Windows XP support

2017-12-14 Thread Tomas Härdin
On 2017-12-14 14:26, wm4 wrote: I propose that FFmpeg sets the minimum supported Windows version to Windows Vista (or maybe Windows 7). This would remove Windows XP support. The reason is that Windows XP does not provide certain convenient APIs, in particular locking primitives that map well to

Re: [FFmpeg-devel] [RFC] [Vote] Drop Windows XP support

2017-12-14 Thread Rostislav Pehlivanov
On 14 December 2017 at 13:26, wm4 wrote: > I propose that FFmpeg sets the minimum supported Windows version to > Windows Vista (or maybe Windows 7). This would remove Windows XP > support. > > The reason is that Windows XP does not provide certain convenient APIs, > in

Re: [FFmpeg-devel] [RFC] [Vote] Drop Windows XP support

2017-12-14 Thread Steven Liu
> 在 2017年12月14日,下午10:12,Hendrik Leppkes 写道: > >> On Thu, Dec 14, 2017 at 2:26 PM, wm4 wrote: >> I propose that FFmpeg sets the minimum supported Windows version to >> Windows Vista (or maybe Windows 7). This would remove Windows XP >> support. >>

Re: [FFmpeg-devel] [RFC] [Vote] Drop Windows XP support

2017-12-14 Thread Hendrik Leppkes
On Thu, Dec 14, 2017 at 2:26 PM, wm4 wrote: > I propose that FFmpeg sets the minimum supported Windows version to > Windows Vista (or maybe Windows 7). This would remove Windows XP > support. > > The reason is that Windows XP does not provide certain convenient APIs, > in

Re: [FFmpeg-devel] [RFC] [Vote] Drop Windows XP support

2017-12-14 Thread Derek Buitenhuis
On 12/14/2017 1:26 PM, wm4 wrote: > The subject of the vote is: > > Should we drop support for Windows XP starting in git master and the > next FFmpeg major release? I am not on the voting list (which is form 2015 and contains people who have since vanished, as well), but I would like to put

Re: [FFmpeg-devel] [RFC] [Vote] Drop Windows XP support

2017-12-14 Thread Rodger Combs
> On Dec 14, 2017, at 07:26, wm4 wrote: > > I propose that FFmpeg sets the minimum supported Windows version to > Windows Vista (or maybe Windows 7). This would remove Windows XP > support. > > The reason is that Windows XP does not provide certain convenient APIs, > in

Re: [FFmpeg-devel] [RFC] [Vote] Drop Windows XP support

2017-12-14 Thread Ronald S. Bultje
Hi, On Thu, Dec 14, 2017 at 8:26 AM, wm4 wrote: > I propose that FFmpeg sets the minimum supported Windows version to > Windows Vista (or maybe Windows 7). This would remove Windows XP > support. > > The reason is that Windows XP does not provide certain convenient APIs,