Re: Question about device.hints man page

2002-08-26 Thread Craig Rodrigues

On Mon, Aug 26, 2002 at 11:18:36AM +1000, Bruce Evans wrote:
 
 It seems to be proper for disabling acpi itself (see dev/acpica/acpi.c)
 but not its loading.  So to fully disable acpica, you have to do something
 like:
 
 hint.acpi.0.disable=I prefer not to use code that (mis)uses !getenv()
 hint.acpi.0.disabled=1

I'm new to FreeBSD, so I don't know the naming conventions involved.  
Is the fact that acpi required two different hints to disable it the intended
behavior?  Or should this just be hint.acpi.0.disabled?
This seems to me like inconsistent usage.

-- 
Craig Rodrigues
http://www.gis.net/~craigr
[EMAIL PROTECTED]

To Unsubscribe: send mail to [EMAIL PROTECTED]
with unsubscribe freebsd-current in the body of the message



Question about device.hints man page

2002-08-25 Thread Craig Rodrigues

Hi,

Running: 5.0-CURRENT-20020818-JPSNAP

I am reading the man page for device.hints, and I think I see an
inconsistency:

=
A device hint line looks like:

   hint.driver.unit.keyword=value

 where driver is the name of a device driver, unit is the unit number,
 keyword is the keyword of the hint.  The keyword may be:

...
...
   disabled  is set to 1 to disable the device.


 The following example disables the ACPI driver

   hint.acpi.0.disable=1
=



The example does not match the previous description.  Should the
keyword be disabled or disable?

Thanks.
-- 
Craig Rodrigues
http://www.gis.net/~craigr
[EMAIL PROTECTED]

To Unsubscribe: send mail to [EMAIL PROTECTED]
with unsubscribe freebsd-current in the body of the message



Re: Question about device.hints man page

2002-08-25 Thread Craig Rodrigues

On Sun, Aug 25, 2002 at 05:49:38PM +0200, Jan Stocker wrote:
 
   The following example disables the ACPI driver
  
 hint.acpi.0.disable=1
 
 My man page doest have this example (but is is some days older), but a
 look to 
 
 Twoflower# grep disable /sys/i386/conf/GENERIC.hints 
 
 hint.apm.0.disabled=1
 hint.pcic.1.disabled=1
 hint.sio.2.disabled=1
 hint.sio.3.disabled=1
 
 shows that the description is right and the example wrong...

OK.  The ident for my device.hints.5 man page is:

device.hints.5:
 $FreeBSD: src/share/man/man5/device.hints.5,v 1.3 2002/08/09 06:07:33 obrien Exp $


I would like to submit the following trivial patch:


--- device.hints.5.orig Sun Aug 25 12:52:02 2002
+++ device.hints.5  Sun Aug 25 12:52:26 2002
@@ -145,7 +145,7 @@
 
 The following example disables the ACPI driver
 .Bd -literal -offset indent
-hint.acpi.0.disable=1
+hint.acpi.0.disabled=1
 .Ed
 .\ .Pp
 .\ A control variable may look like:


-- 
Craig Rodrigues
http://www.gis.net/~craigr
[EMAIL PROTECTED]

To Unsubscribe: send mail to [EMAIL PROTECTED]
with unsubscribe freebsd-current in the body of the message



Re: Question about device.hints man page

2002-08-25 Thread Mike Barcroft

Craig Rodrigues [EMAIL PROTECTED] writes:
 device.hints.5:
  $FreeBSD: src/share/man/man5/device.hints.5,v 1.3 2002/08/09 06:07:33 obrien 
Exp $
 
 
 I would like to submit the following trivial patch:
 
 
 --- device.hints.5.orig   Sun Aug 25 12:52:02 2002
 +++ device.hints.5Sun Aug 25 12:52:26 2002
 @@ -145,7 +145,7 @@
  
  The following example disables the ACPI driver
  .Bd -literal -offset indent
 -hint.acpi.0.disable=1
 +hint.acpi.0.disabled=1
  .Ed
  .\ .Pp
  .\ A control variable may look like:


Committed, thanks.

Best regards,
Mike Barcroft

To Unsubscribe: send mail to [EMAIL PROTECTED]
with unsubscribe freebsd-current in the body of the message



Re: Question about device.hints man page

2002-08-25 Thread Mike Barcroft

David O'Brien [EMAIL PROTECTED] writes:
 On Sun, Aug 25, 2002 at 12:43:44PM -0400, Mike Barcroft wrote:
  Craig Rodrigues [EMAIL PROTECTED] writes:
   device.hints.5:
$FreeBSD: src/share/man/man5/device.hints.5,v 1.3 2002/08/09 06:07:33 
obrien Exp $
   I would like to submit the following trivial patch:
   
   
   --- device.hints.5.orig   Sun Aug 25 12:52:02 2002
   +++ device.hints.5Sun Aug 25 12:52:26 2002
   @@ -145,7 +145,7 @@

The following example disables the ACPI driver
.Bd -literal -offset indent
   -hint.acpi.0.disable=1
   +hint.acpi.0.disabled=1
.Ed
.\ .Pp
.\ A control variable may look like:
  
  
  Committed, thanks.
 
 Uh WAIT!  Was this tested?!?
 $ grep disable /sys/boot/i386/libi386/i386_module.c 
 if ((getenv(acpi_load)  !getenv(hint.acpi.0.disable))) {
 
 hint.acpi.0.disable=1 certainly did not load the acpi.ko module for me
 (as expected by inspecting the code).  I'm backing this commit out
 someone can prove it is proper.

I checked with sys/dev/acpica/acpi.c:223 to confirm the hint name.  I
think one of these two places has it misspelled.  Would someone please
fix it or explain why we have differing hints for the seemingly the
same thing?

Best regards,
Mike Barcroft

To Unsubscribe: send mail to [EMAIL PROTECTED]
with unsubscribe freebsd-current in the body of the message



Re: Question about device.hints man page

2002-08-25 Thread Bruce Evans

On Sun, 25 Aug 2002, David O'Brien wrote:

 On Sun, Aug 25, 2002 at 12:43:44PM -0400, Mike Barcroft wrote:
  Craig Rodrigues [EMAIL PROTECTED] writes:
   device.hints.5:
$FreeBSD: src/share/man/man5/device.hints.5,v 1.3 2002/08/09 06:07:33 
obrien Exp $
   I would like to submit the following trivial patch:
  
  
   --- device.hints.5.orig   Sun Aug 25 12:52:02 2002
   +++ device.hints.5Sun Aug 25 12:52:26 2002
   @@ -145,7 +145,7 @@
  
The following example disables the ACPI driver
.Bd -literal -offset indent
   -hint.acpi.0.disable=1
   +hint.acpi.0.disabled=1
.Ed
.\ .Pp
.\ A control variable may look like:
 
 
  Committed, thanks.

 Uh WAIT!  Was this tested?!?
 $ grep disable /sys/boot/i386/libi386/i386_module.c
 if ((getenv(acpi_load)  !getenv(hint.acpi.0.disable))) {

 hint.acpi.0.disable=1 certainly did not load the acpi.ko module for me
 (as expected by inspecting the code).  I'm backing this commit out
 someone can prove it is proper.

It seems to be proper for disabling acpi itself (see dev/acpica/acpi.c)
but not its loading.  So to fully disable acpica, you have to do something
like:

hint.acpi.0.disable=I prefer not to use code that (mis)uses !getenv()
hint.acpi.0.disabled=1

Bruce


To Unsubscribe: send mail to [EMAIL PROTECTED]
with unsubscribe freebsd-current in the body of the message