Re: Failed to load module pcidata

2007-06-06 Thread Ozan Enginoglu
On Tue, 2007-06-05 at 20:41 -0700, Arthur Barlow wrote:

 Make sure that if you have an xorg.conf file the paths for fonts  
 and modules is updated.  The module path should be /usr/local/lib/ 
 xorg/modules and the fonts path should be /usr/local/lib/X11/fonts.


Arthur is absolutely right... I had the same error message and i fixed
it with changing my old module path.

Hier is my xorg section part:

Section Files
RgbPath  /usr/local/share/X11/rgb
ModulePath   /usr/local/lib/xorg/modules
FontPath /usr/local/lib/X11/fonts/artwiz-fonts
FontPath /usr/local/lib/X11/fonts/misc/
FontPath /usr/local/lib/X11/fonts/TTF/
FontPath /usr/local/lib/X11/fonts/Type1/
FontPath /usr/local/lib/X11/fonts/OTF/
FontPath /usr/local/lib/X11/fonts/local/
#   FontPath /usr/local/lib/X11/fonts/CID/
FontPath /usr/local/lib/X11/fonts/75dpi/
FontPath /usr/local/lib/X11/fonts/100dpi/
EndSection



-- 
Ozan Engino─člu
Mechanical Engineer

GPG / PGP Fingerprint:
247C EE12 7AF9 5181 B6E5  A70F 0D5C 77FB B350 D715


signature.asc
Description: This is a digitally signed message part


Re: Failed to load module pcidata

2007-06-06 Thread Karsten Rothemund
On Wed, Jun 06, 2007 at 10:38:10AM -0400, Gerard wrote:

 Actually, I went a different route. I moved /etc/X11/xorg.conf out of
 the way, and then ran: Xorg --configure to build a new file. The
 system did start up without any error messages or missing module
 problems.

Went the same way.

 Now, I am experiencing a new problem. I use 'xfce4' for the windows
 manager. It starts to load, then the system just crashes. I have the
 Xorg.0.log file, etc. I am attempting to rebuild the entire 'xfce4'
 meta port and retry starting the program. If it fails again, I will
 start a new thread regarding this problem.

Same here. And I ended by installing the whole xorg meta port. Some
important packages seemed to be missing after the portupgrade from
xorg 6.9. 

Now xfce4 starts again, but I have a lot of packages here :-/ (Maybe,
I try to deinstall some of them later)

Ciao,

Karsten

-- 

Karsten Rothemund [EMAIL PROTECTED] /\
PGP-Key: 0x7019CAA5   \ /
Fingerprint: E752 C759 B9B2 2057 E42F  \  ASCII Ribbon Campaign
 50EE 47AC A7CE 7019 CAA5 / \ Against HTML Mail and News
___
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to [EMAIL PROTECTED]


Re: Failed to load module pcidata

2007-06-05 Thread Paul Schmehl
--On Tuesday, June 05, 2007 18:25:42 -0400 Gerard [EMAIL PROTECTED] 
wrote:



I believe this problem has been reported recently; however, I am unable
to locate it.

I just finished updating to 'Xorg-7.2'. I followed the directions in the
UPDATING file to the letter (I think). Now when I attempt to run
'startx', this error message is displayed.

X Window System Version 7.2.0
Release Date: 22 January 2007
X Protocol Version 11, Revision 0, Release 7.2
Build Operating System: FreeBSD 6.2-RELEASE-p5 i386 Current Operating
System: FreeBSD scorpio.seibercom.net 6.2-RELEASE-p5 FreeBSD
6.2-RELEASE-p5 #0: Thu May 24 12:27:57 EDT 2007
[EMAIL PROTECTED]:/usr/obj/usr/src/sys/SCORPIO i386
Build Date: 01 June 2007
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: /var/log/Xorg.0.log, Time: Tue Jun  5 18:16:09 2007
(==) Using config file: /etc/X11/xorg.conf
(EE) Failed to load module pcidata (module does not exist, 0)

Fatal server error:
Unable to load required base modules, Exiting...

X connection to :0.0 broken (explicit kill or server shutdown).


* This is the contents of the /var/log/Xorg.0.log *

log start

X Window System Version 7.2.0
Release Date: 22 January 2007
X Protocol Version 11, Revision 0, Release 7.2
Build Operating System: FreeBSD 6.2-RELEASE-p5 i386 Current Operating
System: FreeBSD scorpio.seibercom.net 6.2-RELEASE-p5 FreeBSD
6.2-RELEASE-p5 #0: Thu May 24 12:27:57 EDT 2007
[EMAIL PROTECTED]:/usr/obj/usr/src/sys/SCORPIO i386
Build Date: 01 June 2007
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: /var/log/Xorg.0.log, Time: Tue Jun  5 18:16:09 2007
(==) Using config file: /etc/X11/xorg.conf
(==) ServerLayout X.org Configured
(**) |--Screen Screen0 (0)
(**) |   |--Monitor Monitor0
(**) |   |--Device Card0
(**) |--Input Device Mouse0
(**) |--Input Device Keyboard0
(WW) The directory /usr/X11R6/lib/X11/fonts/misc/ does not exist.
Entry deleted from font path.
(WW) The directory /usr/X11R6/lib/X11/fonts/TTF/ does not exist.
Entry deleted from font path.
(WW) The directory /usr/X11R6/lib/X11/fonts/Type1/ does not exist.
Entry deleted from font path.
(WW) The directory /usr/X11R6/lib/X11/fonts/CID/ does not exist.
Entry deleted from font path.
(WW) The directory /usr/X11R6/lib/X11/fonts/75dpi/ does not exist.
Entry deleted from font path.
(WW) The directory /usr/X11R6/lib/X11/fonts/100dpi/ does not exist.
Entry deleted from font path.
(WW) The directory /usr/X11R6/lib/X11/fonts/webfonts/ does not exist.
Entry deleted from font path.
(WW) The directory /usr/X11R6/lib/X11/fonts/TTF does not exist.
Entry deleted from font path.
(WW) The directory /usr/X11R6/lib/X11/fonts/URW does not exist.
Entry deleted from font path.
(WW) The directory /usr/X11R6/lib/X11/fonts/urwfonts-ttf does not exist.
Entry deleted from font path.
(**) FontPath set to:
/usr/local/share/ghostscript/fonts/
(**) RgbPath set to /usr/X11R6/lib/X11/rgb
(**) ModulePath set to /usr/X11R6/lib/modules
(II) Loader magic: 0x81c0280
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.3
X.Org Video Driver: 1.1
X.Org XInput driver : 0.7
X.Org Server Extension : 0.3
X.Org Font Renderer : 0.5
(II) Loader running on freebsd
(II) LoadModule: pcidata
(WW) Warning, couldn't open module pcidata
(II) UnloadModule: pcidata
(EE) Failed to load module pcidata (module does not exist, 0)

Fatal server error:
Unable to load required base modules, Exiting...

log end

What is the best way to remedy this problem?


Install the xorg metaport: /usr/ports/x11/xorg/

--
Paul Schmehl ([EMAIL PROTECTED])
Senior Information Security Analyst
The University of Texas at Dallas
http://www.utdallas.edu/ir/security/


Re: Failed to load module pcidata

2007-06-05 Thread youshi10

On Tue, 5 Jun 2007, Paul Schmehl wrote:


--On Tuesday, June 05, 2007 18:25:42 -0400 Gerard [EMAIL PROTECTED] wrote:


I believe this problem has been reported recently; however, I am unable
to locate it.

I just finished updating to 'Xorg-7.2'. I followed the directions in the
UPDATING file to the letter (I think). Now when I attempt to run
'startx', this error message is displayed.

X Window System Version 7.2.0
Release Date: 22 January 2007
X Protocol Version 11, Revision 0, Release 7.2
Build Operating System: FreeBSD 6.2-RELEASE-p5 i386 Current Operating
System: FreeBSD scorpio.seibercom.net 6.2-RELEASE-p5 FreeBSD
6.2-RELEASE-p5 #0: Thu May 24 12:27:57 EDT 2007
[EMAIL PROTECTED]:/usr/obj/usr/src/sys/SCORPIO i386
Build Date: 01 June 2007
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: /var/log/Xorg.0.log, Time: Tue Jun  5 18:16:09 2007
(==) Using config file: /etc/X11/xorg.conf
(EE) Failed to load module pcidata (module does not exist, 0)

Fatal server error:
Unable to load required base modules, Exiting...

X connection to :0.0 broken (explicit kill or server shutdown).


* This is the contents of the /var/log/Xorg.0.log *

log start

X Window System Version 7.2.0
Release Date: 22 January 2007
X Protocol Version 11, Revision 0, Release 7.2
Build Operating System: FreeBSD 6.2-RELEASE-p5 i386 Current Operating
System: FreeBSD scorpio.seibercom.net 6.2-RELEASE-p5 FreeBSD
6.2-RELEASE-p5 #0: Thu May 24 12:27:57 EDT 2007
[EMAIL PROTECTED]:/usr/obj/usr/src/sys/SCORPIO i386
Build Date: 01 June 2007
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: /var/log/Xorg.0.log, Time: Tue Jun  5 18:16:09 2007
(==) Using config file: /etc/X11/xorg.conf
(==) ServerLayout X.org Configured
(**) |--Screen Screen0 (0)
(**) |   |--Monitor Monitor0
(**) |   |--Device Card0
(**) |--Input Device Mouse0
(**) |--Input Device Keyboard0
(WW) The directory /usr/X11R6/lib/X11/fonts/misc/ does not exist.
Entry deleted from font path.
(WW) The directory /usr/X11R6/lib/X11/fonts/TTF/ does not exist.
Entry deleted from font path.
(WW) The directory /usr/X11R6/lib/X11/fonts/Type1/ does not exist.
Entry deleted from font path.
(WW) The directory /usr/X11R6/lib/X11/fonts/CID/ does not exist.
Entry deleted from font path.
(WW) The directory /usr/X11R6/lib/X11/fonts/75dpi/ does not exist.
Entry deleted from font path.
(WW) The directory /usr/X11R6/lib/X11/fonts/100dpi/ does not exist.
Entry deleted from font path.
(WW) The directory /usr/X11R6/lib/X11/fonts/webfonts/ does not exist.
Entry deleted from font path.
(WW) The directory /usr/X11R6/lib/X11/fonts/TTF does not exist.
Entry deleted from font path.
(WW) The directory /usr/X11R6/lib/X11/fonts/URW does not exist.
Entry deleted from font path.
(WW) The directory /usr/X11R6/lib/X11/fonts/urwfonts-ttf does not exist.
Entry deleted from font path.
(**) FontPath set to:
/usr/local/share/ghostscript/fonts/
(**) RgbPath set to /usr/X11R6/lib/X11/rgb
(**) ModulePath set to /usr/X11R6/lib/modules
(II) Loader magic: 0x81c0280
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.3
X.Org Video Driver: 1.1
X.Org XInput driver : 0.7
X.Org Server Extension : 0.3
X.Org Font Renderer : 0.5
(II) Loader running on freebsd
(II) LoadModule: pcidata
(WW) Warning, couldn't open module pcidata
(II) UnloadModule: pcidata
(EE) Failed to load module pcidata (module does not exist, 0)

Fatal server error:
Unable to load required base modules, Exiting...

log end

What is the best way to remedy this problem?


Install the xorg metaport: /usr/ports/x11/xorg/

--
Paul Schmehl ([EMAIL PROTECTED])
Senior Information Security Analyst
The University of Texas at Dallas
http://www.utdallas.edu/ir/security/



Just do some hunting around the ports tree and search for something like 
'pcidata' in the x11* folders.

Everything's modular now, so to avoid having a large X11 distro laying around, 
it's just better to build the necessary components. Besides, compiling x11/xorg 
will take more time and will be slower with 7.2 than with 6.8 (unless major 
performance enhancements were made between then and now), because of the shared 
lib loading and compiling / installing the components one by one..

The only catch is that it will take a little bit of time to find components if 
stuff is missing, but 

Re: Failed to load module pcidata

2007-06-05 Thread Gerard
On Tuesday June 05, 2007 at 06:46:27 (PM) Paul Schmehl wrote:

{snip}

 Install the xorg metaport: /usr/ports/x11/xorg/

Strange, I had the Xorg-6.9 meta port installed when I did the
original update. Oh well, I will try your suggest. Thanks!

-- 
Gerard


I choose to ignore, of course, the fact that self-Googling is perhaps
the most narcissistic thing a person can do that doesn't involve
actually humping a mirror.

Dan Kois
___
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to [EMAIL PROTECTED]


Re: Failed to load module pcidata

2007-06-05 Thread Gerard
On Tuesday June 05, 2007 at 07:22:15 (PM) Gerard wrote:


 On Tuesday June 05, 2007 at 06:46:27 (PM) Paul Schmehl wrote:
 
 {snip}
 
  Install the xorg metaport: /usr/ports/x11/xorg/
 
 Strange, I had the Xorg-6.9 meta port installed when I did the
 original update. Oh well, I will try your suggest. Thanks!

OK, I installed the /x11/xorg port. There were only 5 files that
needed updating, but nothing new installed. After installing the port,
I again tried running 'startx' and received the same error message I
was receiving before. I am unable to locate a 'pcidata' file on my
system, although there is a reference to something similar:

/usr/local/lib/xorg/modules/libpcidata.la
/usr/local/lib/xorg/modules/libpcidata.so

I am at a loose here. I have tried Googling; however, I have not come
up with a definitive answer.

-- 
Gerard
___
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to [EMAIL PROTECTED]


Re: Failed to load module pcidata

2007-06-05 Thread Arthur Barlow


On Jun 5, 2007, at 8:06 PM, Gerard wrote:


On Tuesday June 05, 2007 at 07:22:15 (PM) Gerard wrote:



On Tuesday June 05, 2007 at 06:46:27 (PM) Paul Schmehl wrote:

{snip}


Install the xorg metaport: /usr/ports/x11/xorg/


Strange, I had the Xorg-6.9 meta port installed when I did the
original update. Oh well, I will try your suggest. Thanks!


OK, I installed the /x11/xorg port. There were only 5 files that
needed updating, but nothing new installed. After installing the port,
I again tried running 'startx' and received the same error message I
was receiving before. I am unable to locate a 'pcidata' file on my
system, although there is a reference to something similar:

/usr/local/lib/xorg/modules/libpcidata.la
/usr/local/lib/xorg/modules/libpcidata.so

I am at a loose here. I have tried Googling; however, I have not come
up with a definitive answer.

--  
Gerard

___
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to freebsd-questions- 
[EMAIL PROTECTED]


Make sure that if you have an xorg.conf file the paths for fonts  
and modules is updated.  The module path should be /usr/local/lib/ 
xorg/modules and the fonts path should be /usr/local/lib/X11/fonts.


___
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to [EMAIL PROTECTED]