[Freedreno] [PATCH v4 4/7] drm/msm/dpu: Remove _dpu_crtc_power_enable

2018-09-26 Thread Bruce Wang
All checks for _dpu_crtc_power_enable are not true, so the function can never return an error code. This removes the need for the function as pm_runtime functions can be used instead. v3: Separated _dpu_crtc_power_enable into _dpu_crtc_power_enable and _dpu_crtc_power_disable for clarity. v4:

Re: [Freedreno] [PATCH 2/2] drm/msm: dpu: Make legacy cursor updates asynchronous

2018-09-26 Thread Jeykumar Sankaran
On 2018-09-19 11:56, Sean Paul wrote: From: Sean Paul This patch sprinkles a few async/legacy_cursor_update checks through commit to ensure that cursor updates aren't blocked on vsync. There are 2 main components to this, the first is that we don't want to wait_for_commit_done in msm_atomic

Re: [Freedreno] [PATCH v3 2/3] drm/msm: Replace drm_gem_object_{un/reference} with put, get functions

2018-09-26 Thread Jordan Crouse
On Wed, Sep 26, 2018 at 01:48:58PM +0200, Thomas Zimmermann wrote: > This patch unifies the naming of DRM functions for reference counting > of struct drm_gem_object. The resulting code is more aligned with the > rest of the Linux kernel interfaces. Reviewed-by: Jordan Crouse > Signed-off-by:

Re: [Freedreno] [PATCH v16 5/5] iommu/arm-smmu: Add support for qcom, smmu-v2 variant

2018-09-26 Thread Robin Murphy
On 30/08/18 15:45, Vivek Gautam wrote: qcom,smmu-v2 is an arm,smmu-v2 implementation with specific clock and power requirements. On msm8996, multiple cores, viz. mdss, video, etc. use this smmu. On sdm845, this smmu is used with gpu. Add bindings for the same. Signed-off-by: Vivek Gautam

Re: [Freedreno] [PATCH v16 4/5] dt-bindings: arm-smmu: Add bindings for qcom, smmu-v2

2018-09-26 Thread Robin Murphy
On 30/08/18 15:45, Vivek Gautam wrote: Add bindings doc for Qcom's smmu-v2 implementation. Reviewed-by: Robin Murphy Signed-off-by: Vivek Gautam Reviewed-by: Tomasz Figa Tested-by: Srinivas Kandagatla --- .../devicetree/bindings/iommu/arm,smmu.txt | 39 ++

Re: [Freedreno] [PATCH v16 3/5] iommu/arm-smmu: Add the device_link between masters and smmu

2018-09-26 Thread Robin Murphy
On 30/08/18 15:45, Vivek Gautam wrote: From: Sricharan R Finally add the device link between the master device and smmu, so that the smmu gets runtime enabled/disabled only when the master needs it. This is done from add_device callback which gets called once when the master is added to the

Re: [Freedreno] [PATCH v16 2/5] iommu/arm-smmu: Invoke pm_runtime during probe, add/remove device

2018-09-26 Thread Robin Murphy
On 30/08/18 15:45, Vivek Gautam wrote: From: Sricharan R The smmu device probe/remove and add/remove master device callbacks gets called when the smmu is not linked to its master, that is without the context of the master device. So calling runtime apis in those places separately. Global locks

Re: [Freedreno] [PATCH v16 1/5] iommu/arm-smmu: Add pm_runtime/sleep ops

2018-09-26 Thread Robin Murphy
On 30/08/18 15:45, Vivek Gautam wrote: From: Sricharan R The smmu needs to be functional only when the respective master's using it are active. The device_link feature helps to track such functional dependencies, so that the iommu gets powered when the master device enables itself using

[Freedreno] [PATCH v3 0/3] drm/msm: Replace {un/reference} with {put, get} functions

2018-09-26 Thread Thomas Zimmermann
This patch set replaces functions named {un,reference} by their {put,get} counterparts. Affected data types are struct struct drm_framebuffer, struct drm_gem_object, and struct drm_device. With the reference-counting functions being named {put,get}, the DRM interface is more aligned to Linux

[Freedreno] [PATCH v3 1/3] drm/msm: Replace drm_framebuffer_{un/reference} with put, get functions

2018-09-26 Thread Thomas Zimmermann
This patch unifies the naming of DRM functions for reference counting of struct drm_framebuffer. The resulting code is more aligned with the rest of the Linux kernel interfaces. Signed-off-by: Thomas Zimmermann --- drivers/gpu/drm/msm/disp/mdp5/mdp5_plane.c | 4 ++-- 1 file changed, 2

[Freedreno] [PATCH v3 2/3] drm/msm: Replace drm_gem_object_{un/reference} with put, get functions

2018-09-26 Thread Thomas Zimmermann
This patch unifies the naming of DRM functions for reference counting of struct drm_gem_object. The resulting code is more aligned with the rest of the Linux kernel interfaces. Signed-off-by: Thomas Zimmermann --- drivers/gpu/drm/msm/adreno/a5xx_debugfs.c | 4 ++--

Re: [Freedreno] [PATCH v3 4/7] drm/msm/dpu: Change _dpu_crtc_power_enable to void

2018-09-26 Thread Sean Paul
On Mon, Sep 24, 2018 at 12:22:25PM -0400, Bruce Wang wrote: > All checks for _dpu_crtc_power_enable are not true, so the function > can never return an error code. All calls of the function have also > been changed so that they don't expect a return value. > > v3: Separated _dpu_crtc_power_enable