Re: [Freedreno] [DPU PATCH 3/3] drm/msm/dp: add support for DP PLL driver

2018-11-06 Thread Stephen Boyd
This patch is too big. Please split it up more. I have far too many review comments on it so it will help if you keep splitting the patch up into smaller parts that can be more easily reviewed and fixed. Quoting Chandan Uddaraju (2018-10-10 10:15:59) > diff --git

Re: [Freedreno] [PATCH v4 2/3] arm64: dts: sdm845: Add dsi pinctrl nodes

2018-11-06 Thread Doug Anderson
Hi (sending again since I screwed up my previous reply), On Fri, Nov 2, 2018 at 3:26 PM Jeykumar Sankaran wrote: > > Add dsi active/suspend pinctrl nodes to sdm845 SoC dts. > > Changes in v4: > - patch introduced in the series > > Signed-off-by: Jeykumar Sankaran > --- >

Re: [Freedreno] [DPU PATCH 1/3] dt-bindings: msm/dp: add bindings of DP/DP-PLL driver for Snapdragon 845

2018-11-06 Thread Stephen Boyd
Quoting Chandan Uddaraju (2018-10-10 10:15:57) > diff --git a/Documentation/devicetree/bindings/display/msm/dp.txt > b/Documentation/devicetree/bindings/display/msm/dp.txt > new file mode 100644 > index 000..0155266 > --- /dev/null > +++ b/Documentation/devicetree/bindings/display/msm/dp.txt

Re: [Freedreno] [PATCH v2 5/5] drm/msm: subclass work object for vblank events

2018-11-06 Thread Jordan Crouse
On Tue, Nov 06, 2018 at 02:36:30PM -0800, Jeykumar Sankaran wrote: > msm maintains a separate structure to define vblank > work definitions and a list to track events submitted > to the workqueue. We can avoid this redundant list > and its protection mechanism, if we subclass the > work object to

Re: [Freedreno] [PATCH 2/2] drm/msm/dsi: Get PHY ref clock from the DT

2018-11-06 Thread Stephen Boyd
Quoting Matthias Kaehlcke (2018-11-02 14:45:34) > @@ -630,7 +632,8 @@ static int pll_10nm_register(struct dsi_pll_10nm > *pll_10nm) > char clk_name[32], parent[32], vco_name[32]; > char parent2[32], parent3[32], parent4[32]; > struct clk_init_data vco_init = { > -

Re: [Freedreno] [PATCH 1/2] dt-bindings: msm/dsi: Add ref clock for 10nm PHY

2018-11-06 Thread Stephen Boyd
Quoting Matthias Kaehlcke (2018-11-02 14:45:33) > Allow the 10nm PHY driver to get the ref clock from the DT. > > Signed-off-by: Matthias Kaehlcke > --- > Documentation/devicetree/bindings/display/msm/dsi.txt | 4 > 1 file changed, 4 insertions(+) > > diff --git

Re: [Freedreno] [PATCH] drm/msm: Set dma maximum segment size for mdss

2018-11-06 Thread Stephen Boyd
Quoting Sean Paul (2018-11-06 13:32:32) > From: Sean Paul > > Turning on CONFIG_DMA_API_DEBUG_SG results in the following error: > > [ 12.078665] msm ae0.mdss: DMA-API: mapping sg segment longer than > device claims to support [len=3526656] [max=65536] > [ 12.089870] WARNING: CPU: 6

[Freedreno] [PATCH v2 3/5] drm/msm/dpu: use system wq for idle power collapse

2018-11-06 Thread Jeykumar Sankaran
msm is using system wq for dispatching commit and vblank events. Switch idle power collapse feature also to use system wq to handle delayed work handlers so that msm can get rid of redundant display threads. changes in v2: - patch introduced in v2 Signed-off-by: Jeykumar Sankaran ---

[Freedreno] [PATCH v2 4/5] drm/msm: clean up display thread

2018-11-06 Thread Jeykumar Sankaran
Since there are no clients using these threads, cleaning it up. changes in v2: - switch all the dependent clients to use system wq before removing the disp_threads (Sean Paul) Signed-off-by: Jeykumar Sankaran --- drivers/gpu/drm/msm/msm_drv.c | 35

[Freedreno] [PATCH v2 1/5] drm/msm: destroy msm threads after config cleanup

2018-11-06 Thread Jeykumar Sankaran
To avoid any possible work queues to msm threads, clean up the threads after the CRTC objects are released in config cleanup. changes in v2: - fix race condition before kthread flush and stop (Sean Paul) - use kthread_destroy_worker for cleaning up kthread (Sean Paul)

[Freedreno] [PATCH v2 2/5] drm/msm/dpu: use system wq for vblank events

2018-11-06 Thread Jeykumar Sankaran
DPU was using one thread per display to dispatch async commits and vblank requests. Since clean up already happened in msm to use the common thread for all the display commits, display threads are only used to cater vblank requests. Since a single thread is sufficient to do the job without any

[Freedreno] [PATCH v2 5/5] drm/msm: subclass work object for vblank events

2018-11-06 Thread Jeykumar Sankaran
msm maintains a separate structure to define vblank work definitions and a list to track events submitted to the workqueue. We can avoid this redundant list and its protection mechanism, if we subclass the work object to encapsulate vblank event parameters. changes in v2: - subclass

Re: [Freedreno] [PATCH v2] drm: Convert to using %pOFn instead of device_node.name

2018-11-06 Thread Daniel Vetter
On Tue, Nov 06, 2018 at 03:57:16PM -0600, Rob Herring wrote: > On Mon, Oct 1, 2018 at 3:17 AM Daniel Vetter wrote: > > > > On Fri, Sep 28, 2018 at 05:50:44PM -0500, Rob Herring wrote: > > > In preparation to remove the node name pointer from struct device_node, > > > convert printf users to use

Re: [Freedreno] [PATCH v2] drm: Convert to using %pOFn instead of device_node.name

2018-11-06 Thread Rob Herring
On Mon, Oct 1, 2018 at 3:17 AM Daniel Vetter wrote: > > On Fri, Sep 28, 2018 at 05:50:44PM -0500, Rob Herring wrote: > > In preparation to remove the node name pointer from struct device_node, > > convert printf users to use the %pOFn format specifier. > > > > For drm_modes.c, the full node path

[Freedreno] [PATCH] drm/msm: Set dma maximum segment size for mdss

2018-11-06 Thread Sean Paul
From: Sean Paul Turning on CONFIG_DMA_API_DEBUG_SG results in the following error: [ 12.078665] msm ae0.mdss: DMA-API: mapping sg segment longer than device claims to support [len=3526656] [max=65536] [ 12.089870] WARNING: CPU: 6 PID: 334 at

Re: [Freedreno] [PATCH 2/2] drm/msm/a6xx: Fix a typo in a6xx gpu crash state

2018-11-06 Thread Jordan Crouse
On Tue, Nov 06, 2018 at 12:38:29PM +0530, Sharat Masetty wrote: > This patch simply fixes a typo for the name of an indexed register. > CP_MEMPOOOL -> CP_MEMPOOL. > > Signed-off-by: Sharat Masetty Reviewed by: Jordan Crouse > --- > drivers/gpu/drm/msm/adreno/a6xx_gpu_state.h | 2 +- > 1 file

Re: [Freedreno] [PATCH 1/2] drm/msm/a6xx: Build a6xx_gpu_state under the right conditionals

2018-11-06 Thread Jordan Crouse
On Tue, Nov 06, 2018 at 12:38:28PM +0530, Sharat Masetty wrote: > Build a6xx_gpu_state.c only if either of CONFIG_DEBUG_FS, CONFIG_DEV_COREDUMP > is defined. Can you do the same for the other targets too? With that, Reviewed-by: Jordan Crouse > Signed-off-by: Sharat Masetty > --- >

Re: [Freedreno] [PATCH 3/3] drm/msm: Optimize adreno_show_object()

2018-11-06 Thread Jordan Crouse
On Tue, Nov 06, 2018 at 11:40:06AM +0530, Sharat Masetty wrote: > When the userspace tries to read the crashstate dump, the read side > implementation in the driver currently ascii85 encodes all the binary > buffers and it does this each time the read system call is called. > A userspace tool like

Re: [Freedreno] [PATCH 1/3] drm/msm: use kvmalloc for ring data in gpu crashstate

2018-11-06 Thread Jordan Crouse
On Tue, Nov 06, 2018 at 11:40:04AM +0530, Sharat Masetty wrote: > The ringbuffer data to capture at crashtime can end up being large > sometimes, and the size can vary from being less than a page to the > full size of 32KB. So use the kvmalloc variant that perfectly fits the bill. > >

Re: [Freedreno] [PATCH 11/11] drm/msm/dpu: Clean up dpu_media_info.h static inline functions

2018-11-06 Thread Sam Ravnborg
Hi Jordan. > case COLOR_FMT_P010_UBWC: > - alignment = 256; > - stride = MSM_MEDIA_ALIGN(width * 2, alignment); > + stride = MSM_MEDIA_ALIGN(width * 2, 256); > break; > case COLOR_FMT_P010: > - alignment = 128; > -

Re: [Freedreno] [PATCH 11/11] drm/msm/dpu: Clean up dpu_media_info.h static inline functions

2018-11-06 Thread Sean Paul
On Mon, Nov 05, 2018 at 04:31:03PM -0700, Jordan Crouse wrote: > Do some cleanup in the static inline functions defined in > dpu_media_info.h by cleaning up gotos and unneeded local > variables. > > Signed-off-by: Jordan Crouse > --- > .../gpu/drm/msm/disp/dpu1/msm_media_info.h| 164

Re: [Freedreno] [PATCH 10/11] drm/msm/dpu: Further cleanups for static inline functions

2018-11-06 Thread Sean Paul
On Mon, Nov 05, 2018 at 04:31:02PM -0700, Jordan Crouse wrote: > Remove more static inline functions that are lightly used and/or > very simple and easy to build into the calling functions. > > v2: Removed another unused function from dpu_hw_lm.c and add back > dpu_crtc_get_client_type() since

Re: [Freedreno] [PATCH 09/11] drm/msm/dpu: Cleanup the debugfs functions

2018-11-06 Thread Sean Paul
On Mon, Nov 05, 2018 at 04:31:01PM -0700, Jordan Crouse wrote: > Do some debugfs cleanups from across the DPU driver. The DRM > destroy functions will do a recursive delete on the entire > debugfs node so there is no need to store dentry pointers for > the debugfs files that are persistent for the

Re: [Freedreno] [PATCH 07/11] drm/msm: Make irq_postinstall optional

2018-11-06 Thread Sean Paul
On Mon, Nov 05, 2018 at 04:30:59PM -0700, Jordan Crouse wrote: > Allow the KMS operation 'irq_postinstall' to be optional > so that the target display drivers don't need to define > a dummy function if they don't need one. > > Signed-off-by: Jordan Crouse Reviewed-by: Sean Paul > --- >

Re: [Freedreno] [PATCH 08/11] drm/msm/dpu: Remove dpu_irq and unused functions

2018-11-06 Thread Sean Paul
On Mon, Nov 05, 2018 at 04:31:00PM -0700, Jordan Crouse wrote: > dpu_irq.c does some unneeded checks and passes control > to dpu_core_irq.c The simple functions can be defined > in the same file where we use them and the files and > their associated hangers on can be deleted. > > Additionally

Re: [Freedreno] [PATCH 06/11] drm/msm/dpu: Cleanup callers of dpu_hw_blk_init

2018-11-06 Thread Sean Paul
On Mon, Nov 05, 2018 at 04:30:58PM -0700, Jordan Crouse wrote: > Outside of superfluous parameter checks the dpu_hw_blk_init() > doesn't have any failure paths. Switch it over to be a void > function and we can remove error handling paths in all the functions > that call it. While we're in those

Re: [Freedreno] [PATCH 05/11] drm/msm/dpu: Remove unused functions

2018-11-06 Thread Sean Paul
On Mon, Nov 05, 2018 at 04:30:57PM -0700, Jordan Crouse wrote: > Remove some unused container_of() helper functions. > > v2: Retained still used helper functions in the name of readability > > Signed-off-by: Jordan Crouse Reviewed-by: Sean Paul > --- >

Re: [Freedreno] [PATCH 04/11] drm/msm/dpu: Remove dpu_crtc_is_enabled()

2018-11-06 Thread Sean Paul
On Mon, Nov 05, 2018 at 04:30:56PM -0700, Jordan Crouse wrote: > The static inline function dpu_crtc_enabled() is only called once > and the function that calls it in turn is only called once and > the return value can be easily checked in the calling functions > so collapse everything down. > >

Re: [Freedreno] [PATCH 03/11] drm/msm/dpu: Remove dpu_crtc_get_mixer_height

2018-11-06 Thread Sean Paul
On Mon, Nov 05, 2018 at 04:30:55PM -0700, Jordan Crouse wrote: > dpu_crtc_get_mixer_height() is only used once and the value it > returns can be easily derived from the calling function. > > Signed-off-by: Jordan Crouse Reviewed-by: Sean Paul > --- > drivers/gpu/drm/msm/disp/dpu1/dpu_crtc.c

Re: [Freedreno] [PATCH 02/11] drm/msm/dpu: Use DEFINE_SHOW_ATTRIBUTE

2018-11-06 Thread Sean Paul
On Mon, Nov 05, 2018 at 04:30:54PM -0700, Jordan Crouse wrote: > Use the standard DEFINE_SHOW_ATTRIBUTE macro for seq_file based > debugfs files instead of custom macros and hand-coded functions. > > v2: Added a cleanup for dpu_encoder.c too > > Signed-off-by: Jordan Crouse Reviewed-by: Sean

Re: [Freedreno] [PATCH 01/11] drm/msm/dpu: Remove dpu_dbg

2018-11-06 Thread Sean Paul
On Mon, Nov 05, 2018 at 04:30:53PM -0700, Jordan Crouse wrote: > The functions in dpu_dbg.c aren't used. The two main dump functions > fail after a lookup from dpu_dbg_base.reg_base_list which turns out > to never be populated and once those are removed the rest of the > file doesn't make any