Re: [Freedreno] [PATCH v1 5/5] drm/msm/dpu: make dpu hardware catalog static const

2022-06-01 Thread kernel test robot
Hi Dmitry, I love your patch! Yet something to improve: [auto build test ERROR on drm/drm-next] [also build test ERROR on next-20220601] [cannot apply to v5.18] [If your patch is applied to the wrong git tree, kindly drop us a note. And when submitting patch, we suggest to use '--base

Re: [Freedreno] [PATCH v2] drm/msm/dpu: Move min BW request and full BW disable back to mdss

2022-06-01 Thread Dmitry Baryshkov
On 01/06/2022 02:01, Douglas Anderson wrote: In commit a670ff578f1f ("drm/msm/dpu: always use mdp device to scale bandwidth") we fully moved interconnect stuff to the DPU driver. This had no change for sc7180 but _did_ have an impact for other SoCs. It made them match the sc7180 scheme.

Re: [Freedreno] [PATCH v2] drm/msm/dpu: Move min BW request and full BW disable back to mdss

2022-06-01 Thread Abhinav Kumar
On 6/1/2022 12:58 PM, Dmitry Baryshkov wrote: On Wed, 1 Jun 2022 at 20:18, Abhinav Kumar wrote: On 6/1/2022 3:04 AM, Dmitry Baryshkov wrote: On Wed, 1 Jun 2022 at 02:01, Douglas Anderson wrote: In commit a670ff578f1f ("drm/msm/dpu: always use mdp device to scale bandwidth") we fully

[Freedreno] [PATCH v2 11/11] drm/msm/dsi_phy_7nm: Replace parent names with clk_hw pointers

2022-06-01 Thread Marijn Suijten
parent_hw pointers are easier to manage and cheaper to use than repeatedly formatting the parent name and subsequently leaving the clk framework to perform lookups based on that name. Signed-off-by: Marijn Suijten Reviewed-by: Dmitry Baryshkov --- drivers/gpu/drm/msm/dsi/phy/dsi_phy_7nm.c | 70

[Freedreno] [PATCH v2 10/11] drm/msm/dsi_phy_10nm: Replace parent names with clk_hw pointers

2022-06-01 Thread Marijn Suijten
parent_hw pointers are easier to manage and cheaper to use than repeatedly formatting the parent name and subsequently leaving the clk framework to perform lookups based on that name. Signed-off-by: Marijn Suijten Reviewed-by: Dmitry Baryshkov --- drivers/gpu/drm/msm/dsi/phy/dsi_phy_10nm.c |

[Freedreno] [PATCH v2 09/11] drm/msm/dsi_phy_14nm: Replace parent names with clk_hw pointers

2022-06-01 Thread Marijn Suijten
parent_hw pointers are easier to manage and cheaper to use than repeatedly formatting the parent name and subsequently leaving the clk framework to perform lookups based on that name. Signed-off-by: Marijn Suijten Reviewed-by: Dmitry Baryshkov --- drivers/gpu/drm/msm/dsi/phy/dsi_phy_14nm.c |

[Freedreno] [PATCH v2 08/11] drm/msm/dsi_phy_28nm: Replace parent names with clk_hw pointers

2022-06-01 Thread Marijn Suijten
parent_hw pointers are easier to manage and cheaper to use than repeatedly formatting the parent name and subsequently leaving the clk framework to perform lookups based on that name. Signed-off-by: Marijn Suijten --- drivers/gpu/drm/msm/dsi/phy/dsi_phy_28nm.c | 50 ++ 1

[Freedreno] [PATCH v2 07/11] drm/msm/dsi_phy_28nm_8960: Replace parent names with clk_hw pointers

2022-06-01 Thread Marijn Suijten
parent_hw pointers are easier to manage and cheaper to use than repeatedly formatting the parent name and subsequently leaving the clk framework to perform lookups based on that name. Signed-off-by: Marijn Suijten Reviewed-by: Dmitry Baryshkov ---

[Freedreno] [PATCH v2 06/11] drm/msm/dsi/phy: Replace hardcoded char-array length with sizeof()

2022-06-01 Thread Marijn Suijten
Now that the last DSI PHY PLL driver (dsi_phy_28nm_8960) has been converted to use a simple stack-local char-array instead of a devm_kzalloc heap allocation we can safely call sizeof() on every string variable (that's now a sized array instead of a pointer) passed into snprintf instead of

[Freedreno] [PATCH v2 04/11] drm/msm/dsi/phy: Reindent and reflow multiline function calls

2022-06-01 Thread Marijn Suijten
Patch 613cbd1da3c9 ("drm/msm/dsi: use devm_clk_*register to registe DSI PHY clocks") introduced the devm_ prefix to clk_hw registration calls, without updating the indentation of the arguments on the following lines. Similarly e55b3fc8 ("drm/msm/dsi: drop PLL accessor functions") moved from

[Freedreno] [PATCH v2 03/11] clk: fixed-factor: Introduce *clk_hw_register_fixed_factor_parent_hw()

2022-06-01 Thread Marijn Suijten
Add the devres and non-devres variant of clk_hw_register_fixed_factor_parent_hw() for registering a fixed factor clock with clk_hw parent pointer instead of parent name. Signed-off-by: Marijn Suijten --- drivers/clk/clk-fixed-factor.c | 57 --

[Freedreno] [PATCH v2 00/11] drm/msm/dsi_phy: Replace parent names with clk_hw pointers

2022-06-01 Thread Marijn Suijten
As stated in [1] I promised to tackle and send this series. parent_hw pointers are easier to manage and cheaper to use than repeatedly formatting the parent name and subsequently leaving the clk framework to perform lookups based on that name. This series starts out by adding extra constructors

[Freedreno] [PATCH v2 02/11] clk: mux: Introduce devm_clk_hw_register_mux_parent_hws()

2022-06-01 Thread Marijn Suijten
Add the devres variant of clk_hw_register_mux_hws() for registering a mux clock with clk_hw parent pointers instead of parent names. Signed-off-by: Marijn Suijten --- include/linux/clk-provider.h | 7 +++ 1 file changed, 7 insertions(+) diff --git a/include/linux/clk-provider.h

[Freedreno] [PATCH v2 01/11] clk: divider: Introduce devm_clk_hw_register_divider_parent_hw()

2022-06-01 Thread Marijn Suijten
Add the devres variant of clk_hw_register_divider_parent_hw() for registering a divider clock with clk_hw parent pointer instead of parent name. Signed-off-by: Marijn Suijten --- include/linux/clk-provider.h | 19 +++ 1 file changed, 19 insertions(+) diff --git

Re: [Freedreno] [PATCH v3 4/4] drm/bridge: parade-ps8640: Handle DP AUX more properly

2022-06-01 Thread Dmitry Baryshkov
On 10/05/2022 22:29, Douglas Anderson wrote: While it works, for the most part, to assume that the panel has finished probing when devm_of_dp_aux_populate_ep_devices() returns, it's a bit fragile. This is talked about at length in commit a1e3667a9835 ("drm/bridge: ti-sn65dsi86: Promote the AUX

Re: [Freedreno] [PATCH v4] drm/probe-helper: Default to 640x480 if no EDID on DP

2022-06-01 Thread Dmitry Baryshkov
On 01/06/2022 21:23, Douglas Anderson wrote: If we're unable to read the EDID for a display because it's corrupt / bogus / invalid then we'll add a set of standard modes for the display. Since we have no true information about the connected display, these modes are essentially guesses but better

Re: [Freedreno] [PATCH v3 1/2] drm/probe-helper: Add helper for drm_helper_probe_single_connector_modes()

2022-06-01 Thread Dmitry Baryshkov
On 12/05/2022 01:58, Douglas Anderson wrote: The drm_helper_probe_single_connector_modes() is a bit long. Let's break a chunk off to update and validate modes. This helps avoid one goto and also will allow us to more easily call the helper a second time in a future patch without adding looping

Re: [Freedreno] [PATCH v3 1/4] drm/dp: Export symbol / kerneldoc fixes for DP AUX bus

2022-06-01 Thread Dmitry Baryshkov
On 10/05/2022 22:29, Douglas Anderson wrote: While working on the DP AUX bus code I found a few small things that should be fixed. Namely the non-devm version of of_dp_aux_populate_ep_devices() was missing an export. There was also an extra blank line in a kerneldoc and a kerneldoc that

Re: [Freedreno] [PATCH] drm/msm: less magic numbers in msm_mdss_enable

2022-06-01 Thread Dmitry Baryshkov
On Wed, 1 Jun 2022 at 20:38, Abhinav Kumar wrote: > > > > On 6/1/2022 2:46 AM, Dmitry Baryshkov wrote: > > On Wed, 1 Jun 2022 at 01:01, Abhinav Kumar > > wrote: > >> On 5/31/2022 5:18 AM, Dmitry Baryshkov wrote: > >>> Replace magic register writes in msm_mdss_enable() with version that > >>>

Re: [Freedreno] [PATCH v2] drm/msm/dpu: Move min BW request and full BW disable back to mdss

2022-06-01 Thread Dmitry Baryshkov
On Wed, 1 Jun 2022 at 20:18, Abhinav Kumar wrote: > On 6/1/2022 3:04 AM, Dmitry Baryshkov wrote: > > On Wed, 1 Jun 2022 at 02:01, Douglas Anderson wrote: > >> > >> In commit a670ff578f1f ("drm/msm/dpu: always use mdp device to scale > >> bandwidth") we fully moved interconnect stuff to the DPU

Re: [Freedreno] [PATCH v4] drm/probe-helper: Default to 640x480 if no EDID on DP

2022-06-01 Thread Sean Paul
On Wed, Jun 1, 2022 at 2:23 PM Douglas Anderson wrote: > > If we're unable to read the EDID for a display because it's corrupt / > bogus / invalid then we'll add a set of standard modes for the > display. Since we have no true information about the connected > display, these modes are essentially

[Freedreno] [PATCH v4] drm/probe-helper: Default to 640x480 if no EDID on DP

2022-06-01 Thread Douglas Anderson
If we're unable to read the EDID for a display because it's corrupt / bogus / invalid then we'll add a set of standard modes for the display. Since we have no true information about the connected display, these modes are essentially guesses but better than nothing. At the moment, none of the modes

Re: [Freedreno] [PATCH] drm/msm: less magic numbers in msm_mdss_enable

2022-06-01 Thread Abhinav Kumar
On 6/1/2022 2:46 AM, Dmitry Baryshkov wrote: On Wed, 1 Jun 2022 at 01:01, Abhinav Kumar wrote: On 5/31/2022 5:18 AM, Dmitry Baryshkov wrote: Replace magic register writes in msm_mdss_enable() with version that contains less magic and more variable names that can be traced back to the

Re: [Freedreno] [PATCH v2] drm/msm/dpu: Move min BW request and full BW disable back to mdss

2022-06-01 Thread Abhinav Kumar
On 6/1/2022 3:04 AM, Dmitry Baryshkov wrote: On Wed, 1 Jun 2022 at 02:01, Douglas Anderson wrote: In commit a670ff578f1f ("drm/msm/dpu: always use mdp device to scale bandwidth") we fully moved interconnect stuff to the DPU driver. This had no change for sc7180 but _did_ have an impact for

[Freedreno] [PATCH v1 3/4] drm/msm/dpu: merge base_off with blk_off in struct dpu_hw_blk_reg_map

2022-06-01 Thread Dmitry Baryshkov
There is little point in keeping a separate MDP address and block offset in this struct. Merge them to form a new blk_addr field used for all register access. Signed-off-by: Dmitry Baryshkov --- drivers/gpu/drm/msm/disp/dpu1/dpu_hw_ctl.c| 3 +--

[Freedreno] [PATCH v1 4/4] drm/msm/dpu: move struct dpu_hw_blk definition to dpu_hw_utils.h

2022-06-01 Thread Dmitry Baryshkov
There is little point in having a separate header just for a single opaque struct definition. Drop it now and move the struct to the dpu_hw_util.h header. Signed-off-by: Dmitry Baryshkov --- drivers/gpu/drm/msm/disp/dpu1/dpu_crtc.h | 1 - .../drm/msm/disp/dpu1/dpu_encoder_phys_wb.c | 1

[Freedreno] [PATCH v1 2/4] drm/msm/dpu: drop length from struct dpu_hw_blk_reg_map

2022-06-01 Thread Dmitry Baryshkov
We (nearly) do not use the length field from struct dpu_hw_blk_reg_map, so we can drop it safely. Signed-off-by: Dmitry Baryshkov --- drivers/gpu/drm/msm/disp/dpu1/dpu_hw_ctl.c | 1 - drivers/gpu/drm/msm/disp/dpu1/dpu_hw_dsc.c | 1 - drivers/gpu/drm/msm/disp/dpu1/dpu_hw_dspp.c | 1

[Freedreno] [PATCH v1 0/4] drm/msm/dpu: cleanup struct dpu_hw_blk_reg_map

2022-06-01 Thread Dmitry Baryshkov
Cleanup the fields of struct dpu_hw_blk_reg_map, remove unused fields, merge base_off with blk_off into blk_addr. This patch series depends on the patch [1]. [1] https://patchwork.freedesktop.org/patch/488001/?series=104613=1 Dmitry Baryshkov (4): drm/msm/dpu: drop xin_id from struct

[Freedreno] [PATCH v1 1/4] drm/msm/dpu: drop xin_id from struct dpu_hw_blk_reg_map

2022-06-01 Thread Dmitry Baryshkov
Drop the unused field xin_id. Signed-off-by: Dmitry Baryshkov --- drivers/gpu/drm/msm/disp/dpu1/dpu_hw_util.h | 2 -- 1 file changed, 2 deletions(-) diff --git a/drivers/gpu/drm/msm/disp/dpu1/dpu_hw_util.h b/drivers/gpu/drm/msm/disp/dpu1/dpu_hw_util.h index 550b2e2b3e34..e8adb118fa85 100644

[Freedreno] [PATCH v1 5/5] drm/msm/dpu: make dpu hardware catalog static const

2022-06-01 Thread Dmitry Baryshkov
Replace superfluous cfg_init functions, which just assign a static config to the struct dpu_mdss_cfg, with static instances of struct dpu_mdss_cfg. Signed-off-by: Dmitry Baryshkov --- .../gpu/drm/msm/disp/dpu1/dpu_hw_catalog.c| 475 --

[Freedreno] [PATCH v1 3/5] drm/msm/dpu: remove hwversion field from data structures

2022-06-01 Thread Dmitry Baryshkov
The driver should not depend on hw revision for detecting features. Instead it should use features from the hw catalog. Drop the hwversion field from struct dpu_mdss_cfg and struct dpu_hw_blk_reg_map. Signed-off-by: Dmitry Baryshkov --- drivers/gpu/drm/msm/disp/dpu1/dpu_hw_catalog.c| 1 -

[Freedreno] [PATCH v1 4/5] drm/msm/dpu: constify struct dpu_mdss_cfg

2022-06-01 Thread Dmitry Baryshkov
Mark struct dpu_mdss_cfg instance as a const pointer. This is mostly a preparation for the next patch. Signed-off-by: Dmitry Baryshkov --- drivers/gpu/drm/msm/disp/dpu1/dpu_core_perf.c | 6 +++--- drivers/gpu/drm/msm/disp/dpu1/dpu_core_perf.h | 4 ++--

[Freedreno] [PATCH v1 2/5] drm/msm/dpu: move VBIF_XINL_QOS_LVL_REMAP size to hw_catalog

2022-06-01 Thread Dmitry Baryshkov
Rather than detecting VBIF_XINL_QOS_LVL_REMAP_000 based on the hwversion, push the offset to the hw_catalog. Signed-off-by: Dmitry Baryshkov --- drivers/gpu/drm/msm/disp/dpu1/dpu_hw_catalog.c | 2 ++ drivers/gpu/drm/msm/disp/dpu1/dpu_hw_catalog.h | 2 ++

[Freedreno] [PATCH v1 1/5] drm/msm/dpu: use feature bit for LM combined alpha check

2022-06-01 Thread Dmitry Baryshkov
Rather than checking hwversion, follow the usual patter and add special bit to the lm->features to check whether the LM has combined or separate alpha registers. While we are at it, rename dpu_hw_lm_setup_blend_config_sdm845() to dpu_hw_lm_setup_blend_config_combined_alpha(). Signed-off-by:

[Freedreno] [PATCH v1 0/5] drm/msm: clean up the hw catalog init

2022-06-01 Thread Dmitry Baryshkov
Replace superfluous cfg_init functions, which just assign a static config to the struct dpu_mdss_cfg, with static instances of struct dpu_mdss_cfg. Dmitry Baryshkov (5): drm/msm/dpu: use feature bit for LM combined alpha check drm/msm/dpu: move VBIF_XINL_QOS_LVL_REMAP size to hw_catalog

Re: [Freedreno] [PATCH v3] drm/probe-helper: Make 640x480 first if no EDID

2022-06-01 Thread Daniel Vetter
On Thu, May 26, 2022 at 09:01:03AM -0700, Doug Anderson wrote: > Hi, > > On Thu, May 26, 2022 at 8:42 AM Daniel Vetter wrote: > > > > On Thu, 26 May 2022 at 03:28, Sean Paul wrote: > > > > > > On Wed, May 25, 2022 at 9:26 AM Daniel Vetter wrote: > > > > > > > > On Mon, May 23, 2022 at

Re: [Freedreno] [PATCH v2] drm/msm/dpu: Move min BW request and full BW disable back to mdss

2022-06-01 Thread Dmitry Baryshkov
On Wed, 1 Jun 2022 at 02:01, Douglas Anderson wrote: > > In commit a670ff578f1f ("drm/msm/dpu: always use mdp device to scale > bandwidth") we fully moved interconnect stuff to the DPU driver. This > had no change for sc7180 but _did_ have an impact for other SoCs. It > made them match the sc7180