Re: [Freeipa-devel] [PATCH 0149] Clean up PTR record synchronization code and make it more robust

2013-05-14 Thread Tomas Babej
On 05/13/2013 05:22 PM, Petr Spacek wrote: On 13.5.2013 16:49, Simo Sorce wrote: On Mon, 2013-05-13 at 16:32 +0200, Petr Spacek wrote: + if ((ip = inet_addr(ip_str)) == INADDR_NONE) { This kind of construct is hard to read and debug in gdb I would suggest you do: ip =

Re: [Freeipa-devel] [PATCH 0149] Clean up PTR record synchronization code and make it more robust

2013-05-14 Thread Petr Spacek
On 14.5.2013 16:41, Tomas Babej wrote: On 05/13/2013 05:22 PM, Petr Spacek wrote: On 13.5.2013 16:49, Simo Sorce wrote: On Mon, 2013-05-13 at 16:32 +0200, Petr Spacek wrote: + if ((ip = inet_addr(ip_str)) == INADDR_NONE) { This kind of construct is hard to read and debug in gdb I

Re: [Freeipa-devel] [PATCH 0149] Clean up PTR record synchronization code and make it more robust

2013-05-13 Thread Lukas Slebodnik
On (06/05/13 14:03), Petr Spacek wrote: On 18.4.2013 11:04, Petr Spacek wrote: Hello, Clean up PTR record synchronization code and make it more robust. PTR record synchronization was split to smaller functions. Input validation, error handling and logging was improved significantly. Tbabej's

Re: [Freeipa-devel] [PATCH 0149] Clean up PTR record synchronization code and make it more robust

2013-05-13 Thread Petr Spacek
On 13.5.2013 15:23, Lukas Slebodnik wrote: On (06/05/13 14:03), Petr Spacek wrote: On 18.4.2013 11:04, Petr Spacek wrote: Hello, Clean up PTR record synchronization code and make it more robust. PTR record synchronization was split to smaller functions. Input validation, error handling and

Re: [Freeipa-devel] [PATCH 0149] Clean up PTR record synchronization code and make it more robust

2013-05-13 Thread Petr Spacek
On 13.5.2013 16:49, Simo Sorce wrote: On Mon, 2013-05-13 at 16:32 +0200, Petr Spacek wrote: + if ((ip = inet_addr(ip_str)) == INADDR_NONE) { This kind of construct is hard to read and debug in gdb I would suggest you do: ip = inet_addr(ip_str); if (ip == INADDER_NONE) { I agree,

Re: [Freeipa-devel] [PATCH 0149] Clean up PTR record synchronization code and make it more robust

2013-05-09 Thread Tomas Hozza
On 04/18/2013 11:04 AM, Petr Spacek wrote: Hello, Clean up PTR record synchronization code and make it more robust. PTR record synchronization was split to smaller functions. Input validation, error handling and logging was improved significantly. ACK. The patch looks OK! Regards,

Re: [Freeipa-devel] [PATCH 0149] Clean up PTR record synchronization code and make it more robust

2013-05-06 Thread Petr Spacek
On 18.4.2013 11:04, Petr Spacek wrote: Hello, Clean up PTR record synchronization code and make it more robust. PTR record synchronization was split to smaller functions. Input validation, error handling and logging was improved significantly. Tbabej's GCC cries about uninitialized variable

Re: [Freeipa-devel] [PATCH 0149] Clean up PTR record synchronization code and make it more robust

2013-05-06 Thread Tomas Babej
On 05/06/2013 02:03 PM, Petr Spacek wrote: On 18.4.2013 11:04, Petr Spacek wrote: Hello, Clean up PTR record synchronization code and make it more robust. PTR record synchronization was split to smaller functions. Input validation, error handling and logging was improved significantly.