[PATCH v3] Add --ld-path= to specify an arbitrary executable as the linker

2020-07-25 Thread Fangrui Song via Gcc-patches
Attached v3 to address nits. On 2020-07-23, Martin Liška wrote: On 7/21/20 6:07 AM, Fangrui Song wrote: If the value does not contain any path component separator (e.g. a slash), the linker will be searched for using COMPILER_PATH followed by PATH. Otherwise, it is either an absolute path or a

Re: [PATCH v3] Add --ld-path= to specify an arbitrary executable as the linker

2020-07-25 Thread Andreas Schwab
On Jul 24 2020, Fangrui Song via Gcc-patches wrote: > This is to mimick nearly lines. collect2 should filter out options like > -fno-lto, -flto, -fuse-ld= before passing to ld. -f* are handled by case 'f'. > --ld-path needs its own `else if`. If you handle --ld-path as -fld-path then you don't

[PATCH] libgomp: Add helper functions for memory handling.

2020-07-25 Thread y2s1982 via Gcc-patches
This patch adds few helper functions aims to improve readability of fetching addresses, sizes, and values. It also proposes a syntax for querying these information through the callback functions, similar to that of LLVM implementation. The syntax format is _, or __. '_' is the delimiter between

Re: [Patch, fortran] PR 93592 - Invalid UP/DOWN rounding with EN descriptor

2020-07-25 Thread dhumieres . dominique
Le 2020-07-25 13:54, Thomas Koenig a écrit : Am 24.07.20 um 23:19 schrieb dhumieres.domini...@free.fr: Le 2020-07-24 20:50, Thomas Koenig a écrit : Hi Dominique, I have committed the patch after regression-testing. Thanks. Dou you want to backport this, as well? IMO it is worth the

[committed] amdgcn: Enable TImode

2020-07-25 Thread Andrew Stubbs
This enables types __int128 et al for move, add, subtract, and logical operations. At least shift, rotate, multiple, divide, and modulus are broken so we can expect some test failures. This is required now because libgomp no longer builds without __int128. An additional patch will be

Re: [PATCH] config/debuginfod.m4: Use PKG_CHECK_MODULES

2020-07-25 Thread H.J. Lu via Gcc-patches
On Fri, Jul 24, 2020 at 1:04 PM Aaron Merey via Gcc-patches wrote: > > On Tue, Jul 21, 2020 at 2:11 PM Aaron Merey wrote: > > > > On Tue, Jul 21, 2020 at 11:20 AM Tom Tromey wrote: > > > > > > Simon> Since it's debuginfo.m4 that is using PKG_CHECK_MODULES, can you > > > put the include > > >

Re: [Patch, fortran] PR 93592 - Invalid UP/DOWN rounding with EN descriptor

2020-07-25 Thread Thomas Koenig via Gcc-patches
Am 24.07.20 um 23:19 schrieb dhumieres.domini...@free.fr: Le 2020-07-24 20:50, Thomas Koenig a écrit : Hi Dominique, I have committed the patch after regression-testing. Thanks. Dou you want to backport this, as well? IMO it is worth the work. OK. The patch for PR 93592 is now

[PATCH] Use vec::reserve before vec_safe_grow_cleared is called

2020-07-25 Thread Martin Liška
Hello. When inserting into fast_call_summary (or fast_function_summary), we grow a vector to a _exact_ size based on cgraph_max_summary_id or edges_max_summary_id. Problem is that it causes very many reallocation and we should rather use ::reserve function that selects a reasonable size of a

[PATCH] ipa/96291: don't crash on unoptimized lto functions

2020-07-25 Thread Sergei Trofimovich via Gcc-patches
From: Sergei Trofimovich In PR ipa/96291 the test contained an SCC with one unoptimized function. This tricked ipa-cp into NULL dereference. has_undead_caller_from_outside_scc_p() did not take into account that unoptimized funtions don't have IPA summary analysis. and dereferenced NULL pointer

[committed] print -Wnonnull note only after warning (PR c++/96310)

2020-07-25 Thread Martin Sebor via Gcc-patches
I committed the patch below in r11-2322. Martin Fix PR c++/96310 - Ignoring -Wnonnull via pragma gcc diagnostics still produces an unwanted note. gcc/c-family/ChangeLog: PR c++/96310 * c-common.c (check_nonnull_arg): Print note only when warning was issued. diff --git

Re: [Patch, fortran] PR 93592 - Invalid UP/DOWN rounding with EN descriptor

2020-07-25 Thread Thomas König
Hi Dominique, I am trying t...@tkoenig.net. That works :-) I'll try to use that address in the future for my mails to the fortran mailing list, so it does not bounce for you. Best regards Thomas

[pushed] C++, testsuite: Adjust pure-virtual1.C options for Darwin.

2020-07-25 Thread Iain Sandoe
Hi, Darwin's static linker expects, by default, that all linkage will be satisfied (even for weak items). This allows the two-level namespace to work even for weak cases. However, there's an option to make it behave in a similar manner to ELF. This is needed for the pure-virtual1.C testcase to

config/mmix/mmix.c (TARGET_ASM_OUTPUT_IDENT): Override.

2020-07-25 Thread Hans-Peter Nilsson
Funny that default_asm_output_ident_directive isn't the default... Anyway, since dot-pseudos like .ident are treated as comments by mmixal, there's nothing lost compatibilitywise by supporting it. If mmix-knuth-mmixware had included elfos.h this'd have been the default. There might be enough

[Patch, committed] libgfortran: configure - skip integer(kind=16) for libgfortran for AMDGN (PR96306)

2020-07-25 Thread Tobias Burnus
OpenMP requires an integer kind for omp_depend_kind and libgomp uses twice the pointer size – hence, one needs on 64bit systems kind=16 integers or __int128. See PR and links in it. AMDGCN did not expose TI and, hence, failed to build libgomp. For AMDGCN, initial support has been added via

gcc.dg/torture/pr59330.c: Disable for mmix

2020-07-25 Thread Hans-Peter Nilsson
Committed. With the dejagnu status-wrapper, there's a reference to write in each executable, which for mmix in newlib has a reference to a variable defined in open, which for mmix in newlib has a reference to sprintf (oops!) and the dependency-chain goes on; ad finitum there's a reference to

gcc.dg/tree-ssa/forwprop-36.c: Adjust for mmix

2020-07-25 Thread Hans-Peter Nilsson
Committed. The label of interest here is "b.0_2" for e.g. x86_64-pc-linux-gnu but "b::1_2" for mmix-knuth-mmixware. The test seems to be of some interest for mmix (hey, gcc open-coded 128-bit integer support behind my back!) so I didn't want to just disable it. I also didn't want to obscure the