Re: [PATCH 1/5] Use MADV_DONTNEED for freeing in garbage collector

2011-10-16 Thread Andi Kleen
Andi Kleen a...@firstfloor.org writes: From: Andi Kleen a...@linux.intel.com Use the Linux MADV_DONTNEED call to unmap free pages in the garbage collector.Then keep the unmapped pages in the free list. This avoid excessive memory fragmentation on large LTO bulds, which can lead to gcc

Re: [PATCH] Optimize some loops using bool types (PR tree-optimization/50596)

2011-10-16 Thread Ira Rosen
On 12 October 2011 17:54, Jakub Jelinek ja...@redhat.com wrote: Hi! Hi, This patch allows vectorization of some loops that use bool (which is especially important now that we use bool more often even for stmts that weren't originally using bool in the sources), in particular (when bool is

Re: [PATCH/RFA] Fix up gcc.dg/vect/pr30858.c expected output

2011-10-16 Thread Ira Rosen
gcc-patches-ow...@gcc.gnu.org wrote on 14/10/2011 04:43:48 PM: All, The attached patch corrects the expected output of the gcc.dg/vect/pr30858.c testcase. Historically it has expected the output Unknown def-use cycle pattern. just once. However, recent changes to GCC for ARM targets

Re: [PATCH] fortran/50524 -- Check return status of resolving substring ref

2011-10-16 Thread Janus Weil
Hi Steve, resolve_ref() calls resolve_substring() but failed to check its return value.  This patch does the check. Looks pretty obvious. Please commit. Thanks for the patch, Janus 2011-10-15  Steven G. Kargl  ka...@gcc.gcu.org        * resolve.c (resolve_ref): Check return value of

Fix thunkalias issues

2011-10-16 Thread Jan Hubicka
Hi, this patch makes cgrpahunit to output all thunks and aliases after the function, not before. Outputting before leads to better code layout and we might omit tailjump when thunk is just one, but it breaks one pass assembler and comdat group symbols. This is the easiest fix and I will play

Re: [PR50672, PATCH] Fix ice triggered by -ftree-tail-merge: verify_ssa failed: no immediate_use list

2011-10-16 Thread Tom de Vries
On 10/14/2011 12:00 PM, Richard Guenther wrote: On Fri, Oct 14, 2011 at 1:12 AM, Tom de Vries tom_devr...@mentor.com wrote: On 10/12/2011 02:19 PM, Richard Guenther wrote: On Wed, Oct 12, 2011 at 8:35 AM, Tom de Vries vr...@codesourcery.com wrote: Richard, I have a patch for PR50672.

Re: [C++ Patch] PR 32614

2011-10-16 Thread Gabriel Dos Reis
On Sun, Oct 16, 2011 at 5:03 AM, Paolo Carlini paolo.carl...@oracle.com wrote: Hi, in this simple documentation PR, Tom noticed that we have a (very long standing) inconsistency between the default value of -fmessage-length for C++ as documented and as implemented: in fact it's 0 in

Re: [PATCH] Rename __gnu_slim_lto to __gnu_lto_slim

2011-10-16 Thread Richard Guenther
On Sun, Oct 16, 2011 at 1:12 AM, Andi Kleen a...@firstfloor.org wrote: From: Andi Kleen a...@linux.intel.com Some external tools special case __gnu_lto* symbols, and the new __gnu_slim_lto was the only LTO symbol not matching this pattern. Since I don't think there are any users rename it

Re: [C++ Patch] PR 32614

2011-10-16 Thread Paolo Carlini
On 10/16/2011 12:28 PM, Gabriel Dos Reis wrote: On Sun, Oct 16, 2011 at 5:03 AM, Paolo Carlinipaolo.carl...@oracle.com wrote: Hi, in this simple documentation PR, Tom noticed that we have a (very long standing) inconsistency between the default value of -fmessage-length for C++ as documented

Re: [PATCH 1/5] Use MADV_DONTNEED for freeing in garbage collector

2011-10-16 Thread Richard Guenther
On Sun, Oct 16, 2011 at 7:30 AM, Andi Kleen a...@firstfloor.org wrote: Andi Kleen a...@firstfloor.org writes: From: Andi Kleen a...@linux.intel.com Use the Linux MADV_DONTNEED call to unmap free pages in the garbage collector.Then keep the unmapped pages in the free list. This avoid

[patch] Support subchains of interleaving chains in basic block SLP

2011-10-16 Thread Ira Rosen
Hi, This patch allows to vectorize a subchain of interleaved loads in basic block SLP (in loop vectorization this would be more complicated because of loop peeling). This patch also swaps operands if necessary (and possible) to make operations isomorphic. Bootstrapped and tested on

Re: [C++ Patch] PR 32614

2011-10-16 Thread Gabriel Dos Reis
On Sun, Oct 16, 2011 at 5:42 AM, Richard Guenther richard.guent...@gmail.com wrote: On Sun, Oct 16, 2011 at 12:31 PM, Paolo Carlini paolo.carl...@oracle.com wrote: On 10/16/2011 12:28 PM, Gabriel Dos Reis wrote: On Sun, Oct 16, 2011 at 5:03 AM, Paolo Carlinipaolo.carl...@oracle.com  wrote:

[PATCH] fix -Wsign-compare error in objc-act.c (PR objc/50743)

2011-10-16 Thread Mikael Pettersson
This fixes a bootstrap failure on trunk with objc enabled, caused by a recent change which introduced for-loops that compare a size_t index variable with a TREE_VEC_LENGTH limit. TREE_VEC_LENGTH returns a signed integer, resulting in a signed/unsigned comparison. The C++ front-end fails to catch

[Ada] Allow use of GNU ld on AIX

2011-10-16 Thread Arnaud Charlet
Reorder chunks in link.c so that the correct configuration is selected when compiling with --with-gnu-ld on AIX. No change in behaviour. Note that in particular it's important that we use native AIX switches even when using GNU ld. This is important with response files as they must be

[Ada] Move Implementation_Defined pragma to inner package

2011-10-16 Thread Arnaud Charlet
The declaration of the Implementation_Defined pragma was moved from the outer scope to the scope of the nested package Implementation. Tested on x86_64-pc-linux-gnu, committed on trunk 2011-10-16 Matthew Heaney hea...@adacore.com * a-cusyqu.ads, a-cbsyqu.ads, a-cuprqu.ads,

[Patch, Fortran] PR 47023: [4.6/4.7 regression] C_Sizeof: Rejects valid code

2011-10-16 Thread Janus Weil
Hi all, here is a patch which fixes the regression in comment #2 of the PR in the subject line. What it does is setting the 'ts.is_c_interop' flag correctly for constants with kind-parameter specification (such as '0.0_c_double'), as is already being done for variables. Regtested on

Re: [PATCH] Optimize some loops using bool types (PR tree-optimization/50596)

2011-10-16 Thread Jakub Jelinek
On Sun, Oct 16, 2011 at 09:56:57AM +0200, Ira Rosen wrote: by moving? Yeah. Could you please add some more explanations here? I found it very difficult to follow. It would be nice to have an example here (similar to vect_recog_bool_pattern) to illustrate what these statements and operands

Re: [Patch,AVR] Print no-return functions as JMP

2011-10-16 Thread Paolo Bonzini
-moptimize-noreturn-calls        Optimize noreturn calls.  This might make debugging harder but        will save storing the return address when calling roreturn        functions.        Enabled at levels -O2, -O3, -Os. But the makes debugging harder clause is true for almost any

Re: [Patch,AVR] Print no-return functions as JMP

2011-10-16 Thread Georg-Johann Lay
Paolo Bonzini schrieb: -moptimize-noreturn-calls Optimize noreturn calls. This might make debugging harder but will save storing the return address when calling roreturn functions. Enabled at levels -O2, -O3, -Os. But the makes debugging harder clause is true for

[patch] Fix PR tree-optimization/50727

2011-10-16 Thread Ira Rosen
Hi, This patch fixes another occurrence of the same bug as in PR 50635. Bootstrapped and tested on powerpc64-suse-linux. Committed. Ira ChangeLog: PR tree-optimization/50727 * tree-vect-patterns.c (vect_operation_fits_smaller_type): Add DEF_STMT to the list of

[PATCH] Clear DECL_GIMPLE_REG_P when making parameter copy addressable (PR tree-optimization/50735)

2011-10-16 Thread Jakub Jelinek
Hi! gimplify_parameters uses create_tmp_reg, but sometimes it decides to make it addressable (if the PARM_DECL is addressable). If so, it must not be DECL_GIMPLE_REG_P. Alternatively we could call create_tmp_reg only if !TREE_ADDRESSABLE and call create_tmp_var instead for TREE_ADDRESSABLE (+

[wwwdocs] gcc-4.4/porting_to.html headers

2011-10-16 Thread Gerald Pfeifer
Looking at the new gcc-4.6/porting_to.html last week, I noticed that in the original version there as well as the older instance for GCC 4.4 we would skip h2 headers and directly move from h1 to h3. I addressed this when committing the GCC 4.6 flavor, and the patch below which I committed does

Re: [Patch, Fortran] PR 47023: [4.6/4.7 regression] C_Sizeof: Rejects valid code

2011-10-16 Thread Paul Richard Thomas
Dear Janus, This is OK for trunk. Thanks fo rthe patch. Cheers Paul On Sun, Oct 16, 2011 at 2:58 PM, Janus Weil ja...@gcc.gnu.org wrote: Hi all, here is a patch which fixes the regression in comment #2 of the PR in the subject line. What it does is setting the 'ts.is_c_interop' flag

Re: [PATCH 1/5] Use MADV_DONTNEED for freeing in garbage collector

2011-10-16 Thread Andi Kleen
On Sun, Oct 16, 2011 at 12:38:16PM +0200, Richard Guenther wrote: On Sun, Oct 16, 2011 at 7:30 AM, Andi Kleen a...@firstfloor.org wrote: Andi Kleen a...@firstfloor.org writes: From: Andi Kleen a...@linux.intel.com Use the Linux MADV_DONTNEED call to unmap free pages in the garbage

Re: [PATCH, alpha]: Fix PR target/50737, FAIL: Throw_3 -O3 execution

2011-10-16 Thread Uros Bizjak
On Sun, Oct 16, 2011 at 8:09 AM, Uros Bizjak ubiz...@gmail.com wrote: As explained in length in the PR [1], we fail to mark signal frames correctly, leading to the abort in EH support library. As suggested by Eric, attached patch marks fs-signal_frame in the same way as other dwarf2 targets.

Re: PowerPC shrink-wrap support 3 of 3

2011-10-16 Thread David Edelsohn
On Wed, Sep 28, 2011 at 11:47 AM, Alan Modra amo...@gmail.com wrote:        * config/rs6000/rs6000.c (rs6000_make_savres_rtx): Delete unneeded        declaration.        (rs6000_emit_stack_reset): Only return insn emitted when it adjusts sp.        (rs6000_make_savres_rtx): Rename to

[C++ Patch] PR 48489

2011-10-16 Thread Paolo Carlini
Hi, in this diagnostic PR the issue it that for: struct Base{ }; struct Concrete : Base { void setValue(); }; int main() { Concrete d; d.Base::setValue(); } the error message is: 48489.C:11:11: error: ‘struct Derived’ has no member named ‘setValue’ instead of: 48489.C:11:11: error:

Re: [Patch, Fortran] PR 50547 / cleanup in resolve_formal_arglist

2011-10-16 Thread Janus Weil
while working on PR50547, I noticed some strange things about resolve_formal_arglist, so I decided to clean it up a little. The attached patch does a couple of things: Regtested on x86_64-unknown-linux-gnu. Ok for trunk? OK. Thanks for the cleanup. Thanks. Committed as r180061. (I almost

[patch, fortran] Some cleanup / fixes in front-end statement walker

2011-10-16 Thread Thomas Koenig
Hello world, working on PR 50690, I noticed a few things which are not quite right in front-end optimization statement walking: - BLOCKs were walked via their namespaces, not directly. This caused out-of-order walking, which was confusing. - current_ns was not marked static. - ASSOCIATE lists

Re: [patch, fortran] Some cleanup / fixes in front-end statement walker

2011-10-16 Thread Steven Bosscher
This patch corrects these things.  Regression-tested. OK for trunk?  (I will not be able to commit for a few days due to business travel, unless somebody is _really_ fast :-) Looks OK to me. Fast enough for you? Ciao! Steven

Re: PR c++/30195

2011-10-16 Thread Fabien Chêne
[...] Does the attached testcase checked  what you mention ? ... with the testcase attached. -- Fabien // { dg-do run } template class T struct A { int f() { return 1; } }; template class T struct B : AT { int f() { return 2; } using AT::f; void g() { if (AT::f() != 1 )

Re: [C++ Patch] PR 48489

2011-10-16 Thread Paolo Carlini
On 10/16/2011 09:12 PM, Paolo Carlini wrote: 48489.C:11:11: error: ‘struct Derived’ has no member named ‘setValue’ of course there is a typo here, should read 48489.C:11:11: error: ‘struct Concrete’ has no member named ‘setValue’ Paolo.

Re: [PATCH] fix -Wsign-compare error in objc-act.c (PR objc/50743)

2011-10-16 Thread Mike Stump
On Oct 16, 2011, at 4:28 AM, Mikael Pettersson wrote: This fixes a bootstrap failure on trunk with objc enabled Ok for trunk? Ok.

[pph] Refactor Vectors and Chains (issue5263051)

2011-10-16 Thread Lawrence Crowl
Factor the vector and chain output routines to remove boolean control parameters. The functions pph_out_tree_vec_1 and pph_out_chain_1 split their conditional parts of their implementation into their use cases, calling each other as needed. pph_out_tree_vec - nothing special

Re: [C++ Patch] PR 48489

2011-10-16 Thread Jason Merrill
OK. Jason