ping x3 : latch mem to reg before multi-access in convert_move

2012-06-24 Thread Olivier Hainque
Hello, ping # 3 for http://gcc.gnu.org/ml/gcc-patches/2012-04/msg00298.html This is related to convert-move possibly emitting a sequence with multiple accesses to one input, triggering multiple memory accesses when that input happens to be a mem. The original problem we had with this was the

ping x2: fix mem+32760 ICE on powerpc - introduce predicates weaker than mode_dependent_address_p

2012-06-24 Thread Olivier Hainque
Hello, Ping #2 for the non-back-end parts of http://gcc.gnu.org/ml/gcc-patches/2012-04/msg01668.html Thanks much in advance, Olivier David approved the rs6000 parts already (with adjustments to comments, http://gcc.gnu.org/ml/gcc-patches/2012-05/msg00368.html) Thanks much in advance for

Fix MIPS --enable-werror build

2012-06-24 Thread Richard Sandiford
As per subject. Tested on mips64-elf and mipsisa64-elf. Applied. Richard gcc/ * config/mips/mips.c (mips_process_sync_loop): Add missing enum cast. Index: gcc/config/mips/mips.c === --- gcc/config/mips/mips.c

RFA: dwarf2out vs. LP64-on-ELF32

2012-06-24 Thread Richard Sandiford
One of the more unfortunate things MIPS has inherited is an LP64 ABI that uses 32-bit rather than 64-bit ELF. I've no idea how many people use it these days (if anyone), but it happens to the ABI of the MIPS primary target, mipsisa64-elf. Because we're using 32-bit ELF, DWARF2_ADDR_SIZE is 4

RFA: dead_debug_* ICE

2012-06-24 Thread Richard Sandiford
gcc.c-torture/compile/vector-2.c fails on mips64-elf with RTL checking enabled because dead_debug_insert_temp tries to read the REGNO of something that it has already replaced with a debug temporary. The original register was (reg:TI 2), which occupies two hard registers, and so each reference

Re: const char* constructor overloads for stdexcept and system_error.

2012-06-24 Thread Jonathan Wakely
On 24 June 2012 04:57, Ed Smith-Rowland wrote: Here is a beginning patch to add const char* constructors for the standard exception classes. I didn't bump the so version because I'm not positive how to do it. I tried changing libtool_VERSION in acinclude.m4 and running the autotools commands.

[patch] Remove and poison a few more old target macros

2012-06-24 Thread Steven Bosscher
Like the ones before: they are unused. Will commit as an obvious cleanup in a few days' time. Ciao! Steven * system.h (UNALIGNED_SHORT_ASM_OP, UNALIGNED_INT_ASM_OP, UNALIGNED_LONG_ASM_OP, UNALIGNED_DOUBLE_INT_ASM_OP): Poison. * vmsdbgout.c (UNALIGNED_SHORT_ASM_OP,

Re: RFA: dwarf2out vs. LP64-on-ELF32

2012-06-24 Thread H.J. Lu
On Sun, Jun 24, 2012 at 3:36 AM, Richard Sandiford rdsandif...@googlemail.com wrote: One of the more unfortunate things MIPS has inherited is an LP64 ABI that uses 32-bit rather than 64-bit ELF.  I've no idea how many people use it these days (if anyone), but it happens to the ABI of the MIPS

Re: [patch] Remove and poison a few more old target macros

2012-06-24 Thread Steven Bosscher
On Sun, Jun 24, 2012 at 3:42 PM, Steven Bosscher stevenb@gmail.com wrote: Like the ones before: they are unused. Will commit as an obvious cleanup in a few days' time. ...and one more... * system.h (USE_COMMON_FOR_ONE_ONLY): Poison. * defaults.h (USE_COMMON_FOR_ONE_ONLY):

Re: [Patch] PR 51938: extend ifcombine

2012-06-24 Thread Joseph S. Myers
On Sat, 23 Jun 2012, Marc Glisse wrote: Actually, what would you think of s/flag_trapping_math/flag_signaling_nans/ in invert_tree_comparison? Are there other possible ways ab can trap than having a sNaN for a or b? Ordered comparisons raise exceptions for both quiet and signaling NaNs.

Re: [Patch] PR 51938: extend ifcombine

2012-06-24 Thread Marc Glisse
On Sun, 24 Jun 2012, Joseph S. Myers wrote: On Sat, 23 Jun 2012, Marc Glisse wrote: Actually, what would you think of s/flag_trapping_math/flag_signaling_nans/ in invert_tree_comparison? Are there other possible ways ab can trap than having a sNaN for a or b? Ordered comparisons raise

Re: [patch] Put some global vars into crtl

2012-06-24 Thread Richard Guenther
On Sat, Jun 23, 2012 at 10:38 PM, Steven Bosscher stevenb@gmail.com wrote: Hello, There are three global variables defined in function.c and exported via output.h: current_function_is_leaf, current_function_sp_is_unchanging, and current_function_uses_only_leaf_regs. All 3 can be added to

Re: [Patch, Fortran] Add parsing support for assumed-rank array

2012-06-24 Thread Tobias Burnus
Tobias Burnus wrote: To cleanup my local trees; I had the patch lingering there for a many weeks. User visible, it only adds parsing support for dimension(..) and a sorry message. I have now updated the patch. Changes: * No longer stops with a sorry message (except for scalars to

Re: RFA: dwarf2out vs. LP64-on-ELF32

2012-06-24 Thread Richard Sandiford
H.J. Lu hjl.to...@gmail.com writes: On Sun, Jun 24, 2012 at 3:36 AM, Richard Sandiford rdsandif...@googlemail.com wrote: I realise it's a bit clunky, but is the attached patch OK? Tested on mipsisa64-elf, where it restores the build, and on x86_64-linux-gnu. Richard gcc/        *

Re: [PATCH 3/n, i386]: Merge SSE and AVX patterns using enable attribute.

2012-06-24 Thread H.J. Lu
On Thu, Apr 7, 2011 at 11:51 AM, Uros Bizjak ubiz...@gmail.com wrote: Hello! This patch converts Parallel single-precision floating point element swizzling and Parallel double-precision floating point element swizzling sections of sse.md. 2011-04-07  Uros Bizjak  ubiz...@gmail.com        

New German PO file for 'gcc' (version 4.7.1)

2012-06-24 Thread Translation Project Robot
Hello, gentle maintainer. This is a message from the Translation Project robot. A revised PO file for textual domain 'gcc' has been submitted by the German team of translators. The file is available at: http://translationproject.org/latest/gcc/de.po (This file, 'gcc-4.7.1.de.po', has just

Re: RFA: dwarf2out vs. LP64-on-ELF32

2012-06-24 Thread Andrew Pinski
On Sun, Jun 24, 2012 at 3:36 AM, Richard Sandiford rdsandif...@googlemail.com wrote: One of the more unfortunate things MIPS has inherited is an LP64 ABI that uses 32-bit rather than 64-bit ELF.  I've no idea how many people use it these days (if anyone), but it happens to the ABI of the MIPS

[patch][doc] Add some missing libraries to sourcebuild.texi

2012-06-24 Thread Steven Bosscher
Hello, Noticed while going through sourcebuild.texi to see what needs updating for the move of the C front end to its own subdirectory of gcc/. Ok for trunk? Ciao! Steven * doc/sourcebuild.texi: Add missing subdirectories. Index: doc/sourcebuild.texi

[patch] Only define JMP_BUF_SIZE in backends that also define DONT_USE_BUILTIN_SETJMP

2012-06-24 Thread Steven Bosscher
Hello, For targets that define DONT_USE_BUILTIN_SETJMP, the JMP_BUF_SIZE macro can be used to set the size of the exception jump buffer. The JMP_BUF_SIZE macro is not used unless DONT_USE_BUILTIN_SETJMP is defined. See gcc/except.c and libgcc/unwind-sjlj.c. The PA and SPARC back ends do not

[patch][doc] Document JMP_BUF_SIZE

2012-06-24 Thread Steven Bosscher
Hello, Documentation for this target macro is missing. This patch adds it. OK for trunk? Ciao! Steven * doc/tm.texi.in: Document JMP_BUF_SIZE. * doc/tm.texi: Regenerate. Index: doc/tm.texi.in === ---

Re: [patch] Only define JMP_BUF_SIZE in backends that also define DONT_USE_BUILTIN_SETJMP

2012-06-24 Thread DJ Delorie
The rl78 apparently doesn't know what it wants to do: /* NOTE: defined but zero means dwarf2 debugging, but sjlj EH. */ #define DWARF2_UNWIND_INFO 0 /*#define DONT_USE_BUILTIN_SETJMP 1*/ #undef DONT_USE_BUILTIN_SETJMP #define JMP_BUF_SIZE (8*3+8) But I'll leave that to an rl78

Re: [Ping] Fix gcc/gcov.c and libgcc/libgcov.c to fix build on VxWorks

2012-06-24 Thread rbmj
On 06/22/2012 06:52 PM, rbmj wrote: On 06/11/2012 08:01 AM, Paolo Bonzini wrote: Il 11/06/2012 13:56, rbmj ha scritto: 1. VxWorks does not have a variadic open - it must receive three arguments. gcc/gcov.c however opens a file for reading and does not pass in a mode argument, which causes an

Re: [patch] Remove and poison a few more old target macros

2012-06-24 Thread Hans-Peter Nilsson
On Sun, 24 Jun 2012, Steven Bosscher wrote: * doc/tm.texi.in: Remove UNALIGNED_INT_ASM_OP reference from the documentation. * doc/tm.texi: Regenerate. * doc/cpp.texi: Make example for #error generic. * config/frv/frv.h: Fix example text to match tm.texi. FWIW,

Re: [C++ PATCH] Disable -Wuninitialized warnings on NSDMI initialized fields (PR c++/53594)

2012-06-24 Thread Jason Merrill
OK. Jason

Re: [C++] Reject variably modified types in operator new

2012-06-24 Thread Jason Merrill
On 06/11/2012 12:11 PM, Florian Weimer wrote: + tree inner_nelts_cst = maybe_constant_value (inner_nelts); + if (!TREE_CONSTANT (inner_nelts_cst)) + { + if (complain tf_error) + error_at (EXPR_LOC_OR_HERE (inner_nelts), + array size in

Re: [RFC C++ / PR51033 ] Handle __builtin_shuffle in constexpr properly in the C++ frontend.

2012-06-24 Thread Jason Merrill
On 06/18/2012 09:04 AM, Ramana Radhakrishnan wrote: + location_t loc = EXPR_LOC_OR_HERE (t); We should only use EXPR_LOC_OR_HERE for diagnostics. For a location to use in building other expressions, use EXPR_LOCATION. OK with that change. Jason

Re: RFA: dead_debug_* ICE

2012-06-24 Thread Alexandre Oliva
On Jun 24, 2012, Richard Sandiford rdsandif...@googlemail.com wrote: gcc.c-torture/compile/vector-2.c fails on mips64-elf with RTL checking enabled because dead_debug_insert_temp tries to read the REGNO of something that it has already replaced with a debug temporary. This sounds like

Re: RFA: dead_debug_* ICE

2012-06-24 Thread Jakub Jelinek
On Sun, Jun 24, 2012 at 11:50:12AM +0100, Richard Sandiford wrote: gcc/ Please mention PR debug/53740 here. * df.h (dead_debug_add): Remove third argument. * df-problems.c (dead_debug_add): Likewise. Use the REGNO of the REG that we want to replace instead.