[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2019-05-19 Thread Andreas Sturmlechner
commit: 1d657185391429b5c963fc2a2ffeab0e708726cd
Author: Andreas Sturmlechner  gentoo  org>
AuthorDate: Sun May 19 13:32:35 2019 +
Commit: Andreas Sturmlechner  gentoo  org>
CommitDate: Sun May 19 16:55:51 2019 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=1d657185

media-plugins/kipi-plugins: Drop 5.9.0

Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner  gentoo.org>

 media-plugins/kipi-plugins/Manifest|  1 -
 .../kipi-plugins/kipi-plugins-5.9.0.ebuild | 81 --
 2 files changed, 82 deletions(-)

diff --git a/media-plugins/kipi-plugins/Manifest 
b/media-plugins/kipi-plugins/Manifest
index e138ab4a654..15a76e53743 100644
--- a/media-plugins/kipi-plugins/Manifest
+++ b/media-plugins/kipi-plugins/Manifest
@@ -1,2 +1 @@
-DIST digikam-5.9.0.tar.xz 132931184 BLAKE2B 
cfbcbae8471c9c00bdf846d13bbc1ce3fbbd2ee4cc86500d011f9e15c1a21d7799638f94708794e8bc36a200df455667f9df8fcefdc38aaa00060630807d11cb
 SHA512 
f6134a957dcd11343e34f0bc90f5560a28ed205c47d2ffd76a5418a4c63f76706045e9179c47f1448304b59081051b524f7a6847c3c1dcee4673047ce5d90e63
 DIST kipi-plugins-5.9.1.tar.xz 1468084 BLAKE2B 
92ae30ae4c3fa2af173b32b294a610c1670754be5e40d395aec939e192ada42b274572de3dd449e74f26f1680abe07cd3ba48f67d25b75541317e9dc7ac3b494
 SHA512 
7536602edc85464aa651f5134f1dc085141632775907603d738f3915c718df359adb155013571ab836f91a1fb597418a1437e677b98c086bce5ea884133cca51

diff --git a/media-plugins/kipi-plugins/kipi-plugins-5.9.0.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-5.9.0.ebuild
deleted file mode 100644
index a4f54618310..000
--- a/media-plugins/kipi-plugins/kipi-plugins-5.9.0.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-KDE_TEST="true"
-inherit kde5
-
-DESCRIPTION="Plugins for the KDE Image Plugin Interface"
-HOMEPAGE="https://www.digikam.org/;
-
-LICENSE="GPL-2+"
-IUSE="flashexport mediawiki +remotestorage vkontakte"
-
-if [[ ${KDE_BUILD_TYPE} = release ]]; then
-   KEYWORDS="amd64 ~arm64 x86"
-   if [[ ${PV} =~ beta[0-9]$ ]]; then
-   SRC_BRANCH="unstable"
-   else
-   SRC_BRANCH="stable"
-   fi
-
-   MY_PV="${PV/_/-}"
-   MY_P="digikam-${MY_PV}"
-   SRC_URI="mirror://kde/${SRC_BRANCH}/digikam/${MY_P}.tar.xz"
-   S="${WORKDIR}/${MY_P}/extra/${PN}"
-fi
-
-COMMON_DEPEND="
-   $(add_frameworks_dep kcompletion)
-   $(add_frameworks_dep kconfig)
-   $(add_frameworks_dep kconfigwidgets)
-   $(add_frameworks_dep kcoreaddons)
-   $(add_frameworks_dep ki18n)
-   $(add_frameworks_dep kwindowsystem)
-   $(add_frameworks_dep kxmlgui)
-   $(add_kdeapps_dep libkipi '' '' '5=')
-   $(add_qt_dep qtgui)
-   $(add_qt_dep qtnetwork)
-   $(add_qt_dep qtprintsupport)
-   $(add_qt_dep qtsvg)
-   $(add_qt_dep qtwidgets)
-   $(add_qt_dep qtxml)
-   $(add_qt_dep qtxmlpatterns)
-   flashexport? ( $(add_frameworks_dep karchive) )
-   mediawiki? ( net-libs/libmediawiki:5 )
-   remotestorage? ( $(add_frameworks_dep kio) )
-   vkontakte? ( net-libs/libkvkontakte:5 )
-"
-DEPEND="${COMMON_DEPEND}
-   $(add_qt_dep qtconcurrent)
-   sys-devel/gettext
-"
-RDEPEND="${COMMON_DEPEND}
-   !media-plugins/kipi-plugins:4
-"
-
-src_prepare() {
-   if [[ ${KDE_BUILD_TYPE} = release ]]; then
-   if [[ ${SRC_BRANCH} = stable ]]; then
-   # prepare the translations
-   mv "${WORKDIR}/${MY_P}/po" po || die
-   find po -name "*.po" -and -not -name "kipiplugin*.po" 
-delete || die
-   echo "find_package(Gettext REQUIRED)" >> CMakeLists.txt 
|| die
-   echo "add_subdirectory( po )" >> CMakeLists.txt || die
-   fi
-   fi
-
-   kde5_src_prepare
-}
-
-src_configure() {
-   local mycmakeargs=(
-   $(cmake-utils_use_find_package flashexport KF5Archive)
-   $(cmake-utils_use_find_package mediawiki KF5MediaWiki)
-   -DENABLE_KIO=$(usex remotestorage)
-   $(cmake-utils_use_find_package vkontakte KF5Vkontakte)
-   )
-
-   kde5_src_configure
-}



[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2019-05-19 Thread Thomas Deutschmann
commit: 9c4bf5784ba8424d6563261b328f8c44ca723935
Author: Thomas Deutschmann  gentoo  org>
AuthorDate: Sun May 19 12:59:40 2019 +
Commit: Thomas Deutschmann  gentoo  org>
CommitDate: Sun May 19 12:59:40 2019 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=9c4bf578

media-plugins/kipi-plugins: x86 stable (bug #683920)

Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Thomas Deutschmann  gentoo.org>

 media-plugins/kipi-plugins/kipi-plugins-5.9.1.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/media-plugins/kipi-plugins/kipi-plugins-5.9.1.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-5.9.1.ebuild
index 610b6300b5b..11fe9c31b7b 100644
--- a/media-plugins/kipi-plugins/kipi-plugins-5.9.1.ebuild
+++ b/media-plugins/kipi-plugins/kipi-plugins-5.9.1.ebuild
@@ -10,7 +10,7 @@ DESCRIPTION="Plugins for the KDE Image Plugin Interface"
 HOMEPAGE="https://userbase.kde.org/KIPI https://cgit.kde.org/kipi-plugins.git/;
 
 if [[ ${KDE_BUILD_TYPE} = release ]]; then
-   KEYWORDS="amd64 ~arm64 ~x86"
+   KEYWORDS="amd64 ~arm64 x86"
SRC_URI="mirror://kde/stable/kipi-plugins/${P}.tar.xz"
 fi
 



[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2019-05-13 Thread Mikle Kolyada
commit: 694e0b74032fbdbd113b275312e68fb944179d85
Author: Mikle Kolyada  gentoo  org>
AuthorDate: Mon May 13 10:04:50 2019 +
Commit: Mikle Kolyada  gentoo  org>
CommitDate: Mon May 13 10:04:50 2019 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=694e0b74

media-plugins/kipi-plugins: amd64 stable wrt bug #683920

Signed-off-by: Mikle Kolyada  gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11
RepoMan-Options: --include-arches="amd64"

 media-plugins/kipi-plugins/kipi-plugins-5.9.1.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/media-plugins/kipi-plugins/kipi-plugins-5.9.1.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-5.9.1.ebuild
index 64b32bdd9c3..610b6300b5b 100644
--- a/media-plugins/kipi-plugins/kipi-plugins-5.9.1.ebuild
+++ b/media-plugins/kipi-plugins/kipi-plugins-5.9.1.ebuild
@@ -10,7 +10,7 @@ DESCRIPTION="Plugins for the KDE Image Plugin Interface"
 HOMEPAGE="https://userbase.kde.org/KIPI https://cgit.kde.org/kipi-plugins.git/;
 
 if [[ ${KDE_BUILD_TYPE} = release ]]; then
-   KEYWORDS="~amd64 ~arm64 ~x86"
+   KEYWORDS="amd64 ~arm64 ~x86"
SRC_URI="mirror://kde/stable/kipi-plugins/${P}.tar.xz"
 fi
 



[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2019-04-20 Thread Andreas Sturmlechner
commit: 503c6394a3479ae8880914a489b9491aa59b5e6b
Author: Andreas Sturmlechner  gentoo  org>
AuthorDate: Fri Apr 19 12:23:02 2019 +
Commit: Andreas Sturmlechner  gentoo  org>
CommitDate: Fri Apr 19 12:30:26 2019 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=503c6394

media-plugins/kipi-plugins: 5.9.1 version bump

Signed-off-by: Andreas Sturmlechner  gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

 media-plugins/kipi-plugins/Manifest|  1 +
 .../kipi-plugins/kipi-plugins-5.9.1.ebuild | 55 ++
 2 files changed, 56 insertions(+)

diff --git a/media-plugins/kipi-plugins/Manifest 
b/media-plugins/kipi-plugins/Manifest
index 0cb547b5865..e138ab4a654 100644
--- a/media-plugins/kipi-plugins/Manifest
+++ b/media-plugins/kipi-plugins/Manifest
@@ -1 +1,2 @@
 DIST digikam-5.9.0.tar.xz 132931184 BLAKE2B 
cfbcbae8471c9c00bdf846d13bbc1ce3fbbd2ee4cc86500d011f9e15c1a21d7799638f94708794e8bc36a200df455667f9df8fcefdc38aaa00060630807d11cb
 SHA512 
f6134a957dcd11343e34f0bc90f5560a28ed205c47d2ffd76a5418a4c63f76706045e9179c47f1448304b59081051b524f7a6847c3c1dcee4673047ce5d90e63
+DIST kipi-plugins-5.9.1.tar.xz 1468084 BLAKE2B 
92ae30ae4c3fa2af173b32b294a610c1670754be5e40d395aec939e192ada42b274572de3dd449e74f26f1680abe07cd3ba48f67d25b75541317e9dc7ac3b494
 SHA512 
7536602edc85464aa651f5134f1dc085141632775907603d738f3915c718df359adb155013571ab836f91a1fb597418a1437e677b98c086bce5ea884133cca51

diff --git a/media-plugins/kipi-plugins/kipi-plugins-5.9.1.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-5.9.1.ebuild
new file mode 100644
index 000..64b32bdd9c3
--- /dev/null
+++ b/media-plugins/kipi-plugins/kipi-plugins-5.9.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="Plugins for the KDE Image Plugin Interface"
+HOMEPAGE="https://userbase.kde.org/KIPI https://cgit.kde.org/kipi-plugins.git/;
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+   KEYWORDS="~amd64 ~arm64 ~x86"
+   SRC_URI="mirror://kde/stable/kipi-plugins/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+IUSE="flashexport mediawiki +remotestorage vkontakte"
+
+BDEPEND="sys-devel/gettext"
+RDEPEND="
+   $(add_frameworks_dep kcompletion)
+   $(add_frameworks_dep kconfig)
+   $(add_frameworks_dep kconfigwidgets)
+   $(add_frameworks_dep kcoreaddons)
+   $(add_frameworks_dep ki18n)
+   $(add_frameworks_dep kwindowsystem)
+   $(add_frameworks_dep kxmlgui)
+   $(add_kdeapps_dep libkipi '' '' '5=')
+   $(add_qt_dep qtgui)
+   $(add_qt_dep qtnetwork)
+   $(add_qt_dep qtprintsupport)
+   $(add_qt_dep qtsvg)
+   $(add_qt_dep qtwidgets)
+   $(add_qt_dep qtxml)
+   $(add_qt_dep qtxmlpatterns)
+   flashexport? ( $(add_frameworks_dep karchive) )
+   mediawiki? ( net-libs/libmediawiki:5 )
+   remotestorage? ( $(add_frameworks_dep kio) )
+   vkontakte? ( net-libs/libkvkontakte:5 )
+"
+DEPEND="${RDEPEND}
+   $(add_qt_dep qtconcurrent)
+"
+
+src_configure() {
+   local mycmakeargs=(
+   $(cmake-utils_use_find_package flashexport KF5Archive)
+   $(cmake-utils_use_find_package mediawiki KF5MediaWiki)
+   -DENABLE_KIO=$(usex remotestorage)
+   $(cmake-utils_use_find_package vkontakte KF5Vkontakte)
+   )
+
+   kde5_src_configure
+}



[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2018-05-02 Thread Johannes Huber
commit: d23ee782a6d7d81031d6d07c317e202b733e3ab3
Author: Johannes Huber  gentoo  org>
AuthorDate: Wed May  2 19:12:04 2018 +
Commit: Johannes Huber  gentoo  org>
CommitDate: Wed May  2 19:12:19 2018 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d23ee782

media-plugins/kipi-plugins: Remove 5.7.0

Package-Manager: Portage-2.3.33, Repoman-2.3.9

 media-plugins/kipi-plugins/Manifest|  1 -
 .../kipi-plugins/kipi-plugins-5.7.0.ebuild | 81 --
 2 files changed, 82 deletions(-)

diff --git a/media-plugins/kipi-plugins/Manifest 
b/media-plugins/kipi-plugins/Manifest
index d23807cfbbd..0cb547b5865 100644
--- a/media-plugins/kipi-plugins/Manifest
+++ b/media-plugins/kipi-plugins/Manifest
@@ -1,2 +1 @@
-DIST digikam-5.7.0.tar.xz 123315064 BLAKE2B 
0879b25e674e39d204038ab629dec36757ae034e3dd7e9a0a3700f9703272c4a972a21c1db5a42c6c294247a1226b1cb9a8b980bb90cdcc12e0cd752459273ef
 SHA512 
626c9854311c637b994325237f171adce3dba39159fb336dfe95f1de287e2d08a3aaddd611eea87e8018047d331aff252b555c382cfbe1d8e14413c51a3849f4
 DIST digikam-5.9.0.tar.xz 132931184 BLAKE2B 
cfbcbae8471c9c00bdf846d13bbc1ce3fbbd2ee4cc86500d011f9e15c1a21d7799638f94708794e8bc36a200df455667f9df8fcefdc38aaa00060630807d11cb
 SHA512 
f6134a957dcd11343e34f0bc90f5560a28ed205c47d2ffd76a5418a4c63f76706045e9179c47f1448304b59081051b524f7a6847c3c1dcee4673047ce5d90e63

diff --git a/media-plugins/kipi-plugins/kipi-plugins-5.7.0.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-5.7.0.ebuild
deleted file mode 100644
index 8335d0fe00e..000
--- a/media-plugins/kipi-plugins/kipi-plugins-5.7.0.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-KDE_TEST="true"
-inherit kde5
-
-DESCRIPTION="Plugins for the KDE Image Plugin Interface"
-HOMEPAGE="https://www.digikam.org/;
-
-LICENSE="GPL-2+"
-IUSE="flashexport mediawiki +remotestorage vkontakte"
-
-if [[ ${KDE_BUILD_TYPE} = release ]]; then
-   KEYWORDS="amd64 x86"
-   if [[ ${PV} =~ beta[0-9]$ ]]; then
-   SRC_BRANCH="unstable"
-   else
-   SRC_BRANCH="stable"
-   fi
-
-   MY_PV="${PV/_/-}"
-   MY_P="digikam-${MY_PV}"
-   SRC_URI="mirror://kde/${SRC_BRANCH}/digikam/${MY_P}.tar.xz"
-   S="${WORKDIR}/${MY_P}/extra/${PN}"
-fi
-
-COMMON_DEPEND="
-   $(add_frameworks_dep kcompletion)
-   $(add_frameworks_dep kconfig)
-   $(add_frameworks_dep kconfigwidgets)
-   $(add_frameworks_dep kcoreaddons)
-   $(add_frameworks_dep ki18n)
-   $(add_frameworks_dep kwindowsystem)
-   $(add_frameworks_dep kxmlgui)
-   $(add_kdeapps_dep libkipi '' '' '5=')
-   $(add_qt_dep qtgui)
-   $(add_qt_dep qtnetwork)
-   $(add_qt_dep qtprintsupport)
-   $(add_qt_dep qtsvg)
-   $(add_qt_dep qtwidgets)
-   $(add_qt_dep qtxml)
-   $(add_qt_dep qtxmlpatterns)
-   flashexport? ( $(add_frameworks_dep karchive) )
-   mediawiki? ( net-libs/libmediawiki:5 )
-   remotestorage? ( $(add_frameworks_dep kio) )
-   vkontakte? ( net-libs/libkvkontakte:5 )
-"
-DEPEND="${COMMON_DEPEND}
-   $(add_qt_dep qtconcurrent)
-   sys-devel/gettext
-"
-RDEPEND="${COMMON_DEPEND}
-   !media-plugins/kipi-plugins:4
-"
-
-src_prepare() {
-   if [[ ${KDE_BUILD_TYPE} = release ]]; then
-   if [[ ${SRC_BRANCH} = stable ]]; then
-   # prepare the translations
-   mv "${WORKDIR}/${MY_P}/po" po || die
-   find po -name "*.po" -and -not -name "kipiplugin*.po" 
-delete || die
-   echo "find_package(Gettext REQUIRED)" >> CMakeLists.txt 
|| die
-   echo "add_subdirectory( po )" >> CMakeLists.txt || die
-   fi
-   fi
-
-   kde5_src_prepare
-}
-
-src_configure() {
-   local mycmakeargs=(
-   $(cmake-utils_use_find_package flashexport KF5Archive)
-   $(cmake-utils_use_find_package mediawiki KF5MediaWiki)
-   -DENABLE_KIO=$(usex remotestorage)
-   $(cmake-utils_use_find_package vkontakte KF5Vkontakte)
-   )
-
-   kde5_src_configure
-}



[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2018-05-02 Thread Thomas Deutschmann
commit: ca45765f5736d16c0b7aa3c2ea1ac57ce2e599dd
Author: Thomas Deutschmann  gentoo  org>
AuthorDate: Wed May  2 16:18:49 2018 +
Commit: Thomas Deutschmann  gentoo  org>
CommitDate: Wed May  2 16:32:46 2018 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ca45765f

media-plugins/kipi-plugins: x86 stable (bug #654370)

Package-Manager: Portage-2.3.31, Repoman-2.3.9

 media-plugins/kipi-plugins/kipi-plugins-5.9.0.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/media-plugins/kipi-plugins/kipi-plugins-5.9.0.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-5.9.0.ebuild
index 23bc086ac0e..245fd0ff11a 100644
--- a/media-plugins/kipi-plugins/kipi-plugins-5.9.0.ebuild
+++ b/media-plugins/kipi-plugins/kipi-plugins-5.9.0.ebuild
@@ -13,7 +13,7 @@ LICENSE="GPL-2+"
 IUSE="flashexport mediawiki +remotestorage vkontakte"
 
 if [[ ${KDE_BUILD_TYPE} = release ]]; then
-   KEYWORDS="amd64 ~x86"
+   KEYWORDS="amd64 x86"
if [[ ${PV} =~ beta[0-9]$ ]]; then
SRC_BRANCH="unstable"
else



[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2018-05-02 Thread Mikle Kolyada
commit: d1b54810577073b7fc9a23e5cd2d86e5bf936767
Author: Mikle Kolyada  gentoo  org>
AuthorDate: Wed May  2 14:18:18 2018 +
Commit: Mikle Kolyada  gentoo  org>
CommitDate: Wed May  2 14:18:50 2018 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d1b54810

media-plugins/kipi-plugins: amd64 stable wrt bug #654370

Package-Manager: Portage-2.3.24, Repoman-2.3.6

 media-plugins/kipi-plugins/kipi-plugins-5.9.0.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/media-plugins/kipi-plugins/kipi-plugins-5.9.0.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-5.9.0.ebuild
index 5a19db42937..23bc086ac0e 100644
--- a/media-plugins/kipi-plugins/kipi-plugins-5.9.0.ebuild
+++ b/media-plugins/kipi-plugins/kipi-plugins-5.9.0.ebuild
@@ -13,7 +13,7 @@ LICENSE="GPL-2+"
 IUSE="flashexport mediawiki +remotestorage vkontakte"
 
 if [[ ${KDE_BUILD_TYPE} = release ]]; then
-   KEYWORDS="~amd64 ~x86"
+   KEYWORDS="amd64 ~x86"
if [[ ${PV} =~ beta[0-9]$ ]]; then
SRC_BRANCH="unstable"
else



[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2018-03-26 Thread Johannes Huber
commit: 0b98e23e7594d12d19b88e48ddd9b37d1f5a5c18
Author: Johannes Huber  gentoo  org>
AuthorDate: Tue Mar 27 05:10:14 2018 +
Commit: Johannes Huber  gentoo  org>
CommitDate: Tue Mar 27 05:10:14 2018 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=0b98e23e

media-plugins/kipi-plugins: Version bump 5.9.0

Bug: https://bugs.gentoo.org/650546
Package-Manager: Portage-2.3.24, Repoman-2.3.6

 media-plugins/kipi-plugins/Manifest|  1 +
 .../kipi-plugins/kipi-plugins-5.9.0.ebuild | 81 ++
 2 files changed, 82 insertions(+)

diff --git a/media-plugins/kipi-plugins/Manifest 
b/media-plugins/kipi-plugins/Manifest
index 76ae0410132..d23807cfbbd 100644
--- a/media-plugins/kipi-plugins/Manifest
+++ b/media-plugins/kipi-plugins/Manifest
@@ -1 +1,2 @@
 DIST digikam-5.7.0.tar.xz 123315064 BLAKE2B 
0879b25e674e39d204038ab629dec36757ae034e3dd7e9a0a3700f9703272c4a972a21c1db5a42c6c294247a1226b1cb9a8b980bb90cdcc12e0cd752459273ef
 SHA512 
626c9854311c637b994325237f171adce3dba39159fb336dfe95f1de287e2d08a3aaddd611eea87e8018047d331aff252b555c382cfbe1d8e14413c51a3849f4
+DIST digikam-5.9.0.tar.xz 132931184 BLAKE2B 
cfbcbae8471c9c00bdf846d13bbc1ce3fbbd2ee4cc86500d011f9e15c1a21d7799638f94708794e8bc36a200df455667f9df8fcefdc38aaa00060630807d11cb
 SHA512 
f6134a957dcd11343e34f0bc90f5560a28ed205c47d2ffd76a5418a4c63f76706045e9179c47f1448304b59081051b524f7a6847c3c1dcee4673047ce5d90e63

diff --git a/media-plugins/kipi-plugins/kipi-plugins-5.9.0.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-5.9.0.ebuild
new file mode 100644
index 000..5a19db42937
--- /dev/null
+++ b/media-plugins/kipi-plugins/kipi-plugins-5.9.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="Plugins for the KDE Image Plugin Interface"
+HOMEPAGE="https://www.digikam.org/;
+
+LICENSE="GPL-2+"
+IUSE="flashexport mediawiki +remotestorage vkontakte"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+   KEYWORDS="~amd64 ~x86"
+   if [[ ${PV} =~ beta[0-9]$ ]]; then
+   SRC_BRANCH="unstable"
+   else
+   SRC_BRANCH="stable"
+   fi
+
+   MY_PV="${PV/_/-}"
+   MY_P="digikam-${MY_PV}"
+   SRC_URI="mirror://kde/${SRC_BRANCH}/digikam/${MY_P}.tar.xz"
+   S="${WORKDIR}/${MY_P}/extra/${PN}"
+fi
+
+COMMON_DEPEND="
+   $(add_frameworks_dep kcompletion)
+   $(add_frameworks_dep kconfig)
+   $(add_frameworks_dep kconfigwidgets)
+   $(add_frameworks_dep kcoreaddons)
+   $(add_frameworks_dep ki18n)
+   $(add_frameworks_dep kwindowsystem)
+   $(add_frameworks_dep kxmlgui)
+   $(add_kdeapps_dep libkipi '' '' '5=')
+   $(add_qt_dep qtgui)
+   $(add_qt_dep qtnetwork)
+   $(add_qt_dep qtprintsupport)
+   $(add_qt_dep qtsvg)
+   $(add_qt_dep qtwidgets)
+   $(add_qt_dep qtxml)
+   $(add_qt_dep qtxmlpatterns)
+   flashexport? ( $(add_frameworks_dep karchive) )
+   mediawiki? ( net-libs/libmediawiki:5 )
+   remotestorage? ( $(add_frameworks_dep kio) )
+   vkontakte? ( net-libs/libkvkontakte:5 )
+"
+DEPEND="${COMMON_DEPEND}
+   $(add_qt_dep qtconcurrent)
+   sys-devel/gettext
+"
+RDEPEND="${COMMON_DEPEND}
+   !media-plugins/kipi-plugins:4
+"
+
+src_prepare() {
+   if [[ ${KDE_BUILD_TYPE} = release ]]; then
+   if [[ ${SRC_BRANCH} = stable ]]; then
+   # prepare the translations
+   mv "${WORKDIR}/${MY_P}/po" po || die
+   find po -name "*.po" -and -not -name "kipiplugin*.po" 
-delete || die
+   echo "find_package(Gettext REQUIRED)" >> CMakeLists.txt 
|| die
+   echo "add_subdirectory( po )" >> CMakeLists.txt || die
+   fi
+   fi
+
+   kde5_src_prepare
+}
+
+src_configure() {
+   local mycmakeargs=(
+   $(cmake-utils_use_find_package flashexport KF5Archive)
+   $(cmake-utils_use_find_package mediawiki KF5MediaWiki)
+   -DENABLE_KIO=$(usex remotestorage)
+   $(cmake-utils_use_find_package vkontakte KF5Vkontakte)
+   )
+
+   kde5_src_configure
+}



[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2018-03-16 Thread Andreas Sturmlechner
commit: 6a380d12c5e620c2868a88d5616f245a5c3258b1
Author: Andreas Sturmlechner  gentoo  org>
AuthorDate: Fri Mar 16 21:54:21 2018 +
Commit: Andreas Sturmlechner  gentoo  org>
CommitDate: Sat Mar 17 00:26:26 2018 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=6a380d12

media-plugins/kipi-plugins: Drop 5.5.0

Package-Manager: Portage-2.3.24, Repoman-2.3.6

 media-plugins/kipi-plugins/Manifest|  1 -
 .../kipi-plugins/kipi-plugins-5.5.0.ebuild | 83 --
 2 files changed, 84 deletions(-)

diff --git a/media-plugins/kipi-plugins/Manifest 
b/media-plugins/kipi-plugins/Manifest
index df4ebda002b..76ae0410132 100644
--- a/media-plugins/kipi-plugins/Manifest
+++ b/media-plugins/kipi-plugins/Manifest
@@ -1,2 +1 @@
-DIST digikam-5.5.0.tar.xz 129499600 BLAKE2B 
73722461e1d4cb4dda2d0628abe2f4b7b9811aa588350c46c2323e25a84d1c2d76e2dfd084d590458acf721bb397541e559823564816b374e6b3fd372f980f42
 SHA512 
3c64774916d4804d932009ba3753d387ecf31e9e3d435c580497d3badb6cc3e57ab5ef1a2334a23379d0987d96dd107be4f01adbb63039f4510aa94ac6d71344
 DIST digikam-5.7.0.tar.xz 123315064 BLAKE2B 
0879b25e674e39d204038ab629dec36757ae034e3dd7e9a0a3700f9703272c4a972a21c1db5a42c6c294247a1226b1cb9a8b980bb90cdcc12e0cd752459273ef
 SHA512 
626c9854311c637b994325237f171adce3dba39159fb336dfe95f1de287e2d08a3aaddd611eea87e8018047d331aff252b555c382cfbe1d8e14413c51a3849f4

diff --git a/media-plugins/kipi-plugins/kipi-plugins-5.5.0.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-5.5.0.ebuild
deleted file mode 100644
index a6282115d1a..000
--- a/media-plugins/kipi-plugins/kipi-plugins-5.5.0.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-KDE_TEST="true"
-inherit kde5
-
-DESCRIPTION="Plugins for the KDE Image Plugin Interface"
-HOMEPAGE="https://www.digikam.org/;
-
-LICENSE="GPL-2+"
-KEYWORDS="amd64 x86"
-IUSE="flashexport mediawiki +remotestorage vkontakte"
-
-if [[ ${KDE_BUILD_TYPE} = release ]]; then
-   MY_PV="${PV/_/-}"
-   MY_P="digikam-${MY_PV}"
-
-   if [[ ${PV} =~ beta[0-9]$ ]]; then
-   SRC_BRANCH="unstable"
-   else
-   SRC_BRANCH="stable"
-   fi
-
-   SRC_URI="mirror://kde/${SRC_BRANCH}/digikam/${MY_P}.tar.xz"
-
-   S="${WORKDIR}/${MY_P}/extra/${PN}"
-fi
-
-COMMON_DEPEND="
-   $(add_frameworks_dep kcompletion)
-   $(add_frameworks_dep kconfig)
-   $(add_frameworks_dep kconfigwidgets)
-   $(add_frameworks_dep kcoreaddons)
-   $(add_frameworks_dep ki18n)
-   $(add_frameworks_dep kwindowsystem)
-   $(add_frameworks_dep kxmlgui)
-   $(add_kdeapps_dep libkipi '' '' '5=')
-   $(add_qt_dep qtgui)
-   $(add_qt_dep qtnetwork)
-   $(add_qt_dep qtprintsupport)
-   $(add_qt_dep qtsvg)
-   $(add_qt_dep qtwidgets)
-   $(add_qt_dep qtxml)
-   $(add_qt_dep qtxmlpatterns)
-   flashexport? ( $(add_frameworks_dep karchive) )
-   mediawiki? ( net-libs/libmediawiki:5 )
-   remotestorage? ( $(add_frameworks_dep kio) )
-   vkontakte? ( net-libs/libkvkontakte:5 )
-"
-DEPEND="${COMMON_DEPEND}
-   $(add_qt_dep qtconcurrent)
-   sys-devel/gettext
-"
-RDEPEND="${COMMON_DEPEND}
-   !media-plugins/kipi-plugins:4
-"
-
-src_prepare() {
-   if [[ ${KDE_BUILD_TYPE} = release ]]; then
-   if [[ ${SRC_BRANCH} = stable ]]; then
-   # prepare the translations
-   mv "${WORKDIR}/${MY_P}/po" po || die
-   find po -name "*.po" -and -not -name "kipiplugin*.po" 
-delete || die
-   echo "find_package(Gettext REQUIRED)" >> CMakeLists.txt 
|| die
-   echo "add_subdirectory( po )" >> CMakeLists.txt || die
-   fi
-   fi
-
-   kde5_src_prepare
-}
-
-src_configure() {
-   local mycmakeargs=(
-   $(cmake-utils_use_find_package flashexport KF5Archive)
-   $(cmake-utils_use_find_package mediawiki KF5MediaWiki)
-   -DENABLE_KIO=$(usex remotestorage)
-   $(cmake-utils_use_find_package vkontakte KF5Vkontakte)
-   )
-
-   kde5_src_configure
-}



[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2017-12-16 Thread Tobias Klausmann
commit: 275a5278db399113203785294f53de065c3cb106
Author: Tobias Klausmann  gentoo  org>
AuthorDate: Sat Dec 16 14:18:10 2017 +
Commit: Tobias Klausmann  gentoo  org>
CommitDate: Sat Dec 16 17:23:49 2017 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=275a5278

media-plugins/kipi-plugins-5.7.0-r0: amd64 stable

Gentoo-Bug: http://bugs.gentoo.org/638400

 media-plugins/kipi-plugins/kipi-plugins-5.7.0.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/media-plugins/kipi-plugins/kipi-plugins-5.7.0.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-5.7.0.ebuild
index e8ef608dc0d..8335d0fe00e 100644
--- a/media-plugins/kipi-plugins/kipi-plugins-5.7.0.ebuild
+++ b/media-plugins/kipi-plugins/kipi-plugins-5.7.0.ebuild
@@ -13,7 +13,7 @@ LICENSE="GPL-2+"
 IUSE="flashexport mediawiki +remotestorage vkontakte"
 
 if [[ ${KDE_BUILD_TYPE} = release ]]; then
-   KEYWORDS="~amd64 x86"
+   KEYWORDS="amd64 x86"
if [[ ${PV} =~ beta[0-9]$ ]]; then
SRC_BRANCH="unstable"
else



[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2017-12-08 Thread Thomas Deutschmann
commit: 033bc1b0caa75739860238ab3cede829eef062eb
Author: Thomas Deutschmann  gentoo  org>
AuthorDate: Fri Dec  8 21:38:26 2017 +
Commit: Thomas Deutschmann  gentoo  org>
CommitDate: Fri Dec  8 21:58:43 2017 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=033bc1b0

media-plugins/kipi-plugins: x86 stable (bug #638400)

Package-Manager: Portage-2.3.16, Repoman-2.3.6

 media-plugins/kipi-plugins/kipi-plugins-5.7.0.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/media-plugins/kipi-plugins/kipi-plugins-5.7.0.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-5.7.0.ebuild
index 8f69d808059..e8ef608dc0d 100644
--- a/media-plugins/kipi-plugins/kipi-plugins-5.7.0.ebuild
+++ b/media-plugins/kipi-plugins/kipi-plugins-5.7.0.ebuild
@@ -13,7 +13,7 @@ LICENSE="GPL-2+"
 IUSE="flashexport mediawiki +remotestorage vkontakte"
 
 if [[ ${KDE_BUILD_TYPE} = release ]]; then
-   KEYWORDS="~amd64 ~x86"
+   KEYWORDS="~amd64 x86"
if [[ ${PV} =~ beta[0-9]$ ]]; then
SRC_BRANCH="unstable"
else



[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2017-09-06 Thread Johannes Huber
commit: fcfe5fd0694c591e423acf9f3df46c7d34e0651b
Author: Johannes Huber  gentoo  org>
AuthorDate: Wed Sep  6 18:44:12 2017 +
Commit: Johannes Huber  gentoo  org>
CommitDate: Wed Sep  6 18:50:19 2017 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=fcfe5fd0

media-plugins/kipi-plugins: Version bump 5.7.0

Package-Manager: Portage-2.3.8, Repoman-2.3.3

 media-plugins/kipi-plugins/Manifest|  1 +
 .../kipi-plugins/kipi-plugins-5.7.0.ebuild | 81 ++
 2 files changed, 82 insertions(+)

diff --git a/media-plugins/kipi-plugins/Manifest 
b/media-plugins/kipi-plugins/Manifest
index 085d5348886..8bc66589753 100644
--- a/media-plugins/kipi-plugins/Manifest
+++ b/media-plugins/kipi-plugins/Manifest
@@ -1,2 +1,3 @@
 DIST digikam-5.5.0.tar.xz 129499600 SHA256 
df9cbf1b8dbfb9235cebc97e77c02fcb1498c5a905c7fd3b9fb42fd7accc6252 SHA512 
3c64774916d4804d932009ba3753d387ecf31e9e3d435c580497d3badb6cc3e57ab5ef1a2334a23379d0987d96dd107be4f01adbb63039f4510aa94ac6d71344
 WHIRLPOOL 
e67b444975ad37e939b2f62bba949bcafb41eee2975470daa02e4ffdd62c6c792b6656edf4811daead52fdc1bf064951fbec7b687192e5d5ee542d5d706140be
 DIST digikam-5.6.0.tar.xz 166913492 SHA256 
65bdd3f15668e314b852d523a0bf95da32450f31fcfda60da62e57d4622a663c SHA512 
015024aaff6193ca29072f7340d62982b50467d84b69bac38f60319eaf771ce2a570a514e62fefc54f194b0c27df0c36980b1eed3433023a2d8290f24cc8905d
 WHIRLPOOL 
a8af3ac8e71cc2205027b9151cba9e57a266d590e7f26bd21f691cabd9b07212043d116d4f95fb2680e3e03a6884a58dc553bb3339fc59b3e9fc927432d0272f
+DIST digikam-5.7.0.tar.xz 123315064 SHA256 
3605ffb5b6e8fbd6b725e5075f74f505d7edee7531789c2882d11df2d20150f5 SHA512 
626c9854311c637b994325237f171adce3dba39159fb336dfe95f1de287e2d08a3aaddd611eea87e8018047d331aff252b555c382cfbe1d8e14413c51a3849f4
 WHIRLPOOL 
b452919ce9bcf8ccc8434586ace23b96b68b76f49d7229d418b2dc5883e9646c79fb99ecd660d732b8d96efc3a49b70d218756b09a3f16ef9f7f2b174679be70

diff --git a/media-plugins/kipi-plugins/kipi-plugins-5.7.0.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-5.7.0.ebuild
new file mode 100644
index 000..8f69d808059
--- /dev/null
+++ b/media-plugins/kipi-plugins/kipi-plugins-5.7.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="Plugins for the KDE Image Plugin Interface"
+HOMEPAGE="https://www.digikam.org/;
+
+LICENSE="GPL-2+"
+IUSE="flashexport mediawiki +remotestorage vkontakte"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+   KEYWORDS="~amd64 ~x86"
+   if [[ ${PV} =~ beta[0-9]$ ]]; then
+   SRC_BRANCH="unstable"
+   else
+   SRC_BRANCH="stable"
+   fi
+
+   MY_PV="${PV/_/-}"
+   MY_P="digikam-${MY_PV}"
+   SRC_URI="mirror://kde/${SRC_BRANCH}/digikam/${MY_P}.tar.xz"
+   S="${WORKDIR}/${MY_P}/extra/${PN}"
+fi
+
+COMMON_DEPEND="
+   $(add_frameworks_dep kcompletion)
+   $(add_frameworks_dep kconfig)
+   $(add_frameworks_dep kconfigwidgets)
+   $(add_frameworks_dep kcoreaddons)
+   $(add_frameworks_dep ki18n)
+   $(add_frameworks_dep kwindowsystem)
+   $(add_frameworks_dep kxmlgui)
+   $(add_kdeapps_dep libkipi '' '' '5=')
+   $(add_qt_dep qtgui)
+   $(add_qt_dep qtnetwork)
+   $(add_qt_dep qtprintsupport)
+   $(add_qt_dep qtsvg)
+   $(add_qt_dep qtwidgets)
+   $(add_qt_dep qtxml)
+   $(add_qt_dep qtxmlpatterns)
+   flashexport? ( $(add_frameworks_dep karchive) )
+   mediawiki? ( net-libs/libmediawiki:5 )
+   remotestorage? ( $(add_frameworks_dep kio) )
+   vkontakte? ( net-libs/libkvkontakte:5 )
+"
+DEPEND="${COMMON_DEPEND}
+   $(add_qt_dep qtconcurrent)
+   sys-devel/gettext
+"
+RDEPEND="${COMMON_DEPEND}
+   !media-plugins/kipi-plugins:4
+"
+
+src_prepare() {
+   if [[ ${KDE_BUILD_TYPE} = release ]]; then
+   if [[ ${SRC_BRANCH} = stable ]]; then
+   # prepare the translations
+   mv "${WORKDIR}/${MY_P}/po" po || die
+   find po -name "*.po" -and -not -name "kipiplugin*.po" 
-delete || die
+   echo "find_package(Gettext REQUIRED)" >> CMakeLists.txt 
|| die
+   echo "add_subdirectory( po )" >> CMakeLists.txt || die
+   fi
+   fi
+
+   kde5_src_prepare
+}
+
+src_configure() {
+   local mycmakeargs=(
+   $(cmake-utils_use_find_package flashexport KF5Archive)
+   $(cmake-utils_use_find_package mediawiki KF5MediaWiki)
+   -DENABLE_KIO=$(usex remotestorage)
+   $(cmake-utils_use_find_package vkontakte KF5Vkontakte)
+   )
+
+   kde5_src_configure
+}



[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2017-09-06 Thread Johannes Huber
commit: 1adeeb50173bdb6c6e73d54ab40c966566b441bb
Author: Johannes Huber  gentoo  org>
AuthorDate: Wed Sep  6 18:44:47 2017 +
Commit: Johannes Huber  gentoo  org>
CommitDate: Wed Sep  6 18:50:19 2017 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=1adeeb50

media-plugins/kipi-plugins: Remove 5.6.0

Package-Manager: Portage-2.3.8, Repoman-2.3.3

 media-plugins/kipi-plugins/Manifest|  1 -
 .../kipi-plugins/kipi-plugins-5.6.0.ebuild | 83 --
 2 files changed, 84 deletions(-)

diff --git a/media-plugins/kipi-plugins/Manifest 
b/media-plugins/kipi-plugins/Manifest
index 8bc66589753..c301533b1d9 100644
--- a/media-plugins/kipi-plugins/Manifest
+++ b/media-plugins/kipi-plugins/Manifest
@@ -1,3 +1,2 @@
 DIST digikam-5.5.0.tar.xz 129499600 SHA256 
df9cbf1b8dbfb9235cebc97e77c02fcb1498c5a905c7fd3b9fb42fd7accc6252 SHA512 
3c64774916d4804d932009ba3753d387ecf31e9e3d435c580497d3badb6cc3e57ab5ef1a2334a23379d0987d96dd107be4f01adbb63039f4510aa94ac6d71344
 WHIRLPOOL 
e67b444975ad37e939b2f62bba949bcafb41eee2975470daa02e4ffdd62c6c792b6656edf4811daead52fdc1bf064951fbec7b687192e5d5ee542d5d706140be
-DIST digikam-5.6.0.tar.xz 166913492 SHA256 
65bdd3f15668e314b852d523a0bf95da32450f31fcfda60da62e57d4622a663c SHA512 
015024aaff6193ca29072f7340d62982b50467d84b69bac38f60319eaf771ce2a570a514e62fefc54f194b0c27df0c36980b1eed3433023a2d8290f24cc8905d
 WHIRLPOOL 
a8af3ac8e71cc2205027b9151cba9e57a266d590e7f26bd21f691cabd9b07212043d116d4f95fb2680e3e03a6884a58dc553bb3339fc59b3e9fc927432d0272f
 DIST digikam-5.7.0.tar.xz 123315064 SHA256 
3605ffb5b6e8fbd6b725e5075f74f505d7edee7531789c2882d11df2d20150f5 SHA512 
626c9854311c637b994325237f171adce3dba39159fb336dfe95f1de287e2d08a3aaddd611eea87e8018047d331aff252b555c382cfbe1d8e14413c51a3849f4
 WHIRLPOOL 
b452919ce9bcf8ccc8434586ace23b96b68b76f49d7229d418b2dc5883e9646c79fb99ecd660d732b8d96efc3a49b70d218756b09a3f16ef9f7f2b174679be70

diff --git a/media-plugins/kipi-plugins/kipi-plugins-5.6.0.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-5.6.0.ebuild
deleted file mode 100644
index 5bcd38bc4ad..000
--- a/media-plugins/kipi-plugins/kipi-plugins-5.6.0.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-KDE_TEST="true"
-inherit kde5
-
-DESCRIPTION="Plugins for the KDE Image Plugin Interface"
-HOMEPAGE="https://www.digikam.org/;
-
-LICENSE="GPL-2+"
-KEYWORDS="~amd64 ~x86"
-IUSE="flashexport mediawiki +remotestorage vkontakte"
-
-if [[ ${KDE_BUILD_TYPE} = release ]]; then
-   MY_PV="${PV/_/-}"
-   MY_P="digikam-${MY_PV}"
-
-   if [[ ${PV} =~ beta[0-9]$ ]]; then
-   SRC_BRANCH="unstable"
-   else
-   SRC_BRANCH="stable"
-   fi
-
-   SRC_URI="mirror://kde/${SRC_BRANCH}/digikam/${MY_P}.tar.xz"
-
-   S="${WORKDIR}/${MY_P}/extra/${PN}"
-fi
-
-COMMON_DEPEND="
-   $(add_frameworks_dep kcompletion)
-   $(add_frameworks_dep kconfig)
-   $(add_frameworks_dep kconfigwidgets)
-   $(add_frameworks_dep kcoreaddons)
-   $(add_frameworks_dep ki18n)
-   $(add_frameworks_dep kwindowsystem)
-   $(add_frameworks_dep kxmlgui)
-   $(add_kdeapps_dep libkipi '' '' '5=')
-   $(add_qt_dep qtgui)
-   $(add_qt_dep qtnetwork)
-   $(add_qt_dep qtprintsupport)
-   $(add_qt_dep qtsvg)
-   $(add_qt_dep qtwidgets)
-   $(add_qt_dep qtxml)
-   $(add_qt_dep qtxmlpatterns)
-   flashexport? ( $(add_frameworks_dep karchive) )
-   mediawiki? ( net-libs/libmediawiki:5 )
-   remotestorage? ( $(add_frameworks_dep kio) )
-   vkontakte? ( net-libs/libkvkontakte:5 )
-"
-DEPEND="${COMMON_DEPEND}
-   $(add_qt_dep qtconcurrent)
-   sys-devel/gettext
-"
-RDEPEND="${COMMON_DEPEND}
-   !media-plugins/kipi-plugins:4
-"
-
-src_prepare() {
-   if [[ ${KDE_BUILD_TYPE} = release ]]; then
-   if [[ ${SRC_BRANCH} = stable ]]; then
-   # prepare the translations
-   mv "${WORKDIR}/${MY_P}/po" po || die
-   find po -name "*.po" -and -not -name "kipiplugin*.po" 
-delete || die
-   echo "find_package(Gettext REQUIRED)" >> CMakeLists.txt 
|| die
-   echo "add_subdirectory( po )" >> CMakeLists.txt || die
-   fi
-   fi
-
-   kde5_src_prepare
-}
-
-src_configure() {
-   local mycmakeargs=(
-   $(cmake-utils_use_find_package flashexport KF5Archive)
-   $(cmake-utils_use_find_package mediawiki KF5MediaWiki)
-   -DENABLE_KIO=$(usex remotestorage)
-   $(cmake-utils_use_find_package vkontakte KF5Vkontakte)
-   )
-
-   kde5_src_configure
-}



[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2017-06-23 Thread Michael Palimaka
commit: b098f0bdc3e491e2e599fd94e660c001b5e13cc9
Author: Michael Palimaka  gentoo  org>
AuthorDate: Sat Jun 24 03:15:18 2017 +
Commit: Michael Palimaka  gentoo  org>
CommitDate: Sat Jun 24 03:15:22 2017 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=b098f0bd

media-plugins/kipi-plugins: version bump 5.6.0

Package-Manager: Portage-2.3.6, Repoman-2.3.2

 media-plugins/kipi-plugins/Manifest|  1 +
 .../kipi-plugins/kipi-plugins-5.6.0.ebuild | 83 ++
 2 files changed, 84 insertions(+)

diff --git a/media-plugins/kipi-plugins/Manifest 
b/media-plugins/kipi-plugins/Manifest
index 0ccca3cbdd0..085d5348886 100644
--- a/media-plugins/kipi-plugins/Manifest
+++ b/media-plugins/kipi-plugins/Manifest
@@ -1 +1,2 @@
 DIST digikam-5.5.0.tar.xz 129499600 SHA256 
df9cbf1b8dbfb9235cebc97e77c02fcb1498c5a905c7fd3b9fb42fd7accc6252 SHA512 
3c64774916d4804d932009ba3753d387ecf31e9e3d435c580497d3badb6cc3e57ab5ef1a2334a23379d0987d96dd107be4f01adbb63039f4510aa94ac6d71344
 WHIRLPOOL 
e67b444975ad37e939b2f62bba949bcafb41eee2975470daa02e4ffdd62c6c792b6656edf4811daead52fdc1bf064951fbec7b687192e5d5ee542d5d706140be
+DIST digikam-5.6.0.tar.xz 166913492 SHA256 
65bdd3f15668e314b852d523a0bf95da32450f31fcfda60da62e57d4622a663c SHA512 
015024aaff6193ca29072f7340d62982b50467d84b69bac38f60319eaf771ce2a570a514e62fefc54f194b0c27df0c36980b1eed3433023a2d8290f24cc8905d
 WHIRLPOOL 
a8af3ac8e71cc2205027b9151cba9e57a266d590e7f26bd21f691cabd9b07212043d116d4f95fb2680e3e03a6884a58dc553bb3339fc59b3e9fc927432d0272f

diff --git a/media-plugins/kipi-plugins/kipi-plugins-5.6.0.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-5.6.0.ebuild
new file mode 100644
index 000..5bcd38bc4ad
--- /dev/null
+++ b/media-plugins/kipi-plugins/kipi-plugins-5.6.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="Plugins for the KDE Image Plugin Interface"
+HOMEPAGE="https://www.digikam.org/;
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="flashexport mediawiki +remotestorage vkontakte"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+   MY_PV="${PV/_/-}"
+   MY_P="digikam-${MY_PV}"
+
+   if [[ ${PV} =~ beta[0-9]$ ]]; then
+   SRC_BRANCH="unstable"
+   else
+   SRC_BRANCH="stable"
+   fi
+
+   SRC_URI="mirror://kde/${SRC_BRANCH}/digikam/${MY_P}.tar.xz"
+
+   S="${WORKDIR}/${MY_P}/extra/${PN}"
+fi
+
+COMMON_DEPEND="
+   $(add_frameworks_dep kcompletion)
+   $(add_frameworks_dep kconfig)
+   $(add_frameworks_dep kconfigwidgets)
+   $(add_frameworks_dep kcoreaddons)
+   $(add_frameworks_dep ki18n)
+   $(add_frameworks_dep kwindowsystem)
+   $(add_frameworks_dep kxmlgui)
+   $(add_kdeapps_dep libkipi '' '' '5=')
+   $(add_qt_dep qtgui)
+   $(add_qt_dep qtnetwork)
+   $(add_qt_dep qtprintsupport)
+   $(add_qt_dep qtsvg)
+   $(add_qt_dep qtwidgets)
+   $(add_qt_dep qtxml)
+   $(add_qt_dep qtxmlpatterns)
+   flashexport? ( $(add_frameworks_dep karchive) )
+   mediawiki? ( net-libs/libmediawiki:5 )
+   remotestorage? ( $(add_frameworks_dep kio) )
+   vkontakte? ( net-libs/libkvkontakte:5 )
+"
+DEPEND="${COMMON_DEPEND}
+   $(add_qt_dep qtconcurrent)
+   sys-devel/gettext
+"
+RDEPEND="${COMMON_DEPEND}
+   !media-plugins/kipi-plugins:4
+"
+
+src_prepare() {
+   if [[ ${KDE_BUILD_TYPE} = release ]]; then
+   if [[ ${SRC_BRANCH} = stable ]]; then
+   # prepare the translations
+   mv "${WORKDIR}/${MY_P}/po" po || die
+   find po -name "*.po" -and -not -name "kipiplugin*.po" 
-delete || die
+   echo "find_package(Gettext REQUIRED)" >> CMakeLists.txt 
|| die
+   echo "add_subdirectory( po )" >> CMakeLists.txt || die
+   fi
+   fi
+
+   kde5_src_prepare
+}
+
+src_configure() {
+   local mycmakeargs=(
+   $(cmake-utils_use_find_package flashexport KF5Archive)
+   $(cmake-utils_use_find_package mediawiki KF5MediaWiki)
+   -DENABLE_KIO=$(usex remotestorage)
+   $(cmake-utils_use_find_package vkontakte KF5Vkontakte)
+   )
+
+   kde5_src_configure
+}



[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2017-04-27 Thread Michael Palimaka
commit: 6029a5e1e7f3644d550b1c2069ad7dd5d3798e39
Author: Michael Palimaka  gentoo  org>
AuthorDate: Thu Apr 27 12:11:23 2017 +
Commit: Michael Palimaka  gentoo  org>
CommitDate: Thu Apr 27 12:17:04 2017 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=6029a5e1

media-plugins/kipi-plugins: remove 5.3.0

Package-Manager: Portage-2.3.5, Repoman-2.3.2

 media-plugins/kipi-plugins/Manifest|  1 -
 .../kipi-plugins/kipi-plugins-5.3.0.ebuild | 83 --
 2 files changed, 84 deletions(-)

diff --git a/media-plugins/kipi-plugins/Manifest 
b/media-plugins/kipi-plugins/Manifest
index aa72b433e7d..0ccca3cbdd0 100644
--- a/media-plugins/kipi-plugins/Manifest
+++ b/media-plugins/kipi-plugins/Manifest
@@ -1,2 +1 @@
-DIST digikam-5.3.0.tar.xz 121417224 SHA256 
b36cfa27278936d41ab5f33c99fe9ccdfd545eada3e1e32efe9f9e3fdf2c3e5c SHA512 
6190944d09badec6ddac194f2029e86d0ef658e08a6a120f04c86109dc2b9d9cd2e772a900d09781b563fcd0caaff186fb5fd6cde9744ce3b4e8dcc9ff29d421
 WHIRLPOOL 
c1c0987e23587356968484d936a0a99f10d6e6ce004ffe1f5eb4d0a42b59fc1e84ec4a03f491c91c93be172ab6b78444c684221fb515e1562cc76bcc61346158
 DIST digikam-5.5.0.tar.xz 129499600 SHA256 
df9cbf1b8dbfb9235cebc97e77c02fcb1498c5a905c7fd3b9fb42fd7accc6252 SHA512 
3c64774916d4804d932009ba3753d387ecf31e9e3d435c580497d3badb6cc3e57ab5ef1a2334a23379d0987d96dd107be4f01adbb63039f4510aa94ac6d71344
 WHIRLPOOL 
e67b444975ad37e939b2f62bba949bcafb41eee2975470daa02e4ffdd62c6c792b6656edf4811daead52fdc1bf064951fbec7b687192e5d5ee542d5d706140be

diff --git a/media-plugins/kipi-plugins/kipi-plugins-5.3.0.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-5.3.0.ebuild
deleted file mode 100644
index 3efe19dd070..000
--- a/media-plugins/kipi-plugins/kipi-plugins-5.3.0.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-KDE_TEST="true"
-inherit kde5
-
-DESCRIPTION="Plugins for the KDE Image Plugin Interface"
-HOMEPAGE="https://www.digikam.org/;
-
-LICENSE="GPL-2+"
-KEYWORDS="amd64 x86"
-IUSE="flashexport mediawiki +remotestorage vkontakte"
-
-if [[ ${KDE_BUILD_TYPE} = release ]]; then
-   MY_PV="${PV/_/-}"
-   MY_P="digikam-${MY_PV}"
-
-   if [[ ${PV} =~ beta[0-9]$ ]]; then
-   SRC_BRANCH="unstable"
-   else
-   SRC_BRANCH="stable"
-   fi
-
-   SRC_URI="mirror://kde/${SRC_BRANCH}/digikam/${MY_P}.tar.xz"
-
-   S="${WORKDIR}/${MY_P}/extra/${PN}"
-fi
-
-COMMON_DEPEND="
-   $(add_frameworks_dep kcompletion)
-   $(add_frameworks_dep kconfig)
-   $(add_frameworks_dep kconfigwidgets)
-   $(add_frameworks_dep kcoreaddons)
-   $(add_frameworks_dep ki18n)
-   $(add_frameworks_dep kwindowsystem)
-   $(add_frameworks_dep kxmlgui)
-   $(add_kdeapps_dep libkipi '' '16.08.3-r1' '5=')
-   $(add_qt_dep qtgui)
-   $(add_qt_dep qtnetwork)
-   $(add_qt_dep qtprintsupport)
-   $(add_qt_dep qtsvg)
-   $(add_qt_dep qtwidgets)
-   $(add_qt_dep qtxml)
-   $(add_qt_dep qtxmlpatterns)
-   flashexport? ( $(add_frameworks_dep karchive) )
-   mediawiki? ( net-libs/libmediawiki:5 )
-   remotestorage? ( $(add_frameworks_dep kio) )
-   vkontakte? ( net-libs/libkvkontakte:5 )
-"
-DEPEND="${COMMON_DEPEND}
-   $(add_qt_dep qtconcurrent)
-   sys-devel/gettext
-"
-RDEPEND="${COMMON_DEPEND}
-   !media-plugins/kipi-plugins:4
-"
-
-src_prepare() {
-   if [[ ${KDE_BUILD_TYPE} = release ]]; then
-   if [[ ${SRC_BRANCH} = stable ]]; then
-   # prepare the translations
-   mv "${WORKDIR}/${MY_P}/po" po || die
-   find po -name "*.po" -and -not -name "kipiplugin*.po" 
-delete || die
-   echo "find_package(Gettext REQUIRED)" >> CMakeLists.txt 
|| die
-   echo "add_subdirectory( po )" >> CMakeLists.txt || die
-   fi
-   fi
-
-   kde5_src_prepare
-}
-
-src_configure() {
-   local mycmakeargs=(
-   $(cmake-utils_use_find_package flashexport KF5Archive)
-   $(cmake-utils_use_find_package mediawiki KF5MediaWiki)
-   -DENABLE_KIO=$(usex remotestorage)
-   $(cmake-utils_use_find_package vkontakte KF5Vkontakte)
-   )
-
-   kde5_src_configure
-}



[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2017-04-24 Thread Agostino Sarubbo
commit: dea92edf150f9eaae9bf9a19448feee89bb7f287
Author: Agostino Sarubbo  gentoo  org>
AuthorDate: Mon Apr 24 07:23:01 2017 +
Commit: Agostino Sarubbo  gentoo  org>
CommitDate: Mon Apr 24 07:23:01 2017 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=dea92edf

media-plugins/kipi-plugins: amd64 stable wrt bug #616406

Package-Manager: Portage-2.3.3, Repoman-2.3.1
RepoMan-Options: --include-arches="amd64"
Signed-off-by: Agostino Sarubbo  gentoo.org>

 media-plugins/kipi-plugins/kipi-plugins-5.5.0.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/media-plugins/kipi-plugins/kipi-plugins-5.5.0.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-5.5.0.ebuild
index 5bcd38bc4ad..2abef6470ab 100644
--- a/media-plugins/kipi-plugins/kipi-plugins-5.5.0.ebuild
+++ b/media-plugins/kipi-plugins/kipi-plugins-5.5.0.ebuild
@@ -10,7 +10,7 @@ DESCRIPTION="Plugins for the KDE Image Plugin Interface"
 HOMEPAGE="https://www.digikam.org/;
 
 LICENSE="GPL-2+"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~x86"
 IUSE="flashexport mediawiki +remotestorage vkontakte"
 
 if [[ ${KDE_BUILD_TYPE} = release ]]; then



[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2017-03-18 Thread Andreas Sturmlechner
commit: 628f1b4d2239902de4362831447396e639e47e9e
Author: Andreas Sturmlechner  gentoo  org>
AuthorDate: Sat Mar 18 12:13:03 2017 +
Commit: Andreas Sturmlechner  gentoo  org>
CommitDate: Sat Mar 18 14:44:03 2017 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=628f1b4d

media-plugins/kipi-plugins: 5.5.0 version bump

Package-Manager: Portage-2.3.3, Repoman-2.3.1

 media-plugins/kipi-plugins/Manifest|  1 +
 .../kipi-plugins/kipi-plugins-5.5.0.ebuild | 83 ++
 2 files changed, 84 insertions(+)

diff --git a/media-plugins/kipi-plugins/Manifest 
b/media-plugins/kipi-plugins/Manifest
index 322cdeeabde..aa72b433e7d 100644
--- a/media-plugins/kipi-plugins/Manifest
+++ b/media-plugins/kipi-plugins/Manifest
@@ -1 +1,2 @@
 DIST digikam-5.3.0.tar.xz 121417224 SHA256 
b36cfa27278936d41ab5f33c99fe9ccdfd545eada3e1e32efe9f9e3fdf2c3e5c SHA512 
6190944d09badec6ddac194f2029e86d0ef658e08a6a120f04c86109dc2b9d9cd2e772a900d09781b563fcd0caaff186fb5fd6cde9744ce3b4e8dcc9ff29d421
 WHIRLPOOL 
c1c0987e23587356968484d936a0a99f10d6e6ce004ffe1f5eb4d0a42b59fc1e84ec4a03f491c91c93be172ab6b78444c684221fb515e1562cc76bcc61346158
+DIST digikam-5.5.0.tar.xz 129499600 SHA256 
df9cbf1b8dbfb9235cebc97e77c02fcb1498c5a905c7fd3b9fb42fd7accc6252 SHA512 
3c64774916d4804d932009ba3753d387ecf31e9e3d435c580497d3badb6cc3e57ab5ef1a2334a23379d0987d96dd107be4f01adbb63039f4510aa94ac6d71344
 WHIRLPOOL 
e67b444975ad37e939b2f62bba949bcafb41eee2975470daa02e4ffdd62c6c792b6656edf4811daead52fdc1bf064951fbec7b687192e5d5ee542d5d706140be

diff --git a/media-plugins/kipi-plugins/kipi-plugins-5.5.0.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-5.5.0.ebuild
new file mode 100644
index 000..5bcd38bc4ad
--- /dev/null
+++ b/media-plugins/kipi-plugins/kipi-plugins-5.5.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="Plugins for the KDE Image Plugin Interface"
+HOMEPAGE="https://www.digikam.org/;
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="flashexport mediawiki +remotestorage vkontakte"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+   MY_PV="${PV/_/-}"
+   MY_P="digikam-${MY_PV}"
+
+   if [[ ${PV} =~ beta[0-9]$ ]]; then
+   SRC_BRANCH="unstable"
+   else
+   SRC_BRANCH="stable"
+   fi
+
+   SRC_URI="mirror://kde/${SRC_BRANCH}/digikam/${MY_P}.tar.xz"
+
+   S="${WORKDIR}/${MY_P}/extra/${PN}"
+fi
+
+COMMON_DEPEND="
+   $(add_frameworks_dep kcompletion)
+   $(add_frameworks_dep kconfig)
+   $(add_frameworks_dep kconfigwidgets)
+   $(add_frameworks_dep kcoreaddons)
+   $(add_frameworks_dep ki18n)
+   $(add_frameworks_dep kwindowsystem)
+   $(add_frameworks_dep kxmlgui)
+   $(add_kdeapps_dep libkipi '' '' '5=')
+   $(add_qt_dep qtgui)
+   $(add_qt_dep qtnetwork)
+   $(add_qt_dep qtprintsupport)
+   $(add_qt_dep qtsvg)
+   $(add_qt_dep qtwidgets)
+   $(add_qt_dep qtxml)
+   $(add_qt_dep qtxmlpatterns)
+   flashexport? ( $(add_frameworks_dep karchive) )
+   mediawiki? ( net-libs/libmediawiki:5 )
+   remotestorage? ( $(add_frameworks_dep kio) )
+   vkontakte? ( net-libs/libkvkontakte:5 )
+"
+DEPEND="${COMMON_DEPEND}
+   $(add_qt_dep qtconcurrent)
+   sys-devel/gettext
+"
+RDEPEND="${COMMON_DEPEND}
+   !media-plugins/kipi-plugins:4
+"
+
+src_prepare() {
+   if [[ ${KDE_BUILD_TYPE} = release ]]; then
+   if [[ ${SRC_BRANCH} = stable ]]; then
+   # prepare the translations
+   mv "${WORKDIR}/${MY_P}/po" po || die
+   find po -name "*.po" -and -not -name "kipiplugin*.po" 
-delete || die
+   echo "find_package(Gettext REQUIRED)" >> CMakeLists.txt 
|| die
+   echo "add_subdirectory( po )" >> CMakeLists.txt || die
+   fi
+   fi
+
+   kde5_src_prepare
+}
+
+src_configure() {
+   local mycmakeargs=(
+   $(cmake-utils_use_find_package flashexport KF5Archive)
+   $(cmake-utils_use_find_package mediawiki KF5MediaWiki)
+   -DENABLE_KIO=$(usex remotestorage)
+   $(cmake-utils_use_find_package vkontakte KF5Vkontakte)
+   )
+
+   kde5_src_configure
+}



[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2016-12-23 Thread Johannes Huber
commit: ed041571f49114a8047fc386228933f10fc04afd
Author: Johannes Huber  gentoo  org>
AuthorDate: Fri Dec 23 09:50:13 2016 +
Commit: Johannes Huber  gentoo  org>
CommitDate: Fri Dec 23 10:11:30 2016 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ed041571

media-plugins/kipi-plugins: Drop CMAKE_MIN_VERSION

Covered by cmake-utils eclass now.

Package-Manager: Portage-2.3.3, Repoman-2.3.1

 media-plugins/kipi-plugins/kipi-plugins-5.3.0.ebuild | 1 -
 1 file changed, 1 deletion(-)

diff --git a/media-plugins/kipi-plugins/kipi-plugins-5.3.0.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-5.3.0.ebuild
index 334fd0b..9d47b42 100644
--- a/media-plugins/kipi-plugins/kipi-plugins-5.3.0.ebuild
+++ b/media-plugins/kipi-plugins/kipi-plugins-5.3.0.ebuild
@@ -4,7 +4,6 @@
 
 EAPI=6
 
-CMAKE_MIN_VERSION="3.0"
 KDE_TEST="true"
 inherit kde5
 



[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2016-12-08 Thread Michael Palimaka
commit: 5c0110dba653271e7677d55715f3c844f8cd6a21
Author: Michael Palimaka  gentoo  org>
AuthorDate: Thu Dec  8 07:46:21 2016 +
Commit: Michael Palimaka  gentoo  org>
CommitDate: Thu Dec  8 17:16:45 2016 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=5c0110db

media-plugins/kipi-plugins: stabilise 5.3.0 on amd64/x86

Gentoo-bug: 566918

Package-Manager: portage-2.3.3

 media-plugins/kipi-plugins/kipi-plugins-5.3.0.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/media-plugins/kipi-plugins/kipi-plugins-5.3.0.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-5.3.0.ebuild
index 586ab18..334fd0b 100644
--- a/media-plugins/kipi-plugins/kipi-plugins-5.3.0.ebuild
+++ b/media-plugins/kipi-plugins/kipi-plugins-5.3.0.ebuild
@@ -12,7 +12,7 @@ DESCRIPTION="Plugins for the KDE Image Plugin Interface"
 HOMEPAGE="https://www.digikam.org/;
 
 LICENSE="GPL-2+"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
 IUSE="flashexport mediawiki +remotestorage vkontakte"
 
 if [[ ${KDE_BUILD_TYPE} = release ]]; then



[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2016-12-08 Thread Michael Palimaka
commit: 8eaafc7fae8f55db632e1a2b361a7120f8c6131f
Author: Michael Palimaka  gentoo  org>
AuthorDate: Thu Dec  8 07:41:01 2016 +
Commit: Michael Palimaka  gentoo  org>
CommitDate: Thu Dec  8 17:16:45 2016 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=8eaafc7f

media-plugins/kipi-plugins: raise kde-apps/libkipi dependency

This resolves a build failure caused by eariler versions (see 
1b14ac478300a2b2bb2bb29f131e336ced13cb35).

Package-Manager: portage-2.3.3

 media-plugins/kipi-plugins/kipi-plugins-5.3.0.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/media-plugins/kipi-plugins/kipi-plugins-5.3.0.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-5.3.0.ebuild
index 4a4a3d3..586ab18 100644
--- a/media-plugins/kipi-plugins/kipi-plugins-5.3.0.ebuild
+++ b/media-plugins/kipi-plugins/kipi-plugins-5.3.0.ebuild
@@ -38,7 +38,7 @@ COMMON_DEPEND="
$(add_frameworks_dep ki18n)
$(add_frameworks_dep kwindowsystem)
$(add_frameworks_dep kxmlgui)
-   $(add_kdeapps_dep libkipi '' '' '5=')
+   $(add_kdeapps_dep libkipi '' '16.08.3-r1' '5=')
$(add_qt_dep qtgui)
$(add_qt_dep qtnetwork)
$(add_qt_dep qtprintsupport)



[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2016-11-24 Thread Michael Palimaka
commit: cd685a9ed72ec03f986b12af7fe65ba07a4a9d9c
Author: Andreas Sturmlechner  gmail  com>
AuthorDate: Thu Nov 24 19:46:31 2016 +
Commit: Michael Palimaka  gentoo  org>
CommitDate: Fri Nov 25 05:59:41 2016 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=cd685a9e

media-plugins/kipi-plugins: Use upstream provided build switch for KIO

Package-Manager: portage-2.3.0

 media-plugins/kipi-plugins/kipi-plugins-5.3.0.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/media-plugins/kipi-plugins/kipi-plugins-5.3.0.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-5.3.0.ebuild
index 5bcebc1..4a4a3d3 100644
--- a/media-plugins/kipi-plugins/kipi-plugins-5.3.0.ebuild
+++ b/media-plugins/kipi-plugins/kipi-plugins-5.3.0.ebuild
@@ -77,7 +77,7 @@ src_configure() {
local mycmakeargs=(
$(cmake-utils_use_find_package flashexport KF5Archive)
$(cmake-utils_use_find_package mediawiki KF5MediaWiki)
-   $(cmake-utils_use_find_package remotestorage KF5KIO)
+   -DENABLE_KIO=$(usex remotestorage)
$(cmake-utils_use_find_package vkontakte KF5Vkontakte)
)
 



[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2016-11-08 Thread Johannes Huber
commit: 90ce564f9c21a1e626961454821de440abb5a300
Author: Johannes Huber  gentoo  org>
AuthorDate: Tue Nov  8 09:25:30 2016 +
Commit: Johannes Huber  gentoo  org>
CommitDate: Tue Nov  8 09:26:20 2016 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=90ce564f

media-plugins/kipi-plugins: Remove 5.2.0

Package-Manager: portage-2.3.2

 media-plugins/kipi-plugins/Manifest|  1 -
 .../kipi-plugins/kipi-plugins-5.2.0.ebuild | 89 --
 2 files changed, 90 deletions(-)

diff --git a/media-plugins/kipi-plugins/Manifest 
b/media-plugins/kipi-plugins/Manifest
index df8e98e..c0d6405 100644
--- a/media-plugins/kipi-plugins/Manifest
+++ b/media-plugins/kipi-plugins/Manifest
@@ -1,4 +1,3 @@
 DIST digikam-4.14.0.tar.bz2 59805228 SHA256 
9d7bcb689d8c29be2e81976f0a043220f442a24f2071284044e7f1a799a7fdad SHA512 
3029e9b67d9d055bd9aee0d6d01e87950702e026f9f44b513155946ba087ec58b300f945a035a418afae45365ed007d8db6a1a90ed1d391e5e0e4cb679168ccf
 WHIRLPOOL 
35a3caedc9a4799f161b26b3b4df51da18a31be50a8a6da5b12a339a353755d73a47f103099087e3dc8e6926f65ae19638efea3585c86f72173a086056bf48ce
 DIST digikam-4.4.0.tar.bz2 68871203 SHA256 
5c68a2d200f5b502706128ea64839319aad333fb79548f49ecc92594e280d4e9 SHA512 
4992fad1e574fc44eac53f3ac8d4ab78ccbf8e04beb54a211a9afc20af1efb6f8bacedea07e403f490e7f70a74ed5ac02d4f9b939dfaf25f64a4a9bda0a7d94a
 WHIRLPOOL 
7a05ab9926227232a1cf52bf68da45b849b982e840b171f702610acce85a1ce8e59967a02e845a0ef19c316daee835861573aca40dc7b28422cf7d6d56119e2c
-DIST digikam-5.2.0.tar.xz 143583460 SHA256 
cf243fc1518b5bb6e289573c76d89b5fdcc50be89f6312b276af3320763c9260 SHA512 
483c2331f8f1a145ffd04bfdfe3f3e7e68f7ac4458b8b1698339dc89433d7820548fc461a5acf163997bab086b5faed6dd635af996f2503213a6207603603b4d
 WHIRLPOOL 
9df54368afa4c31791102211a334568c9301082899fa7970b88dcec2047ded299c0a4dc92ccc1d6db3c2efc71be7e78349d6289b68414b6cfbe76bcc0c6fb930
 DIST digikam-5.3.0.tar.xz 121417224 SHA256 
b36cfa27278936d41ab5f33c99fe9ccdfd545eada3e1e32efe9f9e3fdf2c3e5c SHA512 
6190944d09badec6ddac194f2029e86d0ef658e08a6a120f04c86109dc2b9d9cd2e772a900d09781b563fcd0caaff186fb5fd6cde9744ce3b4e8dcc9ff29d421
 WHIRLPOOL 
c1c0987e23587356968484d936a0a99f10d6e6ce004ffe1f5eb4d0a42b59fc1e84ec4a03f491c91c93be172ab6b78444c684221fb515e1562cc76bcc61346158

diff --git a/media-plugins/kipi-plugins/kipi-plugins-5.2.0.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-5.2.0.ebuild
deleted file mode 100644
index 308edfe..
--- a/media-plugins/kipi-plugins/kipi-plugins-5.2.0.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-CMAKE_MIN_VERSION="3.0"
-KDE_TEST="true"
-VIRTUALX_REQUIRED="test"
-inherit kde5
-
-DESCRIPTION="Plugins for the KDE Image Plugin Interface"
-HOMEPAGE="https://www.digikam.org/;
-
-LICENSE="GPL-2+"
-KEYWORDS="~amd64 ~x86"
-IUSE="flashexport mediawiki +remotestorage vkontakte"
-
-if [[ ${KDE_BUILD_TYPE} = release ]]; then
-   MY_PV="${PV/_/-}"
-   MY_P="digikam-${MY_PV}"
-
-   if [[ ${PV} =~ beta[0-9]$ ]]; then
-   SRC_BRANCH="unstable"
-   else
-   SRC_BRANCH="stable"
-   fi
-
-   SRC_URI="mirror://kde/${SRC_BRANCH}/digikam/${MY_P}.tar.xz"
-
-   S="${WORKDIR}/${MY_P}/extra/${PN}"
-fi
-
-COMMON_DEPEND="
-   $(add_frameworks_dep kcompletion)
-   $(add_frameworks_dep kconfig)
-   $(add_frameworks_dep kconfigwidgets)
-   $(add_frameworks_dep kcoreaddons)
-   $(add_frameworks_dep ki18n)
-   $(add_frameworks_dep kwindowsystem)
-   $(add_frameworks_dep kxmlgui)
-   $(add_kdeapps_dep libkipi '' '' '5=')
-   $(add_qt_dep qtgui)
-   $(add_qt_dep qtnetwork)
-   $(add_qt_dep qtprintsupport)
-   $(add_qt_dep qtsvg)
-   $(add_qt_dep qtwidgets)
-   $(add_qt_dep qtxml)
-   $(add_qt_dep qtxmlpatterns)
-   flashexport? ( $(add_frameworks_dep karchive) )
-   mediawiki? ( net-libs/libmediawiki:5 )
-   remotestorage? ( $(add_frameworks_dep kio) )
-   vkontakte? ( net-libs/libkvkontakte:5 )
-"
-DEPEND="${COMMON_DEPEND}
-   $(add_qt_dep qtconcurrent)
-   sys-devel/gettext
-"
-RDEPEND="${COMMON_DEPEND}
-   !media-plugins/kipi-plugins:4
-"
-
-# hangs
-RESTRICT="test"
-
-src_prepare() {
-   if [[ ${KDE_BUILD_TYPE} = release ]]; then
-   if [[ ${SRC_BRANCH} = stable ]]; then
-   # prepare the translations
-   mv "${WORKDIR}/${MY_P}/po" po || die
-   find po -name "*.po" -and -not -name "kipiplugin*.po" 
-delete || die
-   echo "find_package(Gettext REQUIRED)" >> CMakeLists.txt 
|| die
-   echo "add_subdirectory( po )" >> CMakeLists.txt || die
-   fi
-   fi
-
-   kde5_src_prepare
-}
-
-src_configure() {
-   local mycmakeargs=(
-   $(cmake-utils_use_find_package flashexport KF5Archive)
-   

[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2016-11-08 Thread Johannes Huber
commit: 873a1166ef9473cf638ae7ba8375730f44981b69
Author: Johannes Huber  gentoo  org>
AuthorDate: Tue Nov  8 09:24:49 2016 +
Commit: Johannes Huber  gentoo  org>
CommitDate: Tue Nov  8 09:26:20 2016 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=873a1166

media-plugins/kipi-plugins: Remove 5.1.0

Package-Manager: portage-2.3.2

 media-plugins/kipi-plugins/Manifest|  1 -
 .../kipi-plugins/kipi-plugins-5.1.0.ebuild | 98 --
 2 files changed, 99 deletions(-)

diff --git a/media-plugins/kipi-plugins/Manifest 
b/media-plugins/kipi-plugins/Manifest
index 73b18a9..df8e98e 100644
--- a/media-plugins/kipi-plugins/Manifest
+++ b/media-plugins/kipi-plugins/Manifest
@@ -1,5 +1,4 @@
 DIST digikam-4.14.0.tar.bz2 59805228 SHA256 
9d7bcb689d8c29be2e81976f0a043220f442a24f2071284044e7f1a799a7fdad SHA512 
3029e9b67d9d055bd9aee0d6d01e87950702e026f9f44b513155946ba087ec58b300f945a035a418afae45365ed007d8db6a1a90ed1d391e5e0e4cb679168ccf
 WHIRLPOOL 
35a3caedc9a4799f161b26b3b4df51da18a31be50a8a6da5b12a339a353755d73a47f103099087e3dc8e6926f65ae19638efea3585c86f72173a086056bf48ce
 DIST digikam-4.4.0.tar.bz2 68871203 SHA256 
5c68a2d200f5b502706128ea64839319aad333fb79548f49ecc92594e280d4e9 SHA512 
4992fad1e574fc44eac53f3ac8d4ab78ccbf8e04beb54a211a9afc20af1efb6f8bacedea07e403f490e7f70a74ed5ac02d4f9b939dfaf25f64a4a9bda0a7d94a
 WHIRLPOOL 
7a05ab9926227232a1cf52bf68da45b849b982e840b171f702610acce85a1ce8e59967a02e845a0ef19c316daee835861573aca40dc7b28422cf7d6d56119e2c
-DIST digikam-5.1.0.tar.xz 68259780 SHA256 
47915e2e41ded21071309c0b387495bd66f6cc488acbfa647d2d8d57595127f1 SHA512 
aa6b6b2a2f40dc6e1e90549d3b1cdcd2e886d16cfa4bb140093b67366b4aeaa3ebab96f0a28b1aeb969dca1fa64f8377bb8af44da4feeb4356e1f884357aaa86
 WHIRLPOOL 
c09afdcc67fa0643f84f4b026227eb6f6c651369b1452e670d4c4451d967a78c968ec56a39f724d726f251d5fb51411214aa723860a23e936ce282a7285d89bc
 DIST digikam-5.2.0.tar.xz 143583460 SHA256 
cf243fc1518b5bb6e289573c76d89b5fdcc50be89f6312b276af3320763c9260 SHA512 
483c2331f8f1a145ffd04bfdfe3f3e7e68f7ac4458b8b1698339dc89433d7820548fc461a5acf163997bab086b5faed6dd635af996f2503213a6207603603b4d
 WHIRLPOOL 
9df54368afa4c31791102211a334568c9301082899fa7970b88dcec2047ded299c0a4dc92ccc1d6db3c2efc71be7e78349d6289b68414b6cfbe76bcc0c6fb930
 DIST digikam-5.3.0.tar.xz 121417224 SHA256 
b36cfa27278936d41ab5f33c99fe9ccdfd545eada3e1e32efe9f9e3fdf2c3e5c SHA512 
6190944d09badec6ddac194f2029e86d0ef658e08a6a120f04c86109dc2b9d9cd2e772a900d09781b563fcd0caaff186fb5fd6cde9744ce3b4e8dcc9ff29d421
 WHIRLPOOL 
c1c0987e23587356968484d936a0a99f10d6e6ce004ffe1f5eb4d0a42b59fc1e84ec4a03f491c91c93be172ab6b78444c684221fb515e1562cc76bcc61346158

diff --git a/media-plugins/kipi-plugins/kipi-plugins-5.1.0.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-5.1.0.ebuild
deleted file mode 100644
index 5d81971..
--- a/media-plugins/kipi-plugins/kipi-plugins-5.1.0.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-CMAKE_MIN_VERSION="3.0"
-KDE_HANDBOOK="true"
-KDE_TEST="true"
-VIRTUALX_REQUIRED="test"
-inherit kde5
-
-DESCRIPTION="Plugins for the KDE Image Plugin Interface"
-HOMEPAGE="http://www.digikam.org/;
-
-LICENSE="GPL-2+ handbook? ( FDL-1.2 )"
-KEYWORDS="~amd64 ~x86"
-IUSE="flashexport mediawiki +remotestorage vkontakte"
-
-if [[ ${KDE_BUILD_TYPE} = release ]]; then
-   MY_PV="${PV/_/-}"
-   MY_P="digikam-${MY_PV}"
-
-   if [[ ${PV} =~ beta[0-9]$ ]]; then
-   SRC_BRANCH="unstable"
-   else
-   SRC_BRANCH="stable"
-   fi
-
-   SRC_URI="mirror://kde/${SRC_BRANCH}/digikam/${MY_P}.tar.xz"
-
-   S="${WORKDIR}/${MY_P}/extra/${PN}"
-fi
-
-COMMON_DEPEND="
-   $(add_frameworks_dep kcompletion)
-   $(add_frameworks_dep kconfig)
-   $(add_frameworks_dep kconfigwidgets)
-   $(add_frameworks_dep kcoreaddons)
-   $(add_frameworks_dep ki18n)
-   $(add_frameworks_dep kservice)
-   $(add_frameworks_dep kwindowsystem)
-   $(add_frameworks_dep kxmlgui)
-   $(add_kdeapps_dep libkipi '' '' '5=')
-   $(add_qt_dep qtgui)
-   $(add_qt_dep qtnetwork)
-   $(add_qt_dep qtprintsupport)
-   $(add_qt_dep qtsvg)
-   $(add_qt_dep qtwidgets)
-   $(add_qt_dep qtxml)
-   $(add_qt_dep qtxmlpatterns)
-   flashexport? ( $(add_frameworks_dep karchive) )
-   mediawiki? ( net-libs/libmediawiki:5 )
-   remotestorage? ( $(add_frameworks_dep kio) )
-   vkontakte? ( net-libs/libkvkontakte:5 )
-"
-DEPEND="${COMMON_DEPEND}
-   $(add_qt_dep qtconcurrent)
-   sys-devel/gettext
-"
-RDEPEND="${COMMON_DEPEND}
-   !media-plugins/kipi-plugins:4
-"
-
-# hangs
-RESTRICT="test"
-
-src_prepare() {
-   if [[ ${KDE_BUILD_TYPE} = release ]]; then
-   # prepare the handbook
-   mv "${WORKDIR}"/${MY_P}/doc/${PN} "${S}"/doc || die
-
-   if use handbook; then

[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2016-11-07 Thread Johannes Huber
commit: 2413eac2345dd2af841601fb5ac9a1381f5c38fd
Author: Andreas Sturmlechner  gmail  com>
AuthorDate: Sun Nov  6 15:37:15 2016 +
Commit: Johannes Huber  gentoo  org>
CommitDate: Mon Nov  7 21:46:55 2016 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=2413eac2

media-plugins/kipi-plugins: 5.3.0 version bump

Package-Manager: portage-2.3.0

Signed-off-by: Johannes Huber  gentoo.org>

 media-plugins/kipi-plugins/Manifest|  1 +
 .../kipi-plugins/kipi-plugins-5.3.0.ebuild | 85 ++
 2 files changed, 86 insertions(+)

diff --git a/media-plugins/kipi-plugins/Manifest 
b/media-plugins/kipi-plugins/Manifest
index 32c254b..73b18a9 100644
--- a/media-plugins/kipi-plugins/Manifest
+++ b/media-plugins/kipi-plugins/Manifest
@@ -2,3 +2,4 @@ DIST digikam-4.14.0.tar.bz2 59805228 SHA256 
9d7bcb689d8c29be2e81976f0a043220f442
 DIST digikam-4.4.0.tar.bz2 68871203 SHA256 
5c68a2d200f5b502706128ea64839319aad333fb79548f49ecc92594e280d4e9 SHA512 
4992fad1e574fc44eac53f3ac8d4ab78ccbf8e04beb54a211a9afc20af1efb6f8bacedea07e403f490e7f70a74ed5ac02d4f9b939dfaf25f64a4a9bda0a7d94a
 WHIRLPOOL 
7a05ab9926227232a1cf52bf68da45b849b982e840b171f702610acce85a1ce8e59967a02e845a0ef19c316daee835861573aca40dc7b28422cf7d6d56119e2c
 DIST digikam-5.1.0.tar.xz 68259780 SHA256 
47915e2e41ded21071309c0b387495bd66f6cc488acbfa647d2d8d57595127f1 SHA512 
aa6b6b2a2f40dc6e1e90549d3b1cdcd2e886d16cfa4bb140093b67366b4aeaa3ebab96f0a28b1aeb969dca1fa64f8377bb8af44da4feeb4356e1f884357aaa86
 WHIRLPOOL 
c09afdcc67fa0643f84f4b026227eb6f6c651369b1452e670d4c4451d967a78c968ec56a39f724d726f251d5fb51411214aa723860a23e936ce282a7285d89bc
 DIST digikam-5.2.0.tar.xz 143583460 SHA256 
cf243fc1518b5bb6e289573c76d89b5fdcc50be89f6312b276af3320763c9260 SHA512 
483c2331f8f1a145ffd04bfdfe3f3e7e68f7ac4458b8b1698339dc89433d7820548fc461a5acf163997bab086b5faed6dd635af996f2503213a6207603603b4d
 WHIRLPOOL 
9df54368afa4c31791102211a334568c9301082899fa7970b88dcec2047ded299c0a4dc92ccc1d6db3c2efc71be7e78349d6289b68414b6cfbe76bcc0c6fb930
+DIST digikam-5.3.0.tar.xz 121417224 SHA256 
b36cfa27278936d41ab5f33c99fe9ccdfd545eada3e1e32efe9f9e3fdf2c3e5c SHA512 
6190944d09badec6ddac194f2029e86d0ef658e08a6a120f04c86109dc2b9d9cd2e772a900d09781b563fcd0caaff186fb5fd6cde9744ce3b4e8dcc9ff29d421
 WHIRLPOOL 
c1c0987e23587356968484d936a0a99f10d6e6ce004ffe1f5eb4d0a42b59fc1e84ec4a03f491c91c93be172ab6b78444c684221fb515e1562cc76bcc61346158

diff --git a/media-plugins/kipi-plugins/kipi-plugins-5.3.0.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-5.3.0.ebuild
new file mode 100644
index ..5bcebc1
--- /dev/null
+++ b/media-plugins/kipi-plugins/kipi-plugins-5.3.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+CMAKE_MIN_VERSION="3.0"
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="Plugins for the KDE Image Plugin Interface"
+HOMEPAGE="https://www.digikam.org/;
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="flashexport mediawiki +remotestorage vkontakte"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+   MY_PV="${PV/_/-}"
+   MY_P="digikam-${MY_PV}"
+
+   if [[ ${PV} =~ beta[0-9]$ ]]; then
+   SRC_BRANCH="unstable"
+   else
+   SRC_BRANCH="stable"
+   fi
+
+   SRC_URI="mirror://kde/${SRC_BRANCH}/digikam/${MY_P}.tar.xz"
+
+   S="${WORKDIR}/${MY_P}/extra/${PN}"
+fi
+
+COMMON_DEPEND="
+   $(add_frameworks_dep kcompletion)
+   $(add_frameworks_dep kconfig)
+   $(add_frameworks_dep kconfigwidgets)
+   $(add_frameworks_dep kcoreaddons)
+   $(add_frameworks_dep ki18n)
+   $(add_frameworks_dep kwindowsystem)
+   $(add_frameworks_dep kxmlgui)
+   $(add_kdeapps_dep libkipi '' '' '5=')
+   $(add_qt_dep qtgui)
+   $(add_qt_dep qtnetwork)
+   $(add_qt_dep qtprintsupport)
+   $(add_qt_dep qtsvg)
+   $(add_qt_dep qtwidgets)
+   $(add_qt_dep qtxml)
+   $(add_qt_dep qtxmlpatterns)
+   flashexport? ( $(add_frameworks_dep karchive) )
+   mediawiki? ( net-libs/libmediawiki:5 )
+   remotestorage? ( $(add_frameworks_dep kio) )
+   vkontakte? ( net-libs/libkvkontakte:5 )
+"
+DEPEND="${COMMON_DEPEND}
+   $(add_qt_dep qtconcurrent)
+   sys-devel/gettext
+"
+RDEPEND="${COMMON_DEPEND}
+   !media-plugins/kipi-plugins:4
+"
+
+src_prepare() {
+   if [[ ${KDE_BUILD_TYPE} = release ]]; then
+   if [[ ${SRC_BRANCH} = stable ]]; then
+   # prepare the translations
+   mv "${WORKDIR}/${MY_P}/po" po || die
+   find po -name "*.po" -and -not -name "kipiplugin*.po" 
-delete || die
+   echo "find_package(Gettext REQUIRED)" >> CMakeLists.txt 
|| die
+   echo "add_subdirectory( po )" >> CMakeLists.txt || die
+   fi
+   fi
+
+   kde5_src_prepare
+}
+
+src_configure() {
+   local mycmakeargs=(

[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2016-10-20 Thread Michael Palimaka
commit: 34afb325c0676ce808f2aa549b212db61eff1edd
Author: Michael Palimaka  gentoo  org>
AuthorDate: Thu Oct 20 19:00:52 2016 +
Commit: Michael Palimaka  gentoo  org>
CommitDate: Thu Oct 20 20:58:19 2016 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=34afb325

media-plugins/kipi-plugins: version bump

Gentoo-bug: 595334

Package-Manager: portage-2.3.2

 media-plugins/kipi-plugins/Manifest|  1 +
 .../kipi-plugins/kipi-plugins-5.2.0.ebuild | 89 ++
 2 files changed, 90 insertions(+)

diff --git a/media-plugins/kipi-plugins/Manifest 
b/media-plugins/kipi-plugins/Manifest
index 3f04a1b..32c254b 100644
--- a/media-plugins/kipi-plugins/Manifest
+++ b/media-plugins/kipi-plugins/Manifest
@@ -1,3 +1,4 @@
 DIST digikam-4.14.0.tar.bz2 59805228 SHA256 
9d7bcb689d8c29be2e81976f0a043220f442a24f2071284044e7f1a799a7fdad SHA512 
3029e9b67d9d055bd9aee0d6d01e87950702e026f9f44b513155946ba087ec58b300f945a035a418afae45365ed007d8db6a1a90ed1d391e5e0e4cb679168ccf
 WHIRLPOOL 
35a3caedc9a4799f161b26b3b4df51da18a31be50a8a6da5b12a339a353755d73a47f103099087e3dc8e6926f65ae19638efea3585c86f72173a086056bf48ce
 DIST digikam-4.4.0.tar.bz2 68871203 SHA256 
5c68a2d200f5b502706128ea64839319aad333fb79548f49ecc92594e280d4e9 SHA512 
4992fad1e574fc44eac53f3ac8d4ab78ccbf8e04beb54a211a9afc20af1efb6f8bacedea07e403f490e7f70a74ed5ac02d4f9b939dfaf25f64a4a9bda0a7d94a
 WHIRLPOOL 
7a05ab9926227232a1cf52bf68da45b849b982e840b171f702610acce85a1ce8e59967a02e845a0ef19c316daee835861573aca40dc7b28422cf7d6d56119e2c
 DIST digikam-5.1.0.tar.xz 68259780 SHA256 
47915e2e41ded21071309c0b387495bd66f6cc488acbfa647d2d8d57595127f1 SHA512 
aa6b6b2a2f40dc6e1e90549d3b1cdcd2e886d16cfa4bb140093b67366b4aeaa3ebab96f0a28b1aeb969dca1fa64f8377bb8af44da4feeb4356e1f884357aaa86
 WHIRLPOOL 
c09afdcc67fa0643f84f4b026227eb6f6c651369b1452e670d4c4451d967a78c968ec56a39f724d726f251d5fb51411214aa723860a23e936ce282a7285d89bc
+DIST digikam-5.2.0.tar.xz 143583460 SHA256 
cf243fc1518b5bb6e289573c76d89b5fdcc50be89f6312b276af3320763c9260 SHA512 
483c2331f8f1a145ffd04bfdfe3f3e7e68f7ac4458b8b1698339dc89433d7820548fc461a5acf163997bab086b5faed6dd635af996f2503213a6207603603b4d
 WHIRLPOOL 
9df54368afa4c31791102211a334568c9301082899fa7970b88dcec2047ded299c0a4dc92ccc1d6db3c2efc71be7e78349d6289b68414b6cfbe76bcc0c6fb930

diff --git a/media-plugins/kipi-plugins/kipi-plugins-5.2.0.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-5.2.0.ebuild
new file mode 100644
index ..308edfe
--- /dev/null
+++ b/media-plugins/kipi-plugins/kipi-plugins-5.2.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+CMAKE_MIN_VERSION="3.0"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Plugins for the KDE Image Plugin Interface"
+HOMEPAGE="https://www.digikam.org/;
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="flashexport mediawiki +remotestorage vkontakte"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+   MY_PV="${PV/_/-}"
+   MY_P="digikam-${MY_PV}"
+
+   if [[ ${PV} =~ beta[0-9]$ ]]; then
+   SRC_BRANCH="unstable"
+   else
+   SRC_BRANCH="stable"
+   fi
+
+   SRC_URI="mirror://kde/${SRC_BRANCH}/digikam/${MY_P}.tar.xz"
+
+   S="${WORKDIR}/${MY_P}/extra/${PN}"
+fi
+
+COMMON_DEPEND="
+   $(add_frameworks_dep kcompletion)
+   $(add_frameworks_dep kconfig)
+   $(add_frameworks_dep kconfigwidgets)
+   $(add_frameworks_dep kcoreaddons)
+   $(add_frameworks_dep ki18n)
+   $(add_frameworks_dep kwindowsystem)
+   $(add_frameworks_dep kxmlgui)
+   $(add_kdeapps_dep libkipi '' '' '5=')
+   $(add_qt_dep qtgui)
+   $(add_qt_dep qtnetwork)
+   $(add_qt_dep qtprintsupport)
+   $(add_qt_dep qtsvg)
+   $(add_qt_dep qtwidgets)
+   $(add_qt_dep qtxml)
+   $(add_qt_dep qtxmlpatterns)
+   flashexport? ( $(add_frameworks_dep karchive) )
+   mediawiki? ( net-libs/libmediawiki:5 )
+   remotestorage? ( $(add_frameworks_dep kio) )
+   vkontakte? ( net-libs/libkvkontakte:5 )
+"
+DEPEND="${COMMON_DEPEND}
+   $(add_qt_dep qtconcurrent)
+   sys-devel/gettext
+"
+RDEPEND="${COMMON_DEPEND}
+   !media-plugins/kipi-plugins:4
+"
+
+# hangs
+RESTRICT="test"
+
+src_prepare() {
+   if [[ ${KDE_BUILD_TYPE} = release ]]; then
+   if [[ ${SRC_BRANCH} = stable ]]; then
+   # prepare the translations
+   mv "${WORKDIR}/${MY_P}/po" po || die
+   find po -name "*.po" -and -not -name "kipiplugin*.po" 
-delete || die
+   echo "find_package(Gettext REQUIRED)" >> CMakeLists.txt 
|| die
+   echo "add_subdirectory( po )" >> CMakeLists.txt || die
+   fi
+   fi
+
+   kde5_src_prepare
+}
+
+src_configure() {
+   local mycmakeargs=(
+   $(cmake-utils_use_find_package flashexport 

[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2016-08-10 Thread Michael Palimaka
commit: d1ea96567d53520e1234cc1ac65cfba5e2ec3f47
Author: Andreas Sturmlechner  gmail  com>
AuthorDate: Tue Aug  9 20:41:08 2016 +
Commit: Michael Palimaka  gentoo  org>
CommitDate: Wed Aug 10 17:51:51 2016 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d1ea9656

media-plugins/kipi-plugins: Drop old

Package-Manager: portage-2.2.28

 media-plugins/kipi-plugins/Manifest|  1 -
 .../kipi-plugins/kipi-plugins-5.0.0.ebuild | 96 --
 2 files changed, 97 deletions(-)

diff --git a/media-plugins/kipi-plugins/Manifest 
b/media-plugins/kipi-plugins/Manifest
index 483c78c..3f04a1b 100644
--- a/media-plugins/kipi-plugins/Manifest
+++ b/media-plugins/kipi-plugins/Manifest
@@ -1,4 +1,3 @@
 DIST digikam-4.14.0.tar.bz2 59805228 SHA256 
9d7bcb689d8c29be2e81976f0a043220f442a24f2071284044e7f1a799a7fdad SHA512 
3029e9b67d9d055bd9aee0d6d01e87950702e026f9f44b513155946ba087ec58b300f945a035a418afae45365ed007d8db6a1a90ed1d391e5e0e4cb679168ccf
 WHIRLPOOL 
35a3caedc9a4799f161b26b3b4df51da18a31be50a8a6da5b12a339a353755d73a47f103099087e3dc8e6926f65ae19638efea3585c86f72173a086056bf48ce
 DIST digikam-4.4.0.tar.bz2 68871203 SHA256 
5c68a2d200f5b502706128ea64839319aad333fb79548f49ecc92594e280d4e9 SHA512 
4992fad1e574fc44eac53f3ac8d4ab78ccbf8e04beb54a211a9afc20af1efb6f8bacedea07e403f490e7f70a74ed5ac02d4f9b939dfaf25f64a4a9bda0a7d94a
 WHIRLPOOL 
7a05ab9926227232a1cf52bf68da45b849b982e840b171f702610acce85a1ce8e59967a02e845a0ef19c316daee835861573aca40dc7b28422cf7d6d56119e2c
-DIST digikam-5.0.0.tar.xz 62980708 SHA256 
b0b4fb7f55101830b8a49d804f622f80e82386d1597cb1b94e6d2f287ab33d9f SHA512 
99cd961b2261a76a2743ecabfb64195b941dc20f8fc57318cef9ca6e34ca9bd5c944c6019aa92b493316db47385a98f0f77fa04fcbd20ac0e3b01a03936eddfb
 WHIRLPOOL 
c15d19da31c7ba0679475fca7dc9f9b60104fee9f55a7b41b4b655e37d910d0bc963ebfd87a241ef5536ef4a0c362be42e6c5b054ee5a46998bee54ef8ad41f3
 DIST digikam-5.1.0.tar.xz 68259780 SHA256 
47915e2e41ded21071309c0b387495bd66f6cc488acbfa647d2d8d57595127f1 SHA512 
aa6b6b2a2f40dc6e1e90549d3b1cdcd2e886d16cfa4bb140093b67366b4aeaa3ebab96f0a28b1aeb969dca1fa64f8377bb8af44da4feeb4356e1f884357aaa86
 WHIRLPOOL 
c09afdcc67fa0643f84f4b026227eb6f6c651369b1452e670d4c4451d967a78c968ec56a39f724d726f251d5fb51411214aa723860a23e936ce282a7285d89bc

diff --git a/media-plugins/kipi-plugins/kipi-plugins-5.0.0.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-5.0.0.ebuild
deleted file mode 100644
index f053f5c..000
--- a/media-plugins/kipi-plugins/kipi-plugins-5.0.0.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-KDE_HANDBOOK="true"
-KDE_TEST="true"
-VIRTUALX_REQUIRED="test"
-inherit kde5
-
-DESCRIPTION="Plugins for the KDE Image Plugin Interface"
-HOMEPAGE="http://www.digikam.org/;
-
-LICENSE="GPL-2+ handbook? ( FDL-1.2 )"
-KEYWORDS="~amd64 ~x86"
-IUSE="flashexport mediawiki vkontakte"
-
-if [[ ${KDE_BUILD_TYPE} = release ]]; then
-   MY_PV="${PV/_/-}"
-   MY_P="digikam-${MY_PV}"
-
-   if [[ ${PV} =~ beta[0-9]$ ]]; then
-   SRC_BRANCH="unstable"
-   else
-   SRC_BRANCH="stable"
-   fi
-
-   SRC_URI="mirror://kde/${SRC_BRANCH}/digikam/${MY_P}.tar.xz"
-
-   S="${WORKDIR}/${MY_P}/extra/${PN}"
-fi
-
-COMMON_DEPEND="
-   $(add_frameworks_dep kcompletion)
-   $(add_frameworks_dep kconfig)
-   $(add_frameworks_dep kconfigwidgets)
-   $(add_frameworks_dep kcoreaddons)
-   $(add_frameworks_dep ki18n)
-   $(add_frameworks_dep kio)
-   $(add_frameworks_dep kservice)
-   $(add_frameworks_dep kwindowsystem)
-   $(add_frameworks_dep kxmlgui)
-   $(add_qt_dep qtconcurrent)
-   $(add_qt_dep qtgui)
-   $(add_qt_dep qtnetwork)
-   $(add_qt_dep qtprintsupport)
-   $(add_qt_dep qtsvg)
-   $(add_qt_dep qtwidgets)
-   $(add_qt_dep qtxml)
-   $(add_qt_dep qtxmlpatterns)
-   kde-apps/libkipi:5=
-   flashexport? ( $(add_frameworks_dep karchive) )
-   mediawiki? ( net-libs/libmediawiki:5 )
-   vkontakte? ( net-libs/libkvkontakte:5 )
-"
-DEPEND="${COMMON_DEPEND}
-   sys-devel/gettext
-"
-RDEPEND="${COMMON_DEPEND}
-   !media-plugins/kipi-plugins:4
-"
-
-# hangs
-RESTRICT="test"
-
-src_prepare() {
-   if [[ ${KDE_BUILD_TYPE} = release ]]; then
-   # prepare the handbook
-   mv "${WORKDIR}"/${MY_P}/doc/${PN} "${S}"/doc || die
-
-   if use handbook; then
-   echo "add_subdirectory( doc )" >> CMakeLists.txt || die
-   fi
-
-   if [[ ${SRC_BRANCH} = stable ]]; then
-   # prepare the translations
-   mv "${WORKDIR}/${MY_P}/po" po || die
-   find po -name "*.po" -and -not -name "kipiplugin*.po" 
-delete || die
-   echo "find_package(Gettext REQUIRED)" >> CMakeLists.txt 
|| die
- 

[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2016-07-10 Thread Johannes Huber
commit: 22d2b5903c17487b6ec242210bf8183231919213
Author: Johannes Huber  gentoo  org>
AuthorDate: Sun Jul 10 11:00:45 2016 +
Commit: Johannes Huber  gentoo  org>
CommitDate: Sun Jul 10 11:00:56 2016 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=22d2b590

media-plugins/kipi-plugins: Version bump 5.0.0

Package-Manager: portage-2.3.0

 media-plugins/kipi-plugins/Manifest|  1 +
 .../kipi-plugins/kipi-plugins-5.0.0.ebuild | 96 ++
 media-plugins/kipi-plugins/metadata.xml|  1 +
 3 files changed, 98 insertions(+)

diff --git a/media-plugins/kipi-plugins/Manifest 
b/media-plugins/kipi-plugins/Manifest
index 80b14ab..8a2bb84 100644
--- a/media-plugins/kipi-plugins/Manifest
+++ b/media-plugins/kipi-plugins/Manifest
@@ -1,2 +1,3 @@
 DIST digikam-4.14.0.tar.bz2 59805228 SHA256 
9d7bcb689d8c29be2e81976f0a043220f442a24f2071284044e7f1a799a7fdad SHA512 
3029e9b67d9d055bd9aee0d6d01e87950702e026f9f44b513155946ba087ec58b300f945a035a418afae45365ed007d8db6a1a90ed1d391e5e0e4cb679168ccf
 WHIRLPOOL 
35a3caedc9a4799f161b26b3b4df51da18a31be50a8a6da5b12a339a353755d73a47f103099087e3dc8e6926f65ae19638efea3585c86f72173a086056bf48ce
 DIST digikam-4.4.0.tar.bz2 68871203 SHA256 
5c68a2d200f5b502706128ea64839319aad333fb79548f49ecc92594e280d4e9 SHA512 
4992fad1e574fc44eac53f3ac8d4ab78ccbf8e04beb54a211a9afc20af1efb6f8bacedea07e403f490e7f70a74ed5ac02d4f9b939dfaf25f64a4a9bda0a7d94a
 WHIRLPOOL 
7a05ab9926227232a1cf52bf68da45b849b982e840b171f702610acce85a1ce8e59967a02e845a0ef19c316daee835861573aca40dc7b28422cf7d6d56119e2c
+DIST digikam-5.0.0.tar.xz 62980708 SHA256 
b0b4fb7f55101830b8a49d804f622f80e82386d1597cb1b94e6d2f287ab33d9f SHA512 
99cd961b2261a76a2743ecabfb64195b941dc20f8fc57318cef9ca6e34ca9bd5c944c6019aa92b493316db47385a98f0f77fa04fcbd20ac0e3b01a03936eddfb
 WHIRLPOOL 
c15d19da31c7ba0679475fca7dc9f9b60104fee9f55a7b41b4b655e37d910d0bc963ebfd87a241ef5536ef4a0c362be42e6c5b054ee5a46998bee54ef8ad41f3

diff --git a/media-plugins/kipi-plugins/kipi-plugins-5.0.0.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-5.0.0.ebuild
new file mode 100644
index 000..f053f5c
--- /dev/null
+++ b/media-plugins/kipi-plugins/kipi-plugins-5.0.0.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="true"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Plugins for the KDE Image Plugin Interface"
+HOMEPAGE="http://www.digikam.org/;
+
+LICENSE="GPL-2+ handbook? ( FDL-1.2 )"
+KEYWORDS="~amd64 ~x86"
+IUSE="flashexport mediawiki vkontakte"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+   MY_PV="${PV/_/-}"
+   MY_P="digikam-${MY_PV}"
+
+   if [[ ${PV} =~ beta[0-9]$ ]]; then
+   SRC_BRANCH="unstable"
+   else
+   SRC_BRANCH="stable"
+   fi
+
+   SRC_URI="mirror://kde/${SRC_BRANCH}/digikam/${MY_P}.tar.xz"
+
+   S="${WORKDIR}/${MY_P}/extra/${PN}"
+fi
+
+COMMON_DEPEND="
+   $(add_frameworks_dep kcompletion)
+   $(add_frameworks_dep kconfig)
+   $(add_frameworks_dep kconfigwidgets)
+   $(add_frameworks_dep kcoreaddons)
+   $(add_frameworks_dep ki18n)
+   $(add_frameworks_dep kio)
+   $(add_frameworks_dep kservice)
+   $(add_frameworks_dep kwindowsystem)
+   $(add_frameworks_dep kxmlgui)
+   $(add_qt_dep qtconcurrent)
+   $(add_qt_dep qtgui)
+   $(add_qt_dep qtnetwork)
+   $(add_qt_dep qtprintsupport)
+   $(add_qt_dep qtsvg)
+   $(add_qt_dep qtwidgets)
+   $(add_qt_dep qtxml)
+   $(add_qt_dep qtxmlpatterns)
+   kde-apps/libkipi:5=
+   flashexport? ( $(add_frameworks_dep karchive) )
+   mediawiki? ( net-libs/libmediawiki:5 )
+   vkontakte? ( net-libs/libkvkontakte:5 )
+"
+DEPEND="${COMMON_DEPEND}
+   sys-devel/gettext
+"
+RDEPEND="${COMMON_DEPEND}
+   !media-plugins/kipi-plugins:4
+"
+
+# hangs
+RESTRICT="test"
+
+src_prepare() {
+   if [[ ${KDE_BUILD_TYPE} = release ]]; then
+   # prepare the handbook
+   mv "${WORKDIR}"/${MY_P}/doc/${PN} "${S}"/doc || die
+
+   if use handbook; then
+   echo "add_subdirectory( doc )" >> CMakeLists.txt || die
+   fi
+
+   if [[ ${SRC_BRANCH} = stable ]]; then
+   # prepare the translations
+   mv "${WORKDIR}/${MY_P}/po" po || die
+   find po -name "*.po" -and -not -name "kipiplugin*.po" 
-delete || die
+   echo "find_package(Gettext REQUIRED)" >> CMakeLists.txt 
|| die
+   echo "add_subdirectory( po )" >> CMakeLists.txt || die
+   fi
+   fi
+
+   kde5_src_prepare
+}
+
+src_configure() {
+   local mycmakeargs=(
+   $(cmake-utils_use_find_package flashexport KF5Archive)
+   $(cmake-utils_use_find_package mediawiki KF5MediaWiki)
+

[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2016-05-22 Thread Michael Palimaka
commit: cda16cfe8e6f32d781225ee39f308b4573799cca
Author: Michael Palimaka  gentoo  org>
AuthorDate: Sun May 22 18:10:39 2016 +
Commit: Michael Palimaka  gentoo  org>
CommitDate: Sun May 22 18:10:54 2016 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=cda16cfe

media-plugins/kipi-plugins: remove old

Package-Manager: portage-2.2.28

 media-plugins/kipi-plugins/Manifest|   1 -
 .../kipi-plugins/kipi-plugins-4.12.0.ebuild| 145 -
 2 files changed, 146 deletions(-)

diff --git a/media-plugins/kipi-plugins/Manifest 
b/media-plugins/kipi-plugins/Manifest
index 978ab34..80b14ab 100644
--- a/media-plugins/kipi-plugins/Manifest
+++ b/media-plugins/kipi-plugins/Manifest
@@ -1,3 +1,2 @@
-DIST digikam-4.12.0.tar.bz2 69527960 SHA256 
15043afb04733e059460165bc3cdf58dc42a67d7a349fbe12c2ebbe1946e3420 SHA512 
a5ebe481ef9803475cd2d4d198b0d093753ecb71367662f0e83a151ab34a2ff071139b28c1d9600279463fed96745b025db86d24b059b0794bc4a2b50338df85
 WHIRLPOOL 
cf29c3555ce41a298c9760287996d8edee76ff8a6ec42b503f55059e40b35f91cf56afb054f641e800f6e630d851491c2f77e0bd67020feefe8d6adf36a643f5
 DIST digikam-4.14.0.tar.bz2 59805228 SHA256 
9d7bcb689d8c29be2e81976f0a043220f442a24f2071284044e7f1a799a7fdad SHA512 
3029e9b67d9d055bd9aee0d6d01e87950702e026f9f44b513155946ba087ec58b300f945a035a418afae45365ed007d8db6a1a90ed1d391e5e0e4cb679168ccf
 WHIRLPOOL 
35a3caedc9a4799f161b26b3b4df51da18a31be50a8a6da5b12a339a353755d73a47f103099087e3dc8e6926f65ae19638efea3585c86f72173a086056bf48ce
 DIST digikam-4.4.0.tar.bz2 68871203 SHA256 
5c68a2d200f5b502706128ea64839319aad333fb79548f49ecc92594e280d4e9 SHA512 
4992fad1e574fc44eac53f3ac8d4ab78ccbf8e04beb54a211a9afc20af1efb6f8bacedea07e403f490e7f70a74ed5ac02d4f9b939dfaf25f64a4a9bda0a7d94a
 WHIRLPOOL 
7a05ab9926227232a1cf52bf68da45b849b982e840b171f702610acce85a1ce8e59967a02e845a0ef19c316daee835861573aca40dc7b28422cf7d6d56119e2c

diff --git a/media-plugins/kipi-plugins/kipi-plugins-4.12.0.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-4.12.0.ebuild
deleted file mode 100644
index c1089d4..000
--- a/media-plugins/kipi-plugins/kipi-plugins-4.12.0.ebuild
+++ /dev/null
@@ -1,145 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-#
-# TODO: complete packaging of qtsoap and qtkoauth, see dilfridge overlay for 
work in progress
-#
-
-EAPI=5
-
-OPENGL_REQUIRED="optional"
-KDE_HANDBOOK="optional"
-KDE_LINGUAS="af ar az be bg bn br bs ca cs csb cy da de el en_GB eo es et eu fa
-fi fo fr fy ga gl ha he hi hr hsb hu id is it ja ka kk km ko ku lb lo lt lv mi
-mk mn ms mt nb nds ne nl nn nso oc pa pl pt pt_BR ro ru rw se sk sl sq sr
-sr@Latn ss sv ta te tg th tr tt uk uz uz@cyrillic ven vi wa xh zh_CN zh_HK 
zh_TW
-zu"
-inherit flag-o-matic kde4-base
-
-MY_PV=${PV/_/-}
-MY_P="digikam-${MY_PV}"
-
-DESCRIPTION="Plugins for the KDE Image Plugin Interface"
-HOMEPAGE="http://www.digikam.org/;
-SRC_URI="mirror://kde/stable/digikam/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2
-   handbook? ( FDL-1.2 )"
-KEYWORDS="~amd64 ~x86"
-SLOT="4"
-IUSE="cdr calendar crypt debug expoblending gpssync +imagemagick ipod 
mediawiki panorama redeyes scanner upnp videoslideshow vkontakte"
-
-COMMONDEPEND="
-   kde-apps/libkipi:4
-   kde-apps/libkdcraw:4=
-   kde-apps/libkexiv2:4=
-   dev-libs/expat
-   dev-libs/kqoauth
-   dev-libs/libxml2
-   dev-libs/libxslt
-   dev-libs/qjson
-   dev-qt/qtxmlpatterns:4
-   gpssync? ( >=kde-apps/libkgeomap-4.12.0:4 )
-   media-libs/libpng:0=
-   media-libs/tiff:0
-   virtual/jpeg:0
-   calendar? ( $(add_kdeapps_dep kdepimlibs) )
-   crypt? ( app-crypt/qca:2[qt4(+)] )
-   ipod? (
-   media-libs/libgpod
-   x11-libs/gtk+:2
-   )
-   mediawiki? ( >=net-libs/libmediawiki-3.0.0:4 )
-   opengl? (
-   media-libs/phonon[qt4]
-   x11-libs/libXrandr
-   )
-   redeyes? ( >=media-libs/opencv-2.4.9 =media-libs/qt-gstreamer-0.9.0[qt4(+)]
-   || ( media-gfx/imagemagick 
media-gfx/graphicsmagick[imagemagick] )
-   )
-   vkontakte? ( >=net-libs/libkvkontakte-4.12.0:4 )
-"
-DEPEND="${COMMONDEPEND}
-   sys-devel/gettext
-   panorama? (
-   sys-devel/bison
-   sys-devel/flex
-   )
-"
-RDEPEND="${COMMONDEPEND}
-   cdr? ( app-cdr/k3b )
-   expoblending? ( media-gfx/hugin )
-   imagemagick? ( || ( media-gfx/imagemagick 
media-gfx/graphicsmagick[imagemagick] ) )
-   panorama? (
-   media-gfx/enblend
-   >=media-gfx/hugin-2011.0.0
-   )
-"
-
-S=${WORKDIR}/${MY_P}/extra/${PN}
-
-RESTRICT=test
-# bug 420203
-
-PATCHES=(
-   "${FILESDIR}/${PN}-4.6.0-options.patch"
-   "${FILESDIR}/${PN}-4.10.0-jpeg.patch"
-)
-
-src_prepare() {
-   # prepare the handbook
-   mv "${WORKDIR}/${MY_P}/doc/${PN}" "${WORKDIR}/${MY_P}/extra/${PN}/doc" 
|| die
-   if 

[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2016-03-07 Thread Michael Palimaka
commit: 51e588b0f55f4c108fb33a481d7bb88341ed3628
Author: Andreas Sturmlechner  gmail  com>
AuthorDate: Sun Mar  6 14:06:16 2016 +
Commit: Michael Palimaka  gentoo  org>
CommitDate: Mon Mar  7 15:07:44 2016 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=51e588b0

media-plugins/kipi-plugins: Add slot operator for opencv

Package-Manager: portage-2.2.27

 media-plugins/kipi-plugins/kipi-plugins-4.14.0.ebuild | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/media-plugins/kipi-plugins/kipi-plugins-4.14.0.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-4.14.0.ebuild
index daca71a..98505c4 100644
--- a/media-plugins/kipi-plugins/kipi-plugins-4.14.0.ebuild
+++ b/media-plugins/kipi-plugins/kipi-plugins-4.14.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -56,7 +56,7 @@ COMMONDEPEND="
media-libs/phonon[qt4]
x11-libs/libXrandr
)
-   redeyes? ( >=media-libs/opencv-3.0.0[contrib] )
+   redeyes? ( >=media-libs/opencv-3.0.0:=[contrib] )
scanner? (
$(add_kdeapps_dep libksane)
media-gfx/sane-backends



[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2015-12-10 Thread Michael Palimaka
commit: 331576f9bc43ee67511f692e889a49ec7754be79
Author: Michael Palimaka  gentoo  org>
AuthorDate: Thu Dec 10 18:11:00 2015 +
Commit: Michael Palimaka  gentoo  org>
CommitDate: Thu Dec 10 18:11:30 2015 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=331576f9

media-plugins/kipi-plugins: raise kde-base/kdelibs dependency

Gentoo-bug: 567728

Package-Manager: portage-2.2.26

 media-plugins/kipi-plugins/kipi-plugins-4.14.0.ebuild | 1 +
 1 file changed, 1 insertion(+)

diff --git a/media-plugins/kipi-plugins/kipi-plugins-4.14.0.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-4.14.0.ebuild
index ced4001..d265f9b 100644
--- a/media-plugins/kipi-plugins/kipi-plugins-4.14.0.ebuild
+++ b/media-plugins/kipi-plugins/kipi-plugins-4.14.0.ebuild
@@ -31,6 +31,7 @@ SLOT="4"
 IUSE="cdr calendar crypt debug expoblending gpssync +imagemagick ipod 
mediawiki panorama redeyes scanner upnp videoslideshow vkontakte"
 
 COMMONDEPEND="
+   $(add_kdebase_dep kdelibs '' 4.14.14)
kde-apps/libkipi:4
kde-apps/libkdcraw:4=
kde-apps/libkexiv2:4=



[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/, media-plugins/kipi-plugins/files/

2015-10-22 Thread Michael Palimaka
commit: a05ab574b379db7d00ff0e9ccc4a65f1225eff5c
Author: Michael Palimaka  gentoo  org>
AuthorDate: Thu Oct 22 11:49:37 2015 +
Commit: Michael Palimaka  gentoo  org>
CommitDate: Thu Oct 22 11:55:04 2015 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=a05ab574

media-plugins/kipi-plugins: remove old

Package-Manager: portage-2.2.20.1

 media-plugins/kipi-plugins/Manifest|   2 -
 .../files/kipi-plugins-3.4.0-staticar.patch|  18 ---
 .../kipi-plugins/kipi-plugins-4.10.0.ebuild| 149 -
 .../kipi-plugins/kipi-plugins-4.7.0.ebuild | 148 
 4 files changed, 317 deletions(-)

diff --git a/media-plugins/kipi-plugins/Manifest 
b/media-plugins/kipi-plugins/Manifest
index d9b60e0..f4e8528 100644
--- a/media-plugins/kipi-plugins/Manifest
+++ b/media-plugins/kipi-plugins/Manifest
@@ -1,4 +1,2 @@
-DIST digikam-4.10.0.tar.bz2 69413654 SHA256 
4207e68b6221307111b66bb69485d3e88150df95dae014a99f6f161a3da0c725 SHA512 
a2f1d5f44719409ee45158106cc44541e7226e3c948b722045e104bc398f96233481d60e11dd198e96bfe3028201dac335be403ec74af1ef07e3137c3e9221a4
 WHIRLPOOL 
5d7997787c549318e5d7d677edc68ee2ebaa95c789b7d5f05e3ea5dea48d56afc23aa7bf3afa33f44353f4189644df7573683580486c0d248352ffb534215f37
 DIST digikam-4.12.0.tar.bz2 69527960 SHA256 
15043afb04733e059460165bc3cdf58dc42a67d7a349fbe12c2ebbe1946e3420 SHA512 
a5ebe481ef9803475cd2d4d198b0d093753ecb71367662f0e83a151ab34a2ff071139b28c1d9600279463fed96745b025db86d24b059b0794bc4a2b50338df85
 WHIRLPOOL 
cf29c3555ce41a298c9760287996d8edee76ff8a6ec42b503f55059e40b35f91cf56afb054f641e800f6e630d851491c2f77e0bd67020feefe8d6adf36a643f5
 DIST digikam-4.4.0.tar.bz2 68871203 SHA256 
5c68a2d200f5b502706128ea64839319aad333fb79548f49ecc92594e280d4e9 SHA512 
4992fad1e574fc44eac53f3ac8d4ab78ccbf8e04beb54a211a9afc20af1efb6f8bacedea07e403f490e7f70a74ed5ac02d4f9b939dfaf25f64a4a9bda0a7d94a
 WHIRLPOOL 
7a05ab9926227232a1cf52bf68da45b849b982e840b171f702610acce85a1ce8e59967a02e845a0ef19c316daee835861573aca40dc7b28422cf7d6d56119e2c
-DIST digikam-4.7.0-1.tar.bz2 70151058 SHA256 
230a5841754107d273c953ad4aeef2b57265c4623decc74a454c437175468002 SHA512 
a9e162c83d83b2183a4e8f254b971993b884677e24676b3dd58dcf8e90ca87f1046c099ea33083ee0f58eedd13aee69a242fbc3d1eab70e285956393637f3dd4
 WHIRLPOOL 
e454bd9c95b3aa9a4c9007065c8ee3e1da595b389fc868a6a21cacba761d8101d4be507c299fd7651d8ab0c0ddff5fb4038bf49f73213a8ec2b69bcdce02808b

diff --git a/media-plugins/kipi-plugins/files/kipi-plugins-3.4.0-staticar.patch 
b/media-plugins/kipi-plugins/files/kipi-plugins-3.4.0-staticar.patch
deleted file mode 100644
index 7287de7..000
--- a/media-plugins/kipi-plugins/files/kipi-plugins-3.4.0-staticar.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-commit b9c0e87c74956196cf0d5042c8c13e9a381ba4e8
-Author: Gilles Caulier 
-Date:   Thu Oct 10 16:11:18 2013 +0200
-
-apply patch #82764 to not install libPropertiesBrowser
-BUGS: 319664
-
-diff --git a/photolayoutseditor/extra/qtpropertybrowser/CMakeLists.txt 
b/photolayoutseditor/extra/qtpropertybrowser/CMakeLists.txt
-index 03cf1bd..46e158c 100644
 a/photolayoutseditor/extra/qtpropertybrowser/CMakeLists.txt
-+++ b/photolayoutseditor/extra/qtpropertybrowser/CMakeLists.txt
-@@ -119,4 +119,5 @@ ADD_DEFINITIONS(${QT_DEFINITIONS})
- ADD_DEFINITIONS(-DQT_DLL)
- ADD_DEFINITIONS(-DQT_PLUGIN)
- 
--INSTALL( TARGETS PropertyBrowser ARCHIVE DESTINATION lib 
${INSTALL_TARGETS_DEFAULT_ARGS} )
-+# Do not install (yet), see https://bugs.kde.org/show_bug.cgi?id=319664
-+# INSTALL( TARGETS PropertyBrowser ARCHIVE DESTINATION lib 
${INSTALL_TARGETS_DEFAULT_ARGS} )

diff --git a/media-plugins/kipi-plugins/kipi-plugins-4.10.0.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-4.10.0.ebuild
deleted file mode 100644
index f861747..000
--- a/media-plugins/kipi-plugins/kipi-plugins-4.10.0.ebuild
+++ /dev/null
@@ -1,149 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-#
-# TODO: complete packaging of qtsoap and qtkoauth, see dilfridge overlay for 
work in progress
-#
-
-EAPI=5
-
-OPENGL_REQUIRED="optional"
-
-KDE_MINIMAL="4.10"
-
-KDE_LINGUAS="af ar az be bg bn br bs ca cs csb cy da de el en_GB eo es et eu fa
-fi fo fr fy ga gl ha he hi hr hsb hu id is it ja ka kk km ko ku lb lo lt lv mi
-mk mn ms mt nb nds ne nl nn nso oc pa pl pt pt_BR ro ru rw se sk sl sq sr ss sv
-ta te tg th tr tt uk uz ven vi wa xh zh_CN zh_HK zh_TW zu"
-
-KDE_HANDBOOK="optional"
-
-inherit flag-o-matic kde4-base
-
-MY_PV=${PV/_/-}
-MY_P="digikam-${MY_PV}"
-
-DESCRIPTION="Plugins for the KDE Image Plugin Interface"
-HOMEPAGE="http://www.digikam.org/;
-SRC_URI="mirror://kde/stable/digikam/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2
-   handbook? ( FDL-1.2 )"
-KEYWORDS="~amd64 ~x86"
-SLOT="4"
-IUSE="cdr calendar crypt debug expoblending gpssync +imagemagick ipod 
mediawiki panorama redeyes scanner upnp videoslideshow vkontakte"
-

[gentoo-commits] repo/gentoo:master commit in: media-plugins/kipi-plugins/

2015-10-22 Thread Michael Palimaka
commit: 6df59629027490c279f1be6406357acfe9e1c10f
Author: Andreas Sturmlechner  gmail  com>
AuthorDate: Fri Oct 16 18:40:45 2015 +
Commit: Michael Palimaka  gentoo  org>
CommitDate: Thu Oct 22 13:18:10 2015 +
URL:https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=6df59629

media-plugins/kipi-plugins: Version bump to 4.14.0

Fixes build with >=media-libs/opencv-3.0.0 - see also:
https://bugs.gentoo.org/show_bug.cgi?id=554494

Package-Manager: portage-2.2.20.1

 media-plugins/kipi-plugins/Manifest|   1 +
 .../kipi-plugins/kipi-plugins-4.14.0.ebuild| 146 +
 2 files changed, 147 insertions(+)

diff --git a/media-plugins/kipi-plugins/Manifest 
b/media-plugins/kipi-plugins/Manifest
index f4e8528..978ab34 100644
--- a/media-plugins/kipi-plugins/Manifest
+++ b/media-plugins/kipi-plugins/Manifest
@@ -1,2 +1,3 @@
 DIST digikam-4.12.0.tar.bz2 69527960 SHA256 
15043afb04733e059460165bc3cdf58dc42a67d7a349fbe12c2ebbe1946e3420 SHA512 
a5ebe481ef9803475cd2d4d198b0d093753ecb71367662f0e83a151ab34a2ff071139b28c1d9600279463fed96745b025db86d24b059b0794bc4a2b50338df85
 WHIRLPOOL 
cf29c3555ce41a298c9760287996d8edee76ff8a6ec42b503f55059e40b35f91cf56afb054f641e800f6e630d851491c2f77e0bd67020feefe8d6adf36a643f5
+DIST digikam-4.14.0.tar.bz2 59805228 SHA256 
9d7bcb689d8c29be2e81976f0a043220f442a24f2071284044e7f1a799a7fdad SHA512 
3029e9b67d9d055bd9aee0d6d01e87950702e026f9f44b513155946ba087ec58b300f945a035a418afae45365ed007d8db6a1a90ed1d391e5e0e4cb679168ccf
 WHIRLPOOL 
35a3caedc9a4799f161b26b3b4df51da18a31be50a8a6da5b12a339a353755d73a47f103099087e3dc8e6926f65ae19638efea3585c86f72173a086056bf48ce
 DIST digikam-4.4.0.tar.bz2 68871203 SHA256 
5c68a2d200f5b502706128ea64839319aad333fb79548f49ecc92594e280d4e9 SHA512 
4992fad1e574fc44eac53f3ac8d4ab78ccbf8e04beb54a211a9afc20af1efb6f8bacedea07e403f490e7f70a74ed5ac02d4f9b939dfaf25f64a4a9bda0a7d94a
 WHIRLPOOL 
7a05ab9926227232a1cf52bf68da45b849b982e840b171f702610acce85a1ce8e59967a02e845a0ef19c316daee835861573aca40dc7b28422cf7d6d56119e2c

diff --git a/media-plugins/kipi-plugins/kipi-plugins-4.14.0.ebuild 
b/media-plugins/kipi-plugins/kipi-plugins-4.14.0.ebuild
new file mode 100644
index 000..ced4001
--- /dev/null
+++ b/media-plugins/kipi-plugins/kipi-plugins-4.14.0.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+#
+# TODO: complete packaging of qtsoap and qtkoauth, see dilfridge overlay for 
work in progress
+#
+
+EAPI=5
+
+OPENGL_REQUIRED="optional"
+KDE_HANDBOOK="optional"
+KDE_LINGUAS="af ar az be bg bn br bs ca cs csb cy da de el en_GB eo es et eu fa
+fi fo fr fy ga gl ha he hi hr hsb hu id is it ja ka kk km ko ku lb lo lt lv mi
+mk mn ms mt nb nds ne nl nn nso oc pa pl pt pt_BR ro ru rw se sk sl sq sr
+sr@Latn ss sv ta te tg th tr tt uk uz uz@cyrillic ven vi wa xh zh_CN zh_HK 
zh_TW
+zu"
+inherit flag-o-matic kde4-base
+
+MY_PV=${PV/_/-}
+MY_P="digikam-${MY_PV}"
+
+DESCRIPTION="Plugins for the KDE Image Plugin Interface"
+HOMEPAGE="http://www.digikam.org/;
+SRC_URI="mirror://kde/stable/digikam/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2
+   handbook? ( FDL-1.2 )"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="cdr calendar crypt debug expoblending gpssync +imagemagick ipod 
mediawiki panorama redeyes scanner upnp videoslideshow vkontakte"
+
+COMMONDEPEND="
+   kde-apps/libkipi:4
+   kde-apps/libkdcraw:4=
+   kde-apps/libkexiv2:4=
+   dev-libs/expat
+   dev-libs/kqoauth
+   dev-libs/libxml2
+   dev-libs/libxslt
+   dev-libs/qjson
+   dev-qt/qtxmlpatterns:4
+   gpssync? ( kde-apps/libkgeomap:4 )
+   media-libs/libpng:0=
+   media-libs/tiff:0
+   virtual/jpeg:0
+   calendar? ( $(add_kdebase_dep kdepimlibs) )
+   crypt? ( app-crypt/qca:2[qt4(+)] )
+   ipod? (
+   media-libs/libgpod
+   x11-libs/gtk+:2
+   )
+   mediawiki? ( >=net-libs/libmediawiki-3.0.0:4 )
+   opengl? (
+   media-libs/phonon[qt4]
+   x11-libs/libXrandr
+   )
+   redeyes? ( >=media-libs/opencv-3.0.0[contrib] )
+   scanner? (
+   $(add_kdeapps_dep libksane)
+   media-gfx/sane-backends
+   )
+   upnp? ( media-libs/herqq )
+   videoslideshow? (
+   >=media-libs/qt-gstreamer-0.9.0[qt4(+)]
+   || ( media-gfx/imagemagick 
media-gfx/graphicsmagick[imagemagick] )
+   )
+   vkontakte? ( >=net-libs/libkvkontakte-4.12.0:4 )
+"
+DEPEND="${COMMONDEPEND}
+   sys-devel/gettext
+   panorama? (
+   sys-devel/bison
+   sys-devel/flex
+   )
+"
+RDEPEND="${COMMONDEPEND}
+   cdr? ( app-cdr/k3b )
+   expoblending? ( media-gfx/hugin )
+   imagemagick? ( || ( media-gfx/imagemagick 
media-gfx/graphicsmagick[imagemagick] ) )
+   panorama? (
+   media-gfx/enblend
+   >=media-gfx/hugin-2011.0.0
+   )
+"
+