[gentoo-dev] last rites: dev-java/jnlp-bin, app-misc/openjnlp, dev-java/netx

2011-10-19 Thread Miroslav Šulc (fordfrog)
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1

all packages are related to following bug:
https://bugs.gentoo.org/show_bug.cgi?id=377967

jnlp-bin has been replaced by jnlp-api.
openjnlp is obsolete and not needed anymore, also depends on jnlp-bin.
netx was a package that we tried to fix the issue, but in the end it
was replaced with jnlp-api.

Miroslav Šulc (fordfrog)
-BEGIN PGP SIGNATURE-
Version: GnuPG v2.0.18 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAk6ez0YACgkQB6q7Q15RwyCV6QCcCFCIolHppVui86eppp6UhDj9
c98Ani7j71kaFCYoIlHOGIIwLAR/pwOB
=NxW3
-END PGP SIGNATURE-



[gentoo-dev] huse: new helper for low level eclass writers

2011-10-19 Thread Mike Frysinger
i wrote a new func for toolchain.eclass: huse.  this is because the 
toolchain.eclass supports multiple versions in parallel, and the IUSE value 
can vary greatly between them.  so doing `use foo` without checking IUSE first 
doesn't work.  since i got a request to use this in other eclasses (for the 
same reason), i figured i'd move it to eutils.eclass so more people can benefit.

now that we have "in_iuse" in eutils.eclass (with all the caveats), i'll be 
adding huse:
huse() {
in_iuse $1 || return 1
use $1
}

any comments before i publish ?
-mike


signature.asc
Description: This is a digitally signed message part.


Re: [gentoo-dev] huse: new helper for low level eclass writers

2011-10-19 Thread Mike Frysinger
On Wednesday 19 October 2011 14:05:50 Mike Frysinger wrote:
> now that we have "in_iuse" in eutils.eclass (with all the caveats), i'll be
> adding huse:
>   huse() {
>   in_iuse $1 || return 1
>   use $1
>   }

actually, after posting this, "iuse" is probably a better name.  "huse" came 
up because the code constructs i was using before was like:
has foo ${IUSE} && use foo && .
which collapses into:
h[as foo ${IUSE} && ]use foo && ...
huse foo && ...

so new proposal for those who love 1 liners:
iuse() { in_iuse $1 && use $1 || return 1 ; }
-mike


signature.asc
Description: This is a digitally signed message part.


Re: [gentoo-dev] huse: new helper for low level eclass writers

2011-10-19 Thread Brian Harring
On Wed, Oct 19, 2011 at 02:05:50PM -0400, Mike Frysinger wrote:
> i wrote a new func for toolchain.eclass: huse.  this is because the 
> toolchain.eclass supports multiple versions in parallel, and the IUSE value 
> can vary greatly between them.  so doing `use foo` without checking IUSE 
> first 
> doesn't work.  since i got a request to use this in other eclasses (for the 
> same reason), i figured i'd move it to eutils.eclass so more people can 
> benefit.
> 
> now that we have "in_iuse" in eutils.eclass (with all the caveats), i'll be 
> adding huse:
>   huse() {
>   in_iuse $1 || return 1
>   use $1
>   }
> 
> any comments before i publish ?

Call it safe_use.
~brian



Re: [gentoo-dev] huse: new helper for low level eclass writers

2011-10-19 Thread Mike Frysinger
On Wednesday 19 October 2011 14:53:07 Brian Harring wrote:
> On Wed, Oct 19, 2011 at 02:05:50PM -0400, Mike Frysinger wrote:
> > i wrote a new func for toolchain.eclass: huse.  this is because the
> > toolchain.eclass supports multiple versions in parallel, and the IUSE
> > value can vary greatly between them.  so doing `use foo` without
> > checking IUSE first doesn't work.  since i got a request to use this in
> > other eclasses (for the same reason), i figured i'd move it to
> > eutils.eclass so more people can benefit.
> > 
> > now that we have "in_iuse" in eutils.eclass (with all the caveats), i'll
> > be
> > 
> > adding huse:
> > huse() {
> > 
> > in_iuse $1 || return 1
> > use $1
> > 
> > }
> > 
> > any comments before i publish ?
> 
> Call it safe_use.

safe for who ?  that implies to me much more vagueness than "iuse" ...
-mike


signature.asc
Description: This is a digitally signed message part.


Re: [gentoo-dev] huse: new helper for low level eclass writers

2011-10-19 Thread Brian Harring
On Wed, Oct 19, 2011 at 03:26:21PM -0400, Mike Frysinger wrote:
> On Wednesday 19 October 2011 14:53:07 Brian Harring wrote:
> > On Wed, Oct 19, 2011 at 02:05:50PM -0400, Mike Frysinger wrote:
> > > i wrote a new func for toolchain.eclass: huse.  this is because the
> > > toolchain.eclass supports multiple versions in parallel, and the IUSE
> > > value can vary greatly between them.  so doing `use foo` without
> > > checking IUSE first doesn't work.  since i got a request to use this in
> > > other eclasses (for the same reason), i figured i'd move it to
> > > eutils.eclass so more people can benefit.
> > > 
> > > now that we have "in_iuse" in eutils.eclass (with all the caveats), i'll
> > > be
> > > 
> > > adding huse:
> > >   huse() {
> > >   
> > >   in_iuse $1 || return 1
> > >   use $1
> > >   
> > >   }
> > > 
> > > any comments before i publish ?
> > 
> > Call it safe_use.
> 
> safe for who ?  that implies to me much more vagueness than "iuse" ...

Safe in the sense it does basic IUSE checks prior, so it doesn't 
trigger QA warnings for when the ebuild doesn't support the flag.

Name's a bit off though considering if the host was amd64, `huse amd64`
would return 1 since it's not in IUSE.

Either way, the 'iuse' naming rather sucks imo; that implies the 
equivalent of `use` (is this flag in iuse?) rather than "is this flag 
in iuse and use".

If you're primarily doing this to bypass the QA warnings, than jam 
safe into the name, and/or while making sure the docs are clear about 
it.

Either way, go nuts- rather not get into a bikeshedding discussion on 
this one. ;)
~harring



Re: [gentoo-dev] huse: new helper for low level eclass writers

2011-10-19 Thread Michał Górny
On Wed, 19 Oct 2011 11:53:07 -0700
Brian Harring  wrote:

> On Wed, Oct 19, 2011 at 02:05:50PM -0400, Mike Frysinger wrote:
> > i wrote a new func for toolchain.eclass: huse.  this is because the 
> > toolchain.eclass supports multiple versions in parallel, and the
> > IUSE value can vary greatly between them.  so doing `use foo`
> > without checking IUSE first doesn't work.  since i got a request to
> > use this in other eclasses (for the same reason), i figured i'd
> > move it to eutils.eclass so more people can benefit.
> > 
> > now that we have "in_iuse" in eutils.eclass (with all the caveats),
> > i'll be adding huse:
> > huse() {
> > in_iuse $1 || return 1
> > use $1
> > }
> > 
> > any comments before i publish ?
> 
> Call it safe_use.

Maybe something off 'default' instead? It could be made a little like
USE defaults, falling back to the default value when USE isn't declared.

-- 
Best regards,
Michał Górny


signature.asc
Description: PGP signature


[gentoo-dev] dev-python/pygobject slotting

2011-10-19 Thread Alexandre Rostovtsev
dev-python/pygobject:3 has been added to gx86 (package.masked for
now). It provides only gobject-introspection based bindings ("from
gi.repository import GLib"). Per upstream decision, pygobject:2,
starting with 2.28.6-r50, will install only "classic" bindings
("import glib"), since its old gi module heavily collides with
pygobject:3. To make the transition a bit easier for users who are
doing their own python development, the introspection USE flag on
pygobject-2.28.6-r50 pulls in pygobject-3 for the new gi module (in
lieu of installing pygobject-2's internal gi).

See http://www.daa.com.au/pipermail/pygtk/2011-August/019920.html for
an introduction to pygobject:3 porting.

Many existing ebuilds will need to have their pygobject dependency
slotted appropriately. I can take care of adding a slot to the
dependency list myself, but wanted to give a heads up in advance.

The following packages will need to depend on pygobject:2 :
app-admin/system-config-printer-common
app-backup/backintime
app-cdr/gcdemu
app-i18n/ibus
app-i18n/libtomoe-gtk
app-office/gtg
app-pda/synce-sync-engine
app-portage/pms-test-suite
dev-libs/keybinder
dev-python/bpython
dev-python/dbus-python
dev-python/gst-python
dev-python/papyon
dev-python/pyclutter
dev-python/pyclutter-gst
dev-python/pygtk
dev-python/pynotifier
dev-python/python-gudev
dev-python/pyudev
dev-python/pywebkitgtk
dev-util/dissy
dev-util/xesam-tools
dev-vcs/rabbitvcs
games-board/pychess
gnome-extra/gdesklets-core
gnome-extra/gnome-dvb-daemon
media-gfx/gnome-specimen
media-libs/gst-rtsp-server
media-libs/libgpod
media-radio/radiotray
media-sound/exaile
media-sound/soundconverter
net-firewall/ufw-frontends
net-libs/gupnp-igd
net-libs/telepathy-farsight
net-misc/blogtk
net-misc/cnetworkmanager
net-misc/neatx
net-misc/ups-monitor
net-misc/wicd
net-p2p/deluge
net-print/hplip
net-wireless/blueman
sys-auth/pam_usb
sys-fs/udiskie
www-client/uzbl
x11-misc/zim

The following gnome-3.0-era packages make use of a probably
incompatible mixture of classic and introspection bindings, so
gnome-3.2-era versions (that use introspection only) will need to be
moved to portage from the gnome overlay:
app-editors/gedit-3.0.6
app-editors/gedit-plugins-3.0.7
dev-libs/libpeas-1.0.0
media-sound/rhythmbox-2.90.1_pre20111001
media-video/totem-3.0.1

-Alexandre Rostovtsev



Re: [gentoo-dev] huse: new helper for low level eclass writers

2011-10-19 Thread Mike Frysinger
On Wednesday 19 October 2011 15:40:50 Brian Harring wrote:
> Name's a bit off though considering if the host was amd64, `huse amd64`
> would return 1 since it's not in IUSE.

good point.  how about "iuse_use" ?  or "use_iuse" ?
-mike


signature.asc
Description: This is a digitally signed message part.