osmo-trx[master]: BitVector: Convert SoftVector from 0..1 to -1..+1 soft bits.

2017-03-21 Thread Alexander Chemeris
Patch Set 2: (1 comment) > (1 comment) https://gerrit.osmocom.org/#/c/2142/2/CommonLibs/BitVector.h File CommonLibs/BitVector.h: Line 305: return (*dp)>0.0F; > Can we just compare "> 0" in here? Yes, but I want to make it clear it's a floating point value. -- To view, visit

osmo-trx[master]: sigProcLib: make energyDetect() simpler by returning actual ...

2017-03-21 Thread Alexander Chemeris
Patch Set 1: (1 comment) > (1 comment) https://gerrit.osmocom.org/#/c/2136/1/Transceiver52M/Transceiver.cpp File Transceiver52M/Transceiver.cpp: Line 609: float toa, max = -1.0, avg = 0.0; > Is there good reason not to move it? I prefer the moved declaration. I follow the rule "declare

osmo-trx[master]: osmo-trx: Separate command line switch to enable EDGE filler.

2017-03-21 Thread Tom Tsou
Patch Set 2: (1 comment) https://gerrit.osmocom.org/#/c/2143/2/Transceiver52M/osmo-trx.cpp File Transceiver52M/osmo-trx.cpp: Line 419: case 'E': > So user can still specify ... -E 123 -r 321 ... without enabling EDGE and i In general, I would very much like to stop adding more

osmo-trx[master]: sigProcLib: make energyDetect() simpler by returning actual ...

2017-03-21 Thread Tom Tsou
Patch Set 1: (2 comments) https://gerrit.osmocom.org/#/c/2136/1/Transceiver52M/Transceiver.cpp File Transceiver52M/Transceiver.cpp: Line 609: float toa, max = -1.0, avg = 0.0; > There's no need to move variable declaration. Is there good reason not to move it? I prefer the moved declaration.

osmo-trx[master]: Call vectorSlicer() right before packing bits for transmissi...

2017-03-21 Thread Alexander Chemeris
Patch Set 2: > Could you elaborate, why is this better than before? vectorSlicer() converts soft-bits from -1..+1 to 0..1 while we want to keep SoftVector in -1..+1 mode until the last minute, because at some point we'll want to transmit -1..+1 to osmo-bts instead of converting it from 0..1

[PATCH] libosmocore[master]: abis: add attribute names

2017-03-21 Thread Max
Hello Jenkins Builder, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/2144 to look at the new patch set (#2). abis: add attribute names Add human-readable names for Attributes from 3GPP TS 52.021 §9.4 Change-Id: I861247c01557dac7e484ef6fb9b170f69c8a7f55

[PATCH] libosmocore[master]: abis: add attribute names

2017-03-21 Thread Max
Review at https://gerrit.osmocom.org/2144 abis: add attribute names Add human-readable names for Attributes from 3GPP TS 52.021 §9.4 Change-Id: I861247c01557dac7e484ef6fb9b170f69c8a7f55 Related: OS#1614 --- M include/osmocom/gsm/protocol/gsm_12_21.h M src/gsm/abis_nm.c M

openbsc[master]: twisted_ipa.py: make debug logging more robust

2017-03-21 Thread Max
Patch Set 5: (1 comment) https://gerrit.osmocom.org/#/c/2133/5/openbsc/contrib/twisted_ipa.py File openbsc/contrib/twisted_ipa.py: Line 25: __version__ = "0.5" # bump this on every non-trivial change > hehe, logging is non-trivial? Yes, because it changes the interface of IPAFactory. -- To

[MERGED] openbsc[master]: twisted_ipa.py: bump version properly

2017-03-21 Thread Max
Max has submitted this change and it was merged. Change subject: twisted_ipa.py: bump version properly .. twisted_ipa.py: bump version properly Adjust version string to comply with PEP8 and PEP386. Change-Id:

openbsc[master]: twisted_ipa.py: make debug logging more robust

2017-03-21 Thread Neels Hofmeyr
Patch Set 5: Code-Review+1 (2 comments) https://gerrit.osmocom.org/#/c/2133/5/openbsc/contrib/twisted_ipa.py File openbsc/contrib/twisted_ipa.py: Line 25: __version__ = "0.5" # bump this on every non-trivial change hehe, logging is non-trivial? Line 31: import argparse, logging,

openbsc[master]: twisted_ipa.py: bump version properly

2017-03-21 Thread Neels Hofmeyr
Patch Set 1: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/2135 To unsubscribe, visit https://gerrit.osmocom.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I44c8521f12e6432038998bfb1ac1bb37a1137787 Gerrit-PatchSet: 1 Gerrit-Project: openbsc Gerrit-Branch: master

osmo-trx[master]: osmo-trx: Separate command line switch to enable EDGE filler.

2017-03-21 Thread Max
Patch Set 2: Code-Review-1 (1 comment) https://gerrit.osmocom.org/#/c/2143/2/Transceiver52M/osmo-trx.cpp File Transceiver52M/osmo-trx.cpp: Line 419: case 'E': So user can still specify ... -E 123 -r 321 ... without enabling EDGE and it'll work (provided options are parsed from

osmo-trx[master]: BitVector: Convert SoftVector from 0..1 to -1..+1 soft bits.

2017-03-21 Thread Max
Patch Set 2: (1 comment) https://gerrit.osmocom.org/#/c/2142/2/CommonLibs/BitVector.h File CommonLibs/BitVector.h: Line 305: return (*dp)>0.0F; Can we just compare "> 0" in here? -- To view, visit https://gerrit.osmocom.org/2142 To unsubscribe, visit

osmo-trx[master]: sigProcLib: Slice SoftVector instead of signalVector for GMS...

2017-03-21 Thread Max
Patch Set 2: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/2138 To unsubscribe, visit https://gerrit.osmocom.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: If9ed6f0f80fbe88c994b2f9c3cae91d0d57f4442 Gerrit-PatchSet: 2 Gerrit-Project: osmo-trx Gerrit-Branch: master

osmo-trx[master]: BitVector: Remove convolutional codec - we don't use it in o...

2017-03-21 Thread Max
Patch Set 2: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/2141 To unsubscribe, visit https://gerrit.osmocom.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I3006b6a26c5eff59dbe9c034f689961802f1d0d0 Gerrit-PatchSet: 2 Gerrit-Project: osmo-trx Gerrit-Branch: master

osmo-trx[master]: Call vectorSlicer() right before packing bits for transmissi...

2017-03-21 Thread Max
Patch Set 2: Could you elaborate, why is this better than before? -- To view, visit https://gerrit.osmocom.org/2139 To unsubscribe, visit https://gerrit.osmocom.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: Idd6ddd7ac219afb0df055a692632678b66373764 Gerrit-PatchSet: 2

osmo-trx[master]: CommonLibs: Print soft bits with less confidence to console ...

2017-03-21 Thread Max
Patch Set 2: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/2140 To unsubscribe, visit https://gerrit.osmocom.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I747a17568ee48f1f3163e8dfab2e450af85e6435 Gerrit-PatchSet: 2 Gerrit-Project: osmo-trx Gerrit-Branch: master

osmo-trx[master]: sigProcLib: Rename demodulateBurst() to demodGmskBurst() for...

2017-03-21 Thread Max
Patch Set 2: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/2137 To unsubscribe, visit https://gerrit.osmocom.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: Ibcef8d7d4a2c06865bed7e4091ccc8dbbd494d77 Gerrit-PatchSet: 2 Gerrit-Project: osmo-trx Gerrit-Branch: master

osmo-trx[master]: sigProcLib: make energyDetect() simpler by returning actual ...

2017-03-21 Thread Max
Patch Set 1: (1 comment) https://gerrit.osmocom.org/#/c/2136/1/Transceiver52M/Transceiver.cpp File Transceiver52M/Transceiver.cpp: Line 609: float toa, max = -1.0, avg = 0.0; There's no need to move variable declaration. -- To view, visit https://gerrit.osmocom.org/2136 To unsubscribe,