[PATCH] osmo-bts[master]: scheduler_trx.c: Avoid code duplication for BER10k computation

2017-05-25 Thread Harald Welte
Review at https://gerrit.osmocom.org/2741 scheduler_trx.c: Avoid code duplication for BER10k computation Use an (inline) function rather than code copy+pasting Change-Id: I42e76a4707968e428cbd2e43d5df71ef445efece --- M src/osmo-bts-trx/scheduler_trx.c 1 file changed, 16 insertions(+), 8

[MERGED] osmo-gsm-tester[master]: event_loop: Create a global event loop to poll and wait for ...

2017-05-25 Thread Pau Espin Pedrol
Pau Espin Pedrol has submitted this change and it was merged. Change subject: event_loop: Create a global event loop to poll and wait for events .. event_loop: Create a global event loop to poll and wait for events

libosmo-abis[master]: Add value_string for input signal names (e1inp_signal_names)

2017-05-25 Thread Harald Welte
Patch Set 1: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/2738 To unsubscribe, visit https://gerrit.osmocom.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I1662d4a969d2d12677646f3120b25be9a20c6d22 Gerrit-PatchSet: 1 Gerrit-Project: libosmo-abis Gerrit-Branch: master

osmo-gsm-tester[master]: default suites: enable osmo-bts-trx

2017-05-25 Thread Pau Espin Pedrol
Patch Set 1: (1 comment) https://gerrit.osmocom.org/#/c/2735/1/example/default-suites.conf File example/default-suites.conf: Line 2: - sms:trx Do we have already a osmo-bts-trx in place for the tests? I though I was going to do that over next days -- To view, visit

osmo-gsm-tester[master]: rename resource nitb_iface to ip_address

2017-05-25 Thread Pau Espin Pedrol
Patch Set 2: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/2712 To unsubscribe, visit https://gerrit.osmocom.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I3ad583ae7a33f7a7bb56fe78a125f73c56a0e860 Gerrit-PatchSet: 2 Gerrit-Project: osmo-gsm-tester Gerrit-Branch:

osmo-gsm-tester[master]: nitb config: set: logging color 1, category 1

2017-05-25 Thread Pau Espin Pedrol
Patch Set 2: Can you please provide a separate patch to remove the file if it's not needed, oterhwise set the logging color 1? -- To view, visit https://gerrit.osmocom.org/2706 To unsubscribe, visit https://gerrit.osmocom.org/settings Gerrit-MessageType: comment Gerrit-Change-Id:

[PATCH] libosmo-abis[master]: ipacces.c: Remove ipa_bts_id_resp() and use libosmocore

2017-05-25 Thread Harald Welte
Review at https://gerrit.osmocom.org/2737 ipacces.c: Remove ipa_bts_id_resp() and use libosmocore In Chanage-Id Icbcd8827a75fd5f3393351c1ca372de85275ad35 we introduced a very similar function to libosocore. Let's use that rather than our own version here. Change-Id:

osmo-gsm-tester[master]: resource error logging that is easier to understand

2017-05-25 Thread Pau Espin Pedrol
Patch Set 2: (2 comments) https://gerrit.osmocom.org/#/c/2705/2/src/osmo_gsm_tester/resource.py File src/osmo_gsm_tester/resource.py: Line 468: self.count(kind) + 1, You didn't move this to the line above

osmo-gsm-tester[master]: log: change 'log_all_origins' from bool to a list of levels ...

2017-05-25 Thread Pau Espin Pedrol
Patch Set 2: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/2731 To unsubscribe, visit https://gerrit.osmocom.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I0277782652548fa321f767da79b207d70678fad1 Gerrit-PatchSet: 2 Gerrit-Project: osmo-gsm-tester Gerrit-Branch:

osmo-gsm-tester[master]: log: change 'log_all_origins' from bool to a list of levels ...

2017-05-25 Thread Pau Espin Pedrol
Patch Set 2: I guess this helps with the issue I was seeing while fighting against "try" vs "with" and logging? -- To view, visit https://gerrit.osmocom.org/2731 To unsubscribe, visit https://gerrit.osmocom.org/settings Gerrit-MessageType: comment Gerrit-Change-Id:

osmo-gsm-tester[master]: bts: add remote_addr() function

2017-05-25 Thread Pau Espin Pedrol
Patch Set 4: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/2715 To unsubscribe, visit https://gerrit.osmocom.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I7af9275914f34808cb60ae16b65ecd3688fd6b5b Gerrit-PatchSet: 4 Gerrit-Project: osmo-gsm-tester Gerrit-Branch:

osmo-gsm-tester[master]: default-suites.conf: run aoip

2017-05-25 Thread Pau Espin Pedrol
Patch Set 4: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/2721 To unsubscribe, visit https://gerrit.osmocom.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I0f7d6feec5062c2aaf07eb9a7f543a4a84cb1ff7 Gerrit-PatchSet: 4 Gerrit-Project: osmo-gsm-tester Gerrit-Branch:

osmo-gsm-tester[master]: cosmetic: comment and SMS token tweak

2017-05-25 Thread Pau Espin Pedrol
Patch Set 1: Code-Review-1 (1 comment) https://gerrit.osmocom.org/#/c/2734/1/src/osmo_gsm_tester/ofono_client.py File src/osmo_gsm_tester/ofono_client.py: Line 299: if hasattr(to_msisdn, 'msisdn'): if it's a modem why not just checking isinstance(modem "Modem") instead for checking

osmo-gsm-tester[master]: fix: refresh dbus object when interfaces have changed

2017-05-25 Thread Pau Espin Pedrol
Patch Set 3: Code-Review-1 (7 comments) I really don't like playing like this wit the dbus proxy objects, but I understand it's most probably a bug (or feature missing) in pydbus and for now we need to workaround it. This means, I'm OK with merging this but please open a bug report in pydbus

osmo-gsm-tester[master]: ofono_client: Discover modem path from imsi

2017-05-25 Thread Pau Espin Pedrol
Patch Set 1: I agree in the sense that the implementation is a bit more complex than what we initially though, but now that it's already there and it works I think it's nice to keep it as it simplifies configuration and still provides the possibility to configure it manually as done before.

[MERGED] openbsc[master]: gsm_data_shared: add value strings for gsm_chreq

2017-05-25 Thread Harald Welte
Harald Welte has submitted this change and it was merged. Change subject: gsm_data_shared: add value strings for gsm_chreq .. gsm_data_shared: add value strings for gsm_chreq Change-Id:

[MERGED] openbsc[master]: pcu_sock: Forward paging request from PCU via RSL to BTS

2017-05-25 Thread Harald Welte
Harald Welte has submitted this change and it was merged. Change subject: pcu_sock: Forward paging request from PCU via RSL to BTS .. pcu_sock: Forward paging request from PCU via RSL to BTS Change-Id:

[MERGED] openbsc[master]: abis_rsl: use msgb_pull to parse tlli from msg

2017-05-25 Thread Harald Welte
Harald Welte has submitted this change and it was merged. Change subject: abis_rsl: use msgb_pull to parse tlli from msg .. abis_rsl: use msgb_pull to parse tlli from msg Change-Id: I971bf6c8821689f9d8a1294a9b3bf1af9c4091f7

[MERGED] openbsc[master]: pcu_sock: Don't re-implement core functionality like gsm_bts...

2017-05-25 Thread Harald Welte
Harald Welte has submitted this change and it was merged. Change subject: pcu_sock: Don't re-implement core functionality like gsm_bts_trx_num() .. pcu_sock: Don't re-implement core functionality like gsm_bts_trx_num()

[MERGED] openbsc[master]: pcu_sock: Fix broken paging command

2017-05-25 Thread Harald Welte
Harald Welte has submitted this change and it was merged. Change subject: pcu_sock: Fix broken paging command .. pcu_sock: Fix broken paging command The pcu sends us an already made up MAC-Block that contains the paging

[MERGED] openbsc[master]: pcu_sock: Forward imm.ass PCU originated messages

2017-05-25 Thread Harald Welte
Harald Welte has submitted this change and it was merged. Change subject: pcu_sock: Forward imm.ass PCU originated messages .. pcu_sock: Forward imm.ass PCU originated messages The PCU sends imm.ass messages in response to a

[MERGED] openbsc[master]: libbsc: add debug log message to S_L_INP_* callbacks

2017-05-25 Thread Harald Welte
Harald Welte has submitted this change and it was merged. Change subject: libbsc: add debug log message to S_L_INP_* callbacks .. libbsc: add debug log message to S_L_INP_* callbacks Improve debug log output of input callbacks

[MERGED] openbsc[master]: pcu_sock: add basic pcu interface support

2017-05-25 Thread Harald Welte
Harald Welte has submitted this change and it was merged. Change subject: pcu_sock: add basic pcu interface support .. pcu_sock: add basic pcu interface support Adds a basic version of a pcu socket interface, similar to the

[MERGED] openbsc[master]: pcu_sock: Send non-NULL hLayer1 to PCU

2017-05-25 Thread Harald Welte
Harald Welte has submitted this change and it was merged. Change subject: pcu_sock: Send non-NULL hLayer1 to PCU .. pcu_sock: Send non-NULL hLayer1 to PCU The BSC-located PCU case looks to the PCU like a BTS-located PCU with

[MERGED] openbsc[master]: pcu_sock: get rid of magic numbers and use ARRAY_SIZE() for ...

2017-05-25 Thread Harald Welte
Harald Welte has submitted this change and it was merged. Change subject: pcu_sock: get rid of magic numbers and use ARRAY_SIZE() for array iteration .. pcu_sock: get rid of magic numbers and use ARRAY_SIZE() for array

[MERGED] openbsc[master]: pcu_sock: pcu_tx_info_ind allow to use TRX not starting from 0

2017-05-25 Thread Harald Welte
Harald Welte has submitted this change and it was merged. Change subject: pcu_sock: pcu_tx_info_ind allow to use TRX not starting from 0 .. pcu_sock: pcu_tx_info_ind allow to use TRX not starting from 0 It would prevent using

openbsc[master]: pcu_sock: pcu_tx_info_ind allow to use TRX not starting from 0

2017-05-25 Thread Harald Welte
Patch Set 2: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/2062 To unsubscribe, visit https://gerrit.osmocom.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I68dc5e837bd2a3602f7875063c85da4082196274 Gerrit-PatchSet: 2 Gerrit-Project: openbsc Gerrit-Branch: master

openbsc[master]: pcu_sock: set flag PCU_IF_FLAG_SYSMO by setting pcu_direct = 1

2017-05-25 Thread Harald Welte
Patch Set 2: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/2061 To unsubscribe, visit https://gerrit.osmocom.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I1f5407264fc4f209456ffcb73d7853ff315aab86 Gerrit-PatchSet: 2 Gerrit-Project: openbsc Gerrit-Branch: master

openbsc[master]: libbsc: add debug log message to S_L_INP_* callbacks

2017-05-25 Thread Harald Welte
Patch Set 2: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/2041 To unsubscribe, visit https://gerrit.osmocom.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: Ifca46dd8b356d0de31cccbd79e406079d3a0d7d2 Gerrit-PatchSet: 2 Gerrit-Project: openbsc Gerrit-Branch: master

openbsc[master]: pcu_sock: add basic pcu interface support

2017-05-25 Thread Harald Welte
Patch Set 2: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/2056 To unsubscribe, visit https://gerrit.osmocom.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: Ib13cb4099d12fa71e9e0b8727e19ab29e11909b2 Gerrit-PatchSet: 2 Gerrit-Project: openbsc Gerrit-Branch: master

[PATCH] openbsc[master]: gsm_data_shared: add value strings for gsm_chreq

2017-05-25 Thread Harald Welte
Hello Neels Hofmeyr, Jenkins Builder, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/2031 to look at the new patch set (#5). gsm_data_shared: add value strings for gsm_chreq Change-Id: I23d3be5610a5a46098d2b12feed4245828599aae --- M

[MERGED] osmocom-bb[master]: host/mobile: use talloc for ms->name allocation

2017-05-25 Thread Harald Welte
Harald Welte has submitted this change and it was merged. Change subject: host/mobile: use talloc for ms->name allocation .. host/mobile: use talloc for ms->name allocation The approach of talloc memory management reduces

osmocom-bb[master]: host/mobile: use talloc for ms->name allocation

2017-05-25 Thread Harald Welte
Patch Set 4: Code-Review+2 (1 comment) https://gerrit.osmocom.org/#/c/2667/4/src/host/layer23/src/mobile/app_mobile.c File src/host/layer23/src/mobile/app_mobile.c: Line 273: mncc_name = talloc_asprintf(ms, "/tmp/ms_mncc_%s", ms->name); mncc_name variable declaration could go

[MERGED] osmocom-bb[master]: Makefile: add forgotten gsmmap to (dist)clean section

2017-05-25 Thread Harald Welte
Harald Welte has submitted this change and it was merged. Change subject: Makefile: add forgotten gsmmap to (dist)clean section .. Makefile: add forgotten gsmmap to (dist)clean section Change-Id:

osmocom-bb[master]: Makefile: add forgotten gsmmap to (dist)clean section

2017-05-25 Thread Harald Welte
Patch Set 2: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/2398 To unsubscribe, visit https://gerrit.osmocom.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I14abe8a061d218ca81dd2d101b218d3030324aa2 Gerrit-PatchSet: 2 Gerrit-Project: osmocom-bb Gerrit-Branch: master