Re: git-diff-index man page

2013-05-20 Thread Jonathan Nieder
Junio C Hamano wrote: --- a/Documentation/git-diff-index.txt +++ b/Documentation/git-diff-index.txt @@ -3,7 +3,7 @@ git-diff-index(1) NAME -git-diff-index - Compares content and mode of blobs between the index and repository +git-diff-index - Compare a tree and the working tree

Re: Outdated and broken online versions of user-manual.html

2013-05-20 Thread Jonathan Nieder
Philip Oakley wrote: From: Thomas Ackermann th.ac...@arcor.de (5) Large overlapping with the tutorials. IMHO all of the tutorials should be blended into user-manual [...] I would be a little cautious of your point 5 if it squoze everything into one overlong document at the expense of losing

Re: [RFC/PATCH] patch-ids: check modified paths before calculating diff

2013-05-20 Thread John Keeping
On Sun, May 19, 2013 at 11:36:23PM -0700, Jonathan Nieder wrote: I don't know what it should mean to try to use --cherry without --no-merges or --first-parent, so I guess this is harmless. Currently --no-merges doesn't actually get passed down this far. We do the patch ID calculations without

[PATCH 0/6] t5000: add test for pax extended header generation

2013-05-20 Thread René Scharfe
This series adds a test that exercises git archive's pax header code. It checks for tar versions that don't support pax headers and works around their deficiency. The first five patches are cleanups and refactorings to centralize tar calls into a helper function. The last patch adds the

[PATCH 5/6] t5000: simplify tar-tree tests

2013-05-20 Thread René Scharfe
Just compare the archives created by git tar-tree with the ones created using git archive with the equivalent options, whose contents are checked already, instead of extracting them again. Signed-off-by: René Scharfe rene.scha...@lsrfire.ath.cx --- t/t5000-tar-tree.sh | 31

[PATCH 3/6] t5000: factor out check_tar

2013-05-20 Thread René Scharfe
Create a helper function that extracts a tar archive and checks its contents, modelled after check_zip in t5003. Signed-off-by: René Scharfe rene.scha...@lsrfire.ath.cx --- t/t5000-tar-tree.sh | 35 ++- 1 file changed, 22 insertions(+), 13 deletions(-) diff --git

[PATCH 4/6] t5000: use check_tar for prefix test

2013-05-20 Thread René Scharfe
Perform the full range of checks against all archived files instead of looking only at the file type of a few of them. Also add a test of a git archive with a prefix ending in with a slash, i.e. adding a full directory level. Signed-off-by: René Scharfe rene.scha...@lsrfire.ath.cx ---

[PATCH 6/6] t5000: test long filenames

2013-05-20 Thread René Scharfe
Add a file with a long name to the test archive in order to check entries with pax extended headers. Also add a check for tar versions that doen't understand this format. Those versions should extract the headers as a regular files. Add code to check_tar() to interpret the path header if

[PATCH 2/6] t5000, t5003: create directories for extracted files lazily

2013-05-20 Thread René Scharfe
Create the directories b and c just before they are needed instead of up front. For t5003 it turns out we don't need them at all. For t5000 it makes the coming modifications easier. Signed-off-by: René Scharfe rene.scha...@lsrfire.ath.cx --- t/t5000-tar-tree.sh| 6 +++---

Re: [PATCH 00/17] Remove assumptions about refname lifetimes

2013-05-20 Thread Johan Herland
On Sun, May 19, 2013 at 10:26 PM, Michael Haggerty mhag...@alum.mit.edu wrote: Recently a number of race conditions related to references have been discovered. There is likely to be a two-pronged solution to the races: * For traditional, filesystem-based references, there will have to be

Re: git-submodule nested subrepo bug (Segmentation fault)

2013-05-20 Thread John Keeping
On Mon, May 20, 2013 at 09:32:21AM +0400, Kirill Berezin wrote: When you trying to add submodule, that already has submodule, it craches. For example you could try: git clone --recursive http://github.com/Exsul/al_server Which version of Git were you using? I was not able to reproduce this

Re: [RFC 16/17] object_array_entry: copy name before storing in name field

2013-05-20 Thread Johan Herland
On Sun, May 19, 2013 at 10:27 PM, Michael Haggerty mhag...@alum.mit.edu wrote: This is the culmination of the last few commits. Since some callers want to store refnames in the name field of object_array elements, but we don't want those callers to assume that the refnames that they got from

Re: [PATCH 0/6] t5000: add test for pax extended header generation

2013-05-20 Thread René Scharfe
Am 20.05.2013 11:58, schrieb René Scharfe: This series adds a test that exercises git archive's pax header code. It checks for tar versions that don't support pax headers and works around their deficiency. The first five patches are cleanups and refactorings to centralize tar calls into a

Storing refs in the odb (was: Re: [PATCH 00/17] Remove assumptions about refname lifetimes)

2013-05-20 Thread Johan Herland
On Mon, May 20, 2013 at 2:15 PM, Michael Haggerty mhag...@alum.mit.edu wrote: This is a very interesting idea. It's turtles all the way down. :) On 05/20/2013 12:28 PM, Johan Herland wrote: For server-class installations we need ref storage that can be read (and updated?) atomically, and

Re: [RFC 16/17] object_array_entry: copy name before storing in name field

2013-05-20 Thread Michael Haggerty
On 05/20/2013 12:33 PM, Johan Herland wrote: On Sun, May 19, 2013 at 10:27 PM, Michael Haggerty mhag...@alum.mit.edu wrote: This is the culmination of the last few commits. Since some callers want to store refnames in the name field of object_array elements, but we don't want those callers

[no subject]

2013-05-20 Thread nitoyon
-- To unsubscribe from this list: send the line unsubscribe git in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html

Re: What's cooking in git.git (May 2013, #04; Wed, 15)

2013-05-20 Thread Junio C Hamano
Duy Nguyen pclo...@gmail.com writes: On Thu, May 16, 2013 at 6:42 AM, Junio C Hamano gits...@pobox.com wrote: * nd/warn-ambiguous-object-name (2013-05-07) 1 commit - get_sha1: improve ambiguity warning regarding SHA-1 and ref names git cmd name, when name happens to be a 40-hex string,

Re: [PATCH 00/17] Remove assumptions about refname lifetimes

2013-05-20 Thread Junio C Hamano
Johan Herland jo...@herland.net writes: For server-class installations we need ref storage that can be read (and updated?) atomically, and the current system of loose + packed files won't work since reading (and updating) more than a single file is not an atomic operation. Trivially, one

Re: [RFC 16/17] object_array_entry: copy name before storing in name field

2013-05-20 Thread Jeff King
On Mon, May 20, 2013 at 04:42:38PM +0200, Michael Haggerty wrote: * Many callers store the empty string () as the name; for example, most of the entries created during a run of rev-list have as their name. This means that lots of needless copies of are being made. I think that

Re: [PATCH 00/17] Remove assumptions about refname lifetimes

2013-05-20 Thread Jeff King
On Mon, May 20, 2013 at 09:37:30AM -0700, Junio C Hamano wrote: Johan Herland jo...@herland.net writes: For server-class installations we need ref storage that can be read (and updated?) atomically, and the current system of loose + packed files won't work since reading (and updating)

Re: [PATCH 00/17] Remove assumptions about refname lifetimes

2013-05-20 Thread Johan Herland
On Mon, May 20, 2013 at 6:37 PM, Junio C Hamano gits...@pobox.com wrote: Johan Herland jo...@herland.net writes: For server-class installations we need ref storage that can be read (and updated?) atomically, and the current system of loose + packed files won't work since reading (and updating)

Re: [PATCH 00/17] Remove assumptions about refname lifetimes

2013-05-20 Thread Johan Herland
On Mon, May 20, 2013 at 6:59 PM, Jeff King p...@peff.net wrote: On Mon, May 20, 2013 at 09:37:30AM -0700, Junio C Hamano wrote: Johan Herland jo...@herland.net writes: For server-class installations we need ref storage that can be read (and updated?) atomically, and the current system of

Re: Storing refs in the odb

2013-05-20 Thread Junio C Hamano
Johan Herland jo...@herland.net writes: Of course in either case we couldn't use a tree object directly, because these new reference tree objects would refer not only to blobs and other trees but also to commits and tags. Indeed. I don't know if the best solution would be to actually _allow_

Re: Storing refs in the odb

2013-05-20 Thread Johan Herland
On Mon, May 20, 2013 at 7:21 PM, Junio C Hamano gits...@pobox.com wrote: Johan Herland jo...@herland.net writes: Of course in either case we couldn't use a tree object directly, because these new reference tree objects would refer not only to blobs and other trees but also to commits and

Re: [RFC/PATCH 1/2] config doc: add dot-repository note

2013-05-20 Thread Junio C Hamano
Jonathan Nieder jrnie...@gmail.com writes: Philip Oakley wrote: --- a/Documentation/config.txt +++ b/Documentation/config.txt @@ -734,6 +734,8 @@ branch.name.remote:: overridden by `branch.name.pushremote`. If no remote is configured, or if you are not on any branch, it defaults

Re: [RFC/PATCH 2/2] doc: command line interface (cli) dot-repository dwimmery

2013-05-20 Thread Junio C Hamano
Jonathan Nieder jrnie...@gmail.com writes: --- a/Documentation/gitcli.txt +++ b/Documentation/gitcli.txt @@ -59,6 +59,10 @@ working tree. After running `git add hello.c; rm hello.c`, you will _not_ see `hello.c` in your working tree with the former, but with the latter you will.

Re: [PATCH 00/17] Remove assumptions about refname lifetimes

2013-05-20 Thread Junio C Hamano
Jeff King p...@peff.net writes: But more importantly, it introduces contention between two unrelated refs that are being updated. Even if we reconcile the differences automatically (e.g., with a merge-and-retry strategy), that is going to be a serious performance regression for a busy

Re: [PATCH] remote-hg: set stdout to binary mode on win32

2013-05-20 Thread Junio C Hamano
Felipe Contreras felipe.contre...@gmail.com writes: On Sun, May 19, 2013 at 6:53 AM, Felipe Contreras felipe.contre...@gmail.com wrote: From: Amit Bakshi ambak...@gmail.com git clone hangs on windows, and file.write would return errno 22 inside of mercurial's windows.winstdout wrapper

Re: Storing refs in the odb

2013-05-20 Thread Junio C Hamano
Johan Herland jo...@herland.net writes: I wasn't considering disallowing _anything_, rather open up to the idea that a tree object might refer to tag objects as well as commits/trees/blobs. E.g. in my suggested-but-pretty-much-retracted scheme, I was considering whether the tree entry at the

Re: Storing refs in the odb

2013-05-20 Thread Johan Herland
On Mon, May 20, 2013 at 8:28 PM, Junio C Hamano gits...@pobox.com wrote: Johan Herland jo...@herland.net writes: I wasn't considering disallowing _anything_, rather open up to the idea that a tree object might refer to tag objects as well as commits/trees/blobs. E.g. in my

Re: [PATCH 3/6] t5000: factor out check_tar

2013-05-20 Thread Eric Sunshine
On Mon, May 20, 2013 at 5:58 AM, René Scharfe rene.scha...@lsrfire.ath.cx wrote: Create a helper function that extracts a tar archive and checks its contents, modelled after check_zip in t5003. Signed-off-by: René Scharfe rene.scha...@lsrfire.ath.cx --- t/t5000-tar-tree.sh | 35

Re: [PATCH 3/6] t5000: factor out check_tar

2013-05-20 Thread René Scharfe
Am 20.05.2013 21:54, schrieb Eric Sunshine: On Mon, May 20, 2013 at 5:58 AM, René Scharfe rene.scha...@lsrfire.ath.cx wrote: +check_tar() { + tarfile=$1.tar + listfile=$1.lst + dir=$1 + dir_with_prefix=$dir/$2 + + test_expect_success ' extract tar archive' ' s/'

[PATCH] contrib/git-subtree: Use /bin/sh interpreter instead of /bin/bash

2013-05-20 Thread Dmitry Marakasov
Use /bin/sh interpreter instead of /bin/bash for contrib/git-subtree: it's required for systems which don't use bash by default (for example, FreeBSD), while there seem to be no bashisms in the script (confirmed by looking through the source and tesing subtree functionality with FreeBSD's /bin/sh)

Re: [RFC/PATCH 1/2] config doc: add dot-repository note

2013-05-20 Thread Philip Oakley
From: Junio C Hamano gits...@pobox.com Sent: Monday, May 20, 2013 6:50 PM Jonathan Nieder jrnie...@gmail.com writes: Philip Oakley wrote: --- a/Documentation/config.txt +++ b/Documentation/config.txt @@ -734,6 +734,8 @@ branch.name.remote:: overridden by `branch.name.pushremote`. If no

Re: [RFC 16/17] object_array_entry: copy name before storing in name field

2013-05-20 Thread Michael Haggerty
On 05/20/2013 06:44 PM, Jeff King wrote: On Mon, May 20, 2013 at 04:42:38PM +0200, Michael Haggerty wrote: * Many callers store the empty string () as the name; for example, most of the entries created during a run of rev-list have as their name. This means that lots of needless copies

Re: [RFC/PATCH 1/2] Doc rebase: Describe rebase as excluding merge commits

2013-05-20 Thread Philip Oakley
From: Junio C Hamano gits...@pobox.com Sent: Monday, May 20, 2013 5:43 AM Jonathan Nieder jrnie...@gmail.com writes: Philip Oakley wrote: Describe rebase in the description section. It already does that. :) I think you mean start with a summary, which is a valuable improvement. It

Re: [PATCH v2] git-svn: introduce --parents parameter for commands branch and tag

2013-05-20 Thread Eric Wong
Tobias Schulte tobias.schu...@gliderpilot.de wrote: This parameter is equivalent to the parameter --parents on svn cp commands and is useful for non-standard repository layouts. Signed-off-by: Tobias Schulte tobias.schu...@gliderpilot.de Signed-off-by: Eric Wong normalper...@yhbt.net

Re: [RFC/PATCH 2/2] doc: command line interface (cli) dot-repository dwimmery

2013-05-20 Thread Junio C Hamano
Philip Oakley philipoak...@iee.org writes: So we can have a branch whose remote is '.' _and_ a remote whose URL is '.' Yes, and they are two separate concepts. git fetch while on mywork branch with this: [branch mywork] remote = git://git.k.org/pub/scm/git/git.git merge =

Re: [RFC/PATCH 1/2] Doc rebase: Describe rebase as excluding merge commits

2013-05-20 Thread Junio C Hamano
Philip Oakley philipoak...@iee.org writes: From: Junio C Hamano gits...@pobox.com Sent: Monday, May 20, 2013 5:43 AM Jonathan Nieder jrnie...@gmail.com writes: Philip Oakley wrote: Describe rebase in the description section. It already does that. :) I think you mean start with a

Re: [PATCH] contrib/git-subtree: Use /bin/sh interpreter instead of /bin/bash

2013-05-20 Thread Junio C Hamano
Dmitry Marakasov amd...@amdmi3.ru writes: Use /bin/sh interpreter instead of /bin/bash for contrib/git-subtree: it's required for systems which don't use bash by default (for example, FreeBSD), while there seem to be no bashisms in the script (confirmed by looking through the source and

Re: [PATCH v2] git-svn: introduce --parents parameter for commands branch and tag

2013-05-20 Thread Junio C Hamano
Eric Wong normalper...@yhbt.net writes: Tobias Schulte tobias.schu...@gliderpilot.de wrote: This parameter is equivalent to the parameter --parents on svn cp commands and is useful for non-standard repository layouts. Signed-off-by: Tobias Schulte tobias.schu...@gliderpilot.de

Re: [PATCH v2] git-svn: introduce --parents parameter for commands branch and tag

2013-05-20 Thread Eric Wong
Junio C Hamano gits...@pobox.com wrote: Thanks; is it a good time for me to pull? Yes, I think so. Thanks! The following changes since commit de3a5c6da194928868b5eee4a9c4d538b4194727: Git 1.8.3-rc3 (2013-05-17 12:19:20 -0700) are available in the git repository at:

Re: [PATCH 0/2] remote-helpers: test fixes

2013-05-20 Thread Junio C Hamano
Felipe Contreras felipe.contre...@gmail.com writes: Hi, I've setup a project in Travis CI for continuous integration with very good results, however, I had to apply a couple of fixes. I'm not sure if this is v1.8.3 material, but here they are. Thanks; I'll queue them at the tip of

Re: git-diff-index man page

2013-05-20 Thread Junio C Hamano
Jonathan Nieder jrnie...@gmail.com writes: Thanks and hope that helps, Jonathan Thanks, the result reads much better, I think. Albert? diff --git i/Documentation/git-diff-index.txt w/Documentation/git-diff-index.txt index 58308e15..a86cf62e 100644 --- i/Documentation/git-diff-index.txt

Re: [PATCH 0/6] t5000: add test for pax extended header generation

2013-05-20 Thread Junio C Hamano
Thanks, will queue. -- To unsubscribe from this list: send the line unsubscribe git in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html

Re: [PATCH v12 00/15] Interactive git-clean

2013-05-20 Thread Junio C Hamano
Will replace what has been queued on 'pu' with trivial style fixups (haven't had a chance to make time to read it through). Thanks. -- To unsubscribe from this list: send the line unsubscribe git in the body of a message to majord...@vger.kernel.org More majordomo info at

Workflow Help

2013-05-20 Thread Quilkey, Tony
Hi, I am looking at formulating and then documenting our vcs workflow using Git at work. I have an idea of how I want things to work, but am a little hazy on some of the details. Our basic workflow will be based around: http://nvie.com/posts/a-successful-git-branching-model, with a few

[PATCH] transport-helper: barf when user tries old:new

2013-05-20 Thread Felipe Contreras
Otherwise with certain remote helpers (the ones that support 'export'), the users will be pushing to the wrong branch: git push topic:master Will push the topic branch, as if the user typed: git push topic Signed-off-by: Felipe Contreras felipe.contre...@gmail.com --- I did fix this

Fw:จับได้ว่า Ambranews ใช้ศาสนาเป็นอาวุธ

2013-05-20 Thread greatfunengl...@yahoo.com
“จับได้ว่า Ambranews ใช้ศาสนาเป็นอาวุธ” เมื่อต้นเดือนพฤษภาคมที่ผ่านมานี้ เวปไซต์ ambranews จัดตั้งและดำเนินงานอยู่ ในประเทศมาเลเซีย ได้นำเสนอข่าวเป็นภาษามาเลเซียโจมตีการทำงานของเจ้าหน้าที่ไทย โดยใช้คำว่า “คนมาลายู” แทนคนไทยมุสลิมในจังหวัดชายแดนภาคใต้ต่อกรณียิงกราด 6

[PATCH 0/2] remote-hg: fix configuration notes

2013-05-20 Thread Felipe Contreras
Hi, For 'master'. Felipe Contreras (2): remote-hg: trivial configuration note cleanup remote-hg: fix order of configuration comments contrib/remote-helpers/git-remote-hg | 8 1 file changed, 4 insertions(+), 4 deletions(-) -- 1.8.3.rc3.1.gf11a2b7.dirty -- To unsubscribe from

[PATCH 2/2] remote-hg: fix order of configuration comments

2013-05-20 Thread Felipe Contreras
The other configurations were added in the wrong place. Signed-off-by: Felipe Contreras felipe.contre...@gmail.com --- contrib/remote-helpers/git-remote-hg | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/contrib/remote-helpers/git-remote-hg

Contributing to git: cleaner git -rm add configuration options

2013-05-20 Thread Mathieu Liénard--Mayor
Hello everyone, I'm Mathieu LIENARD--MAYOR, a french student at Ensimag - Grenoble INP, and together with my fellow student Jorge GARCIA we will try to contribute to git as our school project. As of now, we are considering the implementation of the following two features: -Cleaner error