Re: [PATCH v10 00/20] port branch.c to use ref-filter's printing options

2017-01-14 Thread Karthik Nayak
On Wed, Jan 11, 2017 at 2:21 AM, Junio C Hamano wrote: > Karthik Nayak writes: > >> index 81db67d74..08be8462c 100644 >> --- a/Documentation/git-for-each-ref.txt >> +++ b/Documentation/git-for-each-ref.txt >> @@ -95,13 +95,17 @@ refname:: >> The

Re: [PATCH v10 19/20] branch: use ref-filter printing APIs

2017-01-14 Thread Karthik Nayak
Hello, On Thu, Jan 12, 2017 at 5:17 AM, Jacob Keller wrote: > On Tue, Jan 10, 2017 at 12:49 AM, Karthik Nayak wrote: >> diff --git a/builtin/branch.c b/builtin/branch.c >> index 34cd61cd9..f293ee5b0 100644 >> --- a/builtin/branch.c >> +++

Re: [PATCH v10 03/20] ref-filter: implement %(if:equals=) and %(if:notequals=)

2017-01-14 Thread Karthik Nayak
Hello, On Wed, Jan 11, 2017 at 2:15 AM, Junio C Hamano wrote: > Karthik Nayak writes: > >> + if_then_else->condition_satisfied = 1; >> + } else if (if_then_else->cmp_status == COMPARE_UNEQUAL) { > > Please, no space before tabs

Re: [PATCH 2/2] Use 'env' to find perl instead of fixed path

2017-01-14 Thread Eric Wong
Jeff King wrote: > Just as a devil's advocate, why do we care about warnings in third-party > modules? Or more specifically, why do _users_ who are running Git care > about them? We cannot fix them in Git. A user may report the error to > the module author, but the module author

[ANNOUNCE] Git for Windows 2.11.0(3)

2017-01-14 Thread Johannes Schindelin
MIME-Version: 1.0 Fcc: Sent Dear Git users, It is my pleasure to announce that Git for Windows 2.11.0(3) is available from: https://git-for-windows.github.io/ Changes since Git for Windows v2.11.0(2) (January 13th 2017) Bug Fixes • Fixed an off-by-two bug in the POSIX emulation

Re: [PATCH 2/3] xdiff: -W: include immediately preceding non-empty lines in context

2017-01-14 Thread René Scharfe
Am 14.01.2017 um 00:56 schrieb Junio C Hamano: Vegard Nossum writes: The patch will work as intended and as expected for 95% of the users out there (javadoc, Doxygen, kerneldoc, etc. all have the comment immediately preceding the function) and fixes a very real

Re: [PATCHv3 2/2] builtin/commit.c: switch to xstrfmt(), instead of snprintf,

2017-01-14 Thread Elia Pinto
Ok. I agree. But is it strictly necessary to resend for this ? Thanks 2017-01-13 19:33 GMT+01:00 Brandon Williams : > On 01/13, Elia Pinto wrote: >> In this patch, instead of using xnprintf instead of snprintf, which asserts >> that we don't truncate, we are switching to

gitk pull request // was: Re: gitk: "lime" color incompatible with older Tk versions

2017-01-14 Thread David Aguilar
On Fri, Jan 13, 2017 at 03:20:43AM -0800, David Aguilar wrote: > > Ping.. it would be nice to get this patch applied. Sorry for the noise, and thank you Paul for the fix. This was already fixed by Paul in gitk@22a713c72df. I'm sure Junio will merge gitk.git into git.git soon enough so I can sit

Re: [PATCHv3 2/2] builtin/commit.c: switch to xstrfmt(), instead of snprintf,

2017-01-14 Thread René Scharfe
Am 13.01.2017 um 18:58 schrieb Elia Pinto: > In this patch, instead of using xnprintf instead of snprintf, which asserts > that we don't truncate, we are switching to dynamic allocation with > xstrfmt(), > , so we can avoid dealing with magic numbers in the code and reduce the > cognitive

Re: [PATCH v3 00/38] Teach the sequencer to act as rebase -i's backend

2017-01-14 Thread Johannes Schindelin
Hi Junio, On Mon, 9 Jan 2017, Junio C Hamano wrote: > Johannes Schindelin writes: > > > Changes since v2: > > > > - fixed a TRANSLATORS: comment > > ... > > - replaced a spawned `diff-tree` command by code using the diff functions > > directly > > I just finished

Re: [PATCH v3 01/38] sequencer: avoid unnecessary curly braces

2017-01-14 Thread Jeff King
On Sat, Jan 14, 2017 at 06:57:13PM +0100, Johannes Schindelin wrote: > On Thu, 12 Jan 2017, Junio C Hamano wrote: > > > Johannes Schindelin writes: > > > > > > > > - if (!commit->parents) { > > > + if (!commit->parents) > > > parent = NULL; > > > - } > >

Re: [PATCH 2/2] Use 'env' to find perl instead of fixed path

2017-01-14 Thread brian m. carlson
On Sat, Jan 14, 2017 at 10:31:34AM +, Eric Wong wrote: > Jeff King wrote: > > Just as a devil's advocate, why do we care about warnings in third-party > > modules? Or more specifically, why do _users_ who are running Git care > > about them? We cannot fix them in Git. A user

Re: [PATCH v3 06/38] sequencer (rebase -i): implement the 'edit' command

2017-01-14 Thread Johannes Schindelin
Hi Junio, On Thu, 12 Jan 2017, Junio C Hamano wrote: > Johannes Schindelin writes: > > > +static int make_patch(struct commit *commit, struct replay_opts *opts) > > +{ > > + struct strbuf buf = STRBUF_INIT; > > + struct rev_info log_tree_opt; > > + const char

Re: [PATCH v3 01/38] sequencer: avoid unnecessary curly braces

2017-01-14 Thread Johannes Schindelin
Hi Junio, On Thu, 12 Jan 2017, Junio C Hamano wrote: > Johannes Schindelin writes: > > > > > - if (!commit->parents) { > > + if (!commit->parents) > > parent = NULL; > > - } > > else if (commit->parents->next) { > > /* Reverting

Re: [PATCHv3 2/2] builtin/commit.c: switch to xstrfmt(), instead of snprintf,

2017-01-14 Thread Jeff King
On Sat, Jan 14, 2017 at 05:31:39PM +0100, René Scharfe wrote: > Perhaps I missed it from the discussion, but why not use strbuf? It > would avoid counting the generated string's length. That's probably > not going to make a measurable difference performance-wise, but it's > easy to avoid and

Re: [PATCH v3 00/38] Teach the sequencer to act as rebase -i's backend

2017-01-14 Thread Johannes Schindelin
Hi Junio, On Mon, 9 Jan 2017, Junio C Hamano wrote: > I however think that the renaming of read_author_script() is totally > backwards from maintainability's point of view. You stated elsewhere that converting a script into a builtin should focus on a faithful conversion. The original code

Re: problem with insider build for windows and git

2017-01-14 Thread Johannes Schindelin
Hi Michael, On Thu, 12 Jan 2017, Michael Gooch wrote: > when running commands like pull and clone I get the following message: > > Cygwin WARNING: > Couldn't compute FAST_CWD pointer. This typically occurs if you're using > an older Cygwin version on a newer Windows. Please update to the

Re: merge maintaining history

2017-01-14 Thread Jacob Keller
On Fri, Jan 13, 2017 at 6:01 PM, David J. Bakeman wrote: > History > > git cloned a remote repository and made many changes pushing them all to > said repository over many months. > > The powers that be then required me to move project to new repository > server did so by

Re: gitk pull request // was: Re: gitk: "lime" color incompatible with older Tk versions

2017-01-14 Thread Junio C Hamano
David Aguilar writes: > On Fri, Jan 13, 2017 at 03:20:43AM -0800, David Aguilar wrote: >> >> Ping.. it would be nice to get this patch applied. > > Sorry for the noise, and thank you Paul for the fix. > This was already fixed by Paul in gitk@22a713c72df. > > I'm sure Junio

Re: [PATCH 2/3] xdiff: -W: include immediately preceding non-empty lines in context

2017-01-14 Thread Junio C Hamano
René Scharfe writes: >> I am also more focused on keeping the codebase maintainable in good >> health by making sure that we made an effort to find a solution that >> is general-enough before solving a single specific problem you have >> today. We may end up deciding that a

Re: [PATCH v10 19/20] branch: use ref-filter printing APIs

2017-01-14 Thread Jacob Keller
On Sat, Jan 14, 2017 at 2:01 AM, Karthik Nayak wrote: > Hello, > > On Thu, Jan 12, 2017 at 5:17 AM, Jacob Keller wrote: >> On Tue, Jan 10, 2017 at 12:49 AM, Karthik Nayak >> wrote: >>> diff --git a/builtin/branch.c

Re: [PATCH v3 00/38] Teach the sequencer to act as rebase -i's backend

2017-01-14 Thread Junio C Hamano
Johannes Schindelin writes: > The problem in this instance was that the authorship is no longer retained > when continuing after resolving a conflict. Let me stress again that this > has not been a problem with v1 of sequencer-i, nor with v2. The regression > was

Re: [PATCH v3 00/38] Teach the sequencer to act as rebase -i's backend

2017-01-14 Thread Junio C Hamano
Johannes Schindelin writes: > You stated elsewhere that converting a script into a builtin should focus > on a faithful conversion. > > The original code is: > > . "$author_script" > > Granted, this *cannot* be converted faithfully without reimplementing a >

Re: [PATCHv3 2/2] builtin/commit.c: switch to xstrfmt(), instead of snprintf,

2017-01-14 Thread Junio C Hamano
Elia Pinto writes: > Ok. I agree. But is it strictly necessary to resend for this ? FWIW, the attacched is what I queued locally, after complaining "both have the same title? They need to be explained better." In any case, I sense that 2/2 will be redone using