[PATCH] send-email: extract email-parsing code into a subroutine

2017-12-09 Thread Nathan Payre
The existing code mixes parsing of email header with regular expression and actual code. Extract the parsing code into a new subroutine "parse_header_line()". This improves the code readability and make parse_header_line reusable in other place. "parsed_header_line()" and "filter_body()" could be

Re: [PATCH v2 4/4] t/Makefile: introduce TEST_SHELL_PATH

2017-12-09 Thread Johannes Schindelin
Hi Peff, On Fri, 8 Dec 2017, Jeff King wrote: > On Fri, Dec 08, 2017 at 04:08:19PM +0100, Johannes Schindelin wrote: > > > > Yes, but test-lib.sh sources GIT-BUILD-OPTIONS, which we > > > built during the first "make". And that overrides the > > > environment, giving us the original SHELL_PATH

Re: What's cooking in git.git (Dec 2017, #01; Mon, 4)

2017-12-09 Thread Torsten Bögershausen
On Thu, Dec 07, 2017 at 04:33:12PM -0500, Todd Zullinger wrote: > Jeff Hostetler wrote: > >I'm looking at t5616 now on my mac. > >Looks like the MAC doesn't like my line counting in the tests. > >I'll fix in my next version. > [] > | sort >expect_2.oids && > - test "$(wc -l

Assalamu`Alaikum.

2017-12-09 Thread Mohammad Ouattara
Greetings from Dr. mohammad ouattara. Assalamu`Alaikum. My Name is Dr. mohammad ouattara, I am a banker by profession. I'm from Ouagadougou, Burkina Faso, West Africa. My reason for contacting you is to transfer an abandoned $14.6M to your account. The owner of this fund died since 2004 with

Re: [PATCH 1/2] git version --build-options: report the build platform, too

2017-12-09 Thread Johannes Schindelin
Hi Eric, On Sat, 9 Dec 2017, Eric Sunshine wrote: > On Fri, Dec 08, 2017 at 04:19:25PM -0500, Eric Sunshine wrote: > > On Fri, Dec 8, 2017 at 4:17 PM, Eric Sunshine > > wrote: > > > On Fri, Dec 8, 2017 at 12:43 PM, Junio C Hamano wrote: > > >>

Re: [PATCH 3/3] pull: add config option for verifySignatures

2017-12-09 Thread Kevin Daudt
On Sat, Dec 09, 2017 at 09:05:30AM +, Hans Jerry Illikainen wrote: > Verify the signature of the tip commit when `pull.verifySignatures` is > true. This option overrides `merge.verifySignatures` on pull, and can > be disabled with the option `--no-verify-signatures`. Is there a reason why

Re: [PATCH 2/3] t: add tests for pull --verify-signatures

2017-12-09 Thread Kevin Daudt
On Sat, Dec 09, 2017 at 09:05:29AM +, Hans Jerry Illikainen wrote: > Add tests for `pull --verify-signatures` with untrusted, bad and no > signatures. Previously the only test for `--verify-signatures` was to > make sure that `pull --rebase --verify-signatures` result in a warning >

Re: [PATCH 1/3] merge: add config option for verifySignatures

2017-12-09 Thread Kevin Daudt
Hello Hans Jerry, Thank you for your contribution. I have soem remarks below. On Sat, Dec 09, 2017 at 09:05:28AM +, Hans Jerry Illikainen wrote: > Verify the signature of the tip commit when `merge.verifySignatures` is > true. This can be overridden with `--no-verify-signatures`. > >

Re: [PATCH] docs/pretty-formats: mention commas in %(trailers) syntax

2017-12-09 Thread Jacob Keller
On Thu, Dec 7, 2017 at 9:16 PM, Jeff King wrote: > Commit 84ff053d47 (pretty.c: delimit "%(trailers)" arguments > with ",", 2017-10-01) switched the syntax of the trailers > placeholder, but forgot to update the documentation in > pretty-formats.txt. > > There's need to mention the

[PATCH 3/3] pull: add config option for verifySignatures

2017-12-09 Thread Hans Jerry Illikainen
Verify the signature of the tip commit when `pull.verifySignatures` is true. This option overrides `merge.verifySignatures` on pull, and can be disabled with the option `--no-verify-signatures`. Signed-off-by: Hans Jerry Illikainen --- Documentation/config.txt | 8

[PATCH 2/3] t: add tests for pull --verify-signatures

2017-12-09 Thread Hans Jerry Illikainen
Add tests for `pull --verify-signatures` with untrusted, bad and no signatures. Previously the only test for `--verify-signatures` was to make sure that `pull --rebase --verify-signatures` result in a warning (t5520-pull.sh). Signed-off-by: Hans Jerry Illikainen ---

[PATCH 1/3] merge: add config option for verifySignatures

2017-12-09 Thread Hans Jerry Illikainen
Verify the signature of the tip commit when `merge.verifySignatures` is true. This can be overridden with `--no-verify-signatures`. Signed-off-by: Hans Jerry Illikainen --- Documentation/merge-config.txt | 7 +++ builtin/merge.c| 2 ++

Re: [PATCH 1/2] git version --build-options: report the build platform, too

2017-12-09 Thread Eric Sunshine
On Fri, Dec 08, 2017 at 04:19:25PM -0500, Eric Sunshine wrote: > On Fri, Dec 8, 2017 at 4:17 PM, Eric Sunshine wrote: > > On Fri, Dec 8, 2017 at 12:43 PM, Junio C Hamano wrote: > >> Jonathan Nieder writes: > >>> Can this use

Re: [PATCH 3/4] Makefile: use the sha1collisiondetection submodule by default

2017-12-09 Thread Kevin Daudt
On Tue, Dec 05, 2017 at 02:02:50AM -0500, Jeff King wrote: > On Tue, Nov 28, 2017 at 09:32:13PM +, Ævar Arnfjörð Bjarmason wrote: > > > Change the build process so that instead of needing to supply > > DC_SHA1_SUBMODULE=YesPlease to use the sha1collisiondetection > > submodule instead of the

Re: [PATCH 3/4] Makefile: use the sha1collisiondetection submodule by default

2017-12-09 Thread Kevin Daudt
On Sat, Dec 09, 2017 at 01:30:14PM +0100, Kevin Daudt wrote: > On Tue, Dec 05, 2017 at 02:02:50AM -0500, Jeff King wrote: > > On Tue, Nov 28, 2017 at 09:32:13PM +, Ævar Arnfjörð Bjarmason wrote: > > > > > Change the build process so that instead of needing to supply > > >

Re: [PATCH v2 0/5] SHA1DC fixes & fully moving to a git.git submodule

2017-12-09 Thread Kevin Daudt
On Fri, Dec 08, 2017 at 10:29:56PM +, Ævar Arnfjörð Bjarmason wrote: > Here's v2 as promised. Comments per-patch. > > sha1dc: remove in favor of using sha1collisiondetection as a submodule > > Reword & expand commit message. Is this commit missing from the mailing list because the e-mail

Re: [PATCH v4 7/9] sequencer: load commit related config

2017-12-09 Thread Phillip Wood
On 05/12/17 11:21, Phillip Wood wrote: > On 04/12/17 18:30, Junio C Hamano wrote: >> Phillip Wood writes: >> >>> --- a/builtin/rebase--helper.c >>> +++ b/builtin/rebase--helper.c >>> @@ -9,6 +9,17 @@ static const char * const builtin_rebase_helper_usage[] = { >>>

[Proposed] Externalize man/html ref for quick-install-man and quick-install-html

2017-12-09 Thread Randall S. Becker
I am proposing the following trivial change to allow the external specification of the reference used for quick-install-man. The justification is that I cannot have my production team modifying scripts when non-master versions of git are installed in production (that violates so many rules that I

[PATCH v3 5/7] diff: use skip_to_optional_arg_default() in parsing --relative

2017-12-09 Thread Christian Couder
From: Junio C Hamano Helped-by: Jacob Keller Helped-by: Jeff King Signed-off-by: Junio C Hamano --- diff.c | 7 +++ 1 file changed, 3 insertions(+), 4 deletions(-) diff --git a/diff.c b/diff.c index

[PATCH v3 6/7] diff: add tests for --relative without optional prefix value

2017-12-09 Thread Christian Couder
From: Jacob Keller We already have tests for --relative, but they currently only test when a prefix has been provided. This fails to test the case where --relative by itself should use the current directory as the prefix. Teach the check_$type functions to take a

[PATCH v3 1/7] git-compat-util: introduce skip_to_optional_arg()

2017-12-09 Thread Christian Couder
From: Christian Couder We often accept both a "--key" option and a "--key=" option. These options currently are parsed using something like: if (!strcmp(arg, "--key")) { /* do something */ } else if (skip_prefix(arg, "--key=", )) { /* do something

[PATCH v3 7/7] t4045: reindent to make helpers readable

2017-12-09 Thread Christian Couder
From: Junio C Hamano Signed-off-by: Junio C Hamano --- t/t4045-diff-relative.sh | 104 +-- 1 file changed, 56 insertions(+), 48 deletions(-) diff --git a/t/t4045-diff-relative.sh b/t/t4045-diff-relative.sh index

[PATCH v3 2/7] index-pack: use skip_to_optional_arg()

2017-12-09 Thread Christian Couder
From: Christian Couder Let's simplify index-pack option parsing using skip_to_optional_arg(). Signed-off-by: Christian Couder Signed-off-by: Junio C Hamano --- builtin/index-pack.c | 11 +++ 1 file changed, 3

[PATCH v3 3/7] diff: use skip_to_optional_arg()

2017-12-09 Thread Christian Couder
From: Christian Couder Let's simplify diff option parsing using skip_to_optional_arg(). Signed-off-by: Christian Couder Signed-off-by: Junio C Hamano --- diff.c | 23 +-- 1 file changed, 9

[PATCH v3 4/7] diff: use skip_to_optional_arg_default()

2017-12-09 Thread Christian Couder
From: Christian Couder Let's simplify diff option parsing using skip_to_optional_arg_default(). Signed-off-by: Christian Couder Signed-off-by: Junio C Hamano --- diff.c | 20 1 file changed, 4

Re: [SCRIPT/RFC 0/3] git-commit --onto-parent (three-way merge, noworking tree file changes)

2017-12-09 Thread Igor Djordjevic
Hi Philip, On 09/12/2017 20:01, Phillip Wood wrote: > > > But thanks for clarifying, anyway, it does feel like `git rebase > > -i --autosquash` could be smarter in this regards, if `git rebase > > --onto` does it better...? > > Creating the fixup directly on A rather than on top of B avoids

[PATCH] sequencer: make sign_off_header a file local symbol

2017-12-09 Thread Ramsay Jones
Commit d0aaa46fd3 ("commit: move empty message checks to libgit", 2017-11-10) removes the last use of 'sign_off_header' outside of the "sequencer.c" source file. Remove the extern declaration from the header file and mark the definition of the symbol with the static keyword. Signed-off-by:

Re: [SCRIPT/RFC 0/3] git-commit --onto-parent (three-way merge, noworking tree file changes)

2017-12-09 Thread Phillip Wood
Hi Igor On 09/12/17 03:03, Igor Djordjevic wrote: > > Hi Alexei, > > On 09/12/2017 03:18, Alexei Lozovsky wrote: >> >>> Chris reported in this very topic[1] that sometimes, due to >>> conflicts with later commits, "checkout > commit > [checkout >] >>> rebase --onto" is "much easier to do",

Re: [SCRIPT/RFC 0/3] git-commit --onto-parent (three-way merge,noworking tree file changes)

2017-12-09 Thread Phillip Wood
Hi Igor On 09/12/17 03:03, Igor Djordjevic wrote: > > Hi Alexei, > > On 09/12/2017 03:18, Alexei Lozovsky wrote: >> >>> Chris reported in this very topic[1] that sometimes, due to >>> conflicts with later commits, "checkout > commit > [checkout >] >>> rebase --onto" is "much easier to do",

Re: [PATCH 3/3] pull: add config option for verifySignatures

2017-12-09 Thread Hans Jerry Illikainen
On Sat, Dec 09, 2017 at 01:06:23PM +0100, Kevin Daudt wrote: > On Sat, Dec 09, 2017 at 09:05:30AM +, Hans Jerry Illikainen wrote: > > Verify the signature of the tip commit when `pull.verifySignatures` is > > true. This option overrides `merge.verifySignatures` on pull, and can > > be

[PATCH v2 2/2] t: add tests for pull --verify-signatures

2017-12-09 Thread Hans Jerry Illikainen
Add tests for pull --verify-signatures with untrusted, bad and no signatures. Previously the only test for --verify-signatures was to make sure that pull --rebase --verify-signatures result in a warning (t5520-pull.sh). Signed-off-by: Hans Jerry Illikainen ---

[PATCH v2 1/2] merge: add config option for verifySignatures

2017-12-09 Thread Hans Jerry Illikainen
git merge --verify-signatures can be used to verify that the tip commit of the branch being merged in is properly signed, but it's cumbersome to have to specify that every time. Add a configuration option that enables this behaviour by default, which can be overridden by --no-verify-signatures.