Re: [PATCH 1/3] treewalk.c: Rename variable ret to cb_bits and remove some dead lines.

2013-07-19 Thread Junio C Hamano
Stefan Beller  writes:

> So is there any up-to-date task list for beginning contributors?

I am fairly bad at keeping track of small things incrementally, as
it is often quicker to do them myself if/when I were so inclined,
but there are too many of them and a day does not have enough number
of seconds X-<.

These days, I tend to scan the mailing list backlog in batch every
once in a while.

  http://git-blame.blogspot.com/search?q=leftover+bits

may show some of them.

Thanks for asking and volunteering.
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 1/3] treewalk.c: Rename variable ret to cb_bits and remove some dead lines.

2013-07-19 Thread Stefan Beller
On 07/19/2013 08:13 PM, Junio C Hamano wrote:
> The "ret" was meant to mean "the return value we got from the
> callback function", not "the return value we would give our caller".

Thanks for clarifying.
I assumed the "ret" was meant as the return value of that function
as it was the case before e6c111b4c. In other projects I am using 
ret as "the return value we would give our caller" as it's such a 
convenient name for that if you cannot come up with a better name.

> 
> This rename is a bit misleading in that "cb_bits == -1" does not
> mean "full bits set", and it does not tell us much what these "bits"
> signify.
> 
> They are used to answer this question: which one of the trees in
> t[0..n] did the callback function consumed (hence needs their
> pointers updated).
> 
> So perhaps call it "trees_used" or something?

Sounds indeed way better. I'll rename it.

> 
> By the way, our log message usually do not Capitalize the subject
> after the ":", i.e. do something like this instead:
> 
> Subject: [PATCH 1/3] traverse_trees(): clarify return value of the 
> callback
> 
> Thanks.
> 

Thanks for pointing out.

As a general question: I was mostly doing micro-optimisations or 
the mailmap file, which are rather small fixups, which I think are
ok for beginners. Is there a tasklist for beginners, other than that?
Such as porting shell commands to C or other larger tasks?
I used git://github.com/gitster/git.git as remote/origin. There the todo
branch has the last commit as of 2012/04, so I also found
git://git.kernel.org/pub/scm/git/git.git, where the todo branch seems
more up-to-date, but the TODO file there also seems a little dated to
me.
So is there any up-to-date task list for beginning contributors?

Stefan


--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 1/3] treewalk.c: Rename variable ret to cb_bits and remove some dead lines.

2013-07-19 Thread Junio C Hamano
The "ret" was meant to mean "the return value we got from the
callback function", not "the return value we would give our caller".

This rename is a bit misleading in that "cb_bits == -1" does not
mean "full bits set", and it does not tell us much what these "bits"
signify.

They are used to answer this question: which one of the trees in
t[0..n] did the callback function consumed (hence needs their
pointers updated).

So perhaps call it "trees_used" or something?

By the way, our log message usually do not Capitalize the subject
after the ":", i.e. do something like this instead:

Subject: [PATCH 1/3] traverse_trees(): clarify return value of the callback

Thanks.
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html