Re: [RFC PATCH 1/3] config --global --edit: create a template file if needed

2014-07-25 Thread Junio C Hamano
Matthieu Moy  writes:

> Eric Sunshine  writes:
>
>>> +static char *default_user_config()
>>> +{
>>> +   struct strbuf buf = STRBUF_INIT;
>>> +   strbuf_addf(&buf,
>>> +   _("# This is Git's user-wide configuration file.\n"
>>> + "[core]\n"
>>> + "# Please, adapt and uncomment the following lines:\n"
>>> + "#user = %s\n"
>>> + "#email = %s\n"),
>>
>> "[core]", "user =", "email =" should not be translated. Would it make
>> sense to keep these outside of _()?
>
> I would say no, as the code and the string to translate would be much
> less readable without core, user and email inline.
>
> Were you suggesting stg like
>
> _("# This is Git's user-wide configuration file.\n"
>   "[%s]\n"
>   "# Please, adapt and uncomment the following lines:\n"
>   "#%s = %s\n"
>   "#%s = %s\n"),
>   "core", "name", ..., "email", ...
>
> ?

;-) That is a clever way to say what my first reaction to Eric's
comment was, which was to have this as multiple strbuf_addf().

Technically speaking, the '#' at the beginning of lines must not be
translated, either, and if that goes without saying, i.e. if the
translators know well enough not to change them, then I can be
persuaded that we can expect that translators know well enough not
to touch the three substrings Eric pointed out.

So, the original message may be fine as-is.

>>> +   if (fd) {
>>> +   char *content = default_user_config();
>>> +   write_str_in_full(fd, content);
>>
>> close(fd);
>
> Indeed.
>
>>> +   free(content);
>>> +   }
>>> +   else if (errno != EEXIST)
>>> +   die_errno(_("Cannot create configuration 
>>> file %s"), config_file);
>>
>> Other error messages in this file (including those just above this
>> block) begin with a lowercase letter.
>
> Applied.
>
> Thanks,
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [RFC PATCH 1/3] config --global --edit: create a template file if needed

2014-07-25 Thread Matthieu Moy
Junio C Hamano  writes:

> Probably a good idea; I do not think of any possible interactions we
> have to worry about with the configuration file init-db creates with
> possible templating.

The feature should trigger only for --global, so it shouldn't interfer
with .git/config and templates.

> Do we use "user-wide" as a phrase to refer to these?  It sounds
> somewhat funny to call anything specific to $frotz "$frotz-wide", at
> least to me.
>
> Surely, /etc/gitconfig is called "site-wide".  But .git/config is
> per-project (or project-specific), and I would always have thought
> that ~/.gitconfig was "per-user".

I'm not a native speaker, but to me, "user-wide" insists on the fact
that it applies to everything for this user, and "per-user" insists on
the fact that it does not apply to other users.

Perhaps just "Git's user configuration file" would be enough.

>>  builtin/config.c | 30 +++---
>>  cache.h  |  1 +
>>  ident.c  |  2 +-
>>  3 files changed, 29 insertions(+), 4 deletions(-)
>>
>> diff --git a/builtin/config.c b/builtin/config.c
>> index fcd8474..3821697 100644
>> --- a/builtin/config.c
>> +++ b/builtin/config.c
>> @@ -445,6 +445,20 @@ static int get_urlmatch(const char *var, const char 
>> *url)
>>  return 0;
>>  }
>>  
>> +static char *default_user_config()
>
> static char *default_user_config(void)

Right. Doing too much C++.

>> +{
>> +struct strbuf buf = STRBUF_INIT;
>> +strbuf_addf(&buf,
>> +_("# This is Git's user-wide configuration file.\n"
>> +  "[core]\n"
>> +  "# Please, adapt and uncomment the following lines:\n"
>
> tangent: is it a French tradition to always have comma after please?

Perhaps. In French, the comma would be required after "S'il vous plait"
(litterally, "if you like"). I'll remove it.

-- 
Matthieu Moy
http://www-verimag.imag.fr/~moy/
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [RFC PATCH 1/3] config --global --edit: create a template file if needed

2014-07-25 Thread Eric Sunshine
On Fri, Jul 25, 2014 at 12:01 PM, Matthieu Moy
 wrote:
> Eric Sunshine  writes:
>
>>> +static char *default_user_config()
>>> +{
>>> +   struct strbuf buf = STRBUF_INIT;
>>> +   strbuf_addf(&buf,
>>> +   _("# This is Git's user-wide configuration file.\n"
>>> + "[core]\n"
>>> + "# Please, adapt and uncomment the following lines:\n"
>>> + "#user = %s\n"
>>> + "#email = %s\n"),
>>
>> "[core]", "user =", "email =" should not be translated. Would it make
>> sense to keep these outside of _()?
>
> I would say no, as the code and the string to translate would be much
> less readable without core, user and email inline.
>
> Were you suggesting stg like
>
> _("# This is Git's user-wide configuration file.\n"
>   "[%s]\n"
>   "# Please, adapt and uncomment the following lines:\n"
>   "#%s = %s\n"
>   "#%s = %s\n"),
>   "core", "name", ..., "email", ...
>
> ?

That or some equivalent variation. I'm not a translator, but the above
seems to convey sufficient context for a translator to understand what
needs to be said, while preventing accidental translations of those
strings which should not be translated.

>>> +   if (fd) {
>>> +   char *content = default_user_config();
>>> +   write_str_in_full(fd, content);
>>
>> close(fd);
>
> Indeed.
>
>>> +   free(content);
>>> +   }
>>> +   else if (errno != EEXIST)
>>> +   die_errno(_("Cannot create configuration 
>>> file %s"), config_file);
>>
>> Other error messages in this file (including those just above this
>> block) begin with a lowercase letter.
>
> Applied.
>
> Thanks,
>
> --
> Matthieu Moy
> http://www-verimag.imag.fr/~moy/
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [RFC PATCH 1/3] config --global --edit: create a template file if needed

2014-07-25 Thread Junio C Hamano
Matthieu Moy  writes:

> When the user has no ~/.gitconfig file, git config --global --edit used
> to launch an editor on an nonexistant file name.
>
> Instead, create a file with a default content before launching the
> editor. The template contains only commented-out entries, to save a few
> keystrokes for the user. If the values are guessed properly, the user
> will only have to uncomment the entries.
>
> Advanced users teaching newbies can create a minimalistic configuration
> faster for newbies. Beginners reading a tutorial advising to run "git
> config --global --edit" as a first step will be slightly more guided for
> their first contact with Git.
>
> Signed-off-by: Matthieu Moy 
> ---

Probably a good idea; I do not think of any possible interactions we
have to worry about with the configuration file init-db creates with
possible templating.

Do we use "user-wide" as a phrase to refer to these?  It sounds
somewhat funny to call anything specific to $frotz "$frotz-wide", at
least to me.

Surely, /etc/gitconfig is called "site-wide".  But .git/config is
per-project (or project-specific), and I would always have thought
that ~/.gitconfig was "per-user".

>  builtin/config.c | 30 +++---
>  cache.h  |  1 +
>  ident.c  |  2 +-
>  3 files changed, 29 insertions(+), 4 deletions(-)
>
> diff --git a/builtin/config.c b/builtin/config.c
> index fcd8474..3821697 100644
> --- a/builtin/config.c
> +++ b/builtin/config.c
> @@ -445,6 +445,20 @@ static int get_urlmatch(const char *var, const char *url)
>   return 0;
>  }
>  
> +static char *default_user_config()

static char *default_user_config(void)

> +{
> + struct strbuf buf = STRBUF_INIT;
> + strbuf_addf(&buf,
> + _("# This is Git's user-wide configuration file.\n"
> +   "[core]\n"
> +   "# Please, adapt and uncomment the following lines:\n"

tangent: is it a French tradition to always have comma after please?
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [RFC PATCH 1/3] config --global --edit: create a template file if needed

2014-07-25 Thread Matthieu Moy
Eric Sunshine  writes:

>> +static char *default_user_config()
>> +{
>> +   struct strbuf buf = STRBUF_INIT;
>> +   strbuf_addf(&buf,
>> +   _("# This is Git's user-wide configuration file.\n"
>> + "[core]\n"
>> + "# Please, adapt and uncomment the following lines:\n"
>> + "#user = %s\n"
>> + "#email = %s\n"),
>
> "[core]", "user =", "email =" should not be translated. Would it make
> sense to keep these outside of _()?

I would say no, as the code and the string to translate would be much
less readable without core, user and email inline.

Were you suggesting stg like

_("# This is Git's user-wide configuration file.\n"
  "[%s]\n"
  "# Please, adapt and uncomment the following lines:\n"
  "#%s = %s\n"
  "#%s = %s\n"),
  "core", "name", ..., "email", ...

?

>> +   if (fd) {
>> +   char *content = default_user_config();
>> +   write_str_in_full(fd, content);
>
> close(fd);

Indeed.

>> +   free(content);
>> +   }
>> +   else if (errno != EEXIST)
>> +   die_errno(_("Cannot create configuration 
>> file %s"), config_file);
>
> Other error messages in this file (including those just above this
> block) begin with a lowercase letter.

Applied.

Thanks,

-- 
Matthieu Moy
http://www-verimag.imag.fr/~moy/
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [RFC PATCH 1/3] config --global --edit: create a template file if needed

2014-07-25 Thread Eric Sunshine
On Fri, Jul 25, 2014 at 9:44 AM, Matthieu Moy  wrote:
> When the user has no ~/.gitconfig file, git config --global --edit used
> to launch an editor on an nonexistant file name.
>
> Instead, create a file with a default content before launching the
> editor. The template contains only commented-out entries, to save a few
> keystrokes for the user. If the values are guessed properly, the user
> will only have to uncomment the entries.
>
> Advanced users teaching newbies can create a minimalistic configuration
> faster for newbies. Beginners reading a tutorial advising to run "git
> config --global --edit" as a first step will be slightly more guided for
> their first contact with Git.
>
> Signed-off-by: Matthieu Moy 
> ---
>  builtin/config.c | 30 +++---
>  cache.h  |  1 +
>  ident.c  |  2 +-
>  3 files changed, 29 insertions(+), 4 deletions(-)
>
> diff --git a/builtin/config.c b/builtin/config.c
> index fcd8474..3821697 100644
> --- a/builtin/config.c
> +++ b/builtin/config.c
> @@ -445,6 +445,20 @@ static int get_urlmatch(const char *var, const char *url)
> return 0;
>  }
>
> +static char *default_user_config()
> +{
> +   struct strbuf buf = STRBUF_INIT;
> +   strbuf_addf(&buf,
> +   _("# This is Git's user-wide configuration file.\n"
> + "[core]\n"
> + "# Please, adapt and uncomment the following lines:\n"
> + "#user = %s\n"
> + "#email = %s\n"),

"[core]", "user =", "email =" should not be translated. Would it make
sense to keep these outside of _()?

> +   ident_default_name(),
> +   ident_default_email());
> +   return strbuf_detach(&buf, NULL);
> +}
> +
>  int cmd_config(int argc, const char **argv, const char *prefix)
>  {
> int nongit = !startup_info->have_repository;
> @@ -551,6 +565,8 @@ int cmd_config(int argc, const char **argv, const char 
> *prefix)
> }
> }
> else if (actions == ACTION_EDIT) {
> +   const char *config_file = given_config_source.file ?
> +   given_config_source.file : git_path("config");
> check_argc(argc, 0, 0);
> if (!given_config_source.file && nongit)
> die("not in a git directory");
> @@ -559,9 +575,17 @@ int cmd_config(int argc, const char **argv, const char 
> *prefix)
> if (given_config_source.blob)
> die("editing blobs is not supported");
> git_config(git_default_config, NULL);
> -   launch_editor(given_config_source.file ?
> - given_config_source.file : git_path("config"),
> - NULL, NULL);
> +   if (use_global_config) {
> +   int fd = open(config_file, O_CREAT | O_EXCL | 
> O_WRONLY, 0666);
> +   if (fd) {
> +   char *content = default_user_config();
> +   write_str_in_full(fd, content);

close(fd);

> +   free(content);
> +   }
> +   else if (errno != EEXIST)
> +   die_errno(_("Cannot create configuration file 
> %s"), config_file);

Other error messages in this file (including those just above this
block) begin with a lowercase letter.

> +   }
> +   launch_editor(config_file, NULL, NULL);
> }
> else if (actions == ACTION_SET) {
> int ret;
> diff --git a/cache.h b/cache.h
> index 2f63fd1..8c79c0c 100644
> --- a/cache.h
> +++ b/cache.h
> @@ -1061,6 +1061,7 @@ extern const char *git_author_info(int);
>  extern const char *git_committer_info(int);
>  extern const char *fmt_ident(const char *name, const char *email, const char 
> *date_str, int);
>  extern const char *fmt_name(const char *name, const char *email);
> +extern const char *ident_default_name(void);
>  extern const char *ident_default_email(void);
>  extern const char *git_editor(void);
>  extern const char *git_pager(int stdout_is_tty);
> diff --git a/ident.c b/ident.c
> index 1d9b6e7..77bc882 100644
> --- a/ident.c
> +++ b/ident.c
> @@ -102,7 +102,7 @@ static void copy_email(const struct passwd *pw, struct 
> strbuf *email)
> add_domainname(email);
>  }
>
> -static const char *ident_default_name(void)
> +const char *ident_default_name(void)
>  {
> if (!git_default_name.len) {
> copy_gecos(xgetpwuid_self(), &git_default_name);
> --
> 2.0.2.737.gfb43bde
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html