[gwt-contrib] Re: Filed against Issue 1518032 in bugganizer

2009-02-27 Thread ecc
LGTM http://gwt-code-reviews.appspot.com/8803 --~--~-~--~~~---~--~~ http://groups.google.com/group/Google-Web-Toolkit-Contributors -~--~~~~--~~--~--~---

[gwt-contrib] review for issue 249 fix

2009-02-24 Thread ecc
Reviewers: rjrjr, Description: We deprecate ListBox's setMultipleSelect. Please review this at http://gwt-code-reviews.appspot.com/7801 Affected files: user/src/com/google/gwt/user/client/ui/ListBox.java Index: user/src/com/google/gwt/user/client/ui/ListBox.java

[gwt-contrib] Fixes Issue 3378, adding protected getHandlerCount() to widget.

2009-02-24 Thread ecc
Reviewers: rjrjr, Description: Adding protected getHandlerCount() to widget plus a basic widget unittest to test the implementation.. Please review this at http://gwt-code-reviews.appspot.com/7802 Affected files: user/src/com/google/gwt/user/client/ui/Widget.java

[gwt-contrib] Adding more visual tests

2009-02-12 Thread ecc
Reviewers: jlabanca, Description: Adds some more visual tests and some helper methods to create more visual visual tests still. We love to test don't we :-). Please review this at http://gwt-code-reviews.appspot.com/2807 Affected files:

[gwt-contrib] Re: Adding more visual tests

2009-02-12 Thread ecc
http://gwt-code-reviews.appspot.com/2807/diff/1/3 File reference/code-museum/src/com/google/gwt/museum/client/common/EventReporter.java (right): http://gwt-code-reviews.appspot.com/2807/diff/1/3#newcode78 Line 78: HandlerRegistration r; On 2009/02/12 20:17:30, jlabanca wrote: can you use a

[gwt-contrib] Updates to gwt-incubator's build.demo

2009-02-09 Thread ecc
Reviewers: itruett, Description: This patch upgraded the gwt-incubator build.demos task in the following way: * upgrades target to use new Compiler class, with war rather then out argument * upgrades the index.html to allow each demo to be easily seen in a stand alone frame as well as

[gwt-contrib] Work around for gwt issue 3340

2009-02-06 Thread ecc
style names that were set/added; the only style names that are preserved @@ -225,18 +223,21 @@ private static class UnclippedState extends State { UnclippedState(Element element) { - // Todo(ecc) This is wrong, we should not be sinking these here on such a - // common

[gwt-contrib] Re: FastTree gen2 tweaks

2009-02-04 Thread ecc
http://gwt-code-reviews.appspot.com/2801/diff/1/7 File src/com/google/gwt/gen2/widgetbase/public/FastTree.css (right): http://gwt-code-reviews.appspot.com/2801/diff/1/7#newcode66 Line 66: background: #e3e8f3 url('%selectionBar%') repeat-x; The problem is that this css file needs to work for

[gwt-contrib] FastTree gen2 tweaks

2009-02-03 Thread ecc
Reviewers: nwolf, Description: This patch fixes the dependencies for FastTree, removes dependencies on deprecated gwt 1.6 classes, and adds the css using the interim structure we've fallen back on until the next time. Please review this at http://gwt-code-reviews.appspot.com/2801 Affected

[gwt-contrib] Re: Event triggering patch (Refactored to be closer to W3C standards)

2009-01-27 Thread ecc
This is such awesome new functionality, thanks Joel! There are a couple of things I didn't understand, listed below, please ping me if any of the comments don't make sense! I think we also need an Image test, as it looks like the current image test never actually checks if the load handler is

[gwt-contrib] Re: Event triggering patch (Refactored to be closer to W3C standards)

2009-01-27 Thread ecc
want to add a note in the NativeEvent javadoc directing folks to Document as well though. On 2009/01/27 22:37:33, rjrjr wrote: On 2009/01/27 20:27:05, ecc wrote: Now that we have a NativeEvent class, should we move these methods there? As that would seem more natural to me. I think

[gwt-contrib] Fixes issue 3307 by selecting an item even if focus should not be moved

2009-01-23 Thread ecc
Reviewers: jlabanca, Description: This is about the third or forth time we've run into a bug fixed in FastTree but not in Tree or visa-versa, it might be time in GWT 2.0 to break our current tree implementation and replace it rather then trying to support two almost-identical widgets. Please

[gwt-contrib] Making listener wrapper public

2009-01-16 Thread ecc
Reviewers: jlabanca, Description: This patch makes listener wrapper public. It also switching the default conversion of TextBox.addChangeListener from a custom addDomHandler solution to TextBox.addValueChangeHandler Please review this at http://gwt-code-reviews.appspot.com/2207 Affected files:

[gwt-contrib] creating user sniff-test for build

2009-01-15 Thread ecc
Reviewers: fabbott, Description: Right now about one in a hundred builds or so api checker will break, this patch creates a convenient target to programmers making changes to user can run the tests, api checker, and the checkstyle checks as one command. It also fixed our checkstyle config by

[gwt-contrib] Re: Proposed tweaks to the new event infrastructure

2009-01-15 Thread ecc
http://gwt-code-reviews.appspot.com/2205/diff/1/6 File user/src/com/google/gwt/event/Event.gwt.xml (right): http://gwt-code-reviews.appspot.com/2205/diff/1/6#newcode2 Line 2: source path=shared/ Totally agreed about the overall goal. I was suggesting a slight naming change: gwt.foo.Foo -- in

[gwt-contrib] Re: DOM.getAbsoluteTop/Left() throws JS exception in IE if element is not attached

2009-01-14 Thread ecc
LGTM http://gwt-code-reviews.appspot.com/2201 --~--~-~--~~~---~--~~ http://groups.google.com/group/Google-Web-Toolkit-Contributors -~--~~~~--~~--~--~---

[gwt-contrib] SuggestBox bag of changes

2009-01-13 Thread ecc
Reviewers: jlabanca, Description: This set of changes pulls in work done in gwt-incubator on the now defunct SuggestBoxOverride, it addresses issues 2598, 2739,2888. Also has the following features: Adds ability to create default list of suggestions. Opens the MultiWordSuggestOracle up

[gwt-contrib] PopupPanel -- RollDown animation

2009-01-13 Thread ecc
Reviewers: jlabanca, Description: For SuggestBox and DropDownListBox, porting the RollDown animation class from incubator. Testing in the suggest box visual test. Please review this at http://gwt-code-reviews.appspot.com/2004 Affected files:

[gwt-contrib] Re: TabPanel should not have onBeforeSelection and onSelection

2009-01-07 Thread ecc
We need to add the doc to the old methods on what people should do instead, assuming that is done, LGTM. http://gwt-code-reviews.appspot.com/1804/diff/1/2 File user/src/com/google/gwt/user/client/ui/TabPanel.java (left): http://gwt-code-reviews.appspot.com/1804/diff/1/2#oldcode363 Line 363:

[gwt-contrib] Re: Replace PopupPanel.setAutoHidePar tner() with PopupPanel.addAutoHidePartner()

2009-01-07 Thread ecc
Looks good overall, only quibble is it would be nice to use array list rather then hash set to store the auto hide partners. http://gwt-code-reviews.appspot.com/2001/diff/1/4 File user/src/com/google/gwt/user/client/ui/PopupPanel.java (right):

[gwt-contrib] Making show range fire on initial show.

2008-12-16 Thread ecc
Reviewers: jlabanca, Description: Fixes issue 3181 (http://code.google.com/p/google-web-toolkit/issues/detail?id=3181q=owner:ecc%20DatePicker) by making the show range event fire at the correct time. Please review this at http://gwt-code-reviews.appspot.com/610 Affected files:

[gwt-contrib] Re: Add NativePreviewEvent to replace current EventPreview system

2008-12-12 Thread ecc
http://gwt-code-reviews.appspot.com/606/diff/1/7 File user/src/com/google/gwt/event/logical/shared/HasNativeEvent.java (right): http://gwt-code-reviews.appspot.com/606/diff/1/7#newcode32 Line 32: } Should this interface be in gwt.event.dom.client instead?

[gwt-contrib] Code review for Issue 3194:Need to deprecate SourcesXXXEvents interfaces so we can remove them later

2008-12-12 Thread ecc
Reviewers: jlabanca, Description: Issue details at:http://code.google.com/p/google-web-toolkit/issues/detail?id=3194q=owner:eccsort=priority Please review this at http://gwt-code-reviews.appspot.com/607 Affected files: user/src/com/google/gwt/user/client/ui/FiresDisclosureEvents.java

[gwt-contrib] Adding the happy event

2008-12-12 Thread ecc
Reviewers: jlabanca, Description: Adding Happy event to javadoc in order to be able to refer to it in the events wiki design doc. Please review this at http://gwt-code-reviews.appspot.com/813 Affected files: user/javadoc/com/google/gwt/examples/events/HappyEvent.java

[gwt-contrib] Code review request for blocking mouse leave/enter events in some cases

2008-12-10 Thread ecc
Reviewers: jlabanca, Description: Code review request for gwt issue (3189) Fixes the default Widget code to not trigger mouse enter/leave events when the user did not actually leave or enter the widget. http://code.google.com/p/google-web-toolkit/issues/detail?id=3189 Please review this at

[gwt-contrib] Re: Fix for listenerwrapper, remove listener

2008-12-10 Thread ecc
On 2008/12/09 18:01:50, jlabanca wrote: LGTM Committed at 4298. http://gwt-code-reviews.appspot.com/603 --~--~-~--~~~---~--~~ http://groups.google.com/group/Google-Web-Toolkit-Contributors -~--~~~~--~~--~--~---

[gwt-contrib] Fix for listenerwrapper, remove listener

2008-12-09 Thread ecc
Reviewers: jlabanca, Description: John, Could you review this fix for the assertion error that happens in some circumstances when you remove Window listeners? Also included are two new test cases to ensure we don't have a regression on this issue. As a side note, I think this situation is

[gwt-contrib] Allowing collapsible panel to have collapsed state programically controled

2008-12-09 Thread ecc
Reviewers: jlabanca, Description: Allows collapsible panel to have it state controlled via code. Please review this at http://gwt-code-reviews.appspot.com/809 Affected files: src-demo/com/google/gwt/widgetideas/demo/collapsiblepanel/client/CollapsiblePanelDemo.java

[gwt-contrib] Re: TabBar setTabText doesn't set word wrap false

2008-12-09 Thread ecc
The expansion of the tab interface looks great. Don't quite understand the change to the default word wrapping... http://gwt-code-reviews.appspot.com/604/diff/1/2 File user/src/com/google/gwt/user/client/ui/TabBar.java (right): http://gwt-code-reviews.appspot.com/604/diff/1/2#newcode488 Line

[gwt-contrib] Re: Use LazyPanel in showcase

2008-11-20 Thread ecc
LGTM http://codereview.appspot.com/9656 --~--~-~--~~~---~--~~ http://groups.google.com/group/Google-Web-Toolkit-Contributors -~--~~~~--~~--~--~---