[gwt-contrib] Removed Object.typeId from generated class prototypes, and from the compilation and linkage phas... (issue751803)

2010-08-25 Thread jbrosenberg
Reviewers: scottb, robertvawter, Description: Removed Object.typeId from generated class prototypes, and from the compilation and linkage phases. Type cast checking depends only on the castableTypeMaps and queryIds now. Fixed a bug in deRPC for preserving meta data in transmitted Arrays for

[gwt-contrib] Re: Public: Start of a sample application showing GWT validation. (issue760802)

2010-08-25 Thread bobv
LGTM http://gwt-code-reviews.appspot.com/760802/diff/6001/1032 File samples/validation/src/com/google/gwt/sample/validation/client/Validation.java (right): http://gwt-code-reviews.appspot.com/760802/diff/6001/1032#newcode55

[gwt-contrib] Re: Eclipse: GDT - Scala plugin cooperation problem

2010-08-25 Thread Martin Mauch
I'm running into the same problem here. Is there any known solution? On 15 Jul., 16:09, Marek marek.romanow...@gmail.com wrote: My Eclipse hangs up while startup (showing gwt plugin as actually loaded) and while changing run configuration properties pages. I've checked for thread dumps while

Re: [gwt-contrib] RR: allow CheckBox to accept null?

2010-08-25 Thread Bruce Johnson
Can you provide a little more context for why it should work this way? On Tue, Aug 24, 2010 at 6:49 PM, Ray Ryan rj...@google.com wrote: When we made the CheckBox widget implement HasValue, we had it throw an illegal argument exception when setValue() is called with null. I think we goofed.

[gwt-contrib] Re: Adds a baseTime property to top level events to help re-normalize (issue797801)

2010-08-25 Thread conroy
On 2010/08/24 23:21:14, zundel wrote: LGTM (though it would be better to not have the whitespace jitter) http://gwt-code-reviews.appspot.com/797801/show -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

[gwt-contrib] Re: Add ability to use @UiChild annotation to specify how GWT should add a child element. (issue794801)

2010-08-25 Thread sonnyf
http://gwt-code-reviews.appspot.com/794801/show -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

[gwt-contrib] Re: Adding TreeNode API to CellTree and CellBrowser, which allows users to programmatically open/clo... (issue796801)

2010-08-25 Thread jlabanca
committed as r8642 http://gwt-code-reviews.appspot.com/796801/show -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

[gwt-contrib] Re: Add ability to use @UiChild annotation to specify how GWT should add a child element. (issue794801)

2010-08-25 Thread bobv
http://gwt-code-reviews.appspot.com/794801/diff/8001/9001 File dev/core/src/com/google/gwt/core/ext/typeinfo/JPrimitiveType.java (right): http://gwt-code-reviews.appspot.com/794801/diff/8001/9001#newcode43 dev/core/src/com/google/gwt/core/ext/typeinfo/JPrimitiveType.java:43: DESC_FLOAT, 0.0);

Re: [gwt-contrib] RR: allow CheckBox to accept null?

2010-08-25 Thread Ray Ryan
Yeah, thinking about it by the light of day I think it's the wrong direction. The use case is dealing with boolean values that may be null, and really a check box is just the wrong UI there. Withdrawn. On Wed, Aug 25, 2010 at 7:01 AM, Bruce Johnson br...@google.com wrote: Can you provide a

Re: [gwt-contrib] GWT Trunk failing to build

2010-08-25 Thread Ray Ryan
Did you really send this five days ago? I only just received it. I believe this issue has been fixed? On Thu, Aug 19, 2010 at 10:50 AM, tc camec...@gmail.com wrote: I did an update earlier and now GWT is failing to build. error samples/expenses/war does not exist --

Re: [gwt-contrib] Re: Eclipse: GDT - Scala plugin cooperation problem

2010-08-25 Thread Rajeev Dayal
If you uninstall GPE and leave the Scala plugin, does everything work? What type of launch configuration are you using? Is it a Web Application launch configuration? On Wed, Aug 25, 2010 at 3:06 AM, Martin Mauch martin.ma...@gmail.comwrote: I'm running into the same problem here. Is there any

Re: [gwt-contrib] RR: allow CheckBox to accept null?

2010-08-25 Thread Bruce Johnson
Glad I looked at it funny, then. Micro-design reviews ftw. On Wed, Aug 25, 2010 at 12:16 PM, Ray Ryan rj...@google.com wrote: Yeah, thinking about it by the light of day I think it's the wrong direction. The use case is dealing with boolean values that may be null, and really a check box

Re: [gwt-contrib] GWT Trunk failing to build

2010-08-25 Thread Travis Camechis
Yeah, I did send it 5 days and yeah it has been fixed, However, I am still getting a failed build. Looks like the JPA class are somehow not on the classpath. package javax.persistence does not exist on all Domain objects. during the compile of the samples/expenses app On Wed, Aug 25, 2010 at

Re: [gwt-contrib] GWT Trunk failing to build

2010-08-25 Thread Ray Ryan
Oops. That's the kind of thing that lead us to pull that sample out of M3 at the last minute. I apologize for the broken build, we'll get right on it. On Wed, Aug 25, 2010 at 9:38 AM, Travis Camechis camec...@gmail.com wrote: Yeah, I did send it 5 days and yeah it has been fixed, However, I am

Re: [gwt-contrib] GWT Trunk failing to build

2010-08-25 Thread Travis Camechis
no prob, just wanted to make sure it wasn't something I was doing or if it was a real problem On Wed, Aug 25, 2010 at 12:45 PM, Ray Ryan rj...@google.com wrote: Oops. That's the kind of thing that lead us to pull that sample out of M3 at the last minute. I apologize for the broken build, we'll

Re: [gwt-contrib] GWT Trunk failing to build

2010-08-25 Thread Ray Ryan
Actually, it's working for us here. Is your tools directory stale? On Wed, Aug 25, 2010 at 9:46 AM, Travis Camechis camec...@gmail.com wrote: no prob, just wanted to make sure it wasn't something I was doing or if it was a real problem On Wed, Aug 25, 2010 at 12:45 PM, Ray Ryan

Re: [gwt-contrib] GWT Trunk failing to build

2010-08-25 Thread Travis Camechis
everything appears to be up to date. I have the issue on two different machines. My steps for compiling are ANT CLEAN, ANT. I had been building fine up until the expenses move from bikeshed to samples. On Wed, Aug 25, 2010 at 1:05 PM, Ray Ryan rj...@google.com wrote: Actually, it's working

[gwt-contrib] Re: Modified the MenuBar class to change the Close() method from private to public. (issue798801)

2010-08-25 Thread jlabanca
I think it makes more sense to expose a new method MenuBar.closeSubMenus(), which would close all sub menus. If we expose close(), then the user has to iterate over all submenus to ensure they are closed. http://gwt-code-reviews.appspot.com/798801/show --

[gwt-contrib] Re: Modified the MenuBar class to change the Close() method from private to public. (issue798801)

2010-08-25 Thread rjrjr
Sounds restrictive, though. Any reason not to provide both? On 2010/08/25 17:22:55, jlabanca wrote: I think it makes more sense to expose a new method MenuBar.closeSubMenus(), which would close all sub menus. If we expose close(), then the user has to iterate over all submenus to ensure

[gwt-contrib] Re: Modified the MenuBar class to change the Close() method from private to public. (issue798801)

2010-08-25 Thread jlabanca
I can't really think of a use case where having the close() method makes sense if we expose closeSubMenus(), especially since only one submenu can be open at a time. Also, its a little confusing that it has no effect on top level menus (because they aren't in popups).

[gwt-contrib] Re: Modified the MenuBar class to change the Close() method from private to public. (issue798801)

2010-08-25 Thread Ray Ryan
Okey dokey. On Wed, Aug 25, 2010 at 10:30 AM, jlaba...@google.com wrote: I can't really think of a use case where having the close() method makes sense if we expose closeSubMenus(), especially since only one submenu can be open at a time. Also, its a little confusing that it has no effect

[gwt-contrib] Re: Fix boolean properties, and punch up tests. (issue755802)

2010-08-25 Thread Ray Ryan
Fixed some tests, submitting soon. On Wed, Aug 25, 2010 at 10:37 AM, rj...@google.com wrote: http://gwt-code-reviews.appspot.com/755802/show -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

[gwt-contrib] Re: Public: Start of a sample application showing GWT validation. (issue760802)

2010-08-25 Thread Nick Chalko
I will need a g4 approved also On Aug 25, 2010 5:26 AM, b...@google.com wrote: LGTM http://gwt-code-reviews.appspot.com/760802/diff/6001/1032 File samples/validation/src/com/google/gwt/sample/validation/client/Validation.java (right):

[gwt-contrib] [google-web-toolkit] r8643 committed - Adds a baseTime property to top level events to help re-normalize...

2010-08-25 Thread codesite-noreply
Revision: 8643 Author: zun...@google.com Date: Wed Aug 25 08:20:08 2010 Log: Adds a baseTime property to top level events to help re-normalize timestamps for multi process compiles. Adds some more instrumentation to profile the Compiler task. Review at http://gwt-code-reviews.appspot.com/797801

[gwt-contrib] Not compile-building expenses sample, just collecting its files (issue794802)

2010-08-25 Thread fabbott
Reviewers: cramsdale, Description: Not compile-building expenses sample, just collecting its files into the distro. Review by: cramsd...@google.com Please review this at http://gwt-code-reviews.appspot.com/794802/show Affected files: M samples/build.xml M samples/common.ant.xml A

Re: [gwt-contrib] GWT Trunk failing to build

2010-08-25 Thread Bart Guijt
I am experiencing the same issue(s) - see my Hudson logs here (http://hudson.purpleware.org/job/GWT/). This is TRUNK, FWIW. Bart. On 25 aug 2010, at 25 aug, 19:08, Travis Camechis wrote: everything appears to be up to date. I have the issue on two different machines. My steps for

Re: [gwt-contrib] GWT Trunk failing to build

2010-08-25 Thread Travis Camechis
Where are the JPA libraries supposed to exist? On Wed, Aug 25, 2010 at 3:27 PM, Bart Guijt bgu...@gmail.com wrote: I am experiencing the same issue(s) - see my Hudson logs here ( http://hudson.purpleware.org/job/GWT/). This is TRUNK, FWIW. Bart. On 25 aug 2010, at 25 aug, 19:08, Travis

[gwt-contrib] Re: Not compile-building expenses sample, just collecting its files (issue794802)

2010-08-25 Thread fabbott
http://gwt-code-reviews.appspot.com/794802/show -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

[gwt-contrib] Re: SafeHtml Templates (issue793801)

2010-08-25 Thread xtof
LGTM http://gwt-code-reviews.appspot.com/793801/diff/1/2 File user/src/com/google/gwt/safehtml/client/SafeHtmlTemplates.java (right): http://gwt-code-reviews.appspot.com/793801/diff/1/2#newcode42 user/src/com/google/gwt/safehtml/client/SafeHtmlTemplates.java:42: * SafeHtmlLabel

[gwt-contrib] Re: Not compile-building expenses sample, just collecting its files (issue794802)

2010-08-25 Thread fabbott
http://gwt-code-reviews.appspot.com/794802/show -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

[gwt-contrib] Small SafeHtml method name refactoring for name consistency. (issue799801)

2010-08-25 Thread pdr
Reviewers: xtof, jat, Description: Small SafeHtml method name refactoring for name consistency. Please review this at http://gwt-code-reviews.appspot.com/799801/show Affected files: M user/src/com/google/gwt/safehtml/shared/SafeHtmlUtils.java Index:

[gwt-contrib] Re: Small SafeHtml method name refactoring for name consistency. (issue799801)

2010-08-25 Thread rice
LGTM http://gwt-code-reviews.appspot.com/799801/show -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

[gwt-contrib] Re: Small SafeHtml method name refactoring for name consistency. (issue799801)

2010-08-25 Thread xtof
LGTM http://gwt-code-reviews.appspot.com/799801/show -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

[gwt-contrib] [google-web-toolkit] r8644 committed - Not compile-building expenses sample, just collecting its files...

2010-08-25 Thread codesite-noreply
Revision: 8644 Author: fabb...@google.com Date: Wed Aug 25 11:12:04 2010 Log: Not compile-building expenses sample, just collecting its files into the distro. Review at http://gwt-code-reviews.appspot.com/794802 http://code.google.com/p/google-web-toolkit/source/detail?r=8644 Modified:

[gwt-contrib] Re: Make xsiframe linker use a .js file for hosted mode so that cross site hosted mode will work (issue784801)

2010-08-25 Thread unnurg
http://gwt-code-reviews.appspot.com/784801/show -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

[gwt-contrib] Re: Add ability to use @UiChild annotation to specify how GWT should add a child element. (issue794801)

2010-08-25 Thread sonnyf
http://gwt-code-reviews.appspot.com/794801/show -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

[gwt-contrib] Re: GWT Trunk failing to build

2010-08-25 Thread Kevin Jin
It's confirmed. GWT engineers are working on it (by removing expense from the list of samples to be built from default Ant targets). Expense can be built with Maven 2.2.1 at the mean time. The required libs are supposed to be in tools, but GWT team decided to not add them to tools (I guess because

[gwt-contrib] CurrencyList now uses pure Java in dev mode. (issue771803)

2010-08-25 Thread scottb
Reviewers: jat, Description: This patch makes CurrencyList use a Java implementation in dev mode, which improves performance. Please review this at http://gwt-code-reviews.appspot.com/771803/show Affected files: M user/src/com/google/gwt/i18n/client/CurrencyList.java M

[gwt-contrib] Re: CurrencyList now uses pure Java in dev mode. (issue771803)

2010-08-25 Thread jat
Have you verified that the output is unchanged in the compiled case? You also need to test internal code that mocks this to make sure it doesn't break anything. http://gwt-code-reviews.appspot.com/771803/diff/1/2 File user/src/com/google/gwt/i18n/client/CurrencyList.java (right):

Re: [gwt-contrib] Re: GWT Trunk failing to build

2010-08-25 Thread Freeland Abbott
I think I fixed this at r8644... building GWT (with ant) will no longer compile the expenses sample; however, the code for it, including the maven pom.xml, is incorporated into the distro zip where folks can build it themselves, with maven, auto-fetching the various dependencies. I love having

[gwt-contrib] Re: CurrencyList now uses pure Java in dev mode. (issue771803)

2010-08-25 Thread jat
http://gwt-code-reviews.appspot.com/771803/diff/1/4 File user/src/com/google/gwt/i18n/rebind/CurrencyListGenerator.java (right): http://gwt-code-reviews.appspot.com/771803/diff/1/4#newcode196 user/src/com/google/gwt/i18n/rebind/CurrencyListGenerator.java:196: buf.append(new

Re: [gwt-contrib] Re: GWT Trunk failing to build

2010-08-25 Thread Travis Camechis
Trunk is now building fine On Wed, Aug 25, 2010 at 8:20 PM, Freeland Abbott fabb...@google.com wrote: I think I fixed this at r8644... building GWT (with ant) will no longer compile the expenses sample; however, the code for it, including the maven pom.xml, is incorporated into the distro zip

[gwt-contrib] Merged the valuestore package into the requestfactory package. Removed all (issue800801)

2010-08-25 Thread amitmanjhi
Reviewers: rjrjr, Description: Merged the valuestore package into the requestfactory package. Removed all references to the valuestore module. Patch by: amitmanjhi Review by: rjrjr Please review this at http://gwt-code-reviews.appspot.com/800801/show Affected files: M

[gwt-contrib] Re: Merged the valuestore package into the requestfactory package. Removed all (issue800801)

2010-08-25 Thread Ray Ryan
LGTM On Wed, Aug 25, 2010 at 6:24 PM, amitman...@google.com wrote: Reviewers: rjrjr, Description: Merged the valuestore package into the requestfactory package. Removed all references to the valuestore module. Patch by: amitmanjhi Review by: rjrjr Please review this at

[gwt-contrib] Update i18n Messages to include: (issue796802)

2010-08-25 Thread jat
Reviewers: xtof, pdr, Description: Update i18n Messages to include: - SafeHtml support - extended plurals support - list rendering - static placeholders - format arguments This is not yet complete -- I still need to extract the ListPattern data from CLDR for the rest of the locales. Patch by:

[gwt-contrib] Re: Update i18n Messages to include: (issue796802)

2010-08-25 Thread jat
http://gwt-code-reviews.appspot.com/796802/diff/1/10 File user/src/com/google/gwt/i18n/rebind/MessagesMethodCreator.java (right): http://gwt-code-reviews.appspot.com/796802/diff/1/10#newcode645 user/src/com/google/gwt/i18n/rebind/MessagesMethodCreator.java:645: protected static int

[gwt-contrib] Removed the doc references for ValueStore. (issue792802)

2010-08-25 Thread amitmanjhi
Reviewers: rjrjr, Description: Removed the doc references for ValueStore. Patch by: amitmanjhi Review by: rjrjr (TBR) Please review this at http://gwt-code-reviews.appspot.com/792802/show Affected files: M doc/build.xml Index: doc/build.xml

[gwt-contrib] Re: Removed the doc references for ValueStore. (issue792802)

2010-08-25 Thread Ray Ryan
This broke DynaTableRf pretty thoroughly. I should be able to submit the fix tonight. On Wed, Aug 25, 2010 at 9:54 PM, amitman...@google.com wrote: Reviewers: rjrjr, Description: Removed the doc references for ValueStore. Patch by: amitmanjhi Review by: rjrjr (TBR) Please review this

[gwt-contrib] [google-web-toolkit] r8647 committed - Fix breakage from ValueStore / RequestFactory merge.

2010-08-25 Thread codesite-noreply
Revision: 8647 Author: rj...@google.com Date: Wed Aug 25 19:07:05 2010 Log: Fix breakage from ValueStore / RequestFactory merge. http://code.google.com/p/google-web-toolkit/source/detail?r=8647 Modified:

[gwt-contrib] [google-web-toolkit] r8648 committed - Removed the doc references for ValueStore....

2010-08-25 Thread codesite-noreply
Revision: 8648 Author: amitman...@google.com Date: Wed Aug 25 19:22:01 2010 Log: Removed the doc references for ValueStore. Patch by: amitmanjhi Review by: rjrjr (TBR) Review at http://gwt-code-reviews.appspot.com/792802 http://code.google.com/p/google-web-toolkit/source/detail?r=8648