Re: USB Support

2008-08-17 Thread y.volta
Hi, Great work! BTW. Did you know there is an existing Grub2 USB project from coreboot? y.volta Lately I have been working on USB support for GRUB 2. It's not completely ready yet. The code was only tested on QEMu and supports UHCI, OHCI, USB Mass Storage and HID. Most likely it w

Re: precision formatting in grub_printf

2008-08-17 Thread Deepak Vankadaru
Attached the same in unified diff format. This is listed in known bugs (http://grub.enbug.org/KnownBugs) On Sun, Aug 17, 2008 at 11:28 PM, Deepak Vankadaru < [EMAIL PROTECTED]> wrote: > Hi > > I have implemented precision formatting support in grub_printf. Following > is the diff (of kern/misc.c

Re: precision formatting in grub_printf

2008-08-17 Thread Robert Millan
On Sun, Aug 17, 2008 at 11:28:38PM +0530, Deepak Vankadaru wrote: > Hi > > I have implemented precision formatting support in grub_printf. Following is > the diff (of kern/misc.c) Thanks! Could you please send this in unified diff format? ('diff -u', or just 'svn diff') Also, are there any pla

Re: [PATCH] cleanup in EFI Linux loader

2008-08-17 Thread Robert Millan
On Sun, Aug 17, 2008 at 10:35:38PM +0200, Robert Millan wrote: > - grub_printf (" [Linux-EFI, setup=0x%x, size=0x%x]\n", > + grub_printf (" [Linux, setup=0x%x, size=0x%x]\n", I looked at the other Linux loaders, and to be consistent this would have to be "Linux-bzImage" instead. I propose u

[PATCH] cleanup in EFI Linux loader

2008-08-17 Thread Robert Millan
Hi, I've been working on a pure 32-bit Linux loader that is firmware-agnostic and can be used on coreboot (and probably others later on). I used the EFI Linux loader as a base. Due to the large amount of changes, and the way EFI operates (in which it retains control of memory management, much d

Re: [PATCH] Replace magic numbers by constants

2008-08-17 Thread Carles Pina i Estany
Hello, On Aug/17/2008, Robert Millan wrote: > On Sun, Aug 17, 2008 at 04:29:16PM +0200, Carles Pina i Estany wrote: > > 2008-08-17 Carles Pina i Estany <[EMAIL PROTECTED]> > > > > * menu/normal.c (run_menu): Change magic numbers by constants > > (16 by GRUB_TERM_UP and 14 by GRUB_T

USB Support

2008-08-17 Thread Marco Gerards
Hi, Lately I have been working on USB support for GRUB 2. It's not completely ready yet. The code was only tested on QEMu and supports UHCI, OHCI, USB Mass Storage and HID. Most likely it will not immediately work on real hardware. But please test and report if you want to be sure ;-) You can

precision formatting in grub_printf

2008-08-17 Thread Deepak Vankadaru
Hi I have implemented precision formatting support in grub_printf. Following is the diff (of kern/misc.c) Thanks Deepak ###start of diff *** kern/misc.c2008-08-18 04:46:36.0 +0530 --- /home/deepakv/orig/grub2-1.96+20080724/kern/misc.c2008-06-16 06:12:48.0 +053

Re: [RFC] change grub_print_error to use stderr for the utils

2008-08-17 Thread Bean
On Mon, Aug 18, 2008 at 12:58 AM, Felix Zielcke <[EMAIL PROTECTED]> wrote: > Am Sonntag, den 17.08.2008, 18:37 +0200 schrieb Robert Millan: >> >> If I understood correctly, nvidia's is a _software_ RAID solution which is >> implemented in Linux, in BIOS and in Windows (via non-native drivers), and

Re: [RFC] change grub_print_error to use stderr for the utils

2008-08-17 Thread Felix Zielcke
Am Sonntag, den 17.08.2008, 18:37 +0200 schrieb Robert Millan: > > If I understood correctly, nvidia's is a _software_ RAID solution which is > implemented in Linux, in BIOS and in Windows (via non-native drivers), and > is marketed as if it were hardware RAID. Bah normally I even say myself to t

Re: [PATCH] Move assembly code out of the kernel

2008-08-17 Thread Bean
On Sun, Aug 17, 2008 at 7:31 PM, Vesa Jääskeläinen <[EMAIL PROTECTED]> wrote: > [EMAIL PROTECTED] wrote: >> I have made generic function that does basically the same thing for bios >> service 0x10 (video). In that modification you prepare registers >> structure that will be configured during real m

Re: [RFC] change grub_print_error to use stderr for the utils

2008-08-17 Thread Robert Millan
On Sun, Aug 17, 2008 at 05:47:03PM +0200, Felix Zielcke wrote: > Am Sonntag, den 17.08.2008, 17:34 +0200 schrieb Robert Millan: > > Hiding errors is a very bad practice. And hiding them because the output > > is ugly or because something is reporting false positives is even worse > > IMHO. > > >

Re: [PATCH] decouple mmap parsing and implement Multiboot mmap in the loader

2008-08-17 Thread Robert Millan
Committed. On Sat, Aug 16, 2008 at 04:50:17PM +0200, Marco Gerards wrote: > Robert Millan <[EMAIL PROTECTED]> writes: > > > On Wed, Aug 13, 2008 at 07:52:59PM +0200, Marco Gerards wrote: > >> > #include > >> > #include > >> > +#include /* For struct grub_mmap_entry, which is > >> > als

Re: [RFC] change grub_print_error to use stderr for the utils

2008-08-17 Thread Felix Zielcke
Am Sonntag, den 17.08.2008, 17:34 +0200 schrieb Robert Millan: > Hiding errors is a very bad practice. And hiding them because the output > is ugly or because something is reporting false positives is even worse > IMHO. > > This "out of disk" sounds like a false positive indeed. It's a bug, > so

Re: [PATCH] Replace magic numbers by constants

2008-08-17 Thread Robert Millan
On Sun, Aug 17, 2008 at 04:29:16PM +0200, Carles Pina i Estany wrote: > 2008-08-17 Carles Pina i Estany <[EMAIL PROTECTED]> > > * menu/normal.c (run_menu): Change magic numbers by constants > (16 by GRUB_TERM_UP and 14 by GRUB_TERM_DOWN) When reading the subject I thought it was t

Re: [RFC] change grub_print_error to use stderr for the utils

2008-08-17 Thread Robert Millan
On Sun, Aug 17, 2008 at 05:24:07PM +0200, Felix Zielcke wrote: > Am Sonntag, den 17.08.2008, 17:07 +0200 schrieb Robert Millan: > > > fz:~# update-grub > > > error: out of disk > > > error: out of disk > > > Updating /boot/grub/grub.cfg ... > > > > This just means someone i

Re: [PATCH] romfs support for Grub2

2008-08-17 Thread Marco Gerards
"y.volta" <[EMAIL PROTECTED]> writes: > thanks bean, for your suggestion. I'm not famliar with GNU coding, so, would > you please show me some links to learn? especially the indent style. > and, this patch is just a work-able one, so, i'd like to improve it. > > for the legancy romfs patch, you c

Re: [PATCH] Split of raid scan code

2008-08-17 Thread Robert Millan
On Sun, Aug 17, 2008 at 11:08:07PM +0800, Bean wrote: > >> > >> grub-probe don't use the recover module, so if it have problem at > >> install time, user would know about it (error message would be > >> "raid5rec not loaded"). > > > > Sounds fine to me. But the error message is too cryptic IMHO.

Re: [RFC] change grub_print_error to use stderr for the utils

2008-08-17 Thread Felix Zielcke
Am Sonntag, den 17.08.2008, 17:07 +0200 schrieb Robert Millan: > > fz:~# update-grub > > error: out of disk > > error: out of disk > > Updating /boot/grub/grub.cfg ... > > This just means someone is reporting this error and shouldn't. It's a bug. > Hi Robert, Marco alrea

Re: [RFC] change grub_print_error to use stderr for the utils

2008-08-17 Thread Robert Millan
On Sat, Aug 16, 2008 at 05:06:18PM +0200, Felix Zielcke wrote: > Am Donnerstag, den 14.08.2008, 19:54 +0200 schrieb Robert Millan: > > > Anyway, please let's not waste time in this discussion. It's only a matter > > on which patch goes first. If Bean wants to checkin his code first, then > > it

Re: [PATCH] Split of raid scan code

2008-08-17 Thread Bean
On Sun, Aug 17, 2008 at 10:52 PM, Robert Millan <[EMAIL PROTECTED]> wrote: > On Sat, Aug 16, 2008 at 11:20:04PM +0800, Bean wrote: >> On Sat, Aug 16, 2008 at 8:16 PM, Robert Millan <[EMAIL PROTECTED]> wrote: >> > On Sat, Aug 16, 2008 at 05:07:00PM +0800, Bean wrote: >> >> Hi, >> >> >> >> This new p

Re: [PATCH] Enable grub_cpu_idle for i386 to halt the CPU

2008-08-17 Thread Robert Millan
On Sat, Aug 16, 2008 at 09:44:22AM -0500, David Fries wrote: > On Sat, Aug 16, 2008 at 02:33:17PM +0200, Robert Millan wrote: > > > > We have 4 ports on i386. A proper implementation of grub_cpu_idle > > should work fine on all of them. When I say "proper" I mean that > > 'hlt' instruction shoul

Re: [PATCH] Split of raid scan code

2008-08-17 Thread Robert Millan
On Sat, Aug 16, 2008 at 11:20:04PM +0800, Bean wrote: > On Sat, Aug 16, 2008 at 8:16 PM, Robert Millan <[EMAIL PROTECTED]> wrote: > > On Sat, Aug 16, 2008 at 05:07:00PM +0800, Bean wrote: > >> Hi, > >> > >> This new patch seperates raid5 and raid6 recover code from raid.c, and > >> place them in mo

Re: [PATCH] romfs support for Grub2

2008-08-17 Thread y.volta
Thanks all. Let me check the coding style. ;-) y.volta ___ Grub-devel mailing list Grub-devel@gnu.org http://lists.gnu.org/mailman/listinfo/grub-devel

Re: [PATCH] Replace magic numbers by constants

2008-08-17 Thread Carles Pina i Estany
Hi, On Aug/17/2008, Marco Gerards wrote: > Hi, > > Carles Pina i Estany <[EMAIL PROTECTED]> writes: > > > When I did the Home/End keys patch I noticied that in normal/menu.c > > there was some magic numbers (and some constants was already defined, in > > include/grub/term.h (actually, reading

Re: [PATCH] Replace magic numbers by constants

2008-08-17 Thread Marco Gerards
Hi, Carles Pina i Estany <[EMAIL PROTECTED]> writes: > When I did the Home/End keys patch I noticied that in normal/menu.c > there was some magic numbers (and some constants was already defined, in > include/grub/term.h (actually, reading the ChangeLog was committed by > Robert Millan on 2008-02-

Re: [PATCH] romfs support for Grub2

2008-08-17 Thread Felix Zielcke
Hello, Am Sonntag, den 17.08.2008, 21:17 +0800 schrieb y.volta: > thanks bean, for your suggestion. I'm not famliar with GNU coding, so, would > you please show me some links to learn? especially the indent style. I'm not Bean but I can tell you what I was told as I started to constribute to GRU

Re: [PATCH] romfs support for Grub2

2008-08-17 Thread Bean
On Sun, Aug 17, 2008 at 9:17 PM, y.volta <[EMAIL PROTECTED]> wrote: > > thanks bean, for your suggestion. I'm not famliar with GNU coding, so, would > you please show me some links to learn? especially the indent style. > and, this patch is just a work-able one, so, i'd like to improve it. > > for

Re: [PATCH] romfs support for Grub2

2008-08-17 Thread y.volta
thanks bean, for your suggestion. I'm not famliar with GNU coding, so, would you please show me some links to learn? especially the indent style. and, this patch is just a work-able one, so, i'd like to improve it. for the legancy romfs patch, you can get it from savannah: http://savannah.gnu.or

[PATCH] Replace magic numbers by constants

2008-08-17 Thread Carles Pina i Estany
Hello, When I did the Home/End keys patch I noticied that in normal/menu.c there was some magic numbers (and some constants was already defined, in include/grub/term.h (actually, reading the ChangeLog was committed by Robert Millan on 2008-02-05) I'm sending a patch to change the magic numbers b

grub2 svn 17aug2008 hfs+ partition error

2008-08-17 Thread Guy Forssman
Hi There, I have a Clevo 901C laptop with 3 harddrives on it In Bios I can choose between Normal,AHCI and Raid... Bios is now set to AHCI GParted gives following data hd0 contains /dev/sda1 ntfs 34.99 GiB XP unallocated unallocated 7.57 MiB /dev/sda2 hfs+ 35.12 GiB Leopard-MBR-test unallocated un

Re: [PATCH] Move assembly code out of the kernel

2008-08-17 Thread Vesa Jääskeläinen
[EMAIL PROTECTED] wrote: > I have made generic function that does basically the same thing for bios > service 0x10 (video). In that modification you prepare registers > structure that will be configured during real mode switching. I am yet > to commit it for review, but I think it would be more gen

Re: [PATCH] Home-End keys in menu

2008-08-17 Thread Felix Zielcke
Commited. Am Samstag, den 16.08.2008, 20:51 +0200 schrieb Carles Pina i Estany: > > Hi, > > On Aug/13/2008, Marco Gerards wrote: > > Hi, > > > > Carles Pina i Estany <[EMAIL PROTECTED]> writes: > > > > [...] > > > > > 2008-08-06 Carles Pina i Estany <[EMAIL PROTECTED]> > > > > > > * menu/

Re: [PATCH] romfs support for Grub2

2008-08-17 Thread Vesa Jääskeläinen
Bean wrote: > On Sun, Aug 17, 2008 at 10:43 AM, y.volta <[EMAIL PROTECTED]> wrote: >> btw, i think the grub_dprintf should output to non-display device, this will >> make debuging more easier and comfort . i think the low-cost device is a >> com-port. for, now time virtual machine software has th