Re: [Intel-gfx] [PATCH] drm/i915: Add ddb size field to device info structure

2016-09-14 Thread Jani Nikula
On Wed, 14 Sep 2016, Deepak M wrote: > Adding the ddb size into the devide info will avoid > platform checks while computing wm. > > Suggested-by: Ander Conselvan de Oliveira > > Signed-off-by: Deepak M > --- >

[Intel-gfx] ✗ Fi.CI.BAT: failure for series starting with [01/18] drm/i915: Support asynchronous waits on struct fence from i915_gem_request

2016-09-14 Thread Patchwork
== Series Details == Series: series starting with [01/18] drm/i915: Support asynchronous waits on struct fence from i915_gem_request URL : https://patchwork.freedesktop.org/series/12433/ State : failure == Summary == Series 12433v1 Series without cover letter

Re: [Intel-gfx] 4.8-rc1: it is now common that machine needs re-run of xrandr after resume

2016-09-14 Thread Jani Nikula
On Wed, 14 Sep 2016, Pavel Machek wrote: > For the "sometimes need xrandr after resume": I don't think I can > bisect that. It only happens sometimes :-(. But there's something > helpful in the logs: > [ 1856.218863] [drm:drm_edid_block_valid] *ERROR* EDID checksum is > invalid,

Re: [Intel-gfx] [PATCH] drm/i915: Only expand COND once in wait_for()

2016-09-14 Thread Chris Wilson
On Tue, Sep 13, 2016 at 08:40:19PM +0100, Chris Wilson wrote: > I was looking at some wait_for() timeouts on a slow system, with lots of > debug enabled (KASAN, lockdep, mmio_debug). Thinking that we were > mishandling the timeout, I tried to ensure that we loop at least once > after first testing

Re: [Intel-gfx] [PATCH] drm/i915: Standardize port type for DVO encoders

2016-09-14 Thread Jani Nikula
On Wed, 14 Sep 2016, Dhinakaran Pandiyan wrote: > Changing the return type from 'char' to 'enum port' in > intel_dvo_port_name() makes it easier to later move the port information to > intel_encoder. In addition, the port type conforms to what we have > elsewhere. >

Re: [Intel-gfx] 4.8-rc1: it is now common that machine needs re-run of xrandr after resume

2016-09-14 Thread Jani Nikula
On Wed, 14 Sep 2016, Jani Nikula wrote: > On Wed, 14 Sep 2016, Pavel Machek wrote: >> Hi! >> >>> I have >>> >>> 00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset >>> Integrated Graphics Controller (rev 03) >>> >>> In previous

Re: [Intel-gfx] [PATCH v5 1/5] drm/i915: Fallback to lower link rate and lane count during link training

2016-09-14 Thread Mika Kahola
On Tue, 2016-09-13 at 18:08 -0700, Manasi Navare wrote: > According to the DisplayPort Spec, in case of Clock Recovery failure > the link training sequence should fall back to the lower link rate > followed by lower lane count until CR succeeds. > On CR success, the sequence proceeds with Channel

[Intel-gfx] [PATCH] drm/i915: Add ddb size field to device info structure

2016-09-14 Thread Deepak M
Adding the ddb size into the devide info will avoid platform checks while computing wm. v2: Added comment and WARN_ON if ddb size is zero.(Jani) Suggested-by: Ander Conselvan de Oliveira Signed-off-by: Deepak M ---

Re: [Intel-gfx] [CI 10/21] drm/i915: Mark up all locked waiters

2016-09-14 Thread ch...@chris-wilson.co.uk
On Tue, Sep 13, 2016 at 03:21:48PM +0300, Mika Kuoppala wrote: > Mika Kuoppala writes: > > "Zanoni, Paulo R" writes: > >>> +#if IS_ENABLED(CONFIG_LOCKDEP) > >>> + GEM_BUG_ON(!!lockdep_is_held(>i915->drm.struct_mutex) > >>> != > >>> +

Re: [Intel-gfx] [PATCH 04/18] drm/i915: Remove unused i915_gem_active_wait() in favour of _unlocked()

2016-09-14 Thread Joonas Lahtinen
On ke, 2016-09-14 at 07:52 +0100, Chris Wilson wrote: > Since we only use the more generic unlocked variant, just rename it as > the normal i915_gem_active_wait(). The temporary cost is that we need to > always acquire the reference in a RCU safe manner, but the benefit is > that we will combine

[Intel-gfx] ✓ Fi.CI.BAT: success for drm/i915: Add ddb size field to device info structure (rev2)

2016-09-14 Thread Patchwork
== Series Details == Series: drm/i915: Add ddb size field to device info structure (rev2) URL : https://patchwork.freedesktop.org/series/12427/ State : success == Summary == Series 12427v2 drm/i915: Add ddb size field to device info structure

Re: [Intel-gfx] [PATCH 01/18] drm/i915: Support asynchronous waits on struct fence from i915_gem_request

2016-09-14 Thread Joonas Lahtinen
On ke, 2016-09-14 at 07:52 +0100, Chris Wilson wrote: > +int > +i915_gem_request_await_fence(struct drm_i915_gem_request *req, > +  struct fence *fence) > +{ > + struct fence_array *array; > + int ret; > + int i; > + > + if (test_bit(FENCE_FLAG_SIGNALED_BIT,

Re: [Intel-gfx] 4.8-rc1: it is now common that machine needs re-run of xrandr after resume

2016-09-14 Thread Jani Nikula
On Wed, 14 Sep 2016, Pavel Machek wrote: > Hi! > >> I have >> >> 00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset >> Integrated Graphics Controller (rev 03) >> >> In previous kernels, resume worked ok. With 4.8-rc1, I quite often (1 >> in 10 resumes?) get in

Re: [Intel-gfx] [PATCH] drm/i915: Ignore OpRegion panel type except on select machines

2016-09-14 Thread Ville Syrjälä
On Tue, Sep 13, 2016 at 12:37:16PM +0300, Jani Nikula wrote: > On Tue, 13 Sep 2016, ville.syrj...@linux.intel.com wrote: > > From: Ville Syrjälä > > > > Turns out > > commit a05628195a0d ("drm/i915: Get panel_type from OpRegion panel > > details") has regressed

Re: [Intel-gfx] 4.8-rc1: it is now common that machine needs re-run of xrandr after resume

2016-09-14 Thread Pavel Machek
On Tue 2016-09-13 22:38:45, Martin Steigerwald wrote: > Hi. > > Am Dienstag, 13. September 2016, 22:23:50 CEST schrieb Pavel Machek: > > I have > > > > 00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset > > Integrated Graphics Controller (rev 03) > > 00:02.0 VGA compatible

Re: [Intel-gfx] 4.8-rc1: it is now common that machine needs re-run of xrandr after resume

2016-09-14 Thread Pavel Machek
On Wed 2016-09-14 10:38:18, Jani Nikula wrote: > On Wed, 14 Sep 2016, Pavel Machek wrote: > > Hi! > > > >> I have > >> > >> 00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset > >> Integrated Graphics Controller (rev 03) > >> > >> In previous kernels, resume

Re: [Intel-gfx] [PATCH] drm/i915: Ignore OpRegion panel type except on select machines

2016-09-14 Thread James Hogan
On 13 September 2016 at 10:22, wrote: > From: Ville Syrjälä > > Turns out > commit a05628195a0d ("drm/i915: Get panel_type from OpRegion panel > details") has regressed quite a few machines. So it looks like we > can't use the panel

Re: [Intel-gfx] [PATCH 02/18] drm/i915: Allow i915_sw_fence_await_sw_fence() to allocate

2016-09-14 Thread Chris Wilson
On Wed, Sep 14, 2016 at 10:51:12AM +0300, Joonas Lahtinen wrote: > On ke, 2016-09-14 at 07:52 +0100, Chris Wilson wrote: > > @@ -678,7 +678,7 @@ void __i915_add_request(struct drm_i915_gem_request > > *request, bool flush_caches) > >      >i915->drm.struct_mutex); > >  

Re: [Intel-gfx] [PATCH 03/18] drm/i915: Rearrange i915_wait_request() accounting with callers

2016-09-14 Thread Joonas Lahtinen
On ke, 2016-09-14 at 07:52 +0100, Chris Wilson wrote: > +int > +i915_gem_object_wait(struct drm_i915_gem_object *obj, > +  unsigned int flags, > +  long timeout, > +  struct intel_rps_client *rps) >  { >   [...] > - return 0; > + resv =

Re: [Intel-gfx] [2/9] drm/doc: Polish kerneldoc for encoders

2016-09-14 Thread Pandiyan, Dhinakaran
I guess it's too late for review now. But, I want to send this anyway. On Mon, 2016-08-29 at 10:27 +0200, Daniel Vetter wrote: > - Move missing bits into struct drm_encoder docs. > - Explain that encoders are 95% internal and only 5% uapi, and that in > general the uapi part is broken. > -

<    1   2